'Unable to install busybox-initramfs' during a server installation

Bug #1117292 reported by Para Siva on 2013-02-06
116
This bug affects 28 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Unassigned
usb-creator (Ubuntu)
Medium
Unassigned

Bug Description

Raring virtual-host server preseeded installation failed with the following error with 20130206 i386 image.

Feb 6 09:23:05 base-installer: apt-install or in-target is already running, so you cannot run either of
Feb 6 09:23:05 base-installer: them again until the other instance finishes. You may be able to use
Feb 6 09:23:05 base-installer: 'chroot /target ...' instead.
Feb 6 09:23:05 in-target: Unexpected error; command not executed: 'sh -c debconf-apt-progress --no-progress --logstderr -- apt-get -q -y --no-remove install busybox-initramfs'
Feb 6 09:23:05 debconf: --> SUBST base-installer/kernel/failed-package-install PACKAGE busybox-initramfs
Feb 6 09:23:05 debconf: Adding [PACKAGE] -> [busybox-initramfs]
Feb 6 09:23:05 debconf: <-- 0
Feb 6 09:23:05 base-installer: error: exiting on error base-installer/kernel/failed-package-install
Feb 6 09:23:05 debconf: --> PROGRESS stop
Feb 6 09:23:05 debconf: <-- 0 OK
Feb 6 09:23:05 debconf: --> INPUT critical base-installer/kernel/failed-package-install
Feb 6 09:23:05 debconf: <-- 0 question will be asked
Feb 6 09:23:05 debconf: --> GO

This appears to be an intermittent issue because a manual installation and a consecutive preseeded installation succeeded.

The log files, the preseed file and the screenshot of the failure are attached

Related branches

Para Siva (psivaa) wrote :
description: updated
description: updated
Para Siva (psivaa) wrote :
Para Siva (psivaa) wrote :
Para Siva (psivaa) wrote :
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Matthew (mh00h) wrote :

I experience this issue too. I have 3 drives in the machine and have tried installing using the 12.10 server image and the 13.04 beta2 image. Same result on a core 2 IBM machine. It just won't install past "installing the system."

Brian Murray (brian-murray) wrote :

This may be due to the fact that linux-server is a transitional package and now points to linux-generic. Perhaps if you were to use that package in your preseed you'd have better luck. Could you give this a try? Thanks in advance.

@Matthew - unless you are using the same preseed file as the reporter of this bug you are unlikely to be experiencing the same issue and should open a new bug report.

Changed in debian-installer (Ubuntu):
status: Confirmed → Incomplete
Para Siva (psivaa) wrote :

This issue has not occurred since. The installations with linux-server entry in the preseed do not see any issues now. (Except a couple of instances due to temp kernel version mismatch between the archive and the d-i, but they have been already dealt with.) In any case I'll keep watching if this occurs again. Thanks

Patrick Goetz (pgoetz) wrote :

I'm having exactly the same problem with 13.04 64-bit server. Can someone elaborate on what's involved in using the linux-server package in the preseed? Thanks!

Patrick Goetz (pgoetz) wrote :

So, I ended up in a menu which allowed me to test the bootable USB stick I was trying to use to install 13.04 AMD server, and it reported errors. I downloaded another copy of the 13.04 ISO and made another bootable USB. This one allowed the system to be installed with no problems whatsoever, so maybe my problem was just a bad bootable image. I created the first one with Startup Disk Creator on 12.04 Desktop, and made the second bootable USB using the Pen Drive USB installer on Windows XP.

Same issue: 13.04 64-bit, ubuntu server.

The errors pgoetz reported were actually probably false postives (I see the same thing): http://askubuntu.com/questions/180218/why-does-integrity-check-fail-for-the-12-04-1-alternate-iso

...which makes me wonder what he did that actually solved it. pgoetz - did you do anything else differently? Did you choose the same boot line from the grub menu?

The preseed (default set of auto-answers to the installer's questions, which is in the grub boot options of the kernel boot line) is /cdrom/preeed/ubuntu-server.seed for the "Install Ubuntu Server" choice I've been trying.

I burned a CD (of the same .iso image) and the installation worked fine.

I wonder if there are race conditions in the installer that are only triggered by the speed of the flash-based install?

(That CD, incidentally, did pass the "verification" test... since I created the flash drive with two different creators (unetbootin and the KDE tool) and the drive is fine afaik, I suspect either the creation of it or the use of it was triggering that issue.)

Launchpad Janitor (janitor) wrote :

[Expired for debian-installer (Ubuntu) because there has been no activity for 60 days.]

Changed in debian-installer (Ubuntu):
status: Incomplete → Expired
Harri Pasanen (harri-f) wrote :

I just ran into this same problem, trying to install 13.04 amd64 server to raid10 root with 4 disks from a usb stick created with usb-creator-kde on kubuntu 13.04 desktop.

Verification of the "CD-ROM disc" from the menu fails for the usb stick, but this seems to be bogus.

Failed files are

md5sum: ./install/netboot/ubuntu-installer/amd64/pxelinux.cfg/default: No such file or directory
md5sum: ./install/netboot/pxelinux.0: No such file or directory
md5sum: ./install/netboot/pxelinux.cfg/default: No such file or directory

which are all symlinks, vfat on usb does not support those.

So what's up?

Harri Pasanen (harri-f) wrote :

Just to doubly sure I copied the symlink targets in place of the symlinks on the usb stick, after which the integrity check passed ok.
It does not affect the installation though, still fails as described in the original report.

Changed in debian-installer (Ubuntu):
status: Expired → Confirmed
fejes (anthony-fejes) wrote :

Also seeing this on 13.10 server install. Has any progress been made, or is there a work around for this bug yet?

I am seeing this on a 13.10 serer install with UEFI bios. I am installing onto a RAID1 mirror of two intel SSDs. The "copying files" step appears successful but whatever apt commands get run in the target by the installer seem to fail. Apt and dpkg commands run in chroot by hand seem to work.

One thing to note is that /target/dev does not contain the md device that I am trying to install into. I think I saw errors on console 4 indicating that the raid devices (there are others not involved in the install) could not be accessed due to being busy. The md devices are present in /dev.

I can't say I have a workaround, but I did manage to get my machine built after several hours of trying. After the successful copy of files to the target and the failure to install the subsequent packages I switched to recovery mode, specifying the raid mirror as my root filesystem. In this recovery mode I was able to piece by piece build up the system to a working state. Some of the steps I performed in this mode include:
* Install the packages listed as failed in /var/log/syslog during the original install attempt, such as mdadm
* Perform a find / -name '*.REAL' in the target filesystem. Use these real versions of various executables to overwrite the fake versions. Examples include start-stop-daemon and initctl.
* Create a user and add the user to group sudo
* I actually wanted a desktop install so I installed ubuntu-desktop. Along the way I had to delete some stale symlinks and run a debconf fix perl script to get packages to install correctly.
* I had to install the top-level linux metapackage to get my kernel intalled and install the grub2 package to get it booting.
* My first bootup stalled waiting on dhcp. I had to edit /etc/network/interfaces to rename the primary network interface from p8d11something to eth0

Thomas Neumann (tneumann) wrote :

This happens to me, too, server installation is currently broken in some settings. This appears to be a bug or a race in the installer logic, as running the apt-get command by hand in a chroot succeeded. So apparently there is not really an error during the underlying package installation, just the installer got confused.

As a workaround I have installed 12.04 server (which installed just fine), and then upgraded to 14.04. Not pretty, but at least that worked.

Chris Ball (chris-ubuntu) wrote :

I'm seeing this too, Ubuntu 14.04 server install on a USB3 key to a 4.4GHz machine. I agree that it looks like a race.

You don't need to explain all the ways in which this is probably a terrible idea, but since the current workaround (in #21) is involves upgrading from 12.04 to 14.04 and sounds painful, I thought I'd share what worked for me:

Boot the server installer, Ctrl-Alt-F2, open the terminal, run:

# while true; do rm /var/run/chroot-setup.lock; sleep 1; done

Then just go through the install as normal. Was failing 100% of the time before this change, works after it. Doesn't look like there are any negative consequences to the installed system.

Matthew Lovibond (ub-matt-hv) wrote :

Also seeing this on 14.04 while using a usb key to install (only a cheap slow usb2 one though).

Chris Ball's workaround worked for me though I was almost sick at having to do something this hacky.

Mike Wilson (knobby) wrote :

I saw this installing 14.04 using a usb thumb drive as well. As ugly as it is, Chris Ball's hack got me going.

Mike Wilson (knobby) wrote :

Actually I ran into further problems later down including install hanging due to files that needed to be clobbered and then not being able to boot properly. I went back and made the thumb drive image with rufus instead of unetbootin using the same ISO and this time it installed without issues and booted right up. This could be an issue with unetbootin.

Terence Hong (terryhong) wrote :

FWIW - I also had trouble with this on 14.04 LTS.

I did 2 things, the latter of which I think is the reason I was able install:

1. Recreated the USB using the startup-disk-creator in Ubuntu itself (not Unetbootin!)

2. Plugged the USB stick into a USB 2 (black) slot, as opposed to USB 3 (blue)

costing (costing) wrote :

Same here, I've tried 14.04 and 14.04.1 and both failed in a similar fashion. +1 for Chris Ball's hack, after a frustrating couple of hours of trying various things, this saved the day.

zersenser (zersenser) wrote :

Same here... Chris Ball saved the day.

Andreas (delleske) wrote :

Unfortunately, Chris did not save MY say: I get the same message "unable to install busybox-initramfs" (same text in German).

What is going on please? I did not find anything helpful elsewhere.

Chris' trick did allow me to finish installing...
Though ubuntu server 14.04.1 now tried to startx, complained about cups [FAIL] on boot and takes up twice the disk space on / than another similar install...
Furthermore, trying to dpkg -S some files (say startx, to know why it's there) doesn't give anything and "dpkg -l | grep -i linux-image" doesn't return anything either! So basically it corrupted the dpkg installed package list ...

I'll have to reinstall, but not sure how at this point...

stuart d (daphreak) wrote :

Ran into this bug with the 14.04.1 x64 Server installer. Switched to a slower USB drive after reading this thread and was able to install without any issues.

Tycho Andersen (tycho-s) wrote :

I've also seen this with 14.04.1; I tried Chris' workaround and the install gets further, but ultimately fails (probably for an unrelated reason). In any case, it is definitely still an issue.

Luca Giovenzana (lucagiove) wrote :

Actually I understood what was wrong in my installation!!!
Basically I was reusing the same usb stick I used for a previous Ubuntu installation and the "Startup Disk Creator" application didn't cleared out the usb stick.. so files of two Ubuntu version (14.04 Desktop and Server) were coexisting causing this problem.

Chris' workaround actually worked but in the end I had a server installation with gnome, cups, xorg and other desktop packages.. :( installation was compromised.

SOLUTION:
I used dd instead of "Startup Disk Creator" (never trust GUI tools :P)
dd if=image.iso of=/dev/xxx bs=4M

Brian Murray (brian-murray) wrote :

When you say "Startup Disk Creator", do you mean usb-creator-gtk which is included with Ubuntu?

Finjon Kiang (kiange) wrote :

Also met this issue in both ubuntu-14.04.1-server-amd64.iso and ubuntu-14.04-server-amd64.iso with USB stick to install. With the workaround from Chris Ball could bypass the issue, but the installor just hanged in another point as attached photo.

Finally got it work with ubuntu-14.04-desktop-amd64.iso and used tasksel to remove desktop parts.

The machine details:
# LENOVO ThinkPad W510 (43195RU)
# Intel(R) Core(TM) i5 CPU M 520
# Memory 4+4 GB

Joshua Kugler (jkugler) wrote :

I am seeing this in "Ubuntu-Server 14.10 "Utopic Unicorn" - Release amd64 (20141022.2)"

I will attach my syslog for full analysis.

I am not using any preseed, other than the one that comes with the image, and this is from a USB stick created by usb-creator-kde on Kubuntu 14.04.

Joshua Kugler (jkugler) wrote :

Data point: the work-around in comment #22 worked for me too. Systems seems OK so far.

Looks to me like this would be an issue caused by remaining files from other iso images when they are done using usb-creator.

If you're running into the server install failing with such errors as "busybox-initramfs" failing to install or other messages saying that "apt-install or in-target are already in use"; see if you have a stray "casper" directory on the USB drive used to do the install.

This would happen for people writing a desktop image to a USB drive, then writing a server image without formatting; the base installer will pick the squashfs file from casper/ first if it's there, which could make the installation fail.

Joshua Kugler (jkugler) wrote :

That may be, and I'll take a look, but when using usb-creator-kde (and I assume other versions as well), it formats the USB drive before it begins any copy process.

summary: - 'Unable to install busibux-initramfs' during a preseeded virtual-host
- raring server installation
+ 'Unable to install busybox-initramfs' during a server installation

usb-creator-kde doesn't actually format anything unless you specifically hit the Erase Disk button.

Joshua, any results from your checking of whether you still have a casper directory containing filesystem.squashfs on the media you use to install a server?

Joshua Kugler (jkugler) wrote :

jkugler@hosanna:/media/jkugler/5032-26FC$ find . |grep squashfs
./install/filesystem.squashfs
./pool/main/l/linux/squashfs-modules-3.13.0-24-generic-di_3.13.0-24.46_amd64.udeb

I made a USB disk again, and did "erase disk," and used the "DIscard on shutdown" option (no storage for live image). I used the ubuntu 14.04 server ISO image (ubuntu-14.04-server-amd64.iso). After that, I have this:

jkugler@hosanna:/media/jkugler/0F33-5516$ find .|grep squash
./boot/grub/x86_64-efi/squash4.mod
./install/filesystem.squashfs
./pool/main/l/linux/squashfs-modules-3.13.0-24-generic-di_3.13.0-24.46_amd64.udeb

@Joshua, right, so you'd be seeing a different issue then. Is that generated image also failing to install completely? If so, which options do you choose in the installer? Do you preseed anything?

I've opened a task for usb-creator since there does appear to be a case in which this is the source of issues -- when installing a desktop image first to a usb drive, then installing the server image to the same key without hitting "Erase disk", then the casper/ directory is left around and confuses the server install. It's assigned to me, that particular fix will be uploaded shortly.

Changed in usb-creator (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

Hum, since it seems we may be talking about multiple different issues, I've filed a separate bug specifically for the usb-creator issues I was able to reproduce. That's now at bug 1450597.

Changed in usb-creator (Ubuntu):
status: In Progress → Incomplete
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
Joshua Kugler (jkugler) wrote :

@Mathieu

I don't remember my exact install options, but it wasn't a custom pre-seed. I don't have a system on which to test right now, but yes, I erased the disk every time before I created an install disk.

Don't get me wrong, the workarounds listed are fine, but they shouldn't be required.

@Joshua; I'd still like to understand what happens if possible. Have you verified that the image you downloaded was complete and not corrupted, using md5sum? (and not the check integrity, which has issues of its own that we'll also need to fix)

Changed in debian-installer (Ubuntu):
status: Confirmed → Incomplete
V字龍(Vdragon) (vdragon) wrote :

Hi, there's someone in ubuntu-tw community can also reproduce this issue.

## Environment
windows 7 x64 (HOST) Ubuntu 15.04 server amd64 (Guest) VMware Workstation 11.1.0 build-2496824

According to the user the ISO image is complete(both checksummed using host/media utility)

Changed in debian-installer (Ubuntu):
status: Incomplete → Confirmed
Peter Slump (pnhers) wrote :

Found the same issue with my HP Proliant ML150 G6 server. Thanks to Chris Ball's workaround as described in #22 I've past the point where the error occurred.

Changed in usb-creator (Ubuntu):
status: Incomplete → In Progress
Jurriaan Bremer (jbr-u) wrote :

Small acknowledgement that the workaround described in #22 works like a charm on a HP ProLiant G7 that's being setup with a USB stick.

Martin Vysny (vyzivus) wrote :

I have used Desktop image with the Startup Disk Creator first, then overwritten that with the Server image. Upon installing from such usb stick, the initramfs failed to install. Fixed this by formatting the USB stick and then only using the Server image. Thank you all for your helpful comments.

Joseph Ishac (jishac) wrote :

I can confirm #38 (cyphermox) still applies to 14.04.04. Had a 14.04.04 desktop install and created a server install on the same stick without erasing it first. Ran into the "busybox-initramfs" failing to install issue as some others in this thread have.

Issue was resolved by erasing the install stick as described in:
https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/1450597

Install then went smoothly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers