Default 14.04 server installation fails with error 'busybox-intramfs cannot be installed'

Bug #1312586 reported by Otto Kekäläinen on 2014-04-25
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Unassigned

Bug Description

I tried to install using the official Ubuntu 14.04 server installation image. In the installation I selected as partition layout LVM with automatic partitioning. User details and other input didn't have anything special. At the end to the copying files to disk -stage the process stopped with the error message "Package busybox-intramfs cannot be installed".

I've attached real screenshots of the error message and the output on console 4, which indicate that the root cause was in the base-install or in-target stages.

I rebooted the machine and started the installation from scratch, and it stopped in the same result. Thus this seems like a repeatable bug and worth filing.

As I was unable to get the installation done using the server image I installed Lubuntu. Using Lubuntu I also selected as partition layout LVM with automatic partitioning. Lubuntu installation finished successfully, so this bug does not affect Ubiquity or other parts of LVM nor did it have anything to do with hardware or other parts of Ubuntu. I've also checked the MD5 on the installation image that it was not corrupt.

I'd love to help but unfortunately I cannot re-install this machine or access it's logs again, so I can't do more debugging.

Bug #1117292 seems similar, but in my case the installation failed out-of-the-box, installation was not preseeded and it was not random but repeatable.

Otto Kekäläinen (otto) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I tried this using an amd64 iso of Ubuntu server today without any issues. Did you try installing from a CD or from a USB stick? If it was a USB stick, how did you create it?

Changed in debian-installer (Ubuntu):
status: Confirmed → Incomplete
Otto Kekäläinen (otto) wrote :

I used a USB stick downloaded on a Ubuntu machine and installed using the default Ubuntu tool (usb-creator-gtk).

There are no I/O errors in the log, but the base-installer / in-target components fail to run and exit with errors. But if you cannot repeat this by selecting the LVM options, then I guess it must be something related to drivers on that IBM hardware or something.

Sergey Korablin (s-korablin) wrote :

The same for me. Cannot install from USB stick. Desktop version is installed normally without any problems.

Got the same problem installing from memory stick, but needed to install Server and not desktop, as it is a server environment. I can confirm that burning the ISO image to cd instead, I could fully install 14.04 Server without further problems.

Nathan Boley (nate-boley) wrote :

Same problem - LVM didn't fix this. I ended up installing the desktop version instead.

Dante Sun (dsun) wrote :

Same problem using USB key install server 14.04

Dante Sun (dsun) wrote :

 I only see this issue when installing from USB key. Confirmed that installing from a CD-ROM has no issues.Also installing 14.04 server AMD64 into a KVM VM doesn't have issue too.

 I am using DELL PowerEdge R420 server.

Changed in debian-installer (Ubuntu):
status: Incomplete → Confirmed
psnizek (psnizek-i) wrote :

Same problem here with an USB stick. The installation fails. Needed to go for the desktop version :-(
This bug that prevents admins to install Ubuntu 14.04 Server Edition on a server got confirmed on April 26, 2014.
Interesting that Canonical didn't solve it until now....

Michael Speth (conzar) wrote :

I get the same error trying to install Ubuntu 14.0.4.1 server via USB. Installing through DVD works.

This bug looks a lot like an issue caused by a badly-generated USB key. It's not impossible there was a problem with usb-creator itself, if that's what everyone was using to create the USB keys.

I'd be curious to see; what happens if you create the USB key using dd or mkusb instead? See https://help.ubuntu.com/community/mkusb#Quick_start_manual_and_mkusb_PPA.

Changed in debian-installer (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
Otto Kekäläinen (otto) wrote :

I tested installing Ubuntu server 14.04.2 on a new machine with a new USB stick, and every time it still failed. This time I managed to track down the root cause: the ubuntu-14.04.2-server-amd64.iso contains symbolic links, and these links are lost when the iso image is written to a bootable USB disk as the FAT32 filesystem does not support POSIX links.

The links in question are these (browsing from a loop mounted iso image):

install/netboot$ ll
yhteensä 7
dr-xr-xr-x 1 root root 2048 tammi 22 14:56 ./
dr-xr-xr-x 1 root root 2048 helmi 18 21:46 ../
lr-xr-xr-x 1 root root 33 tammi 22 14:56 pxelinux.0 -> ubuntu-installer/amd64/pxelinux.0
lr-xr-xr-x 1 root root 35 tammi 22 14:56 pxelinux.cfg -> ubuntu-installer/amd64/pxelinux.cfg/
dr-xr-xr-x 1 root root 2048 tammi 22 14:56 ubuntu-installer/
-r--r--r-- 1 root root 58 tammi 22 14:56 version.info
otto@XPS-L322X:~/Lataukset/mnt/install/netboot$ ll ubuntu-installer/amd64/
yhteensä 27792
dr-xr-xr-x 1 root root 2048 tammi 22 14:56 ./
dr-xr-xr-x 1 root root 2048 tammi 22 14:56 ../
dr-xr-xr-x 1 root root 4096 tammi 22 14:56 boot-screens/
-r--r--r-- 1 root root 22073953 tammi 22 14:56 initrd.gz
-r--r--r-- 2 root root 6347032 tammi 22 14:56 linux
-r--r--r-- 1 root root 26720 tammi 22 14:56 pxelinux.0
dr-xr-xr-x 1 root root 2048 tammi 22 14:56 pxelinux.cfg/
otto@XPS-L322X:~/Lataukset/mnt/install/netboot$ ll ubuntu-installer/amd64/pxelinux.cfg/
yhteensä 4
dr-xr-xr-x 1 root root 2048 tammi 22 14:56 ./
dr-xr-xr-x 1 root root 2048 tammi 22 14:56 ../
lr-xr-xr-x 1 root root 28 tammi 22 14:56 default -> ../boot-screens/syslinux.cfg

I fixed it now by copying manually all files that didin't exist due to broken links:

cd /media/04A1-26A8/install/netboot/
cp ubuntu-installer/amd64/pxelinux.0 .
mkdir pxelinux.cfg
cp ubuntu-installer/amd64/boot-screens/syslinux.cfg pxelinux.cfg/default

Otto Kekäläinen (otto) wrote :

Nope. In the comment above I did fix it so that the installation disk integrity check now passes fully (as all files are found as expected) but the original installation fail remains.

It is still impossible to install Ubuntu server 14.04 using a USB stick and showing the same screens as in the screenshots https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1312586/+attachment/4096186/+files/2014-04-24%2015.05.44.jpg

William Corrie (bilbo-9) wrote :

I have the same issue. I have used multiple usb sticks with usb-creator and unetbootin. This is on a Dell CS24-SC Server.

This appears to be caused (at least, as reported to me by Marc Deslauriers) by stray files left over from a previous Desktop image copy on the USB drive; if it has not been formatted before writing the Server image files to the drive.

If you're seeing this issue and are able to reproduce it easily with your USB drive, please see if you have a "casper" directory on the USB drive, if that drive has been configured to contain a server installation image. The casper directory can be removed from a USB drive if it's meant to be used to install the Ubuntu Server (and only Ubuntu Server; the Ubuntu Desktop installer *requires* that directory and will fail if it's not there).

Gerry Duprey (gerry-e) wrote :

The problem was that the ISO image isn't designed to be used with unnetbootin or the USB creator tools. Instead, a direct dd to the USB device is all you need.

dd if=ubuntu-14.04.2-server-amd64.iso of=/dev/sdb bs=16M

(obviously, replace /dev/sdb with your USB key, but don't use any partitions (i.e. don't use /dev/sdb1, /dev/sdb2, etc -- just the whole device)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers