usb-creator allows leftover squashfs data from other images

Bug #1450597 reported by Mathieu Trudel-Lapierre on 2015-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]
Users of usb-creator do not necessarily always hit "Erase Disk" in usb-creator before having it copy a new image to a USB drive. This can lead to leftover files which interfere with the installation process. For example, a casper/filesystem.squashfs file from the desktop image will confuse server installations and cause them to fail in various ways since it may not contain everything required by d-i to do the server installation. This is traditionally experienced as a "apt-install or in-target are already running" error message in syslog (and accompanying failure) sometime during the install.

[Test Case]
Requires: a blank usb drive.
1- Install any recent Desktop image to a USB drive with usb-creator
2- Immediately install a Server image to the same USB drive with usb-creator
3- Run the server install

Expected result:
The installation should complete successfully.

Result without the fix:
The installation fails to complete. "apt-install or in-target is already running..." messages appear in syslog.

[Regression Potential]
This forcibly directories known to contain squashfs filesystem data used by Debian and Ubuntu installers and live images. These directories are (at the time this bug is filed) defined as "casper" for desktop images, "install" for server images, and "live" in Debian. Since the entire directory is removed; any files previously copied there by a user making use of the USB drive's structure coming from install or live images will be deleted.

Related branches

Marc Deslauriers (mdeslaur) wrote :
Changed in usb-creator (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.3.0

---------------
usb-creator (0.3.0) xenial; urgency=medium

  [ Marc Deslauriers ]
  * Rework the whole imaging process for writing to devices:
    - Use an equivalent of dd to make an exact copy of the image to the device
    - This also breaks persistence.

  [ Mathieu Trudel-Lapierre ]
  * Update UI and frontend code to drop the persistence widgets.
  * Drop Erase Disk widgets too.

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 11 Dec 2015 12:37:41 -0500

Changed in usb-creator (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers