gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()

Bug #376145 reported by Martin Olsson on 2009-05-13
This bug affects 527 people
Affects Status Importance Assigned to Milestone
D-Bus
Fix Released
High
gvfs
Fix Released
Critical
dbus (Ubuntu)
High
Martin Pitt
Karmic
High
Martin Pitt

Bug Description

Binary package hint: gvfs

crash

ProblemType: Crash
Architecture: i386
Date: Wed May 13 18:56:52 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/gvfs/gvfs-gdu-volume-monitor
Package: gvfs-backends 1.3git20090512-0ubuntu1
ProcCmdline: /usr/lib/gvfs/gvfs-gdu-volume-monitor
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_DK.UTF-8
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 gdu_pool_get_presentables () from /usr/lib/libgdu.so.0
 ?? ()
 ?? ()
 IA__g_object_newv (object_type=135547960, n_parameters=0,
 IA__g_object_new_valist (object_type=135547960,
Title: gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
Uname: Linux 2.6.30-5-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video
SegvAnalysis:
 Segfault happened at: 0x92cfda <gdu_pool_get_presentables+26>: mov 0xc(%eax),%eax
 PC (0x0092cfda) ok
 source "0xc(%eax)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA

Related branches

Martin Olsson (mnemo) wrote :
Martin Olsson (mnemo) on 2009-05-13
visibility: private → public

StacktraceTop:gdu_pool_get_presentables () from /usr/lib/libgdu.so.0
update_all (monitor=0x8146420,
g_gdu_volume_monitor_constructor (type=135547960,
IA__g_object_newv (object_type=135547960, n_parameters=0,
IA__g_object_new_valist (object_type=135547960,

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=582579

Changed in gvfs (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
Changed in gvfs:
status: Unknown → New
Didius Falco (pagun666) wrote :

This crash happened while downloading a file from a web site in Firefox. The only other thing open at the time was a Bash shell, which was not in use.

There were no effects other than the bug report window opening. I'm still in the same session and it is stable.

I'm new at reporting bugs, so please feel free to let me know if there is any other information I can add to help with this.

Regards,

Didius

Sebastien Bacher (seb128) wrote :

not easy to say since the other bug has not been opened using apport crash informations

Steve Dodd (anarchetic) wrote :

I seem to have steps to reproduce this listed in bug #377426.

Didius Falco (pagun666) wrote :

This crashed when I loaded Update Manager. Apport reported that it was an invalid bug since I needed to update two files. Those two files were part of the update.

Update Manager did not advise a restart, so I did not do so.

It has crashed again after the update.

Matt Walker (matthaeus123) wrote :

I always have this happen when loading soundconverter.

Didius Falco (pagun666) wrote :

Just received kernel update to 2.6.30-6. This crash has not happened in the last week. Update Manager crashed at start up.

Mehdi Abaakouk (sileht) wrote :

I have noticed gvfs-gdu-volume-monitor doesn't crash if the package "devicekit-disks" are installed
gvfs-gdu-volume-monitor crash only if no programme provide the dbus service "org.freedesktop.DeviceKit.Disks.service".

Angel Guzman Maeso (shakaran) wrote :

Same for me (several times) with karmic 2.6.30-7-generic:

Jun 4 17:03:16 otorion kernel: [ 6203.155115] nautilus[4826]: segfault at 0 ip (null) sp bf9d618c error 4 in liblaunchpad-integration.so.1.0.0[110000+3000]
Jun 4 17:03:17 otorion kernel: [ 6203.783958] gvfs-gdu-volume[6809]: segfault at c ip 0052ffda sp bfe22ef0 error 4 in libgdu.so.0.0.0[527000+22000]

Didius Falco (pagun666) wrote :

Mehdi Abaakouk's solution has resolved this issue for me - Thanks Mehdi!!

Sebastien Bacher (seb128) wrote :

gvfs (1.3git20090512-0ubuntu2) karmic; urgency=low

  * debian/control.in:
    - depends on devicekit-disks

Changed in gvfs (Ubuntu):
status: Triaged → Fix Released
Don Zavitz (dzavitz) wrote :

ok launchpad sas a fix was released, has it made it to updates yet? i just updated my system and rebooted and am affected by the bug...

Roy Jamison (xteejx) wrote :

It should be now, my apt says the version I currently have installed is 1.3git20090512-0ubuntu2 which is the version Sebastian says it was fixed in, try updating again, it should be fine. :)

Eyad Salah (eyad-salah) wrote :

I don't know about that. I had just updated my system just minutes before I started Transmission.. a Couple of minutes later it crashed.

Roy Jamison (xteejx) wrote :

ComputerJy, can you confirm that the version you are using is the above?

Eyad Salah (eyad-salah) wrote :

Sorry for the late response. My gvfs version is: 1.3git20090512-0ubuntu2.

So I guess, yes I have the latest version installed

Roy Jamison (xteejx) wrote :

I am unable to make gvfs crash.
@ComputerJy: Can you give full step by step instructions as to how it crashes for you, and what steps I need to take to do the same as you do up to the point it crashes. Also can you run
apport-collect -p linux-image-`uname -r` 376145
and let it collect your system information, allowing it full access to Launchpad. Thank you.

Eyad Salah (eyad-salah) wrote :

I've done the second part but it's saying "you should go back to the application window in which you started the process and inform it that you have done your part of the process". I have no idea what does that mean.

Anyway, I just start transmission, go to the Preferences window I get the error:
"(transmission:5581): Gtk-CRITICAL **: gtk_tree_sortable_set_sort_column_id: assertion `GTK_IS_TREE_SORTABLE (sortable)' failed

(transmission:5581): Gtk-CRITICAL **: gtk_tree_sortable_set_sort_column_id: assertion `GTK_IS_TREE_SORTABLE (sortable)' failed"
 But it doesn't cause any problems. Then switch to the Network tab try changing the port, click "Test Port", wait till it's done, then click it again, while it's doing the test just close the preferences dialog. Give a couple of seconds until the test is complete and you've got your error "Segmentation fault (core dumped)"

Architecture: i386
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=7d13ed99-8bb1-428b-8b80-a77af8041220
MachineType: Dell Inc. Precision M65
NonfreeKernelModules: nvidia
Package: linux-image-2.6.30-9-generic 2.6.30-9.10
PackageArchitecture: i386
ProcCmdLine: root=UUID=815db385-b012-46b6-b15e-d3bd54fe795c ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.30-9.10-generic
RelatedPackageVersions: linux-backports-modules-2.6.30-9-generic N/A
Uname: Linux 2.6.30-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/03/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0JF242
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd04/03/2007:svnDellInc.:pnPrecisionM65:pvr:rvnDellInc.:rn0JF242:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Precision M65
dmi.sys.vendor: Dell Inc.

Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :
Eyad Salah (eyad-salah) wrote :

ComputerJy - your issue is with transmission, and is completely unrelated to
this gvfs issue. I'm slightly puzzled why you thought they were the same
issue.

You should open a new bug report for transmission, by submitting a crash
report using apport when it crashes

On Jun 20, 2009 3:20 PM, "ComputerJy" <email address hidden> wrote:

I've done the second part but it's saying "you should go back to the
application window in which you started the process and inform it that
you have done your part of the process". I have no idea what does that
mean.

Anyway, I just start transmission, go to the Preferences window I get the
error:
"(transmission:5581): Gtk-CRITICAL **: gtk_tree_sortable_set_sort_column_id:
assertion `GTK_IS_TREE_SORTABLE (sortable)' failed

(transmission:5581): Gtk-CRITICAL **: gtk_tree_sortable_set_sort_column_id:
assertion `GTK_IS_TREE_SORTABLE (sortable)' failed"
 But it doesn't cause any problems. Then switch to the Network tab try
changing the port, click "Test Port", wait till it's done, then click it
again, while it's doing the test just close the preferences dialog. Give a
couple of seconds until the test is complete and you've got your error
"Segmentation fault (core dumped)"

-- gvfs-gdu-volume-monitor crashed with SIGSEGV in
gdu_pool_get_presentables() https://bugs.launch...

Eyad Salah (eyad-salah) wrote :

I started this bug report and someone assigned it to gvfs (Not me). And the error I'm getting is about gvfs. Those 2 lines just appear on the cli.. They don't have any effects.

Chris Coulson (chrisccoulson) wrote :

Yes, the original report was a gvfs crash, which you submitted using Apport. The information you've provided about your other problem suggests that it is transmission crashing, which is completely unrelated to this bug report.

Eyad Salah (eyad-salah) wrote :

:D I've filed more than 50 error reports this month (I know it's an Alpha and I have no problem I love it) So maybe I got mixed up between tickets..

Sorry :)

Alexey Kotlyarov (koterpillar) wrote :

With devicekit-disks installed, and gvfs version 1.3git20090512-0ubuntu2, this is still happening.

Chris Coulson (chrisccoulson) wrote :

ComputerJy - no worries.

Koterpillar - if you think you're still experiencing this same issue, please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. That's the only way to know if it is the same issue

Steve Dodd (anarchetic) wrote :

I've just seen this in VBox using an alternate CD install (using today's snapshot - 20090621):

Jun 21 21:33:04 ubuntu kernel: [ 152.508292] gvfs-gdu-volume[3546]: segfault at c ip 003ebfda sp bfc4d680 error 4 in libgdu.so.0.0.0[3e3000+22000]

For some reason apport is still disabled by default with an alternate CD install, and I haven't managed to reproduce this since I enabled it. It seemed to happen immediately after start-up / login.

I can conform devicekit-disks is installed.

I have installed the debugging symbols, but the single crash (so far)
was upon logging into Gnome session, and I can't reproduce it yet.

Changed in gvfs (Ubuntu):
status: Fix Released → Triaged
Sense Egbert Hofstede (sense) wrote :

I can confirm this too on Karmic.
Curiously HALd also refuses to start.

The error message telling gvfs-gdu-volume crashed comes very soon after logging in, together with an error message about bzr-notify crashing, as reported in bug #391158.

Running 'sudo hald --verbose=yes' gives no error messages, neither does running 'sudo /etc/init.d/hal start', even though its status is not running.

Running '/usr/lib/gvfs/gvfs-gdu-volume-monitor' doesn't give you the next emtpy line in the console, but doesn't output anything at all.

Both hal and gvfs-gdu-volume-monitor don't show up at all when you try to run them manually. The only remaining process with hal in it was gvfs-hal-volume(something?).

I can confirm on Karmic amd64. Just after booting it crashed.

Sebastien Bacher (seb128) wrote :

the recent comments were probably crash due to the libudev breakage which made devkit-disks crash and the gdu code too

Sense Egbert Hofstede (sense) wrote :

After an update for udev earlier today the problem seems to have gone. Sound works again and the error isn't raised by Apport. Hal, however, still refuses to run, 'sudo /etc/init.d/hal status' tells me so.

Maybe it was indeed related to udev, I'll keep my eyes open for returning symptoms.

Changed in gvfs:
status: New → Confirmed
Angel Guzman Maeso (shakaran) wrote :

The same crash again today. I have the lastest updates.

George Pollard (porges) wrote :

Just got this upon logging in to Karmic. Updates current as of yesterday.

SpmP (scarletpimpernal) wrote :

problem resolved upon dist upgrade last night
with gvfs* 1.3.4-0ubuntu1

Architecture: i386
DistroRelease: Ubuntu 9.10
Package: gvfs 1.3.5-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-7.27-generic
Uname: Linux 2.6.31-7-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Rami Al-Rfou' (rmyeid) wrote :
tags: added: apport-collected
jbell (bell3180) wrote :

I have a problem with the "gvs" package on start up. On one startup "5 "Nautilas" messages appeared on the lower task bar, one at a time. This time the machine hung up. I re-stared and after a short delay the machine came up running, with the "error message" to report to "Launch Pad". There were two reports, I sent both.

zoomy942 (zoomy942) wrote :

I got this this morning on Karmic wth current updates.

Download full text (4.6 KiB)

This bug happens to me too. Someone said this bug not happens if devicekit-disks is installed, but happened to me just after the https://bugs.launchpad.net/ubuntu/+source/devicekit-disks/+bug/403192

To get short, same report from the bug upside plus my gvfs version:

leleobhz@luana:~$ LANG=C dpkg -l devicekit-disks gvfs ; sudo lshw -short ; stat /var/lib/apt/lists/br.archive.ubuntu.com_ubuntu_dists_karmic_main_binary-i386_Packages
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-===================-===================-======================================================
ii devicekit-disks 006-0ubuntu3 abstraction for enumerating block devices
ii gvfs 1.3.5-0ubuntu1 userspace virtual filesystem - server
H/W path Device Class Description
=========================================================
                                  system Inspiron 910
/0 bus BR0F29
/0/1 memory 100KiB BIOS
/0/5 processor Intel(R) Atom(TM) CPU N270 @ 1.60GHz
/0/5/6 memory 32KiB L1 cache
/0/5/7 memory 512KiB L2 cache
/0/5/0.1 processor Logical CPU
/0/5/0.2 processor Logical CPU
/0/10 memory 1GiB System Memory
/0/10/0 memory 1GiB SODIMM DDR2 Synchronous 533 MHz (1.9 ns)
/0/100 bridge Mobile 945GME Express Memory Controller Hub
/0/100/2 display Mobile 945GME Express Integrated Graphics Controller
/0/100/2.1 display Mobile 945GM/GMS/GME, 943/940GML Express Integrated Grap
/0/100/1b multimedia 82801G (ICH7 Family) High Definition Audio Controller
/0/100/1c bridge 82801G (ICH7 Family) PCI Express Port 1
/0/100/1c/0 generic SD/MMC Host Controller
/0/100/1c/0.2 generic Standard SD Host Controller
/0/100/1c/0.3 generic MS Host Controller
/0/100/1c.1 bridge 82801G (ICH7 Family) PCI Express Port 2
/0/100/1c.1/0 eth1 network BCM4312 802.11b/g
/0/100/1c.2 bridge 82801G (ICH7 Family) PCI Express Port 3
/0/100/1c.2/0 eth0 network RTL8101E/RTL8102E PCI Express Fast Ethernet controller
/0/100/1d bus 82801G (ICH7 Family) USB UHCI Controller #1
/0/100/1d.1 bus 82801G (ICH7 Family) USB UHCI Controller #2
/0/100/1d.2 bus 82801G (ICH7 Family) USB UHCI Controller #3
/0/100/1d.3 bus 82801G (ICH7 Family) USB UHCI Controller #4
/0/100/1d.7 bus 82801G (ICH7 Family) USB2 EHCI Controller
/...

Read more...

Loïc Minier (lool) wrote :

I get that with latest karmic virtualbox running latest UNR daily (alpha 5 proposed image).

zoomy942,
  That is what i was using,English-US. It did not run well from the start.
:jbell

On 9/3/09, Loïc Minier <email address hidden> wrote:
> I get that with latest karmic virtualbox running latest UNR daily (alpha
> 5 proposed image).
>
> --
> gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
> https://bugs.launchpad.net/bugs/376145
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: Confirmed
> Status in “gvfs” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gvfs
>
> crash
>
> ProblemType: Crash
> Architecture: i386
> Date: Wed May 13 18:56:52 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/lib/gvfs/gvfs-gdu-volume-monitor
> Package: gvfs-backends 1.3git20090512-0ubuntu1
> ProcCmdline: /usr/lib/gvfs/gvfs-gdu-volume-monitor
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_DK.UTF-8
> Signal: 11
> SourcePackage: gvfs
> StacktraceTop:
> gdu_pool_get_presentables () from /usr/lib/libgdu.so.0
> ?? ()
> ?? ()
> IA__g_object_newv (object_type=135547960, n_parameters=0,
> IA__g_object_new_valist (object_type=135547960,
> Title: gvfs-gdu-volume-monitor crashed with SIGSEGV in
> gdu_pool_get_presentables()
> Uname: Linux 2.6.30-5-generic i686
> UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev
> video
>

derrick81787 (derrick81787) wrote :

This just happened to me with the latest karmic UNR. All I do is log in, and this happens.

jbell (bell3180) wrote :

Loic and Derreck; I downloaded the latest Karmic build this am,
checked the disk, and did a new clean install. My problems have been
at bootup. Todays install started to bootup and a full screen error
message appeared>*checking root file system/dev/sda1:UNEXPECTED
INCONSISTENCY; run fsck manually. fsck died with exit status 4---after
performing system maintanence, press CONTRL-D to terminate maintanence
shell and reboot system.
  I did this and Karmic,Ubu 9.10 is running and has been used to check
email, import pictures from card reader, take a screen shot, read a
newspaper online, etc.
--Bug 376145 has disappeared and this is the 5th bootup since install.---
jb

On 9/3/09, derrick81787 <email address hidden> wrote:
> This just happened to me with the latest karmic UNR. All I do is log
> in, and this happens.
>
> --
> gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
> https://bugs.launchpad.net/bugs/376145
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: Confirmed
> Status in “gvfs” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gvfs
>
> crash
>
> ProblemType: Crash
> Architecture: i386
> Date: Wed May 13 18:56:52 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/lib/gvfs/gvfs-gdu-volume-monitor
> Package: gvfs-backends 1.3git20090512-0ubuntu1
> ProcCmdline: /usr/lib/gvfs/gvfs-gdu-volume-monitor
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_DK.UTF-8
> Signal: 11
> SourcePackage: gvfs
> StacktraceTop:
> gdu_pool_get_presentables () from /usr/lib/libgdu.so.0
> ?? ()
> ?? ()
> IA__g_object_newv (object_type=135547960, n_parameters=0,
> IA__g_object_new_valist (object_type=135547960,
> Title: gvfs-gdu-volume-monitor crashed with SIGSEGV in
> gdu_pool_get_presentables()
> Uname: Linux 2.6.30-5-generic i686
> UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev
> video
>

Anthony Hook (anthonyhook) wrote :

This happened to me today on startup, latest updates of Karmic.

Thanks for the info. Is there something I need to do?

Bill

--- On Thu, 9/10/09, Anthony Hook <email address hidden> wrote:

From: Anthony Hook <email address hidden>
Subject: [Bug 376145] Re: gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
To: <email address hidden>
Date: Thursday, September 10, 2009, 1:24 PM

This happened to me today on startup, latest updates of Karmic.

--
gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
https://bugs.launchpad.net/bugs/376145
You received this bug notification because you are a direct subscriber
of the bug.

Status in gvfs: Confirmed
Status in “gvfs” package in Ubuntu: Triaged

Bug description:
Binary package hint: gvfs

crash

ProblemType: Crash
Architecture: i386
Date: Wed May 13 18:56:52 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/gvfs/gvfs-gdu-volume-monitor
Package: gvfs-backends 1.3git20090512-0ubuntu1
ProcCmdline: /usr/lib/gvfs/gvfs-gdu-volume-monitor
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_DK.UTF-8
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 gdu_pool_get_presentables () from /usr/lib/libgdu.so.0
 ?? ()
 ?? ()
 IA__g_object_newv (object_type=135547960, n_parameters=0,
 IA__g_object_new_valist (object_type=135547960,
Title: gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
Uname: Linux 2.6.30-5-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

mycl (415fox) wrote :

Is anyone else with this problem running Jungledisk? Although Jungledisk is still running after the crash (on login) it's the only non-standard thing about my volumes. It uses FUSE.

Have this problem too. It happened while running synaptic. Latest updates are installed.

wdcourter (wdcourter) wrote :

I just got the following crash:

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: http://mail.yimg.com/d/combo?/mg/6_1_1/js/yui_utils.js&/mg/6_1_1/js/core.js&bc/bc_2.0.4.js&/mg/6_1_1/js/darla.js&/uh/15/js/uh_mail-1.0.11.js&/mg/6_1_1/js/async.js&/ult/ylc_1.9.js&:1

Apport said it could not report this. How do I report this?

Thanks,

Bill

--- On Sat, 9/12/09, Thorsten Reinbold <email address hidden> wrote:

From: Thorsten Reinbold <email address hidden>
Subject: [Bug 376145] Re: gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
To: <email address hidden>
Date: Saturday, September 12, 2009, 12:29 PM

Have this problem too. It happened while running synaptic. Latest
updates are installed.

--
gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
https://bugs.launchpad.net/bugs/376145
You received this bug notification because you are a direct subscriber
of the bug.

Status in gvfs: Confirmed
Status in “gvfs” package in Ubuntu: Triaged

Bug description:
Binary package hint: gvfs

crash

ProblemType: Crash
Architecture: i386
Date: Wed May 13 18:56:52 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/gvfs/gvfs-gdu-volume-monitor
Package: gvfs-backends 1.3git20090512-0ubuntu1
ProcCmdline: /usr/lib/gvfs/gvfs-gdu-volume-monitor
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_DK.UTF-8
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 gdu_pool_get_presentables () from /usr/lib/libgdu.so.0
 ?? ()
 ?? ()
 IA__g_object_newv (object_type=135547960, n_parameters=0,
 IA__g_object_new_valist (object_type=135547960,
Title: gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
Uname: Linux 2.6.30-5-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

Download full text (3.8 KiB)

<email address hidden>; I believe some of my problems with BUG 376145 is
hardware related. I got the black screen with curser blinking on
bootup last am. Did a clean new install on my(mfg,1/06) HP-Compaq
nx6110 laptop using 3Sep09 build. On bootup did manual fsck, came
running.Did "update/partial upgrade" with "update manager". Did 5
bootups with one task each. No problems. Have put in 6hrs using the
machine processing pictures, internet research, email, usb drives,
hisrorical research, Oo3 Writer, and Presentations. Ubuntu 910 is
running well on this laptop.
Display is excellent, pages centered, power management is excellent.
Firefox3 is excellent. All systems go at this time.

On 9/12/09, wdcourter <email address hidden> wrote:
> I just got the following crash:
>
> A script on this page may be busy, or it may have stopped responding.
> You can stop the script now, or you can continue to see if the script
> will complete.
>
> Script:
> http://mail.yimg.com/d/combo?/mg/6_1_1/js/yui_utils.js&/mg/6_1_1/js/core.js&bc/bc_2.0.4.js&/mg/6_1_1/js/darla.js&/uh/15/js/uh_mail-1.0.11.js&/mg/6_1_1/js/async.js&/ult/ylc_1.9.js&:1
>
> Apport said it could not report this. How do I report this?
>
> Thanks,
>
>
> Bill
>
> --- On Sat, 9/12/09, Thorsten Reinbold
> <email address hidden> wrote:
>
> From: Thorsten Reinbold <email address hidden>
> Subject: [Bug 376145] Re: gvfs-gdu-volume-monitor crashed with SIGSEGV in
> gdu_pool_get_presentables()
> To: <email address hidden>
> Date: Saturday, September 12, 2009, 12:29 PM
>
> Have this problem too. It happened while running synaptic. Latest
> updates are installed.
>
> --
> gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
> https://bugs.launchpad.net/bugs/376145
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: Confirmed
> Status in “gvfs” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gvfs
>
> crash
>
> ProblemType: Crash
> Architecture: i386
> Date: Wed May 13 18:56:52 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/lib/gvfs/gvfs-gdu-volume-monitor
> Package: gvfs-backends 1.3git20090512-0ubuntu1
> ProcCmdline: /usr/lib/gvfs/gvfs-gdu-volume-monitor
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_DK.UTF-8
> Signal: 11
> SourcePackage: gvfs
> StacktraceTop:
> gdu_pool_get_presentables () from /usr/lib/libgdu.so.0
> ?? ()
> ?? ()
> IA__g_object_newv (object_type=135547960, n_parameters=0,
> IA__g_object_new_valist (object_type=135547960,
> Title: gvfs-gdu-volume-monitor crashed with SIGSEGV in
> gdu_pool_get_presentables()
> Uname: Linux 2.6.30-5-generic i686
> UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev
> video
>
> --
> gvfs-gdu-volume-monitor crashed with SIGSEGV in gdu_pool_get_presentables()
> https://bugs.launchpad.net/bugs/376145
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: Confirmed
> Status in “gvfs” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gvfs
>
> crash
>
> ProblemType: Crash
> Architecture: i386
> Date: Wed May 13 18:56:52 2009
> DistroRelease: Ubunt...

Read more...

Kees Cook (kees) on 2009-09-17
description: updated
Changed in gvfs (Ubuntu Karmic):
importance: Medium → High
Chris Coulson (chrisccoulson) wrote :

Could someone here experiencing this bug please attach their ~/.xsession-errors file to this bug report straight after they experience this crash?

Thanks

Changed in gvfs (Ubuntu Karmic):
status: Triaged → Incomplete
Սահակ (petrosyan) wrote :
Changed in gvfs (Ubuntu Karmic):
status: Incomplete → Triaged

i cant reproduce :\

Sense Egbert Hofstede (sense) wrote :

It seems to be gone here as well.

Martin Pitt (pitti) wrote :

I got it about a week ago, but it's gone for me as well. Does anyone still get this on current Karmic? We also got a new devicekit-disks and g-d-u yesterday which fix a slew of bugs.

Changed in gvfs (Ubuntu Karmic):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Martin Pitt (pitti)
status: Triaged → Incomplete
Martin Pitt (pitti) wrote :

I booted my computer/restarted my session several times today, it's gone. Closing for now.

I'll watch out for further duplicates of this. Thanks!

Changed in gvfs (Ubuntu Karmic):
status: Incomplete → Fix Released
Ilmari Vacklin (wolverian) wrote :

I got this on login today. Not sure if apport uploaded anything.

jbell (bell3180) wrote :

I booted at least five times today. Checked installed "gvfs" packages= 1.4.0 Obuntu1 and device kit-disks = 007-Oubuntu1. Karmic 9.10 is running well.

Oliver Grawert (ogra) wrote :

reopening ...

i am seeing this on armel imx51 on the installed system from the beta image happens frequently (not each time) directly after booting. it doesnt happen on the live image

Changed in gvfs (Ubuntu Karmic):
status: Fix Released → Confirmed
James Westby (james-w) wrote :

I've been looking at what we think is the cause of this and other bugs tonight
with Chris.

I've been using gdu-notification-daemon, but we think it is the same root cause,
a timeout on the GetAll call in the gnome-disk-utility code.

Based on Chris' idea we added sleep(5) call to devicekit-disks-daemon as the
first thing it does. This makes the issue more reproducible. Given that at startup
the system is loaded it makes sense that longer time to execute causes the issue.

This sleep is under the 25 seconds timeout that the activation has (different
to the call timeout), so that's not likely to be kicking in (barring accounting
bugs), and even if it does it should give an error response, not cause a call
timeout client-side.

This reliably gives a client-side timeout with the default timeout. We tweaked
that timeout to see what happens.

  * On my machine it is around a 20.15 second timeout that you get the switch.
    Less than this and it times out, more and it works.
  * The time taken to get the timeout error, and the time taken to get the call
     return are ~about equal at 5.something seconds, nowhere near the actual
     timeout specified.
  * Reducing the sleep to 3 seconds doesn't have a linear effect on the issue.
    You have to reduce the timeout by a lot more than 2 seconds to see the failures
    there. I haven't investigated this relationship further or looked for discontinuities.

My current suspicion is that this is a D-Bus bug. Some sort of error means that
when it gets the real response it instead returns the timeout response when the
specified timeout is less than some threshold. I'm not sure why there seems to
be a relationship between that threshold and the amount of time that it takes to
start the service though.

Please bear in mind that this is just my blind pokings, and that nothing I say
should be taken as fact. It may well be that this is the wrong tree to be barking
up in some way.

Thanks,

James

James Westby (james-w) wrote :

"This reliably gives a client-side timeout with the default timeout".

No, it doesn't. Though I thought I was seeing this to start with. Even
more confusing, unless it was just a figment of my imagination.

Thanks,

James

Chris Coulson (chrisccoulson) wrote :

For those who might be interested, here's some of the irclog of the discussions (there might be other conversations mixed in there too)

Hi,

We were getting a lot of crashes related to devicekit-disks on startup.

Chris Coulson correctly deduced that this was due to activation, and found
a way to make the problem reproducible.

The problem is this:

  * D-Bus activated service that is slow to start.
  * Call to that service with a timeout not too far removed from
    time it takes to start the service, but still higher. (e.g. 5s vs 16s)
  * The caller gets a timeout error that comes back to them in
    a time that is close to the time that it takes to start the
    service, even though the service is correctly started.

The cause is this:

  * In _dbus_connection_block_pending_call the elapsed time is counted
    from the start of the block.
  * Every time a message is received this elapsed time is subtracted from
    the total timeout.
  * This means that the timeout is hit much quicker than it should be.

What happens is:

  * The service takes 5s to start, so elapsed_milliseconds is ~5000.
  * There are a number of messages received before the response, in this
    case 3 NameOwnerChanged signals.
  * For each of these the timeout is reduced by about 5000 milliseconds.
  * The real response then comes back. The timeout left is compared against
    the elapsed time, and if it is less the timeout error is returned.
  * So, in this case 3x5000 for the NameOwnerChanged signals leaves ~1000
    left when the response comes back, so it thinks it has timed out, even
    though it's only about 5s in to the 16s timeout.

Therefore this bug will be hit when you are activating the service and

   (time to activate serive) * (number of messages received in that time) > (timeout)

so it explains the non-linearities. Also, the lack of non-determinism in the testing explains why I was able to pinpoint the threshold timeout quite so accurately, and the non-determinism at boot probably explains why some people
see it and some people don't.

The attached patch fixes this by:

  * Not subtracting the elapsed time from the total time, just comparing them.
  * When a timeout is needed for other calls, using the difference so that
    their timeout is the remaining time.
  * Using the already calculated elapsed_milliseconds in the _dbus_verbose at
    end, as we already have the value, and the fact that it wasn't being re-used
    muddied the debugging waters slightly.

Please consider applying this patch. We will probably ship it in the Ubuntu package after review as so many people are hitting this bug.

Thanks,

James

Created an attachment (id=29976)
Patch to fix timeout accounting

Patch looks good.

Can you make that a Git commit and attach it (git format-patch -n1) ?

I think I got nearest to that code last, and it looks right to me

James Westby (james-w) on 2009-10-01
affects: gvfs (Ubuntu Karmic) → dbus (Ubuntu Karmic)
James Westby (james-w) wrote :

Here's my proposed fix for this issue. See the upstream DBus bug for full
rationale.

Thanks,

James

Changed in dbus:
status: Unknown → Confirmed
Changed in dbus:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dbus - 1.2.16-0ubuntu8

---------------
dbus (1.2.16-0ubuntu8) karmic; urgency=low

  * Add debian/patches/11_timeout_handling.patch:
    - Fix timeout accounting. The elapsed_milliseconds contains the time
      from the start, so subtracting it on every iteration means that the
      timeout is much less than what is requested. Instead compare the
      absolute values, but pass the difference to calls which want a timeout
      so that the correct remaining time is used. (LP: #376145)
      Thanks to Chris Coulson for his help in tracking this down.

 -- James Westby <email address hidden> Thu, 01 Oct 2009 14:10:51 +0100

Changed in dbus (Ubuntu Karmic):
status: Confirmed → Fix Released

Hi, I just received this crash on startup and I have 1.2.16-0ubuntu8 of dbus installed.

Changed in dbus (Ubuntu Karmic):
status: Fix Released → Confirmed
Chris Coulson (chrisccoulson) wrote :

It would be better if you could get a backtrace of the crash before re-opening this bug report, or submitting it via Apport instead. There is no other way to be 100% sure you're experiencing the same bug otherwise.

Changed in dbus (Ubuntu Karmic):
status: Confirmed → Fix Released
Renzo (spigolon) on 2009-10-17
Changed in dbus (Ubuntu Karmic):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
kseise (kevin-seise) wrote :

Just happened while using the 9.10 64bit live cd to install. I was formatting a partition and using firefox at the time.

I have 1.2.16-0ubuntu9 of dbus installed, but this crash continues to happen just after startup

tags: added: iso-testing
zob (zob) wrote :

This happens in ubuntu netbook remix 10.04 with 1.2.16-2ubuntu2 on my eeepc 701, kernel 2.6.32-13-generic-pae,

Changed in dbus:
importance: Unknown → High
Changed in gvfs:
importance: Unknown → Critical
Changed in dbus:
importance: High → Unknown
Changed in dbus:
importance: Unknown → High
Changed in gvfs:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.