Ubuntu

Comment 16 for bug 564917

HP Laserjet 4 printer has only parallel and serial ports. It does not have native USB port. I am using Prolific Technology adapter cable that has parallel connector at one end (which is connected to parallel port on printer) and USB connector at other end (which is connected to computer). This equipment setup previously worked for me on all Ubuntu releases prior to 9.10.

Removing the usblp module did not solve printing problem when HP Laserjet 4 was added as a "parallel" printer, even though it was actually connected via USB adapter cable.

I have also tried connecting HP Laserjet 4 to computer using standard parallel cable that has parallel connectors at both ends. Although printer seemed to be properly recognized and added to system, nonetheless all print jobs would still freeze for hang up in "processing" status. However, this is a different issue or problem and belongs in a different bug report, which I may or may not open as a bug report in the future,

My main concern is to try to get the printer to work with Ubuntu via USB adapter cable. The USB adapter cable offers more flexibility for me because I can also use it to connect to other computer equipment that I have, such as Apple laptop computers that are lacking in parallel ports. So far, I have encountered no problems printing out documents when my Apple laptops, running under the Mac operating system, are connected to the printer via USB adapter cable.

--- On Tue, 4/20/10, Pascal De Vuyst <email address hidden> wrote:

> From: Pascal De Vuyst <email address hidden>
> Subject: [Bug 564917] Re: Ubuntu 10.04 does not recognize local printer (HP Laserjet 4) connected via USB.
> To: <email address hidden>
> Date: Tuesday, April 20, 2010, 1:26 PM
> Does this printer have USB connection
> or only parallel connection?
> Are you using standard USB cable? lsusb shows Parallel to
> USB converter Prolific Technology, Inc. PL2305 Parallel Port
>
>
> Does it work after removing lsusb module? Open a terminal
> an run following command:
> sudo rmmod usblp
>
> --
> Ubuntu 10.04 does not recognize local printer (HP Laserjet
> 4) connected via USB.
> https://bugs.launchpad.net/bugs/564917
> You received this bug notification because you are a direct
> subscriber
> of the bug.
>
> Status in “cups” package in Ubuntu: Incomplete
>
> Bug description:
> To me, this is a serious problem that exists in Ubuntu
> 10.04 (also in 9.10). When I try to add a new printer that
> is connected via USB cable,  the "New Printer" popup
> screen only shows three options for adding local printers:
> 1) "LPT #1" for parallel connection, 2) "Serial Port #1" for
> serial connection, and 3) "Other" for devices with a URI.
> The option to add a local USB printer does not show up. In
> earlier releases, such as 8.10 and 8.04, the option to add a
> USB printer does appear, and I have had no problems doing
> so. But, for some reason or another, Ubuntu 9.10 and 10.04
> does not properly recognize the existence of USB printers
> anymore. It does not recognize my HP Laserjet 4 and probably
> fails to recognize other USB printers, too.
> ---
> Architecture: amd64
> CupsErrorLog:
> E [18/Apr/2010:09:43:44 -0600] [cups-deviced] PID 1768
> (usb) crashed on signal 11!
> E [18/Apr/2010:09:46:36 -0600] [cups-deviced] PID 1817
> (usb) crashed on signal 11!
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64
> (20100318)
> Lpstat: Error: command ['lpstat', '-v'] failed with exit
> code 1: lpstat: No destinations added.
> MachineType: Hewlett-Packard hp workstation xw8200
> NonfreeKernelModules: nvidia
> Package: cups 1.4.3-1
> PackageArchitecture: amd64
> Papersize: letter
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic
> root=UUID=cb15fc67-bc14-4617-928d-ed007709063b ro quiet
> splash
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-20.30-generic
> 2.6.32.11+drm33.2
> Tags: lucid
> Uname: Linux 2.6.32-20-generic x86_64
> UserGroups: adm admin cdrom dialout lpadmin plugdev
> sambashare
> dmi.bios.date: 05/31/2006
> dmi.bios.vendor: Hewlett-Packard
> dmi.bios.version: 786B8 v2.10
> dmi.board.name: 08B4h
> dmi.board.vendor: Hewlett-Packard
> dmi.chassis.asset.tag: 2UA5510Z5K
> dmi.chassis.type: 6
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: HP Minitower
> dmi.modalias:
> dmi:bvnHewlett-Packard:bvr786B8v2.10:bd05/31/2006:svnHewlett-Packard:pnhpworkstationxw8200:pvr:rvnHewlett-Packard:rn08B4h:rvr:cvnHewlett-Packard:ct6:cvrHPMinitower:
> dmi.product.name: hp workstation xw8200
> dmi.sys.vendor: Hewlett-Packard
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/cups/+bug/564917/+subscribe
>