all Kyocera network printers stopped working with cups 1.5.2

Bug #951627 reported by Maximilian Federle on 2012-03-10
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
cups-filters (Ubuntu)
High
Till Kamppeter

Bug Description

Two Kyocera printers, the FS 1320D and the FS C1020 MFP refuse to print with cups 1.5.2 delivered in precise.
They are supported by the manufacturer and work as expected in oneiric and cups 1.5.0.

However in Precise as of now, the printer's status led starts to blink and never goes into "ready state" again. The printer hangs and has to be powered off and on again in order to make it work with some other computer.

This is a very serious issue, as this possibly renders the whole business grade Kyocera lineup unusable on Precise.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: cups 1.5.2-6
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CheckboxSubmission: 69266ec2d9afabfcfce94ed6e4f796d8
CheckboxSystem: 2954e74ba17fb0e37fc942cd1d9fab4e
Date: Sat Mar 10 17:39:09 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
Lpstat:
 device for Kyocera-FS-1320D-FS-1320D: dnssd://KM28D3EF2._ipp._tcp.local/
 device for Samsung-ML-1670-Series: usb://Samsung/ML-1670%20Series?serial=Z6ENBKAB706821L.
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 003: ID 04f2:b1d8 Chicony Electronics Co., Ltd
MachineType: Acer TravelMate 8372
Papersize: a4
PpdFiles:
 Samsung-ML-1670-Series: Samsung ML-1670 Series
 Kyocera-FS-1320D-FS-1320D: Kyocera FS-1320D (KPDL)
ProcEnviron:
 TERM=xterm
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=143c65a0-593b-403b-b136-a82051c7e659 ro quiet splash pcie_aspm=force vt.handoff=7
SourcePackage: cups
UpgradeStatus: Upgraded to precise on 2011-12-22 (78 days ago)
dmi.bios.date: 08/03/2010
dmi.bios.vendor: Acer
dmi.bios.version: V1.05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: TravelMate 8372
dmi.board.vendor: Acer
dmi.board.version: PSMBOU-1234567
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: None
dmi.modalias: dmi:bvnAcer:bvrV1.05:bd08/03/2010:svnAcer:pnTravelMate8372:pvrV1.05:rvnAcer:rnTravelMate8372:rvrPSMBOU-1234567:cvnAcer:ct10:cvrNone:
dmi.product.name: TravelMate 8372
dmi.product.version: V1.05
dmi.sys.vendor: Acer

Maximilian Federle (ppd) wrote :
Till Kamppeter (till-kamppeter) wrote :

First, you have problems only with your Kyoceras on the network and not with the USB-connected Samsung?

The Kyocera connected to your machine is connected via IPP, try connecting it via AppSocket/JetDirect or LPD.

Start system-config-printer, right-click on the Kyocera's printer icon, click on "Properties" in the pop-up menu and in the dialog window opening then, click the "Change" button at "Device URI". In the new window opening now wait for the auto-detection to finish (spinning icon to disappear) and in the list of auto-detected network printer, choose your Kyocera and at the lower right ("Connection") choose one of "AppSocket/JetDirect network printer via DNS-SD", "LPD network printer via DNS-SD", "AppSocket/HP JetDirect", ...

Can you print this way?

If it still does not work, please follow the instructions in the sections "CUPS error_log" and "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems. Thanks.

Changed in cups (Ubuntu):
status: New → Incomplete
Maximilian Federle (ppd) wrote :

First of all, thanks a lot for your quick reply, I'll gladly provide you with the logs.

The Samsung device is my private device and has worked flawlessly so far.

At work we spent like two hours combining each of the two printers with each of the modes you described above with no success.
The best we achieved was with the ipp setting, where the printers at least reacted and started blinking their LEDs.
We even managed to get some pages out of the printers correctly, however with a success rate of a most 5% and always with the hanging and restarting of the devices.

And just to state it again: The printers work with Cups 1.5.0 on Oneiric.
I read on the upstream cups bugtracker that there was an ipp-related fix in 1.5 trunk, but did not manage to compile it successfully for testing purposes.

I attached the two files you requested.

Maximilian Federle (ppd) wrote :
Maximilian Federle (ppd) wrote :

In the meantime I successfully compiled cups 1.5 trunk and installed to /opt/cups.
It complained about not being able to run cups-deviced though and so I couldn't test whether the problem persists...

Maybe it would be a possibility to triage this bug if you could provide me with some info on how to run 1.5 trunk on precise?!

Maximilian Federle (ppd) wrote :

Ok, sorry for the spam:

I have managed to run 1.5 trunk on precise and it works perfectly. The same auto-detected settings (in this case: AppSocket) in 1.5.2 cause the FS 1320 to hang in an endless "processing" state.

Summary:

1.5.0: Works
1.5.2: Does not work
What is to become 1.5.3: Works

So the fix should be pretty easy: Wait for a new cups 1.5 release.

Till Kamppeter (till-kamppeter) wrote :

Unfortunately, the 1.5.3 release will not land in time for Precise, what we have to do is either to ship the current SVN snapshot as the CUPS of Precise or to find out which change fixed your problem. The former has the risk to introduce another bug before things can be "unready" in the current development state, the latter is more work and missing already introduced fixes for other bugs. The "more work" will have to be done mainly by you as my HP printers do not show the bug. What has to be done is to go through all the changes since 1.5.2 and find the one which fixes your problem. There are two methods: Look into "svn log" and see what can be the appropriate change and try it, the other is bisecting, which means a binary search for the fix: If rev m does not work and rev m works, try rev (m+n)/2 if this works n := (m+n)/2 otherwise m := (m+n)/2 and try again. svn has perhaps some functionality for this.

Maximilian Federle (ppd) wrote :

Oh dear. I really want to help and do this work, but I am not familiar at all with the described methods.
May I contact you e.g. in the #openprinting irc channel for initial assistance when I find the time today?

Till Kamppeter (till-kamppeter) wrote :

OK, #openprinting on FreeNode.

Here are some first steps:

Try at first with stock 1.5.2, the CUPS 1.5.2 as it comes from cups.org. This way we can find out whether the bug is perhaps caused by the Ubuntu patches.

If stock 1.5.2 works for you, we will have to continue by rebuilding the CUPS package of Ubuntu, removing the patches, one by one until it works.

If stock 1.5.2 still shows the bug, we will have to find the change on the SVN which does the fix for you.

Deeper investigation shows that most probably the problem is Ghostscript. The PostScript generated by Ghostscript 9.04 (Oneiric) prints on Kyocera printers and the PostScript from Ghostscript 9.05 (Precise) does not print on Kyocera printers.

bug 950713is probably the same problem but on Brother printers.

Maximilian Federle (ppd) wrote :

Testing results with nc -w1 <ip> 9100 < file.ps:

- ps by ghostscript in 11.10: does not work
- ps by ghostscript in 12.04: does not work
- ps by poppler in 12.04: works

So either I'm stupid or my/our oneiric installations used something else than ps2pdf for pdf conversion...

I attached the following files:

- Ausgabe.pdf: the source file used
- file-poppler-precise.ps: Ausgabe.pdf converted with pdftops on current precise
- file-gs-precise.ps: Ausgabe.pdf converted with pdf2ps on current precise
- file-gs-oneiric.ps: Ausgabe.pdf converted with pdf2ps on oneiric (11.10)

Maximilian Federle (ppd) wrote :
Maximilian Federle (ppd) wrote :
Maximilian Federle (ppd) wrote :
Maximilian Federle (ppd) wrote :

Some additional files:

- printout_oneiric: printout with FileDevice Yes in 11.10
- printout_precise: the same in 12.04
- error_log_oneiric: error_log from 11.10

Maximilian Federle (ppd) wrote :
Maximilian Federle (ppd) wrote :

All these were created by printing "Ausgabe.pdf" with evince.

Can everyone please do the following tests:

Open an application like evince, gedit, Firefox, ... Print a document into a PDF file by using the "Print to file" function of the print dialog anmd choose PDF as output format or use the attached "Ausgabe.pdf".

Convert it to PostScript via

pdf2ps file.pdf file.ps

Now please add parameters to the pdf2ps command, one at a time. Try the following parameters:

-dLanguageLevel=3
-dLanguageLevel=2
-dLanguageLevel=1
-dASCII85EncodePages=false
-dASCII85EncodePages=true
-dCompressPages=false -dCompressFonts=false

For example

pdf2ps -dLanguageLevel=2 file.pdf file.ps

Print the output file unfiltered, with the "nc" command:

nc -w1 <IP of the printer> 9100 < file.ps

If you do not have "nc" installed, run

sudo apt-get install netcat-openbsd

What is the reaction: Blank page, no page, what is printed on an error message page if you get one?

If none of the parameters helps, try also combinations of more than one parameter.

If you are still out of luck try also to print a PostScript file of an empty page and/or a fontless page, reate with LibreOffice, export to PDF, open with evince, "Print to file", convert the resulting PDF to PostScript as described here, print with "nc".

Can everyone please also send the file

http://www.ghostscript.com/~chrisl/ps2write-empty.ps

to the printer with "nc" and tell whether it works?

Can everyone please also send the file

http://www.ghostscript.com/~chrisl/Ausgabe.ps

to the printer with "nc" and tell whether it works?

Changed in cups (Ubuntu):
importance: Undecided → High

It seems that we have narrowed down the problem to be a bug in Kyocera's PostScript interpreter to make the printers incompatible with the PostScript output of Ghostscript's "ps2write" output device.

A simple modification on the PostScript solves the problem and you can easily test it. Take any Ghostscript-generated PostScript file which makes your Kyocera printer hanging, for example one of the files attached to this bug. Edit the file with a text editor like "gedit" adding the line

/bind {} bind def

right after the line

%!PS-Adobe-3.0

which should be at or at least near the beginning of the file. Now send the file to the printer again with "nc". It should print now.

I will modify the pdftops CUPS filter to insert said line into the PostScript output of Ghostscript if the printer is a Kyocera. This can slow down printing performance a bit but most important is to be able to print at all.

Note that this does not work for Brother printers and so does not fix bug 950713.

affects: cups (Ubuntu) → cups-filters (Ubuntu)
Changed in cups-filters (Ubuntu):
assignee: nobody → Till Kamppeter (till-kamppeter)
milestone: none → ubuntu-12.04-beta-2
status: Incomplete → Triaged

I have fixed the problem in cups-filters upstream (1.0.5) now. A Precise package is on its way.

Thank you very much for all your work on fixing this, Chris and Maximilian!

Changed in cups-filters (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-filters - 1.0.5-1

---------------
cups-filters (1.0.5-1) unstable; urgency=low

  * New upstream release
    - cups-filters 1.0.5 release
    - pdftops: Added insertion of workaround PostScript code for printers
      with bugs in their PS interpreters (LP: #950713, LP: #951627).
    - parallel backend: Break infinite loop (LP: #936647).
    - texttopdf: Complete the implementation of fontconfig-based font
      selection (Closes: #663070).
 -- Martin Pitt <email address hidden> Wed, 14 Mar 2012 11:43:22 +0100

Changed in cups-filters (Ubuntu):
status: Fix Committed → Fix Released

By the way, I have uploaded foomatic-filters 4.0.14 and with this version also printing on Kyocera printers with "Foomatic/Postscript" drivers works, but you need to choose drivers/PPDs explicitly for Kyocera printers (manufacturer "Kyocera").

I'm not sure if the problem is related.

I can print with a local attached printer without any problem, the problem is if a use it in a network.

Through local attachment it works perfectly

Through Network:
-I can add the printers through samba without any problems, print injectors test, clean nozzle heads, print test pages.
-I can't print any document. Tested from windows and ubuntu.

From Ubuntu it ask for authentication and only root works, no other samba user is allowed.

Tested with two printers: Epson Stylus Photo RX610 and Epson Stylus Photo R220.
Precise AMD64 (desktop) and i386 (server) with up to date packages.

I attach smb.conf and cupsd.conf

Julian Clark (julian.clark) wrote :

CUPS 1.5.3 was just released today (15 May 2012). Coincidentally, this was right when I noticed this bug. Hopefully, the necessary changes and bug fixes can be incorporated into the Ubuntu packages for Precise, since an update to 1.5.3 is highly unlikely.

Julian Clark (julian.clark) wrote :

I forgot to mention that I was having the same issue with CUPS 1.5.2 and Kyocera printers (specifically, the FS-3900DN, FS-4000DN, and FS-C5030N), all while using KPDL and other Foomatic/PostScript drivers. The PPDs were not exactly recent -- about six years old (the ones from the Kyocera website). The application that was being the most difficult was Firefox. Jobs would take at least five minutes to process and print, but they would eventually print. The HPIJS drivers do seem to work, though. With HPIJS, jobs would make it to the printer in seconds (as expected), rather than minutes. Preferably, I would use the KPDL drivers.

I was having similar PostScript issues with other printers -- though not as bad -- so I believe that this is a PostScript issue in general.

Gramler (maxf) wrote :

I have some examples of PDF files that still cause this to happen.
Most things print fine, but some particular PDF's crash it.
The same PDF was fine on Lucid.

It is also fine on other printers under Precise.

Gramler, can you attach these PDF files? Thanks.

Can you also test the proposed fix of bug 998087? Follow the instructions in that bug report, especially comments #13, #6, and #15? Thanks.

Download full text (3.8 KiB)

Till

My apologies for the extremely tardy response.
Mostly this was because an apt-get update etc.. seemed to make this
disappear and I on top of it I mislaid the pdf that caused this originally.

However, just yesterday I hit on one pdf that show this behaviour - but
I am just about to go on vacation (for 2 weeks)
As soon as I am back I will try to characterize it fully and get you
proper details on it.

Rgrds

Max

-------- Original Message --------
Subject: [Bug 951627] Re: all Kyocera network printers stopped working
with cups 1.5.2
Date: Tue, 22 May 2012 20:59:11 -0000
From: Till Kamppeter <email address hidden>
Reply-To: Bug 951627 <email address hidden>
To: <email address hidden>

Gramler, can you attach these PDF files? Thanks.

Can you also test the proposed fix of bug 998087? Follow the
instructions in that bug report, especially comments #13, #6, and #15?
Thanks.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/951627

Title:
   all Kyocera network printers stopped working with cups 1.5.2

Status in “cups-filters” package in Ubuntu:
   Fix Released

Bug description:
   Two Kyocera printers, the FS 1320D and the FS C1020 MFP refuse to print with cups 1.5.2 delivered in precise.
   They are supported by the manufacturer and work as expected in oneiric and cups 1.5.0.

   However in Precise as of now, the printer's status led starts to blink
   and never goes into "ready state" again. The printer hangs and has to
   be powered off and on again in order to make it work with some other
   computer.

   This is a very serious issue, as this possibly renders the whole
   business grade Kyocera lineup unusable on Precise.

   ProblemType: Bug
   DistroRelease: Ubuntu 12.04
   Package: cups 1.5.2-6
   ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
   Uname: Linux 3.2.0-18-generic x86_64
   ApportVersion: 1.94.1-0ubuntu2
   Architecture: amd64
   CheckboxSubmission: 69266ec2d9afabfcfce94ed6e4f796d8
   CheckboxSystem: 2954e74ba17fb0e37fc942cd1d9fab4e
   Date: Sat Mar 10 17:39:09 2012
   InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
   Lpstat:
    device for Kyocera-FS-1320D-FS-1320D: dnssd://KM28D3EF2._ipp._tcp.local/
    device for Samsung-ML-1670-Series: usb://Samsung/ML-1670%20Series?serial=Z6ENBKAB706821L.
   Lsusb:
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 003: ID 04f2:b1d8 Chicony Electronics Co., Ltd
   MachineType: Acer TravelMate 8372
   Papersize: a4
   PpdFiles:
    Samsung-ML-1670-Series: Samsung ML-1670 Series
    Kyocera-FS-1320D-FS-1320D: Kyocera FS-1320D (KPDL)
   ProcEnviron:
    TERM=xterm
    LANG=de_DE.UTF-8
    SHELL=/bin/bash
   ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=143c65a0-593b-403b-b136-a82051c7e659 ro quiet splash pcie_aspm=force vt.handoff=7
   SourcePackage: cups
   UpgradeStatus: Upgraded to precise ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers