Comment 26 for bug 64615

bristleburger (spr) wrote :

I upgraded two machines from Dapper to Edgy using gksu "update-manager -c" without any problems. Courier-imap and courier-maildrop were installed on both machines.

But this bug struck when upgrading a third machine.

Fixed as follows:
1. backup /var/lib/dpkg/status to a safe location
2. remove all courier entries from /var/lib/dpkg/status
3. sudo apt-get upgrade
4. sudo apt-get install courier-imap
5. sudo apt-get install courier-maildrop

I am very grateful to HaroldAling for posting details of this fix – I would have been in big trouble without it.

I subsequently upgraded two more machines without any trouble by removing all courier packages before the upgrade and then restoring them again once 6.10 was up and running.

All machines are x86 based apart from one Athlon machine which was the one that the bug struck. I'm not sure if the type of CPU is relevant. All machines were loaded with the same configuration of 6.06 packages.