(Triggered) Compile of svn_vcs.py in python-support fails during upgrades.

Bug #453349 reported by L1049G on 2009-10-16
80
This bug affects 13 people
Affects Status Importance Assigned to Milestone
config-manager
Undecided
Unassigned
config-manager (Debian)
Fix Released
Unknown
config-manager (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: python-support

During the last several upgrades, using Update Manager or apt-get upgrade,
the following SyntaxError is emitted:

...
Processing triggers for python-support ...
Compiling /usr/lib/pymodules/python2.6/config_manager/implementations/svn_vcs.py ...
SyntaxError: ('invalid syntax', ('/usr/lib/pymodules/python2.6/config_manager/implementations/svn_vcs.py', 49, 7, ' def get_test_repo(self):\n'))

The upgrade then terminates, whether prematurely or not; unknown.

-------------------------------
:~$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10
-------------------------------
:~$ apt-cache policy python-support
python-support:
  Installed: 1.0.3ubuntu1
  Candidate: 1.0.3ubuntu1
  Version table:
 *** 1.0.3ubuntu1 0
        500 http://nl3.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
-------------------------------

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 16 19:56:16 2009
DistroRelease: Ubuntu 9.10
Package: python-support 1.0.3ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
SourcePackage: python-support
Uname: Linux 2.6.31-14-generic x86_64

Related branches

L1049G (richard-seabrook) wrote :
Thomas Kluyver (takluyver) wrote :

Got it:
File: /usr/lib/pymodules/python2.6/config_manager/implementations/svn_vcs.py
Problem: Missing bracket, end of line 47.

Should be trivial to fix.

affects: python-support (Ubuntu) → config-manager (Ubuntu)
Changed in config-manager (Ubuntu):
status: New → Confirmed
John Turek (john-turek) on 2010-01-13
Changed in config-manager (Ubuntu):
status: Confirmed → Fix Committed
shoghq (fox-spear-head) wrote :

Brilliant. Simply adding the bracket fixes it for now.

Christian Reis (kiko) wrote :

This should probably be rolled into a package since it's still causing noisy errors upon upgrades.

Changed in config-manager (Debian):
status: Unknown → New
UndiFineD (k.dejong) wrote :

still not fixed in 10.10, applied bracket

Nick (nick222-yandex) wrote :

Still not fixed in Ubuntu 10.10 AMD64

Changed in config-manager (Ubuntu):
status: Fix Committed → New
Changed in config-manager (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in config-manager (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
milestone: none → maverick-updates
Susan Cragin (susancragin) wrote :

I believe that this may be the bug that makes my internet connection go away.
Every time I do aptitude upgrade
"processing triggers for python support"
cuts the internet connection.

I have a Lenovo X201 tablet computer with a quad-core processor
11.04 natty
kernel linux 2.6.38-6-generic
gnome 2.32.1
Python 2.7.1+

Kevin (kdauria-gmail) wrote :

Sorry. I meant to say that this also affects Natty -- at least when I updated from Maverick that is.

Changed in config-manager:
status: New → Invalid
JC Hulce (soaringsky) wrote :

This bug affects Ubuntu 10.10, Maverick Meerkat. Maverick has reached end-of-life and is no longer supported, so I am closing the bugtask for Maverick. Please upgrade to a newer version of Ubuntu.
More information here: https://lists.ubuntu.com/archives/ubuntu-announce/2012-April/000158.html

Changed in config-manager (Ubuntu Maverick):
status: Triaged → Invalid
Changed in config-manager (Debian):
status: New → Fix Committed
Changed in config-manager (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package config-manager - 0.4-2.1

---------------
config-manager (0.4-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix FTBFS with gcc 4.7 by fixing missing <unistd.h> includes.
    Thanks to Cyril Brulebois <email address hidden> for the patch. (Closes: #667141)
  * Fix syntax error in config_manager/implementations/svn_vcs.py
    (Closes: #572808) (LP: #453349)

 -- Salvatore Bonaccorso <email address hidden> Wed, 09 May 2012 22:59:05 +0200

Changed in config-manager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.