Ubuntu

No Alt+Tab in gnome classic session (switcher plugin not loaded)

Reported by sam tygier on 2012-04-01
596
This bug affects 137 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Baltix
Undecided
Unassigned
compiz (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
Undecided
Unassigned

Bug Description

When using the Gnome Classic session (with Compiz) in Ubuntu Precise Pangolin, I cannot use alt + tab to switch applications.

WORKAROUND:
1. Install packages:
   sudo apt-get install compiz-plugins compizconfig-settings-manager
2. Run "ccsm"
3. Scroll down to Window Management and enable (tick) "Application Switcher".

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-panel 1:3.4.0-0ubuntu1
Uname: Linux 3.3.0-030300-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
Date: Sun Apr 1 21:01:11 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120108)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
UpgradeStatus: No upgrade log present (probably fresh install)

sam tygier (samtygier) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Linux Lover (obake) on 2012-04-07
description: updated
Linux Lover (obake) wrote :

Ubuntu user Darxus mentioned in a duplicate bug report that Alt+Tab is shown to be the shortcut for switching applications/windows in
System Settings-----> Keyboard--------> Shortcuts:-----------> Navigation.

I can confirm his findings.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
tags: added: rls-mgr-p-tracking
Changed in gnome-panel (Ubuntu Precise):
importance: Undecided → High
Changed in compiz (Ubuntu Precise):
importance: Undecided → High
Simon Strandman (nejsimon) wrote :

FYI it's possible to work around this problem by installing ccsm and enabling the application switcher plugin.

Norbert (nrbrtx) wrote :

Thank you Simon!
I selected 'Static Application Switcher' in CCSM, it's great.

Daygan (sheerzeal) wrote :

I opened keyboard settings > shortcuts > navigation and set "switch applications" shortcut to Alt-Tab. I wonder if the solution is that simple for everyone else...

Daygan (sheerzeal) wrote :

Sorry, I suppose not - just read obake's comment.

Eduardo Gonzalez (egrueda) wrote :

Confirmed here with amd64. Already checked keyboard shortcuts but still fails

Maris4 (mrucis-gmail) wrote :

Daygan comment (#7) have not resolved problem

Linux xxxx 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Lance Rushing (lance-rushing) wrote :

I found out that the application switcher was not activated in Compiz

To fix: run ccsm
scroll down/filter to "window management"
activate "Application Switcher" or "Static Application Switcher"

http://imgur.com/8LzO2

Ori Tzoran (ori-tzoran) wrote :

Thanks Lance, your workaround works.
refinement: install "Compiz configuration settings manager" and follow the pic in Lance's URL above

"I opened keyboard settings > shortcuts > navigation and set "switch applications" shortcut to Alt-Tab. I wonder if the solution is that simple for everyone else..."

This worked for me after a reboot.

George (z-launchpad-ecto) wrote :

I did the ccsm workaround and it works (thanks!), but I don't much like either of the switchers. Any way to get the old one back?

Zold Gyorgy (gyorgy-zold) wrote :

I can confirm too : after setting at keyboard shortcuts Alt+tab, and a reboot afterwords, it still persists the issue.
As I am a user w/ user level knowledge ( and wish to remain on this level of expertize ), i'd preffer the fix of the bug, instead of high complexity workarounds...

BR
Gyorgy

Kangarooo Jānis (kangarooo) wrote :

Still not fixed. Tryd getting from laggy 12.04 to something usefull installing gnome-session-fallback and it has this bug.

Leszek (bigl-aff) wrote :

For me it works the way bluecalvin described. I've also added missing Alt-F4 for window closing in "Windows" section.

But remember that there are 2 options for gnome-sesion-fallback - normal and "no efffects". This workaroud is only for "no efffects" version (metacity as a window manager). If you use normal mode (compiz as a window manager) you need to use CCSM workaround.

Anyway IMHO it's a bug since it should be enabled by default in both scenarios.

George (z-launchpad-ecto) wrote :

I didn't know about 'no effects'. Switched to that at the login screen and now I have the classic switcher back. It's fast, clean, and simple. Thanks Leszek!

Pander (pander) wrote :

Installing compiz is not always the anwer. gnome-shell --replace sometimes fixes it (at your own risk).

kbsali (kbsali) wrote :

Same issue here, and switching to ugly "gnome classic no effect" does the trick... but it's ugly! :(

ckx (john2-hendrickx) wrote :

I had the same problem after a clean install on this Acer Aspire One netbook. For me it happened with gnome classic both with and without effects. The solution "keyboard settings > shortcuts > navigation and set "switch applications" shortcut to Alt-Tab." worked fine for me.

I never had any problems on my other laptop. I did a clean install on that as well but starting with 12.04 beta-1 and then updating. The difference could be due to the fact that I installed "gnome-fallback" on that machine and "gnome-panel" on this one. Are they just aliasses or are there differences that could explain the problem?

Trompete (atrub) wrote :

I also have the above-mentioned bug in Gnome Classic session + another one (I suppose they are related !).
The second bug is impossibility to customize the top and bottom panels. Alt + right click is not working any more.
But in Gnome Classic (No effects) the both things are OK.

Benjamin Drung (bdrung) wrote :

Trompete, you can customize the panels with additionally press the super button: super + alt + right click.

Aymeric PETIT (mulx) wrote :

Still present when doing an installation from scratch over the network.
By the way I've upgraded a computer running Ubuntu 8.04 and shortcut are configured after reboot.
I've also installed a computer with Xubuntu 12.04 from scratch and then switched to Gnome session classic and shortcut (alt-tab) works.

Viktor Stanchev (5k) wrote :

I have the same problem with ubuntu 12.04. It's extremely frustrating.

Workaround for large scale installations. I made this autostart menu item for our company.

cat <<EOF > /etc/xdg/autostart/metno-switcher-fix.desktop
[Desktop Entry]
Name=metno-switcher-fix
Comment=ALT+TAB hotfix for compiz fallback session
Exec=bash -c "test -f ~/.metno-switcher-fix || /usr/bin/gconftool-2 --set --type list --list-type=string /apps/compiz-1/general/screen0/options/active_plugins '[core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom,staticswitcher]' && touch ~/.metno-switcher-fix"
Terminal=false
Type=Application
OnlyShowIn=GNOME;
X-GNOME-Autostart-Delay=2
EOF

arky (arky) wrote :

Thanks Arnulf That helped!

Dale Spanheimer (dspanheimer) wrote :

I have a 12.04 installation that was upgraded from 10.10 to 11.04 to 11.10 to 12.04 using the update manager and then enabling Gnome Classic.

I had the same problem of alt+tab not working even though my
System Settings-----> Keyboard--------> Shortcuts:-----------> Navigation
setting said Alt+Tab would Switch Applications.

But I tried setting it to alt+super+tab and that worked fine.

I then just for experiment tried setting it back to alt+tab again and it then worked!

Someone else want to try this and see if this is a consistent work-around?

Changed in gnome-panel (Ubuntu):
assignee: nobody → Curtis Gearhardt (cgearhardt2)
Tamas Antal (device--) wrote :

Dale , It works for me too, but if I select switch application, it only switches to the next app, and If I hold down 'alt', and press tab again, the switcher disappears.

If I make it super+tab , it works exactly as it should.

Why does not work with alt+tab and super+tab does? What is it conflicts with ?

dima-tr (dima-tr) wrote :

Run in terminal:
gconftool-2 --set "/apps/metacity/global_keybindings/switch_windows" --type string "<Alt>Tab"

Other useful names/bindings are here: http://www.gungeralv.org/notes/archives/000323.php

Mikko Pesari (mpesari) wrote :

Thanks Arnulf, I made another workaround based on your tip.

We already distributed the file /usr/share/gconf/defaults/99-our-defaults to workstations, so we can just override the default active_plugins specified in 10_compiz-gnome.

That file in turn comes from the package compiz-gnome and I think the package defaults should include staticswitcher.

Mobman02 (mobman02) wrote :

I have done the gconftool-2 --set and the Settings-> Keyboard-> Shortcuts:-> Navigation trick.

Then I have launched "metacity --replace" and I finally have a working ALT-TAB (oh god, 5 months without such a feature, it's been killing me), but Metacity does not look the same as my previous "Gnome Classic" setup (no more transparency for notifications i.e.).

If someone know the difference between the Gnome Classic and what I now have after calling "metacity --replace", maybe we can move forward and fix this bug for real. Thx.

guenther kuenzel (mog71) wrote :

i know that this seems to be a gnome bug, but i got the same issue within kubuntu 12.10

when activating the mouse focus policy "focus under mouse" or "focus strictly under mouse" in the windows property settings alt+tab stops working.
using any other focus policy enables alt+tab again.

maybe this information might help to fix the gnome issue

Changed in gnome-panel (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-panel (Ubuntu Precise):
status: Confirmed → Invalid
no longer affects: gnome-panel (Ubuntu)
no longer affects: gnome-panel (Ubuntu Precise)
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz (Ubuntu Precise):
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
milestone: none → ubuntu-13.04-beta-1
summary: - no alt+tab in gnome classic session
+ No Alt+Tab in gnome classic session (switcher plugin not loaded)
Davias (davias) wrote :

Upgraded to 12.04 lts amd64 from 10.04 lts amd64... same bug here: alt-tab does not work, and it is correctly configured in gconf & settings. It works in gnome classic (no effects) but no in gnome-classic with compiz. Very annoying...

Fred (eldmannen+launchpad) wrote :

This bug is still present in Ubuntu 12.10 Quantal.

The workarounds mentioned in this report does not work.
CCSM does not have any 'Application Switcher' plugin(s).

Daniel van Vugt (vanvugt) wrote :

You need to install the package "compiz-plugins" to get the switcher plugin(s).

description: updated
Ryan Tandy (rtandy) wrote :

Could staticswitcher perhaps be added to the Default profile in /usr/share/gconf/defaults/10_compiz_gnome? It's already included in compiz-plugins-main-default so doesn't involve any universe dependencies.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu Quantal):
status: New → Confirmed
Bib (bybeu) wrote :

Same here (fresh 12.04.2 alternate x86 CD installed in semi-graphic mode, with step "software installation" loop failed then skipped.

Norbert (nrbrtx) wrote :

Bug is back in clean install of Trusty daily image.
Installed gnome-panel package and launched GNOME session FlashBack (Compiz) - there is not application switcher on <Alt>+<Tab>.

tags: added: trusty trusty-desktop

Same problem for me on a fresh 12.04.4 install (zbook 15, i7, nvidia quadro 1100, nvidia driver).
No workaround works. The alternate switcher just don't work.
I had to switch to KDE, which has it's own share of problems but at least alt-tab works. I'd like to get back to gnome classic (sometimes gnome shell freezes).

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.4 LTS
Release: 12.04
Codename: precise

$ uname -a
Linux *** 3.11.0-17-generic #31~precise1-Ubuntu SMP Tue Feb 4 21:25:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ dpkg -l *compiz*|grep ii
ii compiz 1:0.9.7.12-0ubuntu3 OpenGL window and compositing manager
ii compiz-core 1:0.9.7.12-0ubuntu3 OpenGL window and compositing manager
ii compiz-gnome 1:0.9.7.12-0ubuntu3 OpenGL window and compositing manager - GNOME window decorator
ii compiz-plugins 1:0.9.7.12-0ubuntu3 OpenGL window and compositing manager - plugins
ii compiz-plugins-default 1:0.9.7.12-0ubuntu3 OpenGL window and compositing manager - default plugins
ii compiz-plugins-main 1:0.9.7.0~bzr19-0ubuntu10.1 Compiz plugins - main collection
ii compiz-plugins-main-default 1:0.9.7.0~bzr19-0ubuntu10.1 Compiz plugins - main default collection
ii compizconfig-backend-gconf 0.9.5.92-0ubuntu5 Compiz Fusion configuration system - gconf backend
ii compizconfig-settings-manager 0.9.5.92-0ubuntu3 Compiz configuration settings manager
ii libcompizconfig0 0.9.7.0~bzr428-0ubuntu6 Settings library for plugins - OpenCompositing Project
ii python-compizconfig 0.9.5.94-0ubuntu4 Compizconfig bindings for python

Norbert (nrbrtx) wrote :

Bug is back in clean install of Trusty daily image (2014-03-16).
Installed gnome-panel package and launched GNOME session FlashBack (Compiz) - there is not application switcher on <Alt>+<Tab>.

Norbert (nrbrtx) wrote :

Made a clean install of 14.04 beta2 (4cf9e5ef2c1c362317c90312c76cfda0 *ubuntu-14.04-beta2-desktop-i386.iso),
installed gnome-panel package and launched GNOME session FlashBack (Compiz) - there is not application switcher on <Alt>+<Tab>.

Norbert (nrbrtx) wrote :

Ubuntu 14.04 with all updates for today - bug exists. Please fix it as soon as possible.

Dmitry Veltishev (vdmit) wrote :

Confirming this bug.
Same problem on 14.04 LTS updated from 12.04 LTS too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions