[Oneiric] Compiz fails to update window title until focused window is changed unless window is maximized

Bug #806636 reported by Sam_ on 2011-07-06
118
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Fix Released
Undecided
Thomas Thurman
compiz (Ubuntu)
Medium
Thomas Thurman
Oneiric
Medium
Thomas Thurman
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Reproducable.
Create two files with gedit, e.g. test-1, test-2. Save them to a bookmarked folder (otherwise gedit will crash due to Bug #797443).
Open test-1 from dropdown (history) menu.
Result: it doesn't display the file name in window title bar.
Expected is that it displays the file name test-1 in window title bar (as in Natty).
Go to edit -> preferences, now it displays file name in window title bar.

Leave test-1 open and open test-2 from dropdown (history) menu.
Result: file name of test-2 isn't displayed in window title bar, instead file name test-1 still is.
Expected: display file name of the file which has focus, instead of the one which is already open.

ALSO SEEN IN:

Chromium: https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/809101

1. Open Chromium
2. On new tab page, open new tab (CTRL-T)
3. Navigate to page (ubuntu.com for instance).
4. Notice Title bar does not change.

Eye of Gnome: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/809022

Open eog. Enable side pane from view. Open a folder which incl. bunch of images.
Slide through images, window title doesn't change.
Switch the workspace, return to eog. The last image is now displayed also as window title.
Slide through images, window title still doesn't change.

Totem:

1.) Open totem
2.) Movie > Open...
3.) Select a file
4.) Observe the title still says 'Movie Player'
5.) Go to a different window and back to totem. Title updates

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,obs,grid,gnomecompat,vpswitch,mousepoll,wall,compiztoolbox,move,resize,place,imgpng,snap,regex,animation,expo,session,unitymtgrabhandles,ezoom,workarounds,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Wed Jul 6 20:59:49 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.0-2-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.0-1-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.0-3-generic, x86_64: installed
GdmLog1:

GdmLog2:

GraphicsCard:
 ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1475]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
MachineType: Hewlett-Packard HP 625
ProcEnviron:
 LANG=C
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0-3-generic root=UUID=4a760393-cea9-45d3-88c0-841b7a37104d ro
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/07/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68DVA Ver. F.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1475
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 72.0E
dmi.chassis.asset.tag: CNU1080QP1
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68DVAVer.F.06:bd12/07/2010:svnHewlett-Packard:pnHP625:pvr:rvnHewlett-Packard:rn1475:rvrKBCVersion72.0E:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP 625
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Sam_ (and-sam) wrote :

Confirming and setting to medium as this is a usability issue in a core application.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
affects: unity (Ubuntu) → gedit (Ubuntu)

It's probably gedit's responsibility to tell the window manager to change the title and it's clearly not doing this, so this bug should be in gedit, not Unity.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

The plot thickens - this only happens with Unity 3D. Could be a combination of gedit and compiz not being nice to each other.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

affects: gedit (Ubuntu) → compiz (Ubuntu)
Sam_ (and-sam) wrote :

Thanks Brendan. Suspected unity and compiz, in order to gather as much information as possible through apport assigned it to unity.

Sebastien Bacher (seb128) wrote :

duplicate bug #809022?

Changed in compiz (Ubuntu):
importance: Medium → High
summary: - [Oneiric] No window titles displayed and accepted from saved files with
- gedit
+ [Oneiric] Compiz fails to update window title for a number of
+ applications (gedit, eog, chromium)
description: updated

That's three separate reports of applications for which compiz fails to update the title bar (note that it doesn't fail completely, there is usually some operation that causes the title to update, usually switching to another window/workspace does it)

summary: - [Oneiric] Compiz fails to update window title for a number of
- applications (gedit, eog, chromium)
+ [Oneiric] Compiz fails to update window title until focused window is
+ changed for a number of applications (gedit, eog, chromium)

Considering triaged as this bug is easily reproducible in either EoG or GEdit

Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: High → Medium

Seen in Totem too

summary: [Oneiric] Compiz fails to update window title until focused window is
- changed for a number of applications (gedit, eog, chromium)
+ changed for a number of applications (gedit, eog, totem, chromium)
description: updated

Also maximizing causes the title to update

And the title always updates correctly in a maximized window.

summary: [Oneiric] Compiz fails to update window title until focused window is
- changed for a number of applications (gedit, eog, totem, chromium)
+ changed unless window is maximized
David Barth (dbarth) on 2011-07-20
Changed in compiz:
status: New → Confirmed
Download full text (5.0 KiB)

Im pretty this is a bug with the open drivers failing to send damage events
to the decor pixmaps, at least the last time i checked it. Is this
reproducible on nvidia?
On Jul 20, 2011 11:46 PM, "David Barth" <email address hidden> wrote:
>
> ** Changed in: compiz
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a member of Canonical
> Desktop Experience Team, which is a bug assignee.
> https://bugs.launchpad.net/bugs/806636
>
> Title:
> [Oneiric] Compiz fails to update window title until focused window is
> changed unless window is maximized
>
> Status in Compiz:
> Confirmed
> Status in “compiz” package in Ubuntu:
> Triaged
> Status in “compiz” source package in Oneiric:
> Triaged
>
> Bug description:
> Reproducable.
> Create two files with gedit, e.g. test-1, test-2. Save them to a
bookmarked folder (otherwise gedit will crash due to Bug #797443).
> Open test-1 from dropdown (history) menu.
> Result: it doesn't display the file name in window title bar.
> Expected is that it displays the file name test-1 in window title bar (as
in Natty).
> Go to edit -> preferences, now it displays file name in window title bar.
>
> Leave test-1 open and open test-2 from dropdown (history) menu.
> Result: file name of test-2 isn't displayed in window title bar, instead
file name test-1 still is.
> Expected: display file name of the file which has focus, instead of the
one which is already open.
>
> ALSO SEEN IN:
>
> Chromium: https://bugs.launchpad.net/ubuntu/+source/chromium-
> browser/+bug/809101
>
> 1. Open Chromium
> 2. On new tab page, open new tab (CTRL-T)
> 3. Navigate to page (ubuntu.com for instance).
> 4. Notice Title bar does not change.
>
> Eye of Gnome:
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/809022
>
> Open eog. Enable side pane from view. Open a folder which incl. bunch of
images.
> Slide through images, window title doesn't change.
> Switch the workspace, return to eog. The last image is now displayed also
as window title.
> Slide through images, window title still doesn't change.
>
> Totem:
>
> 1.) Open totem
> 2.) Movie > Open...
> 3.) Select a file
> 4.) Observe the title still says 'Movie Player'
> 5.) Go to a different window and back to totem. Title updates
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.2.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic x86_64
> NonfreeKernelModules: wl
> Architecture: amd64
> CompizPlugins:
[core,bailer,detection,composite,opengl,decor,obs,grid,gnomecompat,vpswitch,mousepoll,wall,compiztoolbox,move,resize,place,imgpng,snap,regex,animation,expo,session,unitymtgrabhandles,ezoom,workarounds,staticswitcher,fade,scale,unityshell]
> CompositorRunning: compiz
> Date: Wed Jul 6 20:59:49 2011
> DistUpgraded: Fresh install
> DistroCodename: oneiric
> DistroVariant: ubuntu
> DkmsStatus:
> bcmwl, 5.100.82.38+bdcom, 3.0-2-generic, x86_64: installed
> bcmwl, 5.100.82.38+bdcom, 3.0-1-generic, x86_64: installed
> bcmwl, 5.100.82.38+bdcom, 3.0-3-generic, x86_64: installed
> GdmLog1:
>
> GdmLog2:
>
> GraphicsCard:
> ATI Technolog...

Read more...

David Barth (dbarth) on 2011-07-21
Changed in unity:
assignee: nobody → Thomas Thurman (marnanel)
Changed in compiz (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Thomas Thurman (marnanel)
Changed in unity:
milestone: none → 4.6.0
David Raid (davidraid) wrote :

This problem also existed in Natty, but only when using the proprietary FGLX driver and a theme other than Radiance or Ambiance. It's as if the window decorations of unmaximized windows are 'frozen', unchanging unless forced to with a window resize.

When using the Radiance or Ambiance theme, the window decorations would update fine, unless the window was not in focus, in which case mouse-overing the window controls would not highlight them and the window title would not change until the window was again in focus.

The problem existed for Natty in both compiz-decorator and gtk-window-decorator, but not metacity when using the classic desktop. In addition, this problem was solved for me by downgrading to a pre-Unity compiz version, leading me to believe the problem is somewhere inside compiz itself.

Now, the problem isn't just in the proprietary driver and even occurs when using the default opensource one present in Oneiric. Has that driver changed at all or has Compiz changed in the way it interacts with it? Could this be a kernel or xorg issue?

It's a major issue for most people using ATI graphics for the window decorations not to work as expected.

Sam Spilsbury (smspillaz) wrote :
Download full text (6.6 KiB)

On Wed, Jul 27, 2011 at 6:56 PM, David Raid <email address hidden> wrote:
> This problem also existed in Natty, but only when using the proprietary
> FGLX driver and a theme other than Radiance or Ambiance.  It's as if the
> window decorations of unmaximized windows are 'frozen', unchanging
> unless forced to with a window resize.
>
> When using the Radiance or Ambiance theme, the window decorations would
> update fine, unless the window was not in focus, in which case mouse-
> overing the window controls would not highlight them and the window
> title would not change until the window was again in focus.
>
> The problem existed for Natty in both compiz-decorator and gtk-window-
> decorator, but not metacity when using the classic desktop. In addition,
> this problem was solved for me by downgrading to a pre-Unity compiz
> version, leading me to believe the problem is somewhere inside compiz
> itself.
>
> Now, the problem isn't just in the proprietary driver and even occurs
> when using the default opensource one present in Oneiric. Has that
> driver changed at all or has Compiz changed in the way it interacts with
> it? Could this be a kernel or xorg issue?

I looked into this.

Those drivers aren't sending damage events for pixmap to texture
bindings when the drawable is just backed by a pixmap and not a
window.

There's not much more I know about it at the moment, but at least the
nvidia driver gets it right in this regard.

At least with unity-window-decorator, we are re-sizing the bound
pixmap all the time anyways, so this is effectively worked around.

The decorator work I am doing right now might also help with this. It
caches multiple pixmaps so that they don't need to be regenerated all
the time and then we can just switch between them without needing
damage events to update the bound texture.

>
> It's a major issue for most people using ATI graphics for the window
> decorations not to work as expected.
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity.
> https://bugs.launchpad.net/bugs/806636
>
> Title:
>  [Oneiric] Compiz fails to update window title until focused window is
>  changed unless window is maximized
>
> Status in Compiz:
>  Confirmed
> Status in Unity:
>  New
> Status in “compiz” package in Ubuntu:
>  Triaged
> Status in “compiz” source package in Oneiric:
>  Triaged
>
> Bug description:
>  Reproducable.
>  Create two files with gedit, e.g. test-1, test-2. Save them to a bookmarked folder (otherwise gedit will crash due to Bug #797443).
>  Open test-1 from dropdown (history) menu.
>  Result: it doesn't display the file name in window title bar.
>  Expected is that it displays the file name test-1 in window title bar (as in Natty).
>  Go to edit -> preferences, now it displays file name in window title bar.
>
>  Leave test-1 open and open test-2 from dropdown (history) menu.
>  Result: file name of test-2 isn't displayed in window title bar, instead file name test-1 still is.
>  Expected: display file name of the file which has focus, instead of the one which is already open.
>
>  ALSO SEEN IN:
>
>  Chromium: https://bugs.launchpad.net/ubuntu/+source/chromiu...

Read more...

Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Adam Dingle (adam-yorba) wrote :

I'm seeing this too in the current Oneiric build. I'm running on a MacBook which has an nVidia graphics card, so the problem does not seem to be specific to ATI.

I think this bug should have importance High. It's quite distracting that window titles are wrong all the time. As a workaround, I can resize a window to fix its title every time I notice that it's wrong, but that gets old fast.

David Raid (davidraid) wrote :

Seems fixed in today's daily build. Was the fix made in Compiz or the opensource driver? I'm trying to figure out if we'll still have this problem when using the proprietary fglx driver from Jockey-gtk.

Adam Dingle (adam-yorba) wrote :

This is also fixed for me with Oneiric updates as of today.

Sam_ (and-sam) wrote :

Issue can't be reproduced anymore with gedit and eog. Confirm it's fixed.
$ apt-cache policy unity
unity:
  Installed: 4.6.0-0ubuntu4
  Candidate: 4.6.0-0ubuntu4
  Version table:
 *** 4.6.0-0ubuntu4 0

$ apt-cache policy gedit
gedit:
  Installed: 3.1.3-0ubuntu1
  Candidate: 3.1.3-0ubuntu1
  Version table:
 *** 3.1.3-0ubuntu1 0

$ apt-cache policy compiz-core
compiz-core:
  Installed: 1:0.9.5.0-0ubuntu3
  Candidate: 1:0.9.5.0-0ubuntu3
  Version table:
 *** 1:0.9.5.0-0ubuntu3 0

Changed in compiz:
status: Confirmed → Fix Released
Changed in compiz (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in unity:
status: New → Fix Released
Anton Sudak (anton-sudak) wrote :

Still have this issue. Screenshot attached.

Juan Duarte (jcd001) wrote :

I have the same issue, Window titles and buttons (minimize, maximize, close) doesn't update when the mouse pointer is over them and windows is not maximized.

Aki Rossi (lorkki) wrote :

I still have this issue as well, with the proprietary fglrx drivers. Window decorations remain frozen until I resize or maximize the window.

linux-man (caldas-lopes) wrote :

This issue happens on ati and nvidia, closed and open-source drivers when using the default ambiance Windows theme.
Yet caption is updated if using (for example) the boomerang theme.

Thad Harroun (thad-harroun) wrote :

I must dispute "Fix released" status, and second Aki Rossi's issue.
Effects: Chromium/gedit/libre office
I also wish this would be re-classified as "High" importance.

Unity: 4.28.0-0ubuntu2
Theme: Default ambiance
fglrx: 2:8.881-0ubuntu4.1
gedit: 3.2.3-0ubuntu0.1
compiz: 1:0.9.6+bzr20110929-0ubuntu6.1

enz (markus-enzenberger) wrote :

I am still experiencing this bug in the current beta of Ubuntu 12.04 (with fglrx), so I agree with the previous poster that this bug is not fixed (and also that it should have high importance because it breaks many applications).

Changed in unity (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers