Stacking problem when switching between apps with multiple windows

Bug #802527 reported by Michael Terry
206
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Fix Released
High
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
Oneiric
High
Sam Spilsbury
unity (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

To reproduce (in Unity):

1) Open 2 Terminals. Have them slightly overlap. Note which terminal is on top (terminal A) and which one is partly hidden (terminal B).
2) Switch to a different app.
3) Click back on the Terminal launcher.

What happens:
The terminals will both be raised, but terminal A will now be behind terminal B. It will still have focus though.

what should happen:
Terminal A should still be on top.

Note that the apps must all be on the same workspace to trigger this bug.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.4+bzr20110606-0ubuntu4
ProcVersionSignature: Ubuntu 3.0-1.2-generic 3.0.0-rc3
Uname: Linux 3.0-1-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
Date: Mon Jun 27 09:03:03 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.0.8, 3.0-0-generic, i686: installed
 virtualbox, 4.0.8, 3.0-1-generic, i686: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18) (prog-if 00 [VGA controller])
   Subsystem: CLEVO/KAPOK Computer Device [1558:3100]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110422)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
MachineType: System76, Inc. Lemur UltraThin
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0-1-generic root=UUID=0e585e80-16f1-404c-80cc-7d9805fcc3b0 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/11/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: CALPELLACRB.86C.0000.X.0000000000
dmi.board.asset.tag: Tag 12345
dmi.board.name: Lemur UltraThin
dmi.board.vendor: System76, Inc.
dmi.board.version: lemu2
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: System76, Inc.
dmi.chassis.version: lemu2
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrCALPELLACRB.86C.0000.X.0000000000:bd11/11/2010:svnSystem76,Inc.:pnLemurUltraThin:pvrlemu2:rvnSystem76,Inc.:rnLemurUltraThin:rvrlemu2:cvnSystem76,Inc.:ct10:cvrlemu2:
dmi.product.name: Lemur UltraThin
dmi.product.version: lemu2
dmi.sys.vendor: System76, Inc.
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu4
version.libdrm2: libdrm2 2.4.25-2ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.3-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.3-0ubuntu4
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu5
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Revision history for this message
Michael Terry (mterry) wrote :
Changed in unity (Ubuntu):
status: New → Invalid
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Reproduced and confirmed.

Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in compiz (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Didier Roche (didrocks)
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Moritz Molch (mmolch) wrote :

This bug is really annoying, especially when dealing with maximized windows since you *expect* that the window in front of you is active and the window controls are controlling it. It's been several times now that I lost some stuff because I closed the wrong window. This is really really *really* annoying.

Revision history for this message
Evgeniy Kirov (evg.kirov) wrote :

Same on Natty.

Attached video.

Revision history for this message
David Barth (dbarth) wrote :

A reproducible stacking issue: that's a good news.

Changed in unity:
assignee: nobody → Thomas Thurman (marnanel)
importance: Undecided → High
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
David Barth (dbarth)
Changed in compiz (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Thomas Thurman (marnanel)
Changed in unity:
milestone: none → 4.6.0
Didier Roche (didrocks)
Changed in unity:
milestone: 4.6.0 → 4.8.0
Revision history for this message
Franck (alci) wrote :

Notice that https://bugs.launchpad.net/unity/+bug/814598 , although not really being a duplicate, might be related: also a problem with the stack.

Revision history for this message
Arun T (arunkumar-thondapu) wrote :

I see this issue on Ubuntu 11.04 with every application I use.
It is indeed annoying when you use windows in maximized mode because you end up performing actions in the wrong window.
For example, I launch multiple eclipse windows for development and when I switch from another application to eclipse by clicking on the unity launcher icon, the window that is brought to the foreground is different from the one that actually has focus.
The result is that none of the editor tabs have focus in the eclipse window that is visible and if I start typing inadvertently, changes are made in an unintended editor.

Revision history for this message
Felipe Amado (amadinho10) wrote :

I can't wait to see this bug fixed. It's really annoying indeed and it happens all the time.

Revision history for this message
Andrew (andrew-rw-robinson) wrote :

This is even worse than I thought.

If you have two windows maximized for the same application, and you switch to that application, the wrong window is maximized in the foreground. If you click the close title-bar icon, it closes the window behind it, not the one that is currently maximized.

I just lost a ton of work because of this bug as Ubuntu closed my window with all my unsaved changes instead of the window maximized on top with no changes.

Changed in compiz (Ubuntu Oneiric):
importance: Medium → High
Neil J. Patel (njpatel)
Changed in unity:
milestone: 4.8.0 → 4.14.0
Revision history for this message
Franck (alci) wrote :

Another way to trigger the (supposedly same) bug:

1) open thunderbird
2) don't give it focus (don't click in the window), but minimize it
3) open firefox
4) bring thunderbird back using message indicator

==> firefox window stays on top of the display, but thunderbird has focus. Clicks happen in thunderbird.

Revision history for this message
Omer Akram (om26er) wrote : Re: [Bug 802527] Re: Stacking problem when switching between apps with multiple windows

Frank, are you using Oneiric? if so thats another problem specific to
Oneiric and is being looked into.

Revision history for this message
eden6000 (eden6000) wrote :

Just a thought, off-topic, forgive me...but bugs like these make me convince even more that a release every 6 months is TOO MUCH! Having 1 year between releases would let developers do things better, and make users (especially new ones) happier...

Didier Roche (didrocks)
Changed in unity:
milestone: 4.14.0 → 4.16.0
Revision history for this message
Franck (alci) wrote :

@Omer: yes, this is in Oneiric. But I can't find the bug report. Do you know it ?

Revision history for this message
martinbures (needemesleepe) wrote :

@Omer - I am experiencing the same problem as Franck. Once I launch virtualbox with a Win7 guest, everything works fine for a few minutes. After a while, windows don't grab focus all-the-time - usually, I have to click in the bottom half of the window to regain focus. Then after a little while longer, I am not able to grab focus for windows - especially firefox. This all seemed to work fine last week but a recent series of updates seems to have triggered this for me.

Revision history for this message
Michael Flaig (mflaig) wrote :

I can confirm this as well.
To me it sometimes feel like there are ghost windows around when many windows are open and I want to raise focus somewhere else appears a resize frame that does not belong to any of the other open windows. very weird.

Didier Roche (didrocks)
tags: added: didrocks-oneiric-list
Revision history for this message
Jared (jared-vanvolkenburg) wrote :

This has been happening to me. Especially with firefox, thunderbird, skype, and pidgin running. I can have all the windows open, none of the fully maximized and I am unable to get focus on any of them. Occasionally, I do manage to get focus on a window, but the menu at the top of Unity displays the default desktop menu or the menu of the last application to have focus, Not the application menu.

Didier Roche (didrocks)
Changed in unity:
milestone: 4.16.0 → 4.18.0
tags: added: rls-mgr-o-tracking
David Barth (dbarth)
Changed in compiz (Ubuntu Oneiric):
assignee: Thomas Thurman (marnanel) → Sam Spilsbury (smspillaz)
Changed in unity:
assignee: Thomas Thurman (marnanel) → Sam Spilsbury (smspillaz)
status: Confirmed → Fix Committed
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in compiz:
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.5.94+bzr20110919-0ubuntu1

---------------
compiz (1:0.9.5.94+bzr20110919-0ubuntu1) oneiric; urgency=low

  * New upstream snapshot:
    - "maximized windows fail to update their input extents when undecorated"
      (LP: #853734)
    - Panel shadow conflicts with Window shadow in Ubuntu Classic Desktop
      Session (LP: #731685)
    - "unity-window-decorator: When switching between windows, Orca does not
      speak the title of the focused window (LP: #724093)
    - Dash and launcher appear underneath windows (LP: #805087)
    - A minimized window 'remains' behind on the desktop if
      /apps/<…>/show_minimized_windows is set to true (LP: #847967)
    - compiz and X can disagree on stacking order (LP: #845765)
    - Should keep a list last sent and last recv from server (LP: #841727)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - Dash and launcher appear underneath windows (LP: #805087)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 14:49:10 +0200

Changed in compiz (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Omer Akram (om26er)
Changed in compiz:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers