Functions assigned to extra mouse buttons in compiz do not work anymore.

Bug #1304877 reported by Aavo Tambur on 2014-04-09
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Christopher Townsend
compiz (Ubuntu)
Medium
Christopher Townsend

Bug Description

This is in Ubuntu 14.04 Trusty beta.

Using CompizConfig Settings Manager I have assinged functions to my mouse's buttons 8 and 9 (the thumb buttons).
After some recent update they stopped working, unless the desktop is focused.
I would expect that if I explicitly specify a mouse button for a function, it must work globally.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Christopher Townsend (townsend) wrote :

Thanks for reporting this bug. Sorry about breaking your extra button bindings. What I'm trying to fix is tricky and has many corner case exceptions such as this. I'll get working on this and get your button bindings restored.

Thanks!

Changed in compiz:
status: New → Confirmed
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in compiz:
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
milestone: none → 0.9.11.0
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140409-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140409-0ubuntu1) trusty; urgency=low

  [ Chris Townsend ]
  * Add support to build kde4-window-decorator for KDE 4.10 and older.
    (LP: #1288953)
  * (LP: #1027868)
  * Allow binding of other buttons greater than button 7 for windows
    other than the desktop. (LP: #1304877)
 -- Ubuntu daily release <email address hidden> Wed, 09 Apr 2014 22:14:18 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2014-04-10
Changed in compiz:
status: In Progress → Fix Committed
Aavo Tambur (aavotambur-3) wrote :

The fix works.
Thanks for a fast reaction!

Johfra Kamphuis (johfra) wrote :

Can it be that the fix stopped working in a later package?

I have the same problem as described above, although I'm using buttons 6 and 7 (scroll wheel left/right) to switch between workspaces.

Compiz package 1:0.9.11+14.04.20140423-0ubuntu1 is installed.

Aavo Tambur (aavotambur-3) wrote :

It seems that the patch restored the global nature of the mouse buttons greater than 8...
If I were you, I would open a new bug requesting also the the buttons 6 and 7 to be included.

Johfra Kamphuis (johfra) wrote :

My latest updates included Compiz; now I have Compiz package 1:0.9.11.1+14.04.20140701-0ubuntu1

And it the problem is fixed. Thanks for making it work!

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers