Ubuntu

totem crashes with 'BadAlloc (insufficient resources for operation)' when using compiz and xserver-xorg-video-intel driver

Reported by mon on 2007-04-30
226
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
Won't Fix
High
Fedora
Fix Released
Unknown
compiz (Ubuntu)
Undecided
Unassigned
Nominated for Gutsy by unggnu
xserver-xorg-video-intel (Ubuntu)
High
Michael Vogt
Nominated for Gutsy by unggnu

Bug Description

Hi

I have a widescreen monitor (1440x900) and in order to use it in feisty (x86) I've installed the xserver-xorg-video-intel since 915resolution didn't work out of the box. With this driver I can have maximum resolution and everything seems to work fine, including using video applications (like totem), the problem arises when I'm using compiz and I try to use a video application (totem playing a video or launching pitivi for example).

As said I'm using feisty x86 up to date on a intel x3000 video card.

thanks

Related branches

description: updated
hey560 (hey560) wrote :

I can confirm this bug. It is an XV issue i think.

Changed in totem:
status: Unconfirmed → Confirmed
Niels Breet (maemo) wrote :

I'm having these problems too. Feisty x86 on Intel GMA 3000.

+++ This bug was initially created as a clone of Bug #2772 +++

As mentioned in #2772, this problem persists with the i810 driver.

See also:

http://bugzilla.gnome.org/show_bug.cgi?id=351784

Xorg.0.log, server, and driver version.

John B. (jbuncher) wrote :

I'm having the same issues as well on a 1280x800 screen. For me, switching the video out ("vo") to x11 rather than xv lets the videos play, though I would much rather like to use xv.

1 comments hidden view all 151 comments

gstreamer seems to work with x11 output, but xine doesn't. Since I'm using totem-xine to have dvd playback this isn't a workaround for me.

Baggie (hyperpiper) wrote :

Same here - playing mp3/flac/ video all cause totem to crash when compiz is enabled

Baggie, the crash while playing audio is caused because you have visualizations turned on.

Created an attachment (id=9977)
Xorg.0.log

version:

1.7.4-0ubuntu1

Already fixed.

Eric, which version would that be fixed in?

Same problem here on an intel 915GM, both totem (using gstreamer backend) and mplayer crash receiving the X11 error: "BadAlloc (insufficient resources for operation)"

xf86-video-intel 2.0

I'm using xorg-x11-drv-i810-2.0.0-3.fc7, and still see that problem with compiz running. Running under metacity doesn't show problems.

compiz shouldn't be able to affect this. You're just running compiz on xorg, not compiz on xgl on xorg, right?

No GLX, it's a plain Fedora 7 install. Let me know if you would need to be able to debug this.

wt8008 (wt8008) wrote :

I have the same issue with using the xserver-xorg-video-intel driver in Ubuntu 7.04. Last night I changed drivers and just noticed this issue on my laptop. I have changed back to the xserver-xorg-vide-i810 along and using 915resolution to get 1280x800 on my screen, which is a work around. The reason I tried changing to this driver is because using i810 only gave me two choices for changing resolution in Gnome.

the fix linked by jhasse doesn't work for me on an intel 915GM

wt8008 (wt8008) wrote :

I have an Intel 950GM and the fix also does not work for me.

Doesn't work here.

Intel x3000

Albert Abril (abrilc) wrote :

Here's the same problem, with a "Intel Corporation 82945G/GZ Integrated Graphics Controller" and a "Flatron TFT L192WS ( 19'' Widescreen )".
I'm running the fix 915resolution.

Video only fails when Compiz or Beryl are running, for all the video-players and video-editors.

Doesn't working the fix of jhasse here.

mplayer output:

Starting playback...
VDec: vo config request - 320 x 240 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 320x240 => 320x240 Planar YV12
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0

MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

Regards.

Same here, xorg-x11-drv-i810-2.0.0-3.fc7, metacity, xorg-x11-server-Xorg-1.3.0.0-5.fc7 and
Section "Device"
        Identifier "Videocard0"
        Driver "i810"
        Option "VideoRam" "65536"
        Option "LinearAlloc" "6144"
EndSection

I get this even with small videos (320x200) if played multiple times with
mplayer, which suggest a video memory leak. (totem can't open them anymore too after this occurs)

@Albert

I'm not sure if that is the same bug, if you say you're experiencing
it with 915resolution. The bug that has been reported here (at least
in my case) does NOT involve 915resolution (in fact, that's when stuff
works), but rather with the xserver-xorg-video-intel package/driver,
not the xserver-xorg-video-i810 + 915resolution package/driver/patch
combo.

On 5/29/07, Albert Abril <email address hidden> wrote:
> Here's the same problem, with a "Intel Corporation 82945G/GZ Integrated
> Graphics Controller" and a "Flatron TFT L192WS ( 19'' Widescreen )".
> I'm running the fix 915resolution.
>
> Video only fails when Compiz or Beryl are running, for all the video-
> players and video-editors.
>
> Doesn't working the fix of jhasse here.
>
> mplayer output:
>
> Starting playback...
> VDec: vo config request - 320 x 240 (preferred colorspace: Planar YV12)
> VDec: using Planar YV12 as output csp (no 0)
> Movie-Aspect is undefined - no prescaling applied.
> VO: [xv] 320x240 => 320x240 Planar YV12
> X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
>
>
> MPlayer interrupted by signal 6 in module: vo_check_events
> - MPlayer crashed. This shouldn't happen.
> It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
> gcc version. If you think it's MPlayer's fault, please read
> DOCS/HTML/en/bugreports.html and follow the instructions there. We can't
> and
> won't help unless you provide this information when reporting a possible
> bug.
>
> Regards.
>
> --
> totem crashes with 'BadAlloc (insufficient resources for operation)' when
> using compiz and xserver-xorg-video-intel driver
> https://bugs.launchpad.net/bugs/111257
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Albert Abril (abrilc) wrote :

Now, i have the intel driver (without 915resolution), and works fine for my
resolution.
However, with Compiz or Beryl running, still without can't play videos in
any video player.

Now, i can confirm the bug is with the xserver-xorg-video-intel
package/driver.

Thanks for the info.

On 5/30/07, John Buncher <email address hidden> wrote:
>
> @Albert
>
> I'm not sure if that is the same bug, if you say you're experiencing
> it with 915resolution. The bug that has been reported here (at least
> in my case) does NOT involve 915resolution (in fact, that's when stuff
> works), but rather with the xserver-xorg-video-intel package/driver,
> not the xserver-xorg-video-i810 + 915resolution package/driver/patch
> combo.
>
> On 5/29/07, Albert Abril <email address hidden> wrote:
> > Here's the same problem, with a "Intel Corporation 82945G/GZ Integrated
> > Graphics Controller" and a "Flatron TFT L192WS ( 19'' Widescreen )".
> > I'm running the fix 915resolution.
> >
> > Video only fails when Compiz or Beryl are running, for all the video-
> > players and video-editors.
> >
> > Doesn't working the fix of jhasse here.
> >
> > mplayer output:
> >
> > Starting playback...
> > VDec: vo config request - 320 x 240 (preferred colorspace: Planar YV12)
> > VDec: using Planar YV12 as output csp (no 0)
> > Movie-Aspect is undefined - no prescaling applied.
> > VO: [xv] 320x240 => 320x240 Planar YV12
> > X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0
> >
> >
> > MPlayer interrupted by signal 6 in module: vo_check_events
> > - MPlayer crashed. This shouldn't happen.
> > It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
> > gcc version. If you think it's MPlayer's fault, please read
> > DOCS/HTML/en/bugreports.html and follow the instructions there. We
> can't
> > and
> > won't help unless you provide this information when reporting a
> possible
> > bug.
> >
> > Regards.
> >
> > --
> > totem crashes with 'BadAlloc (insufficient resources for operation)'
> when
> > using compiz and xserver-xorg-video-intel driver
> > https://bugs.launchpad.net/bugs/111257
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
> --
> totem crashes with 'BadAlloc (insufficient resources for operation)' when
> using compiz and xserver-xorg-video-intel driver
> https://bugs.launchpad.net/bugs/111257
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I can confirm this behaviour too; it only happens when compiz is running. It happens with even just a tiny crappy mobile phone video, so it's not related to hd output. If I kill compiz with 'metacity --replace' running the same video then works.

This is with compiz 0.5.0 and the Debian 2.0.0 xserver-xorg-video-intel package on an 915GM/GMS/910GML. I have a very un-fancy xorg.conf with

Section "Device"
        Identifier "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
        Driver "intel"
        BusID "PCI:0:2:0"
        Option "UseFBDev" "true"
        Option "XAANoOffscreenPixmaps" "true"
        Option "DRI" "true"
EndSection

Section "Extensions"
        Option "Composite" "true"
EndSection

Also seems to be reported by ubuntians

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/111257

(In reply to comment #10)
> Option "XAANoOffscreenPixmaps" "true"

Does it happen without this option? (Fedora might still be using the hack to disable XAA offscreen pixmaps when starting a GLX compositing manager)

> Does it happen without this option? (Fedora might still be using the hack to
> disable XAA offscreen pixmaps when starting a GLX compositing manager)

Although I'm using Debian, if I turn this option off none of my terminal window contents get painted, but running "blind" the same thing happens when I try to play a video anyway.

Oh, right. We still have the chance to BadAlloc with XAA, because XAA has no mechanism to force pixmaps into framebuffer. The alternative would be to just violate the composite extension requirements and draw to the front buffer like we used to, but nobody likes that either.

SickNick (sicknick2020) wrote :

I am having the same problem, running on 950GMA from Intel with the 915 driver and 915 resolution fix, it only happens with compiz on. I added the two lines to my xorg and it didnt fix it. Are there any fixes yet on this??

you can try an set a different video sync in gstreamer. I think the command is gstreamer-properties, but I can assure it since Im not at home.

Fine! It worked for me!!

Confirmed: the command is gsreamer-properties.

I went to the video tab, I selected "Default Output -> Plugin: X Window
System ( No XV )," and now works fine with Totem.
Only for totem. Not for mplayer neither VLC. Then, is reconfirmed that the
point is in the video output selected.

Thanks.

On 6/15/07, kmon <email address hidden> wrote:
>
> you can try an set a different video sync in gstreamer. I think the
> command is gstreamer-properties, but I can assure it since Im not at
> home.
>
>

Hi

It only works for gstreamer based player (so it doesn't work with totem-xine either).

I've experienced this problem too, in my normal x-session with beryl+kde all attempts to use Xv fails with the BadAlloc error message.
I've tested to comment out all Options to the intel driver in my xorg.conf, and starting the X server with only an xterm in it, then Xv playback works. If i start beryl it breaks, when i kill beryl it works again. The same goes for xcompmgr.

I've tested with both xserver-xorg-video-intel version 2.0.0-1ubuntu2 and a git snapshot from 2007-06-18 with the same results.

Changed in xorg-server:
status: Unknown → Confirmed

Confirmed on an archlinux system using xorg-server 1.3, the intel 2.0.0 driver, kde 3.5.7 and any player with Xv output. Opengl and other output works fine.

Jeffrey Knockel (jeff250) wrote :

Setting the video output plugin to "X Window System ( No XV )" means that you won't be getting xv video acceleration. This puts more strain on the CPU during video playback, and higher resolution videos can play jerkily.

Changed in compiz:
status: Confirmed → Invalid
Changed in xserver-xorg-video-intel:
status: New → Confirmed
Changed in xserver-xorg-video-intel:
importance: Undecided → High
Michael Vogt (mvo) on 2007-09-13
Changed in compiz:
status: Invalid → Confirmed
Michael Vogt (mvo) on 2007-09-18
Changed in compiz:
status: Confirmed → Fix Released
Michael Vogt (mvo) on 2007-09-19
Changed in xserver-xorg-video-intel:
assignee: nobody → mvo
status: Confirmed → Fix Released
71 comments hidden view all 151 comments

(In reply to comment #23)
> It has been fixed in Ubuntu Gutsy with overlay. If someone is interested:
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/111257

That doesn't work on my system, even forcing the textured overlay.

Very funny. With xv I get around 0.2 fps when
playing 1920x816 movie (most of the CPU time spent on I830PutImage).
With X11 around 20 fps.
Latest git versions of xorg, mesa, drm, intel_drv.
When using xv, also other dock apps are updated at 0.2 fps rate!

xv worked great with Fedora's 1.3.x Xorg, mesa and libdrm.

And where did my "video overlay" go? I remember I had that before.
Unfortunately I can't find xvinfo outputs from earlier months.
Intel(R) 965Q.

X-Video Extension version 2.2
screen #0
  Adaptor #0: "Intel(R) Textured Video"
    number of ports: 16
    port base: 73
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x23
      depth 24, visualID 0x24
      depth 24, visualID 0x25
      depth 24, visualID 0x26
      depth 24, visualID 0x27
      depth 24, visualID 0x28
      depth 24, visualID 0x29
      depth 24, visualID 0x2a
    number of attributes: 2
      "XV_BRIGHTNESS" (range -128 to 127)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range 0 to 255)
              client settable attribute
              client gettable attribute (current value is 0)
    maximum XvImage size: 1920 x 1088
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)

>> And where did my "video overlay" go?

overlay is not supported on i965.

I have had enough with this "stable" 1.4.
I went back to Fedora's 1.3.0.0-24 x86_64 Xorg and i810.

xvideo works. Keyboard leds work (except scroll lock).
At least somebody has quality control.

(In reply to comment #27)
> I have had enough with this "stable" 1.4.
> I went back to Fedora's 1.3.0.0-24 x86_64 Xorg and i810.
>
> xvideo works. Keyboard leds work (except scroll lock).
> At least somebody has quality control.

Which means that you have nothing to contribute to this bug report, so go away.

danda (dan-osc) wrote :

I'd like to know what is going on with regards to the 965 also. Does anyone know if intel is working on resolving this? I took a cursory look in the git repository at freedesktop.org, and I don't see any recent mods that look relevant. As a T61 owner, it is quite annoying to have to choose between compiz and video playback.

Wade Menard (wade-ezri) wrote :

danda: as has been explained earlier in this bug, the fix for i965 is getting EXA support up to speed, something that will slowly happen. Carl worth has been doing some great work that you can follow at http://cworth.org/tag/exa/

Discussion about that is beyond the scope of this bug (BadAlloc crashes) and discussion should be continued on the wiki or forums and not here.

unggnu (unggnu) wrote :

"The patch works here but i have noticed that the colors are off on all video
everything is really way too dark to see anything. i only see a few blues
and reds."
I can confirm this. This only happens with the new intel driver under xv. X11 output and i810 driver haven't this problem.

unggnu (unggnu) wrote :

This color bug seems to be Totem and intel driver related. If I play after X start a video file with vlc oder Mplayer colors are normal but I play a file with Totem colors are very dark and nearly without colors. After playing a video with Totem all other xv players have the same problem until X restart so it seems that Totem changes a gamma value or something like that.

Wade Menard (wade-ezri) wrote :

unggnu: is this an upgrade or a new install? You can adujust the contrast and saturation settings in Totem's preferences.

Please open a new bug for this.

unggnu (unggnu) wrote :

I have made a new install and I am pretty sure that I haven't restored totem settings or the whole gconf directory but resetting totem works and it works on Beta Live CD out of the box too. There will be a bug report I guess but it is not needed.

radicaledward (radicaledward) wrote :

I am getting this problem on my 965GM even when I am not running compiz. Any help? I have the latest everything on gutsy tribe 5.

Marcus Granado (mrc-gran) wrote :

@radicaledward: If you are willing to turn compiz off, you can use EXA with x3100 to play accelerated videos so that xine,mplayer,totem etc all work (at least it works for me in an Inspiron 1720):
Just add 'Option "accelmethod" "exa"' in your xorg.conf's gm965 Device section. Make sure all other options but DRI are commented out, since exa does not currently like e.g. pageflip, cacheline and other options. e.g.
Section "Device"
        Identifier "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
        Driver "intel"
        BusID "PCI:0:2:0"
        Option "DRI" "true"
        Option "AccelMethod" "exa"
EndSection

Dom H (speedsix) wrote :

When people say i965 is this reffering to the GM965 chipset? So I'm guessing this patch doesn't allow you to run XV video with the X3100 gpu?

*** Bug 12527 has been marked as a duplicate of this bug. ***

Thom Pischke (thom-pischke) wrote :

I have the GM965 chipset with x3100 GPU (Dell Intel 1420n). Neither compiz nor video works on gutsy. Compiz refuses to start and video crashes on any player with the Same BadAlloc mentioned here. Haven't tried any of the fixes here, but there seemed to be a lack of responses from people with this chipset, so adding my experiences.

Thom Pischke (thom-pischke) wrote :

Tested with No XV. Video still broken, though the 'Test' button works ok. So as far as I can tell, video is completely broken for the x3100 in gutsy, with no workaround available.

Dom H (speedsix) wrote :

Video works fine on my X3100 aslong as compiz is disabled. Compiz only works if I comment out the blacklist section in /usr/bin/compiz.

unggnu (unggnu) wrote :

GMA965 and X3100 have no overlay support so XV wouldn't work with compiz. That's why compiz is blacklisted.

Thom Pischke (thom-pischke) wrote :

I don't have compiz enabled (still blacklisted), and still no video. Even turning of XV doesn't help so the problem seems to be something else.

unggnu (unggnu) wrote :

Could you recheck it with the Gutsy RC Live CD? Maybe some settings are wrong or something like that.

good idea... will try that when i have time. I did try a script I
found in a forum thread that was supposed to allow compiz to run.
Don't know if video worked before that or not, but compiz still
doesn't work. It's possible the script messed up some settings.

On 10/15/07, unggnu <email address hidden> wrote:
> Could you recheck it with the Gutsy RC Live CD? Maybe some settings are
> wrong or something like that.
>
> --
> totem crashes with 'BadAlloc (insufficient resources for operation)' when using compiz and xserver-xorg-video-intel driver
> https://bugs.launchpad.net/bugs/111257
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thom Pischke (thom-pischke) wrote :

Ok, tried this with the gutsy RC Live CD and video played fine, meaning I have a messed-up configuration. I suppose I'll just wait until the official release and do a fresh install, unless someone wants to walk me through troubleshooting my configuration.

Oxenfrogga (tlatlik) wrote :

Hi Thom,

maybe you have xserver-xgl installed? I had it installed and I simply did not know (probably I just forgot) -- and searched really REALLY long for the reason for my crashes with glxgears and the damned slow display.

Isn't there a way to keep Intel users away from that package?

Ciao,
Harald

Thom Pischke (thom-pischke) wrote :

Thanks for the help. I think I've pinpointed the source of the problem. I had set the CacheLines parameter in my xorg.conf as part of a tutorial for a dual monitor setup. Also had the PageFlip parameter set. Both of these seem to be big no-nos for video playback with the intel card.

Removed them and can now play video. Using AccelMethod EXA also works if CacheLines if these parms are not set.

In short, I just removed all the nonstandard configuration options in the card's device section and that took care of things. Hopefully dual monitor will still work ok. Will find out tomorrow.

This is a regression versus the old, non-native mode setting driver. However, this configuration should work if you use the EXA acceleration method instead of XAA. XAA has several other limitations as well, so we'll be moving to EXA by default in the next release, hopefully dropping XAA altogether at some point.

*** Bug 12647 has been marked as a duplicate of this bug. ***

*** Bug 9930 has been marked as a duplicate of this bug. ***

samstre (samuel-streiner) wrote :

I've got the same problem. I'm using Gutsy (final) on a HP 6720s laptop (intel X3100). Compiz is disabled by default and cannot be enabled (without removing the blacklist check). My machine doesn't play videos at all. It doesent matter whether i try using Mplayer, Totem or VLC. Mplayer crashes when i try to open a video (Error opening/initializing the selected video_out (-vo) device. I tried it with -vo xv, -vo x11 and -vo gl2 ...

I neither have CacheLines nor PageFlip activated in my xorg.conf.

samstre (samuel-streiner) wrote :

sorry for the spam...

here's my xorg.conf

kieran (daralantarial) wrote :

if you're using EXA, try setting FBTexPercent to '0' in your xorg.conf.
this fixed it for me, using radeon/gutsy/exa and metacity with the compositor. i can use xvimagesink in totem no problems now.

we won't fix XAA issue any more and move to EXA. Please test EXA and if it doesn't work, please open a new bug. I'll close this bug. thanks.

Changed in xorg-server:
status: Confirmed → Won't Fix
fanen (afanen01) wrote :

Will someone be so kind as to describe the relationship between this bug you're looking at, and #193777 ? https://bugs.launchpad.net/ubuntu/+source/totem/+bug/193777

Obviously, this one refers to people using Compiz, and Intel Hardware, and the crash is a "Badalloc..."

My hardware is ATI, and I am not using compiz (the ATI drivers in stock Ubuntu gutsy don't support compiz).

A certain person keeps closing this bug as invalid, and has now revoked my rights to edit the same bug. As I speak, totem is still unusable. This is unnerving to say the least.

fanen i think you are suffering from something else. The bug 99% of us
reported here has been resolved.

On Sat, Feb 23, 2008 at 12:42 AM, fanen <email address hidden> wrote:

> Will someone be so kind as to describe the relationship between this bug
> you're looking at, and #193777 ?
> https://bugs.launchpad.net/ubuntu/+source/totem/+bug/193777
>
> Obviously, this one refers to people using Compiz, and Intel Hardware,
> and the crash is a "Badalloc..."
>
> My hardware is ATI, and I am not using compiz (the ATI drivers in stock
> Ubuntu gutsy don't support compiz).
>
> A certain person keeps closing this bug as invalid, and has now revoked
> my rights to edit the same bug. As I speak, totem is still unusable.
> This is unnerving to say the least.
>
> --
> totem crashes with 'BadAlloc (insufficient resources for operation)' when
> using compiz and xserver-xorg-video-intel driver
> https://bugs.launchpad.net/bugs/111257
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sincerely

Justin Sunseri

fanen (afanen01) wrote :

Justin, would you be so kind as to head over to #193777 ( https://bugs.launchpad.net/ubuntu/+source/totem/+bug/193777 ) and explain this to Pedro? He has closed the bug report, marking it as invalid, and revoked my rights to edit that bug.

Justin Sunseri (jmsunseri) wrote :

It appears as thought someone has opened it up

On Sat, Feb 23, 2008 at 3:12 AM, fanen <email address hidden> wrote:

> Justin, would you be so kind as to head over to #193777 (
> https://bugs.launchpad.net/ubuntu/+source/totem/+bug/193777 ) and
> explain this to Pedro? He has closed the bug report, marking it as
> invalid, and revoked my rights to edit that bug.
>
> --
> totem crashes with 'BadAlloc (insufficient resources for operation)' when
> using compiz and xserver-xorg-video-intel driver
> https://bugs.launchpad.net/bugs/111257
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sincerely

Justin Sunseri

Fabián Rodríguez (magicfab) wrote :

Here is a summary of the workaround mentioned before the bug was fixed:

1) Open a terminal window (Applications > Accessories > Terminal)
2) Enable the Multimedia Systems Selector menu option:
a) Go to System > Preferences > Main Menu
b) Under "Menus:" scroll down to and click "Preferences". The right part under "Items;" will update itself
c) Mark the "Multimedia System Selector" checkbox, click "Close"
3) Go to System > Preferences >Multimedia System Selector"
4) Under the "Video" tab change the Default output plugin to "X Window System (no XV)"
5) Click "Test", you should see a window popup with a series of vertical color bars, much as older classic TV color tests
6) Click "OK" to finish the test, now mpeg playback should work.

hanzhaogang (hanzhaogang) wrote :

i used the method intorduced in the summary above.
but the error still there...

i wonder why.

i use mplayer.

anybody help.

Randy Wilson (blazerw) wrote :

Using Intrepid with the intel driver on a laptop with 915GM I still get this bug. The workaround to not use Xv works, but with the high CPU usage. Should this bug still be occurring in Intrepid?

Changed in xorg-server:
importance: Unknown → High
Changed in xorg-server:
importance: High → Unknown
Changed in xorg-server:
importance: Unknown → High
Displaying first 40 and last 40 comments. View all 151 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.