after upgrade to 12.04 amd64 Gnome Classic not properly draw second screen

Bug #1002641 reported by keepitsimpleengr on 2012-05-22
234
This bug affects 50 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Compiz Core
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

Send scree is blank white without panels, background. Only a few icons show.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lightdm 1.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Mon May 21 21:57:57 2012
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: Upgraded to precise on 2012-05-21 (0 days ago)

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in lightdm (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

::1. the specific steps or actions you took that caused you to encounter the problem

[10.10]
1. Disabled 2nd monitor in nvidia settings.
2. Replaced nvidia (295.⋯) driver (not the ubuntu propietary driver) with ubuntu driver.
3. Removed nvidia driver and nvidia settings.
4. Performed upgrade to 11.04 using update manager release upgrade.
[11.04]
1. Ran update manager.
2. Performed upgrade to 11.10 using update manager release upgrade.
[11.10]
1. Ran update manager.
2. Performed an update to 12.04 using update manager release upgrade.
[12.04]
1. Ran update manager.
2. Ran additional drivers, added ubuntu nvidia pripietary drivers. Faild to restart.
3. Checked xorg.conf -tt it was not for nvidia.
4. From console replaced xorg.conf with archived xorg.conf from prior nvidia driver.
5. Using ubuntu software center 10.10, installed gnome-session-fallback, MyUnity
6. Restarted changing to gnome classic at login.
7. Used nvidia settings to enable 2nd monitor.

::2. the behavior you expected, and

Separate X-screen with panels, background and desktop icons.

::3. the behavior you actually encountered (in as much detail as possible)

see attachment
Separate X screen, no panels, no background (solid white) soem icons.

Sebastien Bacher (seb128) wrote :

so the issue is not with lightdm (the login screen) but with the session? could you add your .xsession-errors to the bug?

Changed in lightdm (Ubuntu):
status: Incomplete → New
summary: - after upgrade to 12.04 amd64 Gnome Classic, lightdm will not properly
- draw second screen
+ after upgrade to 12.04 amd64 Gnome Classic not properly draw second
+ screen
affects: lightdm (Ubuntu) → ubuntu

The login screen worked fine. Before lightdm using gdm, the second screen worked well. After the upgrade using lightdm, the second screen did no draw properly.

The useless 12.04 upgrade was deleted and the original 10.10 recovered, so any logs are gone.

The 12.04 was backed up immediately after the upgrade, and could be recovered if there is a possibility of getting this working.

see: http://askubuntu.com/questions/138389/no-background-in-second-screen-separate-x-screen

This behavior occurred in a previous upgrade attempt: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1001712

add your .xsession-errors to the bug...

tags: added: dist-upgrade
Daniel van Vugt (vanvugt) wrote :

This could be another form of bug 729979, which we just fixed and hope to release a fix for soon.

affects: ubuntu → compiz (Ubuntu)

@Daniel van Vugt (vanvugt) "This could be another form of bug 729979, which we just fixed and hope to release a fix for soon."

It would be nice if that were so, here's why it might not...

This occurs on an entire screen of a two monitor system, only on screen1, not screen0.

This apparently occurs only on the 64bit/nvidia system.

It occurred not in 10.04 or 10.10, but in 12.04 and 11.10.

It was a consistent occurrence over multiple upgrade attempts.

It is related to other anomalies, see http://askubuntu.com/questions/138393/when-starting-or-log-off-on-addl-panels-show-and-some-panel-applets-are-duplic

Now that I have 12.04 Gnome Classic (fallback) working reasonably well on screen0, I thought I would try screen1 again.

Updated the computer.

Opened Nvidia settings, changed screen1 from disabled to separate x screen, applied, saved the xorg.conf file, logged out (ctrl-alt-del).

Logged in. screen0 now has some duplicated icons in panel. screen1 flashes the wallpaper, the turn pure white with a empty white panel at the top. Icons from earlier folder creations test are still there. I can create a new folder on screen1 using right mouse. Crtl-alt-del on screen1 opens a terminal on screen0. Disk mounter applet keeps failing and asked "remove?".

Used nvidia settings to disable screen1, applied, saved the xorg.conf file and restarted the computer.

After restart, screen0 has three added empty panels not there before. One each stacked on the top and bottom, and one on the right side. Several panel icons are duplicated on the original panels, all on the bottom and what appears to be the default on the top panel: menus, system tray…

What is difficult to understand is how this anomalous behavior passed testing and why it is given low importance as a bugs, since in my case half of my work space is useless thereby?

tags: added: gnome-panel nvidia

So I log out, logged back in in Unity. Used nvidia-setting to enable screen1 and logged out/in.

Sa

tags: added: compiz

So I log out, logged back in in Unity. Used nvidia-setting to enable screen1 and logged out/in.

Same as before with these differences: No white panel, cursor changes to the X cursor, no rotating cube..

Reset nvidia settings as before, logged in/out. no obvious problems.

Logged out/in as Gnome classic (fallback) and discovered compiz settings had been changed. Desktop size changed, 3D windows disabled, cube disabled. But no added panels or applets. The annoying snapping windows had been enabled.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz:
status: New → Confirmed
Changed in compiz-core:
status: New → Confirmed

There were updates today, and I tried to see if any different...
Adding second screen in Gnome Fallback/Classic (GFC)
Same as before except: Could add an applet to top panel. Could remove applet but popup menu appeared on screen0 in the center. I don't recall trying this before so it may not be new behavior,
Logging out/in in Unity: screen1 same as befor, no panel.
Using nvidia settings to drop screen1
Logging out/in in GFC: Now the Unity Dash Totem shows up on left side of screen and Unity Panle obscures GFC panel. Have to add main menu to lower panel. ccsm settings are changed. Workspace is Unity' s 3x3-using ccsm general option to reset the workspace arrangement to 1x4 fails, stays 2x2. Cube and 3D windows no longer work. ccsm not functioning correctly.
----
As a result GFC nearly useless!

Daniel van Vugt (vanvugt) wrote :

FYI, for confused readers - The above screenshot belongs to bug 1009216, not this one.

Sorry about the confusion, the screen shot actually refers to both this bug and the https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1009216 in that the anomalies are apparently linked,

hansaplast (9orums) wrote :

I'm havving allmost the same issue on fresh install of 12.04.
Using nvidia-settings I selected "Separate X Screens", saved xorg.conf and rebooted. After I logged in my secondary screen looks like a default X session. A black X as mouse pointer, white background, no menu's. I can't do anything on the secondary screen except moving the X with my mouse :)

My guess is that the "Separate X Screens" option in nvidia-settings works for gdm and isn't available (or not yet implemented) in lightdm. I havn't tested this yet, but switching back to gdm should give you separate X screens. Dunno if this impacts Unities behavior.

Would be nice to have this in lightdm too.

Anthony Carr (carranty) wrote :

I have exactly the same issue as hansaplast

After dealing with the diminished functionality of 12.04 Gnome Classic/fallback, I tried using the Xubuntu-desktop.

When using Xubuntu and nvidia-settings to to enable screen1 (of 2 screens), I get this result:

The screen is no longer white but has the XFCE background.

Instead of it's own desktop icons, the icons from screen0 are there.

There are no panels.

The right-mouse-button on screen1 produces the Xubuntu popup menu. Operations with this menu occur in screen1.

This allowed screenshot to operate, attached.

Before enabling screen1, compiz cube and 3D windows worked. After enabling screen1, compiz cube and 3D did not work and also the desktop size was reduced to 1x1. The compiz settings were not changed.

Cont'd from #24

After disabling screen1 and logging out then back into Xubuntu, the compiz setting were still unchanged (Unlike Unity which clobbers them).

Before compiz cube and 3D windows worked, the window manager (compiz) had to be reloaded.

After upgrade from 10.10 xubuntu to 11.04, the same thing that occurred as in #24

After upgrade from 11.04 xubuntu to 11.10, the same thing that occurred as in #24

After upgrade from 11.10 xubuntu to 12.04

screen1 does not have the wallpaper in screen0. When attempting to change wallpaper in screen1 using mouse-right-button-menu.settings/Desktop Settings, the wallpaper in screen0 is changed, no effect on screen1, although the window opens on screen1.

The icons on screen1 are replicated from screen0

Opening an application on screen 1 causes the application to open on screen1. There are no window decorations on the applications window.

Compiz effects working on screen0 (i.e. cube & 3D windows) fail on screen1.

Ruben Undheim (saltmakrell) wrote :

I'm having almost the same problem. I'm running a 32 bit fresh install of 12.04, with nvidia drivers and Unity.
Screen1 is white and quite unusable when configured as a separate X-screen.
I have tried with both compiz and metacity.

Compiz:
   The windows (which have been started with commands like "DISPLAY=:0.1 gnome-terminal" from screen1) have no window decoration. It is not possible to get keyboard focus on them, but it is possible to click on them and navigate with the mouse. Since they have no window decoration, it is not possible to move them. It is also not possible to run "DISPLAY=:0.1 wmctrl -l" from screen1.

Metacity:
  The background on screen1 is still white, but with metacity things work a little bit better. The windows have decoration and can therefore be moved. It is possible to select them so that they get keyboard focus. In this case, "DISPLAY=:0.1 wmctrl -l" does in fact work.

I have also tried with both lightdm and gdm. When using lightdm and compiz, the mouse cursor is an X as described above. With all the other combinations, the mouse cursor is normal. Switching between gdm and lightdm does not seem to have other visible effects.

All in all, this is a pretty annoying thing, but I don't know X well enough to be able to debug this on my own.

James Flowers (jflowers) wrote :

Is there any update with this? Doesn't this effect all dual screen setups using nvidia-current and ubuntu 12.04 64bit? It must not if the importance is 'low'. I normally have no problem using the default drivers and not the nvidia ones, but I need to take advantage of the CUDA support in my geforce 470s. Is there any work around where I can use the functionality of my graphics cards and still have dual monitors?

Scot Bernard (pablo-bueti) wrote :

Same for me, after upgrading from Ubuntu 10.04 to 12.04.

I had configured from nVidia X Server Settings two monitors with Separate X Screens, they worked fine. After the update my left screen (1) is blank with a cursor shaped with an x, only contextual menu from right click works. Right screen (0) works fine.

Jerimiah Cole (jc2le) wrote :

I have an issue that appears related, but on AMD/ATI. If I configure xorg with multiple X screens as I have in the past on 11.04, the session ends up starting metacity instead of compiz (it uses compiz when there is only a single X screen). In the past, I had to tweak the session to start compiz on :0.1 and everything was fine. Also, every time I login, additional panels are created (described http://askubuntu.com/questions/138393/when-starting-or-log-off-on-addl-panels-show-and-some-panel-applets-are-duplic ). Finally, as others have reported, there's no wallpaper displayed and the pointer is the default X shaped pointer.

boril (boril-gourinov) wrote :

I'm having almost the same problem. I'm running a 32 bit fresh install of Ubuntu 12.10. Card nVidia 9800 GTX 512 MB witn nVidia drivers. TwinView works fine. If I configure xorg with multiple X screens the background on screen1 become white after showing for a second or two the background of screen0. If I force a program to start in second screen it has no borders or any decoration. I can't take mouse to second screen. The only one program working on second screen is XBMC in fullscreen.

This problem appears to be the result of Ubuntu's adoption of Unity, which contradicts the use of Compiz and a 2nd screen. Not mentioned in the release notes and denied by developers, there seems to be an abandonment of support for this feature. The only workaround is to abandon Ubuntu when this is desired or required. I found limited success with Xubuntu to use (I have several projects that require Ubuntu). To get 2nd screen Compiz functionality I have moved to another distro, ArchLinux, but this requires a higher level of administration than Ubuntu. I still have my beloved, beautiful and functional Ubuntu 10.10 LTS

Timo Hartmann (baron-timo) wrote :

I have the same problem with 12.04 and NVIDIA. Are there any news?

As far as I can tell, the problem lies with the implementation of Unity, with Unity taking preference over Compiz. It's pretty clear that this is not going to change. One solution is to move to another distro.

* White screen is beacause of nautilus. There is old patch with fix. https://bugs.launchpad.net/nautilus/+bug/885989

* No panels on second screen is because of bug in gnome-panel. It is fixed in saucy, but I hope that soon fix will be included in precise too. https://bugs.launchpad.net/gnome-panel/+bug/1083811

Changed in compiz-core:
status: Confirmed → Invalid
Changed in compiz:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers