Unity Launcher shows up on Gnome Classic Desktop

Bug #1009216 reported by keepitsimpleengr on 2012-06-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I was checking to see if progress had been made on bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641 after todays updates.

When I switched back to Gnome classic/fallback the unity dash totem was on the gnome desktop obscuring the top gnome panel. I had to add the main menu to the lower panel to use gnome.

In addition, ccsm setting had been chnaged. When I reset them for cube and 3D windows, they didnt work. Changing the workspace arrangement from Unity's 2x2 to 1x4 for the cube failed to make the change. cube and 3D windows also did not work.

This pretty much makes 12.04 useless.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.gpus.1: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/1'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 295.40 Thu Apr 5 21:37:00 PDT 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Jun 5 13:47:01 2012
DistUpgraded: 2012-05-25 09:27:30,279 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.40, 3.0.0-19-generic, x86_64: installed
 nvidia-current, 295.40, 3.2.0-24-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GF110 [GeForce GTX 560 Ti] [10de:1200] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:1563]
 NVIDIA Corporation GF110 [GeForce GTX 560 Ti] [10de:1200] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:1563]
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: EVGA 132-YW-E178-FTW
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=98396955-e718-4c04-83fa-b23dbb537615 ro delayacct
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-05-25 (11 days ago)
dmi.bios.date: 01/23/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: 132-YW-E178-FTW
dmi.board.vendor: EVGA
dmi.board.version: 1
dmi.chassis.type: 3
dmi.chassis.vendor: EVGA
dmi.chassis.version: 132-YW-E178-FTW
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd01/23/2009:svnEVGA:pn132-YW-E178-FTW:pvr1:rvnEVGA:rn132-YW-E178-FTW:rvr1:cvnEVGA:ct3:cvr132-YW-E178-FTW:
dmi.product.name: 132-YW-E178-FTW
dmi.product.version: 1
dmi.sys.vendor: EVGA
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Daniel van Vugt (vanvugt) wrote :

I think you mean "Launcher" where you used the word "Totem". The latter usually refers to a video player in Linux.

summary: - Unity's Dash Totem shows up on Gnome Classic Desktop
+ Unity Launcher shows up on Gnome Classic Desktop
Daniel van Vugt (vanvugt) wrote :

keepitsimpleengr,

That slightly corrupt area of the panel that the launcher appears to overdraw is the panel's shadow texture. Obviously containing the wrong texture in this case !?

First, (in Gnome Classic) please open a terminal and run:
    env | grep COMPIZ

Make sure it does _not_ show "COMPIZ_CONFIG_PROFILE=ubuntu" when you're logged into Gnome Classic. If it does show "COMPIZ_CONFIG_PROFILE=ubuntu" then ignore the below instructions...

As for the Launcher showing up at all in Gnome Classic, you should be able to fix that in CCSM:
  1. Click Ubuntu Unity Plugin
  2. Uncheck the tickbox "Enable Ubuntu Unity Plugin".

Omer Akram (om26er) on 2012-06-06
Changed in unity (Ubuntu):
status: New → Incomplete

@vanvugt I don't use Unity because it is very counterproductive to my work-style, so I am unfamilar with the terminology. Launcher is indeed a better term than Totem. Thanks.

@vanvugt Quote:"That slightly corrupt area of the panel that the launcher appears to overdraw is the panel's shadow texture. Obviously containing the wrong texture in this case !?"
If I use the to⋯oops launcher, the launcher covers lower panel. If I use the lower panel, it covers the launcher.
and ― surprise― if I click on a part of the top panel not covered by the (whatever the Unity top bar/panel is called), then the Gnome classic/fallback panel becomes visible.

Quote:"First, (in Gnome Classic) please open a terminal and run:
    env | grep COMPIZ"

running `env | grep COMPIZ' return nothing `env' results attached.

Sebastien Bacher (seb128) wrote :

seems like an user config issue, you probably enabled the unity plugin in your compiz config, reset the config or unset it in ccsm

Changed in unity (Ubuntu):
status: Incomplete → Invalid

@vanvugt Quote:"As for the Launcher showing up at all in Gnome Classic, you should be able to fix that in CCSM"

after running Gnome fallback/classic (GFC) with screen1 enabled, then log off/in into Unity, then log off/in to GFC is when the unity launcher first appeared GFC. Also ccsm settings were changed, although the Unity plugin was not enabled. Resetting CCSM to my preferred working set (used on a 32bit 12.04, a 64bit 10.04 with 2 monitors) and changing work·space arrangement from Unity's 2x2 to 1x4 for cube produces no result, specifically work·space arrangement stayed 2x2 and no cube/3D windows, &c.

In addition, the now revealed top panel has the main menu and Indicator Applet Complete on it each three times.

@Sebastien Bacher - NOT AN user config issue - unity plugin NOT SET. NEVER SET. Perhaps not a good idea to make decisions based on surmises with evidence.

@Sebastien Bacher CORRECTION: "surmises without evidence"

Changed in unity (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

the issue is for sure in your config don't reopen bugs which got closed, you should rather try to figure why your default compiz config includes the unity option

Changed in unity (Ubuntu):
status: New → Invalid

Well I checked, and CCSM does not and did not have the Ubuntu Unity Plugin checked or enabled.

However, at the very bottom of the CCSM window under the category "Uncategorized" was "Unity Grab Handles" and it was checked, but not by me. When I unchecked it Compiz crashed immediately, the Launcher disappeared, and many CCSM settings were changed, presumably to whatever logging in to Unity (with screen1 enabled) and then logging back into Gnome Classic/fallback (GCF).

I reset the CCSM settings to my standard (used in two other systems) and there was no change⋯the general option desktop size was change to 1x4 but the desktop remained at 2x2. After logging out and logging back into GFC the desktop presented with 1x4 and the Desktop cube and 3D windows worked as before the logging in and out of Unity, then into GCF.

So I would claim that something to do with logging in and out of Unity with a 2nd monitor clobbered Compiz settings and defeats CCSM from effectively changing them. Only by unsetting the surreptitiously set "Unity Grab Handles" does the system recover normal operation after logging out and logging in in GCF (and possibly crashing Compiz).

I would also argue that this is not a user configuration error, but is an error caused by Unity clobbering compiz setting an defeating CCSM when logging out and then into GCF ⋯ which I would say is a deficiency in Unity Implementation, that is changing things without notice and not restoring them when used by other elements of the system is at best poor practice.

"User error" may be a general purpose panacea but it does not always fit the bill.

Do I need to file a new bug with this anonymous behavior?

Additional Note: Before unsetting "Unity Grab Handles, the Compiz crash and logging out/in, The Compiz Fusion Icon would not open CCSM, it required the use of a terminal⋯after the usetting, crash and log out/in it worked properly.

Sebastien Bacher (seb128) wrote :

what is GCF?

> Do I need to file a new bug with this anonymous behavior?

open a bug if you have specific steps to trigger that bug from a standard precise installation but it really seems that's due to whatever you are locally doing with your profiles (and no, unity doesn't change the standard profile, the unity session use a special compiz unity profile)

  @Sebastien Bacher (seb128) Gnome Classic/fallback (GCF)

The steps required to reproduce are described in the first three paragraphs of this bug description.

If Unity doesn't change it, then it fails to release the "special compiz unity profile" when logging out. And when releasing it (by unsetting the "Unity Grab Handles", crashing, resetting CCSM config and then logging out/in) then changes CCSM setting while causing multiple panels and repeated applets in gnome.

I DO NOT CHANGE my CCSM configuration. It is the same one I use on multiple systems and have for years. It only changes when I invoke Unity, which I did here to see if https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641 had been fixed. Since Unity is very counterproductive to the way I work, I don't under normal circumstances use it ( I am not against Unity, it may well suit many, many others. This may change is it cannot learn to play nice with Gnome Classic/fallback, et al).

Furthermore, I DO NOT CHANGE my CCSM configuration.

The CCSM I use is the same one I have been using on and since 10.04 LTS which has a 2nd monitor, and on a 32bit 12.04 system which does not have a second monitor.

Do I need to file a new bug with a different name?

Sebastien Bacher (seb128) wrote :

> The steps required to reproduce are described in the first three paragraphs of this bug description.

those "steps" are not really detailled, what is "I was checking to see if progress had been made on bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641 after todays updates.", what action does that include?

Can you confirm the issue on a liveCD or fresh installation?

The bug report has:

"CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]"

unityshell is listed in your compiz config, and no it's not added by changing sessions or it would happen on a new installation or to other users, you are doing something specific which might be triggering a bug but without easy steps showing how to trigger the bug from a new installation there is not a lot we can say

Quote: [those "steps" are not really detailled, what is "I was checking to see if progress had been made on bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641 after todays updates.", what action does that include?]

0.Start 12.04 in default Gnome Classic/fallback (GCF), run update manager.
1 From GCF enable screen1 as separate X·session using nvidia-settings saving xorg.conf.
2.Log out/in GCF.
3.Observe https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641
4.Log out GCF, Log in Unity
5.Observe https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641
6.Disable screen1 using nvidia-settingss saving xorg.conf.
7.Log out Unity, Log In GCF
8.Observe https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1009216

During the above no changes were made by me with CCSM to configuration.
My standard CCSM configuration shown in the CCSM attachments to this bug.

A fresh installation would take several days: 10.10 update-manager to 11.04, 11.04 update-manager to 11.11, 11.11 update-manager to 12.04, install Gnome Classic/fallback.

The bug report was made after step 8 above, so anything in the bug report that differs from my standard CCSM setting would have been made without notification to me.

Note that these are the steps that recovered a working standard CCSM confiuration and caused the Launcher to go away.

1. Verify standard CCSM settings (see attachments) are actually in CCSM.
2. Discover the previously overlooked setting under the category "Uncategorized" was "Unity Grab Handles" and it was checked.
3. Uncheck "Unity Grab Handles".
4. Observe Compiz crash, offering a popup window, "Examine, &c...."; decline.
5. Observe CCSM setting have reverted to apparently what they were after step 7 above.
6. Reset CCSM settings to my standard.
7. Observe no change in Compiz from changing settings, i.e. Desktop from 2x2 to 1x4 ―> no change.
8. Log out/in GCF.
9. Observe expected behavior with standard CCSM settings.

A fresh installation would take several days, 10.10>11.04,11.04>11.10,12.10>12.04,install GFC. This system was upgraded from a clone of my 10.04 boot in November over a year ago, and is used to support a 64bit Mythtv client (successfully and easily upgraded form 10.10) and a 64 bit 10.10 Mythtv 10.10 client/server waiting to be upgraded. It is "tuned" for audi-visual-graphic work.

The upgrade to 10.10 for mythtv was required because of a hardware bug in the mythtv client/server

I am downloading the ubuntu-12.04-desktop-amd64.iso and will do a live_cd attempt if this bug is taken seriously. I will run it from a USB stick (preferrably) or a CD.

Please let me know if it is possible to run GCF, nvidia, 2nd monitor from live_cd and what you would like me to record, observe, &c.

those "steps" are not really detailled, what is "I was checking to see if progress had been made on bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641 after todays updates.", what action does that include?

0.Start 12.04 in Gnome Classic/fallback (GCF), run update manager.
1. From GCF enable screen1 as separate X·session using nvidia-settings.
2.Log out/in GFC.
3.Observe https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641
4.Log out GFC, Log in Unity
5.Observe https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641
6.Disable screen1 using nvidia-settings.
7.Log out Unity, Log In GCF
8.Observe https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1009216

During the above no changes were made with CCSM to configuration.
My standard CCSM configuration shown in the CCSM attachments.

A fresh installation would take several days: 10.10 update-manager to 11.04, 11.04 update-manager to 11.11, 11.11 update-manager to 12.04, install Gnome Classic/fallback.

The bug report was made after step 8 above, so anything in the bug report that differs from my standard CCSM setting would have been made without notification to me.

Note that these are the steps that recovered a working standard CCSM confiuration and caused the Launcher to go away.

1. Verify standard CCSM settings (see attachments) are actually in CCSM.
2. Discover previously ovderlooked setting uner

Quote: [those "steps" are not really detailled, what is "I was checking to see if progress had been made on bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641 after todays updates.", what action does that include?]

0.Start 12.04 in default Gnome Classic/fallback (GCF), run update manager.
1 From GCF enable screen1 as separate X·session using nvidia-settings saving xorg.conf.
2.Log out/in GCF.
3.Observe https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641
4.Log out GCF, Log in Unity
5.Observe https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641
6.Disable screen1 using nvidia-settingss saving xorg.conf.
7.Log out Unity, Log In GCF
8.Observe https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1009216

During the above no changes were made by me with CCSM to configuration.
My standard CCSM configuration shown in the CCSM attachments to this bug.

A fresh installation would take several days: 10.10 update-manager to 11.04, 11.04 update-manager to 11.11, 11.11 update-manager to 12.04, install Gnome Classic/fallback.

The bug report was made after step 8 above, so anything in the bug report that differs from my standard CCSM setting would have been made without notification to me.

Note that these are the steps that recovered a working standard CCSM confiuration and caused the Launcher to go away.

1. Verify standard CCSM settings (see attachments) are actually in CCSM.
2. Discover the previously overlooked setting under the category "Uncategorized" was "Unity Grab Handles" and it was checked.
3. Uncheck "Unity Grab Handles".
4. Observe Compiz crash, offering a popup window, "Examine, &c...."; decline.
5. Observe CCSM setting have reverted to apparently what they were after step 7 above.
6. Reset CCSM settings to my standard.
7. Observe no change in Compiz from changing settings, i.e. Desktop from 2x2 to 1x4 ―> no change.
8. Log out/in GCF.
9. Observe expected behavior with standard CCSM settings.

A fresh installation would take several days, 10.10>11.04,11.04>11.10,12.10>12.04,install GFC. This system was upgraded from a clone of my 10.04 boot in November over a year ago, and is used to support a 64bit Mythtv client (successfully and easily upgraded form 10.10) and a 64 bit 10.10 Mythtv 10.10 client/server waiting to be upgraded. It is "tuned" for audi-visual-graphic work.

The upgrade to 10.10 for mythtv was required because of a hardware bug in the mythtv client/server

I am downloading the ubuntu-12.04-desktop-amd64.iso and will do a live_cd attempt if this bug is taken seriously. I will run it from a USB stick (preferrably) or a CD.

Please let me know if it is possible to run GCF, nvidia, 2nd monitor from live_cd and what you would like me to record, observe, &c.

Sebastien Bacher (seb128) wrote :

ok, I'm out of that bug, the steps are just too complicated (need to read extra bug reports 3 times to figure what to do) and I don't have the hardware config needed anyway, in any case it's for sure not an unity bug since unity doesn't write any configuration, if there would be a bug there it would be a compiz one but it just seems a very weird setup and lot of weird steps leading to a weird situation which seeing the number of real obvious bug recorded nobody is likely to have time to debug

Pardon the miss posts.

@Sebastien Bacher (seb128)

Are saying a Ubuntu system with a second monitor running a 2nd monitor is a weird setup?

Are you saying that switching between Gnome Classic/fallback and Unity is a weird step?

Sebastien Bacher (seb128) wrote :

neither of those, what ever you are doing is complex over that, I'm using 2 screens sometimes and I'm changing session regularly to test things on GNOME classic, neither of those issues lead to the bug

These are the exact steps. They are exact because I was testing to check on the other bug and was careful to not do something extra. Furthermore, this was done immediately after morning start-up ⋯ boot, check for updates...&c

0.Start 12.04 in default Gnome Classic/fallback (GCF), run update manager.
1.From GCF enable screen1 as separate X·session using nvidia-settings saving xorg.conf.
2.Log out/in GCF using Crtl-Alt-Del.
3.Observe defective screen1
4.Log out GCF, Log in Unity using Crtl-Alt-Del.
5.Observe defective screen1
6.Disable screen1 using nvidia-settings saving xorg.conf.
7.Log out Unity, Log In GCF
8.Observe Unity Launcher.

Sebastien Bacher (seb128) wrote :

is the nvidia-settings use important there? does it happen without it? do you get the same issue if you use nouveau (the opensource driver) and configure your screen using the display panel in system settings? it could be the nvidia binary tools doing weird changes to the config...

nvidia-setting is required to enable/disable screen1 **as far as I know**.
I don't use the nouveau driver because **as far as I know**, a second monitor is not supported and SLI is not supported. (NVC0 at http://nouveau.freedesktop.org/wiki/FeatureMatrix)
I believe that this anomaly only occurs with nvidia drivers but I have no evidence for this. See: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1002641/comments/22

Would you have some configuration you wold like me to try?

Sebastien Bacher (seb128) wrote :

no, I said it before, I'm out of this bug, I've argued enough and I've no idea about your issue but I'm pretty sure it's not an unity bug, you should perhaps try the answer tracker for help there

As far as the part about Unity not changing CCSM settings, I tried this:

1. Log out of Gnome Classic/fallback using Ctrl-Alt-Del.
2. Log into Unity
3. Log out of Unity using Ctrl-Alt-Del.
4. Log into Gnome Classic/fallback
5.Observe CCSM setting were changed, including cube & 3D windows unchecked and desktop size set to 2x2 vice 1x4

I will file a bug.

Sergey Slizovskiy (sereza) wrote :

I want to support Keepitsimple,
  I have the same bug! This stupid Unity upper bar is stupid because it does not work properly with two monitors, when one is above another! It is doubled and covers some needed menu bars and complicates the game.
Now this crap appears even in Gnome after update!!!

Sergey Slizovskiy (sereza) wrote :

But I managed to remove it by unchecking Unity plugin in CompizConfig

Sergey Slizovskiy (sereza) wrote :

After I have done it, it's ok with Gnome, but when I start Unity, I see no unity plugin also.
So, somehow, the settings do overlap for Unity and Gnome, and this is to be considered as a bug!

To post a comment you must log in.