2nd screen unuseable after upgrade to 11.10

Bug #1001712 reported by keepitsimpleengr on 2012-05-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Incomplete
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to 11.10, the 2nd screen (screen1 ) blank white with icons from prior system. Mouse cursor changes to X (as in X-windows) whem moved to screen1.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.28.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-19.33-generic 3.0.27
Uname: Linux 3.0.0-19-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.gpus.1: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/1'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Sat May 19 10:07:39 2012
DistUpgraded: Log time: 2012-05-18 18:34:25.821098
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 280.13, 2.6.38-15-generic, x86_64: installed
 nvidia-current, 280.13, 3.0.0-19-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GF110 [GeForce GTX 560 Ti] [10de:1200] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:1563]
 nVidia Corporation GF110 [GeForce GTX 560 Ti] [10de:1200] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:1563]
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: EVGA 132-YW-E178-FTW
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-19-generic root=UUID=98396955-e718-4c04-83fa-b23dbb537615 ro delayacct
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2012-05-19 (0 days ago)
dmi.bios.date: 01/23/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: 132-YW-E178-FTW
dmi.board.vendor: EVGA
dmi.board.version: 1
dmi.chassis.type: 3
dmi.chassis.vendor: EVGA
dmi.chassis.version: 132-YW-E178-FTW
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd01/23/2009:svnEVGA:pn132-YW-E178-FTW:pvr1:rvnEVGA:rn132-YW-E178-FTW:rvr1:cvnEVGA:ct3:cvr132-YW-E178-FTW:
dmi.product.name: 132-YW-E178-FTW
dmi.product.version: 1
dmi.sys.vendor: EVGA
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6.1
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3.2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

tags: added: dist-upgrade
Daniel van Vugt (vanvugt) wrote :

Hi, could you please attach screenshots by any chance?

Also, please consider upgrading to 12.04. The latest ubuntu release always has many fixes that the previous release does not.

@Daniel van Vugt (vanvugt)

I tried to get a screen shot but could only get screen0.

I did upgrade to 12.04, 10.10>11.04>11.10>12.04, and the same behavior occurs there. This is the 1st level of upgrade where it occurs.

This is a "work" system, and Unity is counter-productive in that environment.

I am not alone, see: http://askubuntu.com/questions/138389/no-background-in-second-screen-separate-x-screen

screen1 description; When first starting, the wallpaper appears very briefly, then the screen goes completely white, except possibly for panels which are solid black with no decoration or even hidden icons. The only other thing on screen1 are four desktop icons that were there before the upgrade. On screen1, the cursor changes to the old X cursor.

I have now stopped at 11.04 where I am attempting to work out all bugs before again trying 11.10. One of my 32bit 10.10 systems upgraded to 12.04 with no problems, this is #2 and #3 is waiting.

I again attempted to upgrade to 11.10.

The screen1 again was white, I used the right mouse button and got a popup menu. I selected "create a new folder" and the white screen disappeared leaving the wallpaper.

I installed "Gnome shell" and "Gnome Tweak Tool". ccsm was installed.

I restarted selecting Gnome classic, which opened with the white screen1. Right mouse button again and the white disappeared. There were no panels in screen0 or screen1.

I opened ccsm and set my regular properties. no change.

To remove unity, I ran:
:~$ sudo apt-get remove unity unity-2d-places unity-2d unity-2d-panel unity-2d-spread unity-asset-pool unity-services unity-lens-files unity-lens-music unity-lens-applications gir1.2-unity-4.0 unity-common indicator-sound indicator-power indicator-appmenu libindicator6 indicator-application evolution-indicator indicator-datetime indicator-messages libnux-1.0-0 nuxtools

and got this result:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nuxtools

then: sudo apt-get install nuxtools
[sudo] password for ***:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nuxtools

I ran:
:~$ gnome-panel

(gnome-panel:26730): Gtk-CRITICAL **: gtk_style_context_get: assertion `priv->widget_path != NULL' failed
Segmentation fault

So I used nvidia-settings to disable screen1, and login/out.

Now I have a lower panel and three top panels stacked. The top top panel has working menus/icons.

Compiz Fusion icon is present and compiz is set a s window manager. Compiz settings are as I set but cube only works with keyboard shortcuts, not the mouse.

Daniel van Vugt (vanvugt) wrote :

keepitsimpleengr, we are working on an nvidia-specific bug (today!) that causes various windows (including desktop sometimes) to be blank white. I expect that fix will arrive in compiz 0.9.7.10 for precise, or maybe even sooner in 1:0.9.7.8-0ubuntu2 (maybe).
See bug 1002602 and bug 729979.

More generally, there have been known issues with upgrading customized compiz settings. I thought those bugs were fixed, but if you don't mind resetting your compiz settings then this worked for quite a few people:
    unity --reset
And then log out/in again.

==FinaL ressult after upgrade from 11.04 to 11.10
=screen1 enabled in Xwindow mode
Screen0: wallpaper and desktop icons but no panels
Screen1: solid white with desktop icons
right button click on screen1 causes white to be replaced with wall paper, no icons on screen1; wallpaper only with no icons or panels on scree0
when logging on with screen1 enabled, takes a long time.
when screen1 is disabled and logoff/on, panels w/menu and desktop wall paper but with two extra stacked, empty panels at top
=screen1 is disabled
Screen0: appears to be a normal windowwith wallpaper/icons/functional panels
After logoff/on appears to be a normal windowwith wallpaper/icons/functional panels

@Daniel van Vugt (vanvugt)

I do not use Unity, only gnome classic.

Regards compiz: the setting used are the same setting used in my 12.04 x86 where they work well (except for the flashing after cube rotate).

Thanks for the help...

Omer Akram (om26er) wrote :

so you mean that the issue that you are facing is not exclusive to Unity? Could we now close the unity bug in this case?

Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete

I have upgraded to 12.04.

Behavior is similar, except that right mouse button on screen1 opens a menu "create new folder; create new document...; organize desk...; Keep Aligned; &c" and when logon the icons on top and bottom panel are duplicated

@Omer Akram (om26er) In Unity the second screen unuseable, as in Gnome classic

To post a comment you must log in.