colord crashed with SIGABRT in raise()

Bug #827934 reported by Philipp Meier
This bug affects 335 people
Affects Status Importance Assigned to Milestone
colord (Ubuntu)
Medium
Chris Halse Rogers
Precise
Medium
Chris Halse Rogers
Quantal
Medium
Chris Halse Rogers

Bug Description

I was just trying to install a Samsung Network Printer. The error occurred during driver configuration of the printer.
The printer was installed correctly. Unable to reproduce just now.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: colord 0.1.11-1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
Date: Wed Aug 17 12:46:37 2011
ExecutablePath: /usr/lib/x86_64-linux-gnu/colord/colord
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110802.1)
ProcCmdline: /usr/lib/x86_64-linux-gnu/colord/colord
ProcEnviron:

Signal: 6
SourcePackage: colord
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
Title: colord crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Revision history for this message
Philipp Meier (meier-philipp) wrote :
visibility: private → public
Changed in colord (Ubuntu):
status: New → Confirmed
Revision history for this message
Philipp Meier (meier-philipp) wrote :

I just did the same procedure with the new cups version that came in today. The bug did not occur again.
cups 1.5.0-3
colord 0.1.11-1

Revision history for this message
Borbinceane Iulian (borby87) wrote :

Just install my Epson network printer after updating the sys and had the same error that Philipp had. Printer results install and works fine

Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x41b420 "cd_main_create_profile", message=0x7f9938002a10 "assertion failed: (connection != NULL)") at /build/buildd/glib2.0-2.29.16/./glib/gtestutils.c:1425
 g_assertion_message_expr (domain=0x4172ab "Cd", file=0x41a3b2 "cd-main.c", line=204, func=0x41b420 "cd_main_create_profile", expr=<optimized out>) at /build/buildd/glib2.0-2.29.16/./glib/gtestutils.c:1436
 cd_main_create_profile (error=0x7fff59dcf830, scope=CD_OBJECT_SCOPE_TEMP, profile_id=0x184ea10 "Samsung-CLX-3170-Series-Gray..", sender=0x184a140 ":1.87") at cd-main.c:204
 cd_main_daemon_method_call (connection_=<optimized out>, sender=0x184a140 ":1.87", object_path=<optimized out>, interface_name=<optimized out>, method_name=<optimized out>, parameters=0x17ff810, invocation=0x18488c0, user_data=0x0) at cd-main.c:1027
 call_in_idle_cb (user_data=<optimized out>) at /build/buildd/glib2.0-2.29.16/./gio/gdbusconnection.c:4440

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in colord (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
mazin (mazinm) wrote :

Happened to me when I restarted after I update from 11.04 to 11.10 beta1.
I have a Canon Pixima IP4200 printer, it was connected and on. And I don't have a scanner.

Revision history for this message
Jon Gunnar Rue (jonrue-online) wrote :

All I did was to start Synaptic.

Revision history for this message
Tony Themelis (tony-athemelis) wrote :

I was running hp-setup -i (interactive mode) on Lubuntu Oneiric with a Lenovo T400 laptop (64 bit) when I got this error.

tags: added: bugpattern-needed
Revision history for this message
albert fishnets (mateolingerhaus) wrote :

This popped up while running from a usb thumb drive. The system added my HP 2500 printer and then popped up this error about 30seconds later.

Revision history for this message
Andy (andy-akw) wrote :

First time booting 11.10 from LiveCD. Opened Software Centre for first time and immediately got this error.

Revision history for this message
Eliah Kagan (degeneracypressure) wrote :

I got this crash with the Lubuntu Oneiric amd64 desktop CD (with colord 0.1.12-1ubuntu2) on a Dell Studio XPS 8100, immediately after the desktop came up (after selecting "Try Lubuntu without installing"). The computer had a Samsung ML-2251N laser printer attached via USB. I tried booting without the printer detached, and the crash did not occur. So then I plugged the printer into the computer via USB, which immediately triggered the same crash.

tags: added: precise
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/827934

tags: added: iso-testing
Revision history for this message
Mike O'Donnell (mikeodonnell) wrote :

Precise, live CD (daily build Jan 24/12). When setting up printer, this crash reported. I only use B&W printing and when in properties, that was selected and printing was fine...

HP 1310 (15) inkjet. ~5 years old.

Revision history for this message
Andrew McDonnell (andymc73) wrote :

Got this testing precise i386 Alpha 2 xubuntu

tags: added: i386 xubuntu
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Changed in colord (Ubuntu):
importance: Medium → High
tags: added: dist-upgrade lucid2precise qa-daily-testing rls-mgr-p-tracking
Revision history for this message
Martin Pitt (pitti) wrote :

Chris, can you please have a look at this?

Changed in colord (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
Revision history for this message
Helge Jung (youngage) wrote :

This error doesn't seem to be strictly related to printer setup as the first comments suggest. At least for me this error happens most often right after booting and logging in - I haven't changed my printer setup for a while.

Revision history for this message
Eliah Kagan (degeneracypressure) wrote :

@Helge Jung
When I got this crash, I wasn't explicitly configuring a printer either. But it went away when I booted the live CD (and entered a desktop session) with the printer disconnected (https://bugs.launchpad.net/ubuntu/+source/colord/+bug/827934/comments/12). If you disconnect all your printers (and scanners), does that make the problem go away? Also, is this happening to you on an installed system or on a live CD?

Revision history for this message
Ron Bakker (r0n) wrote : Re: [Bug 827934] Re: colord crashed with SIGABRT in raise()

Op 19-02-12 21:54, Eliah Kagan schreef:
> @Helge Jung
> When I got this crash, I wasn't explicitly configuring a printer either. But it went away when I booted the live CD (and entered a desktop session) with the printer disconnected (https://bugs.launchpad.net/ubuntu/+source/colord/+bug/827934/comments/12). If you disconnect all your printers (and scanners), does that make the problem go away? Also, is this happening to you on an installed system or on a live CD?
>
Problem seems to be solved with todays updates !

Revision history for this message
Helge Jung (youngage) wrote :

@Eliah:
I don't have any local printers (except cups-pdf, but nothing parallel port or USB related). I do have a network-connected printer (Brother HL-3040CW with binary driver), but the colord crash happens whether that driver is available or not.

@Ron:
I have colord-0.1.12-1ubuntu2.1 installed which seems to be the most current version according to packages.ubuntu.com. As my last crash was with this version (bug #936418) the problem does not seems to be resolved, yet.

Revision history for this message
Phil Gorman (cygnus06) wrote :

Using fresh install of 12.04 Beta on Dell Studio XPS Desktop after unable to boot earlier versions of Ubuntu. Attempting to install Canon ipixma 4300 & Epson Stylus Photo R2400 when crash occured.

Revision history for this message
Frans Slothouber (rfsber) wrote :

I'm using a dual monitor setup. I was moving from one monitor to the other, when the mouse got 'stuck' in the middle of the two screens. For a little while it only moved up and down, then the froze completely. Then the whole X server froze. Had to kill it remotely. When I restarted my machine it came up with this this bug report.

tags: added: rls-p-tracking
tags: removed: rls-p-tracking
Revision history for this message
smallreactor (ecmporter) wrote :

Because of this bug, my computer cannot start the x server and brings me to the command prompt. Typing 'startx' doesn't work.

Revision history for this message
Janne Uusitalo (janne-uusitalo-gmail) wrote :

I'm also using a dual monitor setup, and my computer's connected to an SCX-4200 printer, but I almost never touch the settings of either and still encounter this bug after almost every boot. The crash is harmless, but lately seems to have gotten more frequent.

Revision history for this message
NEON SAMURAI (n3on-samurai) wrote :

I got this same error when adding a printer to my laptop. The printer is a network printer so the error didnt occur on startp, install, or after all the updates were done. It only occured when i added the network printer.

My printer is a brother hl2270dw if that helps (im connecting through lan), though reading peoples coments it doesnt seem to matter the model of printer.

i will be at work on monday and will find out if it occurs when adding the networked lexmark, and dymo labelwriter

Revision history for this message
Christopher (soft-kristal) wrote :

Crash shortly after boot while HP OfficeJet 4500 had been already turned on an connected. I just had a quick look at my printing GTK and it had been 'unabled' I enabled it again but had to force quit the window.

This after today's updates.

Revision history for this message
Ron Bakker (r0n) wrote :

This happens in 12.04 and 12.10 (Alpha-2) after I installed my HP Wifi all-in-one printer.
Everything is working, so i have disabled this error ......
This error is on my laptop with ATI and on my laptop with Nvidea, so I don t think it s hardware related.

Revision history for this message
col reilly (lupinehorror) wrote :

did an
apt-get install cups-pdf
to install a local pdf printer.
install completed successfully despite error.

Revision history for this message
Pavel Šefránek (pavelsefranek) wrote :

Affects me too. Occurs everytime I log on my desktop. All updates installed. HP printer connected and turned on all the time.

tags: added: quantal
Revision history for this message
Rafael Belmonte (eaglescreen) wrote :

This happened to me in quantal.

Revision history for this message
Saulo Soares de Toledo (saulotoledo) wrote :

Same here at quantal.

Para Siva (psivaa)
tags: added: rls-q-incoming
Revision history for this message
Didier Roche (didrocks) wrote :

Adding to the quantal list

Changed in colord (Ubuntu Precise):
importance: High → Medium
Changed in colord (Ubuntu Quantal):
importance: High → Medium
tags: removed: rls-q-incoming
Revision history for this message
Sanjeev Gupta (ghane) wrote :

I am running quantal, daily updates.

CUPS was updated yesterday, and hplip today. Error occurred on resuming from suspend.

Revision history for this message
Jake McGregor (jake-mcgregor86) wrote :

I don't know if this is related but my Ubuntu 12.10 machine couldn't successfully print to a network printer...I kept getting a "waiting for authentication" error that I couldn't get rid of even after modding /etc/cups/cupsd.conf and /etc/cups/printers.conf quite a bit. If anyone is interested I can attach those files on my system.

Revision history for this message
Joseph (jwcrespo3) wrote :

Sorry for not already knowing, but are those .txt files up there fixes for this bug? I can see I'm in the right place, because I'm getting the same bug when I try to plug an Acer monitor into my laptop, but I don't know what to do from here...

Revision history for this message
Colin Law (colin-law) wrote :

@Joseph: those are diagnostic files to help analyse the bug. There is no fix or workaround as far as I know. Are you sure it is this bug you get when you plug in an external monitor? The bug is to do with printers.

Revision history for this message
Francois VELUT (francois-velut) wrote :

On every boot, I have a crash detected, often in colord, and with SIGABRT, or SIGSEGV,.
I have also startx not running from time to time, at boot also.
I have installed SSG printer as well, Wifi.

Revision history for this message
Markus Wallgren (markus-k-wallgren) wrote :

On every boot since a couple of days i think.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package colord - 0.1.21-1ubuntu2

---------------
colord (0.1.21-1ubuntu2) quantal-proposed; urgency=low

  * debian/patches/one_shot_colord-sane.patch:
    - Rework colord-sane to be spawned each time a sane scan is required.
      Works around fd leaks in libsane and its plugins, resulting in many, many
      crashes in colord-sane. (LP: #1024081, LP: #1056933, LP: #1056933,
      LP: #1026520)
  * debian/patches/initialise_gdbus_connection_sooner.patch:
    - Initialise gdbus connection in the bus_acquired callback rather than the
      name_acquired callback. The name_acquired callback is fired an
      indeterminate time *after* the name appears on the bus, so requests can
      come in before its called. If this happened, colord would crash with an
      assert(). (LP: #849472, LP: #1064352, LP: #827934)
 -- Christopher James Halse Rogers <email address hidden> Wed, 10 Oct 2012 16:41:44 +1100

Changed in colord (Ubuntu Quantal):
status: Confirmed → Fix Released
Revision history for this message
LAZA (laza74) wrote :

When will this package backported to Precise?
It is very annoying to see the colord crash every time i try to print something...

Precise package is
ii colord 0.1.16-2ubuntu0.1 system service to manage device colour profiles -- system daemon
ii libcolord1 0.1.16-2ubuntu0.1 system service to manage device colour profiles -- runtime

Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :

I just got this bug today after logging in on elementary OS Luna.

Revision history for this message
Wilbert Volkers (wilbertvolkers) wrote :

The crash report comes up short after booting. I understand a fix is released for later versions but I would like to stay with the LTS version for now.

Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

Frequently getting this after boot on Precise.

Revision history for this message
Hairboy (tonycarbone) wrote :

This bug has started occurring for me on 12.04, occurs on boot and then occasionally during my session.
I have the HP Device Manager installed but all printers have been uninstalled for some time.

Interestingly (or maybe not?) on the error report for this "colord" crash, it suggests my Installation media is Karmic Koala 9.10? That was the version of Ubuntu I installed from scratch, and upgraded to 12.04 when it became available.

Could the problem be related to that?

FYI - Printing has never worked from Ubuntu 12.04 - I need to switch to Windoze to print :-s
Used to work fine prior to Ubuntu upgrade. Under 12.04 I get the error "no profiles specified in PPD", even after manually pointing it at the right PPD...

Revision history for this message
DiagonalArg (diagonalarg) wrote :

Happened on boot-up (precise, hd install). I don't have a printer.

Revision history for this message
John Belton (jbelton1950) wrote :

I have had this happen twice when booting Ubuntu 12.04.3 and though I have an HP USB printer it wasn't connected at the time.
This isn't the first problem since I upgraded to 12.04.3, it also seems to block access to UbuntuOne (this doesn't affect the two other machines with the same login one also running Ubuntu 12.04.3 and the other currently running Ubuntu 14.04 Alpha1).
John Belton

Revision history for this message
sokolov (daniel-sokolov) wrote :

Had this crash occur shortly after boot today on 12.04.

Revision history for this message
Michael J Flory (mjflory) wrote :

The bug just appeared for me after a fresh install of Mint 13 (Precise 12.04) while trying to install a networked HP LaserJet 5. Before my drive died I was running the same system on the same machine with the same printer, though with a different motherboard and with a hard drive, which I have replaced with a solid state drive.

Revision history for this message
fermulator (fermulator) wrote :

Still awaiting backport to Precise 12.04

Lukasz (lukaszek130388)
Changed in colord (Ubuntu Precise):
status: Confirmed → Fix Released
Colin Watson (cjwatson)
Changed in colord (Ubuntu Precise):
status: Fix Released → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

The Precise Pangolin has reached end of life, so this bug will not be fixed for that release

Changed in colord (Ubuntu Precise):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers