Text on "Games" menu is outside of window

Bug #445829 reported by GemNEye on 2009-10-07
108
This bug affects 20 people
Affects Status Importance Assigned to Milestone
CluTK
Low
Unassigned
clutk (Ubuntu)
Low
Didier Roche

Bug Description

Binary package hint: netbook-launcher

see attached picture for example of bug

ProblemType: Bug
Architecture: i386
Date: Wed Oct 7 14:27:59 2009
DistroRelease: Ubuntu 9.10
GConfNonDefault:
 /apps/netbook-launcher/disable_single_instance=false
 /apps/netbook-launcher/force_low_graphics=false
MachineType: MICRO-STAR INTERNATIONAL CO., LTD U90/U100
Package: netbook-launcher 2.1.10-0ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-12-generic root=/dev/sda6
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-12.40-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.7.0~git20091007.9c778a90-0ubuntu0tormod
 libdrm2 2.4.14+git20091004.ac34f599-0ubuntu0sarvatt
 xserver-xorg-video-intel 2:2.9.0~git20090930.2841a4cd-0ubuntu0tormod
 xserver-xorg-video-ati 1:6.12.99+git20091007.e59ae082-0ubuntu0tormod
SourcePackage: netbook-launcher
Tags: ubuntu-unr ubuntu-unr
Uname: Linux 2.6.31-12-generic i686
dmi.bios.date: 05/21/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.3
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: U90/U100
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: Ver.001
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.chassis.version: Ver.001
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.3:bd05/21/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnU90/U100:pvrVer.001:rvnMICRO-STARINTERNATIONALCO.,LTD:rnU90/U100:rvrVer.001:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvrVer.001:
dmi.product.name: U90/U100
dmi.product.version: Ver.001
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-12-generic

GemNEye (ubuntu-gemneye) wrote :

I can confirm this, as far as I can see it happens in menus with a lot of icons. I can see it in the System menu too. See attached screenshot.

Changed in netbook-launcher (Ubuntu):
status: New → Confirmed

To complete my last statement, not only the text falls out the windows sometimes, in other situations the icon's marquee is not correctly drawn. Please see image in comment #2.

Paul Larson (pwlars) wrote :

I thought I had seen this bug before, but I can't seem to find the reference at the moment.

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

I can confirm this bug too. Something I noticed: there is more blank space between the first and the second rows of icons than between the others. This only happens in Games menu.

Please ignore the screen shot at comment #2 it was taken in a Virtual Box VM, On real hardware (tested it with a Eee PC 701) the system menu doesn't have any problem.

The Games menu does have the issue that is described.

reh4c (gene-hoffler) wrote :

Problem also exists on the games menu using a Kohjinsha netbook with 1024x600 resolution. Please see attachment.

I think this bug could be related to a failure in handling the Games sub-categories (as described in http://library.gnome.org/devel/menu-spec/#category-registry in Additional Categories table). Karmic's gnome-menu comes with Games-Logic sub-category enabled (check Alt+F1). If you disable it on preferences (alacarte), the issue seems to disappear.

Bertel King (kmetamorphosis) wrote :

I can confirm that this bugs occurs as described, but that the fix mentioned in #8 hasn't worked for me. I've tried deleting the sub-categories and just un-checking them. I've had no luck with either method.

I can confirm the bug and un-checking the Icons fixed the problem for me. Except I now am left with out the games under these categories.

GemNEye (ubuntu-gemneye) wrote :

#8 is a hack; not a solution. The Games menu item works fine in Jaunty Netbook Remix, without a "hack". This is a bug, albeit extremely minor, but none of the other OS "competitors" would allow this bug in a final release.

Paul Larson (pwlars) on 2009-10-26
summary: - Text on "Games" menu it outside of window
+ Text on "Games" menu is outside of window
David Barth (dbarth) on 2009-10-28
Changed in netbook-remix-launcher:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Low
status: New → Triaged
Changed in netbook-launcher (Ubuntu):
importance: Medium → Low
Loïc Minier (lool) on 2009-10-29
Changed in netbook-launcher (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
J (jonathan-vola) wrote :

This issue only appeared for me after changing language (you might want to think about languages with big words)

It also only has 2 coloumns now (due to the size of the text I presume)

Also, in the system menu where the error is also appearing now, the first section overflows into the second section...

I presume this is related (it is all spacing issues yes?)

Attachments...

tags: added: iso-testing
Mike Teehan (mike-teehan) wrote :

There is definitely some sort of rendering bug in the netbook launcher. After installing, the games menu was fine, but somewhere along the line -- probably after installing a batch of games -- it became corrupted.

The problem manifests itself such: The first page or so renders properly, but eventually a large vertical blank space separates the rows and seems to push many of the bottom icons off the page. The last icons before the void render properly, but if one is selected, the "selected highlight" extends all the way down through the empty space. The icons clip at the edge of the launcher window, but many items are past the end of the list and inaccessible.

Screenshots are attached to demonstrate the rendering errors.

Julian (summers-j) wrote :

This bug is not limited to the Games menu. It affects all menus. I have a Compaq Mini 110c and the following menus are affected:
Accessories
Education
Games
Graphics
Office
Sound and Video
System Tools

This is particularly problematic because the "desktop switcher" was deprecated and so it's no longer easy to access the normal gnome desktop unless you turn off the menu altogether. For new users it would add other problems. My "root" and "terminal" icons were not available because they were pushed below the accessible range of the menu. To work around that I simply used the "Main Menu" tool under System -> Administration and moved the "terminal" icon to the "Sytem Administration" menu so I could access it. Of course, if the "main menu" tool was made inaccessible it would be a bigger PITA.

I think it should have a higher priority. It appears that the problem is caused when the menu allocates a large amount of space below one or more icons and this pushes the other icons below the accessible window. If I was a coder I would be glad to help, from all appearances it looks like the rendering algorythm creates a visible window based on the number of icons in a given menu and then renders the icons in that menu and if the procedure that creates the spacing of the icons allocates too much space and pushes the other icons down then the available window is not adjusted for this problem and the program icons become unavailable.

lukerazor (lukerazor) wrote :

I agree with Julian, this bug should be rated a higher priority. The original report is not too serious but the subsequent issues reported in comment #2 do render some icons unusable. This elevates the bug from a purely aesthetic problem to a functional one.

Gabriel Bauman (gabrielbauman) wrote :

I see the problem as well. I've been running a fresh UNR for maybe 3 days. The problem did not occur after the initial installation.

At this time no menus with submenus are rendered correctly by netbook-launcher. Additionally, the last row of icons on each screen is unclickable.

Switching back to standard desktop until this is dealt with. Whoops, desktop-switcher is deprecated. Hooray.

Didier Roche (didrocks) wrote :

Can you please try with last lucid version, adding this ppa: https://launchpad.net/~ubuntu-desktop/+archive/ppa and then upgrading to get last clutk?

There is a proposed patch which should fix that.
Thanks for trying. I'm putting the bug report as Incomplete waiting for feedback.

Changed in netbook-launcher (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
status: Triaged → Incomplete
Changed in netbook-remix-launcher:
status: Triaged → Incomplete
assignee: Jason Smith (jassmith) → nobody
Didier Roche (didrocks) on 2010-03-11
Changed in netbook-launcher (Ubuntu):
milestone: none → ubuntu-10.04-beta-1
Didier Roche (didrocks) on 2010-03-11
Changed in netbook-launcher (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
affects: netbook-launcher (Ubuntu) → clutk (Ubuntu)
Changed in clutk (Ubuntu):
assignee: Didier Roche (didrocks) → nobody
assignee: nobody → Didier Roche (didrocks)
affects: netbook-remix-launcher → clutk
Didier Roche (didrocks) on 2010-03-11
Changed in clutk:
status: Incomplete → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clutk - 0.3.8.is.0.2.10-0ubuntu1

---------------
clutk (0.3.8.is.0.2.10-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - Fix netbook-launcher crashed with SIGFPE in clutter_actor_allocate()
      (LP: #445995)
    - Map/unmap and check that ctk icon children are valid
    - Use GNOME simplified autogen.sh (LP: #456901)
    - Reinitialize to 0 some coordonates to avoid overlapping icons and
      weird behavior in multines scheme
      (LP: #424231, #414353, #435805, #459367, #445829, #447715, #480219)
    - apply to trunk asac fix to fix netbook-launcher segfault on start;
      make ctk_text_new NULL safe
  * debian/control:
    - bump Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 11 Mar 2010 17:04:19 +0100

Changed in clutk (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.