clamav-base fails configure with `/usr/share/doc/clamav-base/examples/main.cvd': No such file or directory

Bug #1015337 reported by Scott Ritchie on 2012-06-19
96
This bug affects 14 people
Affects Status Importance Assigned to Milestone
clamav (Ubuntu)
Undecided
Marc Deslauriers
Natty
Undecided
Marc Deslauriers
Oneiric
Undecided
Marc Deslauriers
Precise
Undecided
Marc Deslauriers
Quantal
Undecided
Marc Deslauriers

Bug Description

My build scripts broke today with the new clamav SRU. They install the dansguardian package, which fails when pulling in the clamav-base dependency. Some testing in a VM shows this to be an easy to replicate problem:

$ sudo apt-get install dansguardian
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libipc-run-perl libnet-ip-perl libnet-dns-perl libclone-perl libsub-name-perl libparse-debianchangelog-perl libio-pty-perl libio-string-perl libnet-domain-tld-perl libemail-valid-perl libapt-pkg-perl
  libclass-accessor-perl libdigest-hmac-perl
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  clamav clamav-base clamav-freshclam libclamav6 libtommath0
Suggested packages:
  clamav-docs squid libclamunrar6
The following NEW packages will be installed:
  clamav clamav-base clamav-freshclam dansguardian libclamav6 libtommath0
0 upgraded, 6 newly installed, 0 to remove and 79 not upgraded.
Need to get 4,954 kB of archives.
After this operation, 14.4 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/main libtommath0 amd64 0.42.0-1 [53.0 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libclamav6 amd64 0.97.5+dfsg-1ubuntu0.12.04.1 [4,068 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main clamav-base all 0.97.5+dfsg-1ubuntu0.12.04.1 [101 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main clamav-freshclam amd64 0.97.5+dfsg-1ubuntu0.12.04.1 [115 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main clamav amd64 0.97.5+dfsg-1ubuntu0.12.04.1 [132 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ precise/universe dansguardian amd64 2.10.1.1-4 [485 kB]
Fetched 4,954 kB in 11s (450 kB/s)
Preconfiguring packages ...
Selecting previously unselected package libtommath0.
(Reading database ... 204129 files and directories currently installed.)
Unpacking libtommath0 (from .../libtommath0_0.42.0-1_amd64.deb) ...
Selecting previously unselected package libclamav6.
Unpacking libclamav6 (from .../libclamav6_0.97.5+dfsg-1ubuntu0.12.04.1_amd64.deb) ...
Selecting previously unselected package clamav-base.
Unpacking clamav-base (from .../clamav-base_0.97.5+dfsg-1ubuntu0.12.04.1_all.deb) ...
Selecting previously unselected package clamav-freshclam.
Unpacking clamav-freshclam (from .../clamav-freshclam_0.97.5+dfsg-1ubuntu0.12.04.1_amd64.deb) ...
Selecting previously unselected package clamav.
Unpacking clamav (from .../clamav_0.97.5+dfsg-1ubuntu0.12.04.1_amd64.deb) ...
Selecting previously unselected package dansguardian.
Unpacking dansguardian (from .../dansguardian_2.10.1.1-4_amd64.deb) ...
dpkg: warning: version 'dansguardian_2.8.0.6-antivirus-6.4.4.1-4' has bad syntax: version number does not start with digit
Processing triggers for man-db ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up libtommath0 (0.42.0-1) ...
Setting up libclamav6 (0.97.5+dfsg-1ubuntu0.12.04.1) ...
Setting up clamav-base (0.97.5+dfsg-1ubuntu0.12.04.1) ...
install: cannot stat `/usr/share/doc/clamav-base/examples/main.cvd': No such file or directory
dpkg: error processing clamav-base (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of clamav-freshclam:
 clamav-freshclam depends on clamav-base (>= 0.97.5+dfsg-1ubuntu0.12.04.1); however:
  Package clamav-base is not configured yet.
dpkg: error processing clamav-freshclam (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of clamav:
 clamav depends on clamav-freshclam | clamav-data; however:
  Package clamav-freshclam is not configured yet.
  Package clamav-data is not installed.
  Package clamav-freshclam which provides clamav-data is not configured yet.
dpkg: error processing clamav (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dansguardian:
 dansguardian depends on clamav (>= 0.80); however:
  Package clamav is not configured yet.
dpkg: error processing dansguardian (--configure):
 dependency problems - leaving unconfigured

description: updated
Changed in clamav (Ubuntu Natty):
status: New → Confirmed
Changed in clamav (Ubuntu Oneiric):
status: New → Confirmed
Changed in clamav (Ubuntu Precise):
status: New → Confirmed
Changed in clamav (Ubuntu Quantal):
status: New → Confirmed
Changed in clamav (Ubuntu Natty):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in clamav (Ubuntu Oneiric):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in clamav (Ubuntu Precise):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in clamav (Ubuntu Quantal):
assignee: nobody → Marc Deslauriers (mdeslaur)
Marc Deslauriers (mdeslaur) wrote :

Looks like the postinst is still trying to install the bundled databases, even though we no longer ship them in the new version.

Marc Deslauriers (mdeslaur) wrote :

New packages are currently being built and will be published as a regression fix in about an hour.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clamav - 0.97.5+dfsg-2ubuntu1

---------------
clamav (0.97.5+dfsg-2ubuntu1) quantal; urgency=low

  * Merge from Debian Unstable. Remaining Ubuntu changes:
    - Drop build-dep on electric-fence (in Universe)
    - Add apparmor profiles for clamd and freshclam along with maintainer
      script changes

clamav (0.97.5+dfsg-2) unstable; urgency=medium

  * Medium urgency due to security fixes
  * Update debian/clamav-base.postinst.in to test for the existence of the
    actual .cvd files before trying to install them and not just the directory
    they should be in (Closes: #678019), (LP: #1015337)
  * Remove /var/run/clamav on purge (LP: #829945)
    - Thanks to Imre Gergely for the patch
  * Add call to /sbin/restorecon in debian/common_functions make_directory to
    to label the /run directory for SE Linux (Closes: #677686)
    - Thanks to Russell Coker for the patch
  * Remove obsolete reference to clamav-data package in clamav-daemon init log
    failure message
 -- Scott Kitterman <email address hidden> Tue, 19 Jun 2012 21:39:28 -0400

Changed in clamav (Ubuntu Quantal):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clamav - 0.97.5+dfsg-1ubuntu0.12.04.2

---------------
clamav (0.97.5+dfsg-1ubuntu0.12.04.2) precise-security; urgency=low

  * SECURITY REGRESSION: Fix installation issue. (LP: #1015337)
    - debian/clamav-base.postinst.in: Since we no longer ship daily.cvd and
      main.cvd anymore, don't try and install them in the postinst.
 -- Marc Deslauriers <email address hidden> Tue, 19 Jun 2012 20:01:11 -0400

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clamav - 0.97.5+dfsg-1ubuntu0.11.10.2

---------------
clamav (0.97.5+dfsg-1ubuntu0.11.10.2) oneiric-security; urgency=low

  * SECURITY REGRESSION: Fix installation issue. (LP: #1015337)
    - debian/clamav-base.postinst.in: Since we no longer ship daily.cvd and
      main.cvd anymore, don't try and install them in the postinst.
 -- Marc Deslauriers <email address hidden> Tue, 19 Jun 2012 20:07:07 -0400

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clamav - 0.97.5+dfsg-1ubuntu0.11.04.2

---------------
clamav (0.97.5+dfsg-1ubuntu0.11.04.2) natty-security; urgency=low

  * SECURITY REGRESSION: Fix installation issue. (LP: #1015337)
    - debian/clamav-base.postinst.in: Since we no longer ship daily.cvd and
      main.cvd anymore, don't try and install them in the postinst.
 -- Marc Deslauriers <email address hidden> Tue, 19 Jun 2012 20:08:18 -0400

Changed in clamav (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in clamav (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in clamav (Ubuntu Precise):
status: Confirmed → Fix Released
Matpen (matpen) wrote :

Great that a fix was released so quickly! Can you please advise how an user can get it? I am still getting the same error while installing via apt. Apparently the package being installed (even after apt-get upgrade) is 0.97.5+dfsg-1ubuntu0.12.04.1

Marc Deslauriers (mdeslaur) wrote :

Wait until your local mirror gets 0.97.5+dfsg-1ubuntu0.12.04.2.

If your local mirror already has it, you may also need to remove the packages that are currently installed, and reinstall clamav.

tags: added: bugpattern-written
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers