Black image (no video) with Live! Cam Connect HD VF0750 with some exceptions

Bug #1650796 reported by Vincas Dargis on 2016-12-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cheese (Ubuntu)
Medium
Unassigned

Bug Description

After upgrading my Inspiron 6400 laptop (32-bit) from 14.04 to 16.04, launching Cheese with Live! Cam Connect HD VF0750 webcam *sometimes* (randomly) gives no video, only black image. No errors are reported on GUI, console, or syslog.

You can start Cheese again and it might start video, but sometimes not, randomly. In case when there is no image, opening Settings and changing resolution makes video appear!

Tried to downgrade libv4l-0, libv4lconvert0 to 14.04 version (1.0.1 I believe) but it did not helped. Upgrading to Linux 4.8 (from hwe package) did not helped either.

On other laptop with Ubuntu 14.04 (with same 4.4 kernel from hwe package) there is no issues as such, so I assume it's bug with Cheese itself.

Interestingly, on yet other laptop (Asus N551JM) with Kubuntu 16.04 Cheese does not show video on launch always (tested with many restarts of Cheese app). If I change resolution in Settings, it does start to show video thought. That computer is faster than Dell 6400 one, so I'm guessing it could be some kind race condition..?

I cannot reproduce this issue with Camorama for example, it seems it always starts video successfully for this webcam.

---
ApportVersion: 2.20.1-0ubuntu2.4
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: petras 2060 F.... pulseaudio
 /dev/snd/controlC0: petras 2060 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
InstallationDate: Installed on 2011-11-23 (1851 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: Dell Inc. MM061
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-30-generic root=UUID=b57d1858-e7f3-42a3-a7ef-5e7ab8dd5ae4 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.8.0-30.32~16.04.1-generic 4.8.6
RelatedPackageVersions:
 linux-restricted-modules-4.8.0-30-generic N/A
 linux-backports-modules-4.8.0-30-generic N/A
 linux-firmware 1.157.6
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: xenial
Uname: Linux 4.8.0-30-generic i686
UpgradeStatus: Upgraded to xenial on 2016-11-19 (28 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare uucp
_MarkForUpload: True
dmi.bios.date: 06/09/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0KD882
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd06/09/2006:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0KD882:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MM061
dmi.sys.vendor: Dell Inc.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1650796

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Vincas Dargis (talkless) wrote :

Sorry, I cannot use apport-collect because of error:

ERROR: Could not import module, is a package upgrade in progress? Error: No module named PyQt5.QtCore

Relevant bug report:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1451808

Any ideas to workaround that?

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.9 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.9

Changed in linux (Ubuntu):
importance: Undecided → Medium
Vincas Dargis (talkless) wrote :

Did I reported this bug as Linux bug? I wanted to report it against cheese, a web cam app.

I was pretty sure it's something with cheese, as other application camorama works OK.

Vincas Dargis, to see if this is already resolved in Ubuntu, could you please test http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

tags: added: bios-outdated-a17 regression-release
description: updated
affects: linux (Ubuntu) → cheese (Ubuntu)
Vincas Dargis (talkless) wrote :

OK I'll try that on this weekend.

Vincas Dargis (talkless) wrote :

Just tried zesty image, Cheese still has the same problem. Camorama works withe with mentioned webcam.

I even tried to launch Cheese/Camorama/Cheese/Camorama/... one after another, and Camorama always stats video successfully, but Cheese sometimes shows black image.

Vincas Dargis, the issue you are reporting is an upstream one. Could you please report this problem to them following the instructions at https://bugzilla.gnome.org/enter_bug.cgi?product=cheese ?

Please provide a direct URL to your upstream report once you have made it so that it may be tracked.

Thank you for your help.

Changed in cheese (Ubuntu):
status: Incomplete → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers