[lucid] live cd does not shutdown

Bug #506418 reported by Mitch Towner on 2010-01-12
124
This bug affects 18 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Steve Langasek
Lucid
High
Steve Langasek

Bug Description

Binary package hint: casper

Testing alpha2 candidate (20100112.1) lucid-desktop-i386 image (burned to cd). Upon clicking shutdown in the live environment, the cd is ejected & then the laptop hangs with the Ubuntu logo displayed. "Please remove the disc and close the tray (if any) then press ENTER" is not displayed. Pressing Enter did nothing. Cycling through the various ctrl-alt-"F" combinations displays "The system is going down for halt NOW!" but the laptop just hangs. Ultimately I need to perform a hard power off. This happens on every shutdown from the live environment.

Further testing revealed that an installed system from the same disc reboots & shuts down normally.

ProblemType: Bug
Architecture: i386
Date: Wed Jan 13 00:21:16 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100112.1)
Package: casper (not installed)
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: casper
Tags: lucid
Uname: Linux 2.6.32-10-generic i686

Related branches

Mitch Towner (kermiac) wrote :

Forgot to mention that this also occurs upon finishing an install from within the live environment (i.e whilst performing Case ID: uwi-001 from the testing tracker (http://testcases.qa.ubuntu.com/Install/DesktopWhole)

tags: added: iso-testing
Tom Pino (metalsmith-rangeweb) wrote :

On my amd64 desktop system the CD was not ejected but everything else was the same as above.

Dave Morley (davmor2) on 2010-01-12
Changed in casper (Ubuntu):
status: New → Confirmed
DTHCND (darrenhobin) wrote :

It works fine for me. After your CD ejected did you try hitting enter? I remember you had to on 9.10 and when I did here it worked fine...

Mitch Towner (kermiac) on 2010-01-13
description: updated
Dave Morley (davmor2) wrote :

This works fine if plymouth doesn't start. However if plymouth starts and you get the white Ubuntu logo you can't do anything.

I've hit enter on the logo screen nothing, gone through all the tty screen hitting enter also still nothing.

Ara Pulido (ara) wrote :

I can confirm that if plymouth does not start, the Live CD shuts down correctly.

Steve Langasek (vorlon) wrote :

This bug appears specifically to only be reproducible when booting from CD, not when booting from USB.

Emmet Hikory (persia) wrote :

From #ubuntu-devel: ( http://irclogs.ubuntu.com/2010/01/12/#ubuntu-devel.txt )

[12:43] <davmor2> pitti: An issue I'm assuming due to plymouth has arisen in that there is no dialogue to press enter to continue shutdown once the install has completed
[12:44] <pitti> davmor2: the one in X? that shouldn't be related to plymouth
[12:44] <pitti> ah, the "press enter" after shutdown
[12:44] <ogra> pitti, the one that used to be in usplash
[12:44] <pitti> davmor2: can you please file a bug? (sorry, at sprint this week)
[12:45] <pitti> should be easy to fix, instead of usplash-send use the equivalent plymouth command
[12:45] <davmor2> pitti: no probs I think it is in process now. Is my assumption about it being plymouth correct and will the dialogue show up on a different tty?
[12:46] <pitti> I'm not sure; I'm a plymouth n00b

DTHCND (darrenhobin) wrote :

It takes about 1 minute to shut down. You NEED to hit enter WITHOUT prompt... For CD and USB... Try waiting for the CD to eject or if it doesn't wait at least 3 minutes then hit "enter" or "return"...

Changed in casper (Ubuntu):
status: Confirmed → Invalid
Alberto Russo (valix) wrote :

The cd is ejected, but is impossible continue shutdown

Changed in casper (Ubuntu):
status: Invalid → Incomplete
status: Incomplete → Confirmed
Steve Langasek (vorlon) on 2010-01-22
Changed in casper (Ubuntu Lucid):
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-1
Colin Watson (cjwatson) on 2010-01-29
Changed in casper (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → lucid-alpha-3
Colin Watson (cjwatson) on 2010-02-24
Changed in casper (Ubuntu Lucid):
milestone: lucid-alpha-3 → ubuntu-10.04-beta-1
Theburn7 (theburn7) wrote :

This is correct and even the Kubuntu website points out that this accusation is correct.

Alberto Russo (valix) wrote :

Today i try the daily live of xubuntu and the current problem is present.

Steve Langasek (vorlon) wrote :

have committed an (untested) fix for this to bzr.

Changed in casper (Ubuntu Lucid):
assignee: nobody → Steve Langasek (vorlon)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.227

---------------
casper (1.227) lucid; urgency=low

  * casper-md5check: port from usplash to plymouth. LP: #500198
  * fix up our reliance on usplash, /dev/console elsewhere. LP: #506418.
 -- Steve Langasek <email address hidden> Fri, 12 Mar 2010 01:12:28 -0800

Changed in casper (Ubuntu Lucid):
status: Fix Committed → Fix Released
Fabio Isgrò (dr.gogeta86) wrote :

I try with today live , just doesn't print press return to shutdown

On Fri, Mar 12, 2010 at 04:07:52PM -0000, Fabio Isgrò wrote:
> I try with today live , just doesn't print press return to shutdown

Today's live CDs were built before the fixed casper package was available.
Please try again with tomorrow's CDs.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Manos Sarris (emmsarris) wrote :

I' m not sure whether this is the right place to post, but since it is similar (if not is the problem) I'll post it here.
Well lucid beta1 does not shutdown (switch-off) either from livecd or installed. On the contrary it reboots! Even when i use "sudo shutdown -P now" or "sudo shutdown -H now".

Steve Langasek (vorlon) wrote :

emmsarris,

That's unrelated to this issue; please file a separate bug report.

Fixmeright (fixmeright) wrote :

10.04 not responding past login screen

Alessandro Losavio (alo21) wrote :

i had this problem on Kubuntu Desktop i386 10.10 Alpha1

Alessandro Losavio (alo21) wrote :

i had this problem on mythbuntu Desktop i386 10.10 Alpha1

It appears that the fix for this bug introduced long-standing bug #966480 ("The prompt asking for media removal is not shown at the end of the installation").

    if [ -x /bin/plymouth ] && plymouth --ping; then
        plymouth message --text="$MSG"
        plymouth watch-keystroke > /dev/null

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers