The keyboard is still installed as US-English even if another language is selected during the installation

Bug #1549529 reported by sudodus on 2016-02-24
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Mathieu Trudel-Lapierre
console-setup (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

- Particularly serious in UEFI mode (when grub is the only boot loader).

- Affects at least Lubuntu and Xubuntu

- Affects not only Swedish, at least also French, probably all languages except US-English.
-----

Workaround:

If I install Swedish language in the live session *before* starting the installer, it works to get Swedish keyboard in the installed system.
-----

This bug is reported from a system installed from Lubuntu Xenial alternate i386, but the corresponding desktop version is also affected. It is a rather new bug, that seems to have appeared at about the same time as the big problems with starting Ubiquity.

Selecting another language in the installer looks the same in the alternate installer. But it looks different in the desktop installer. The locale is not pre-selected, you click on the world map, and you are asked if the selected keyboard is correct. The following window with alternative keyboards is empty. But that would be OK, if the installer would do, what it promises.

After installation a lot of text is in the selected language, Swedish in my case, for example the pulldown menus in lxterminal. But when I type, the US English keyboard is still there. I have to run

setxkbmap se

to get Swedish keyboard.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 4.4.0-7.22-generic 4.4.2
Uname: Linux 4.4.0-7-generic i686
ApportVersion: 2.20-0ubuntu3
Architecture: i386
CurrentDesktop: LXDE
Date: Thu Feb 25 00:21:47 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-02-24 (0 days ago)
InstallationMedia: Lubuntu 16.04 LTS "Xenial Xerus" - Alpha i386 (20160224)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) wrote :

Added an illustration

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1549529

tags: added: iso-testing
sudodus (nio-wiklund) on 2016-02-25
summary: - The keyboard is still installed as US-English even if Swedish is
- selected during the installation
+ The keyboard is still installed as US-English even if another language
+ is selected during the installation
sudodus (nio-wiklund) wrote :

In BIOS mode and booting from syslinux it is possible to select language at the very first screen at boot. It seems this language will survive and be installed for the keyboard.

If US English is kept at the very first screen at boot, it will be the language of the keyboard. It *seems* that you change the language for the keyboard as well as for the printed text, but that change is not transferred to the installed system.

In UEFI mode I don't know any option to select language at such an early stage, so the keyboard will stay in US English. Trying to change it in the installer (Ubiquity) does not work. It is not transferred to the installed system.

Phill Whiteside (phillw) wrote :

Hi, we did see a bug that sweden was not marked as swedish. For me, with the beta1 builds in 32bit on bare metal, I get my UK keyboard layout.

I'm marking this as 'please try latest version'... If you still have this error, please do shout up.!! And thank you for taking the time out to report a bug, we really do appreciate you guys and gals doing so.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
sudodus (nio-wiklund) wrote :

What must be done to make this bug report 'complete'?

sudodus (nio-wiklund) wrote :

Selection of keyboard layout is still borked in the current Lubuntu i386 daily iso file, when booted via grub.

There are almost empty boxes, where there should be several alternatives of Swedish keyboards). It looks like the same bug as I saw when I created the bug report.

There is no logical reason why the only choice should be Latvian (in Swedish !!!) - I have not selected it, but it appeared after I used 'Identify the keyboard layout' and selected button until Swedish was found. The Dialogue in Ubiquity continues to be in Swedish.

The installed system has menus etc in Swedish, but the keyboard layout in the US-English one, so I confirm that the bug is still alive in the current daily iso file. I can change it with setxkbmap se, but it has not been like this before. The keyboard should be possible to select via Ubiquity during the installation.

-o-

I think the most serious problem is that of installing in UEFI mode, because there is only the grub alternative.

Phill Whiteside (phillw) wrote :

Hi Nio,

there is a think that the two bugs seen on desktop installer and alternate installer may be linked. I'm holding judgement, but they have to share commonality at the CLI end. https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1559507 has been bumped to High, and I will include this bug in the notes as it may help the devs work out where it all stopped working.

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
sudodus (nio-wiklund) wrote :

I tested with the current daily xubuntu-xenial-desktop-amd64.iso, and it is affected too.

I tested with French keyboard, even used 'settings-keyboard' to set it, which affected typing in Ubiquity's test window

qwerty --> azerty

but still, only the US-English keyboard layout was ported to the installed system :-(

-o-

So it affects other languages and other flavours of Ubuntu too (not only Swedish and Lubuntu).

sudodus (nio-wiklund) on 2016-03-21
description: updated
description: updated
sudodus (nio-wiklund) wrote :

Could it be that the Swedish locale is somehow incomplete, when not set via the syslinux language menu?

sudodus (nio-wiklund) wrote :

This is weird!

Believe it or not: Installing Xubuntu again, I selected French (instead of Swedish), and then, at the keyboard selection, I could select French and Swedish keyboard too (all the choices were there). I continued the installation, and yes, I could get French text in menus etc, and a Swedish keyboard ported to the installed system.

(But I can't get a Swedish keyboard if I select Swedish language in the beginning of Ubiquity.)

sudodus (nio-wiklund) wrote :

Workaround:

If I install Swedish language in the live session *before* starting the installer, it works to get Swedish keyboard in the installed system.

sudodus (nio-wiklund) on 2016-03-23
description: updated

The install appears to work in Swedish if Swedish is picked as the language before booting (at the graphical boot splash when booting not in EFI). This points me to console-setup and/or something that needs to happen in casper.

affects: ubiquity (Ubuntu) → casper (Ubuntu)
Changed in casper (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → High
status: Confirmed → In Progress
Phill Whiteside (phillw) wrote :

As a workaround. After install issue "sudo dpkg-reconfigure keyboard-configuration" from terminal and it will take you to the missing steps for language, keyboard layout and update the /etc/default/keyboard file.

This also works for the Alternate ISO keyboard bug.

Changed in console-setup (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

console-setup (1.108ubuntu12) xenial; urgency=medium

  * No-change rebuild to properly generate console-setup-udeb's list of
    valid keyboard layouts and variants.

Changed in casper (Ubuntu):
status: In Progress → Invalid
Changed in console-setup (Ubuntu):
status: In Progress → Fix Released
Changed in casper (Ubuntu):
status: Invalid → Triaged
sudodus (nio-wiklund) wrote :

Maybe this bug is also related to the following bug:

https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1560577

'Confusing new locale-gen behavior'

Turns out it's not really completely fixed in console-setup ---

The issue stems from the use of grep which has grown more pedantic about grepping through data that might look like binary. When we grep for the translated names for keyboards, countries and stuff, that translated data looks a bit like binary to grep if we hit the right mix of locales. The solution to this is to make sure we used 'grep -a' where dealing with this data.

Fixing it now...

Changed in casper (Ubuntu):
status: Triaged → Invalid
Changed in console-setup (Ubuntu):
status: Fix Released → In Progress
Changed in console-setup (Ubuntu):
milestone: none → ubuntu-16.04
tags: added: rls-x-incoming
sudodus (nio-wiklund) wrote :

Good catch :-)

I'll look out for other problems, that might be caused by that change in grub (and try the option -a).

Phill Whiteside (phillw) wrote :

Mathieu Trudel-Lapierre you are a little angel.
This is not the 1st bug I've been following where your clean pair of eyes and attitude solves things quickly.
I'll say thank-you and break bug rules.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.108ubuntu13

---------------
console-setup (1.108ubuntu13) xenial; urgency=medium

  * debian/keyboard-configuration.config: run grep with -a (to deal with files
    as ASCII data) when searching for keyboard, locale, and layout names.
    (LP: #1549529)

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 04 Apr 2016 13:47:04 -0400

Changed in console-setup (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers