Status Notifications over SSH

Bug #938920 reported by Derek Morton on 2012-02-22
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
High
Dustin Kirkland 

Bug Description

Version info:
byobu -v
byobu version 5.13
tmux 1.6

Issue: Byobu over SSH with the Logo status notification enabled causes a new byobu status notification bar to be created one on top of another.

Screenshots:
Normal: http://www.screencast.com/t/kahBvULyC
Broken: http://www.screencast.com/t/aXFJHk72vT0W

Steps to reproduce:
1) Login via SSH
2) Run byobu with logo notification enabled (default)

Workaround:
1) Disable the logo status notification, either by the byobu-config menu or manually editing the ~/.byobu/status file

Only SSH sessions/clients seem to be effected by this. Using byobu from tty1 does not cause this issue.

The two SSH clients used were SecureCRT 6.74 and PuTTY 0.6.2, both on a Windows 7 x64 host.

Ugh, that's nasty.

Can you try disabling UTF8? Add UTF8=0 in ~/.byobu/statusrc, and let
me know if that fixes it? If so, then that will help me get a better
permanent fix.

Changed in byobu (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium

Using UTF8=0 did not fix the issue.

Couple more tidbits I've picked up on this:
1) The "network" status notification also exhibits the same behavior (Bug title updated slightly)
2) The issues are isolated to the tmux backend. Switching the backend to screen also causes the issues not to occur

summary: - Logo Status Notification over SSH
+ Status Notifications over SSH
Launchpad Janitor (janitor) wrote :

[Expired for byobu (Ubuntu) because there has been no activity for 60 days.]

Changed in byobu (Ubuntu):
status: Incomplete → Expired
Ayron Jungren (ajungren) wrote :

This bug is still present. Derek provided all the requested information, but janitor closed the bug anyway. Can someone please fix this bug or provide a workaround (other than not using tmux)? It is insanely annoying.

Changed in byobu (Ubuntu):
status: Expired → New
Dustin Kirkland  (kirkland) wrote :

This is a terminal specific issue. Some terminals are not able to handle the special Ubuntu UTF8 logo, .

I tried Putty in Ubuntu and that worked fine. This might be windows specific? I have not yet been able to reproduce this.

Changed in byobu (Ubuntu):
status: New → In Progress
importance: Medium → High
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Setting incomplete. I can't reproduce this yet.

Changed in byobu (Ubuntu):
status: In Progress → Incomplete
status: Incomplete → In Progress
Dustin Kirkland  (kirkland) wrote :

Okay, I have managed to reproduce this under Ubuntu and gnome-terminal with:
 $ export VTE_CJK_WIDTH=1; gnome-terminal --disable-factory

Dustin Kirkland  (kirkland) wrote :

Okay, committing what I think should fix this.

If you can reproduce this on version of byobu >= 5.20, please update this bug with the output of:
 $ echo $LANG
 $ locale charmap

Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.20-0ubuntu1

---------------
byobu (5.20-0ubuntu1) quantal; urgency=low

  [ Dustin Kirkland ]
  * usr/bin/byobu-status: LP: #998812
    - fix upgrades to the new width handling, where some things
      were undefined
  * usr/lib/byobu/updates_available: LP: #976928, #1010505, #999151
    - use flock when running apt-check or apt-get
      + ideally we'd use run-one here, but not yet in main or other distros
    - depend on util-linux, which provides flock
    - drop run-one usage, use flock directly instead
  * debian/control, usr/share/byobu/windows/common:
    - fix some lintian warnings and errors
  * usr/lib/byobu/raid: LP: #1006971
    - ensure raid status cache gets cleared out when done rebuilding
  * debian/postrm: LP: #996873
    - at package removal, ensure that we remove the auto-launch symlink
      if it exists
  * usr/bin/byobu, usr/lib/byobu/include/constants, usr/lib/byobu/logo,
    usr/share/man/man1/byobu.1: LP: #938920, #995412
    - fix "infinite scrolling" of status line, when using multibyte
      utf-8 characters in status
    - detect character map, and only enable utf-8 when possible
  * usr/bin/byobu, usr/bin/byobu-launch, usr/bin/byobu-status,
    usr/lib/byobu/disk_io, usr/lib/byobu/distro,
    usr/lib/byobu/include/common, usr/lib/byobu/include/constants,
    usr/lib/byobu/release, usr/lib/byobu/updates_available: LP: #996285
    - create new BYOBU_TEST global, which is one of:
      [command -v, type, which]
    - command -v doesn't exist in busybox, type does
  * usr/lib/byobu/ec2_cost, usr/lib/byobu/include/shutil,
    usr/lib/byobu/rcs_cost: LP: #1013220
    - gracefully silence status notifications that require /proc/net/route
      when it's not really there (cygwin, mac)
  * usr/share/byobu/profiles/tmux: LP: #1012348
    - fix status activity/alert bolding
    - seems upstream tmux changed the option name from "alert" to "activity"
  * usr/share/man/man1/byobu.1: LP: #977225
    - add documentation about the status line background colors
  * usr/lib/byobu/include/constants: LP: #954031
    - use the sed --follow-symlinks option to keep from recreating files,
      especially .profile and .bashrc

  [ Dustin Kirkland and Daniel Lee ]
  * usr/lib/byobu/disk_io, usr/lib/byobu/mail, usr/lib/byobu/network:
    - LP: #962730, #998202
    - clear out cache on a few other status notifications where we go
      from activity, to none

  [ https://launchpad.net/~ktyubuntu ]
  * usr/lib/byobu/logo: LP: #1004712
    - fix Red Hat logo detection
  * usr/lib/byobu/logo: LP: #1004722
    - add apple distro and logo
 -- Dustin Kirkland <email address hidden> Fri, 08 Jun 2012 17:25:23 -0500

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released

This bug reproduced on latest Ubuntu 14.04:

byobu -v
byobu version 5.74
tmux 1.8

echo $LANG
en_US.UTF-8

locale charmap
UTF-8

I used the provided workaround by disabling logo in the byobu config.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers