bcmwl fails to build with 3.8 kernels [error: 'struct cfg80211_ibss_params' has no member named 'channel']

Bug #1095751 reported by Andy Whitcroft on 2013-01-03
This bug affects 269 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Unassigned
Precise
High
Alberto Milone
broadcom-sta (Ubuntu)
Critical
Unassigned
Precise
Critical
Unassigned

Bug Description

Upcoming 3.8 kernels have broken this DKMS package.

P

SRU request:

[Impact]

 * As a result of this bug, bcmwl-kernel-source will fail to build the module against linux-generic-lts-raring in Ubuntu 12.04.

[Test Case]

 * Enable the precise-proposed repository and install bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu0.0.2).

 * Install linux-generic-lts-raring

 * If the package installs without errors from DKMS with both the linux-generic and lts-raring kernels, then the patches work correctly.

[Regression Potential]

 * The patches that I backported from 13.10 will preserve the current driver behaviour on linux-generic (3.2) and linux-generic-lts-quantal (3.5), thanks to the use of specific macros in the code which check the kernel version. As a result, no regressions of any kind can be expected on these kernels.

Andy Whitcroft (apw) wrote :
Andy Whitcroft (apw) wrote :

Attaching the make.log

summary: - fails to build with 3.8 kernels
+ bcmwl fails to build with 3.8 kernels [error: ‘struct
+ cfg80211_ibss_params’ has no member named ‘channel’]
Changed in bcmwl (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.20.155.1+bdcom-0ubuntu3

---------------
bcmwl (6.20.155.1+bdcom-0ubuntu3) raring; urgency=low

  * 0006-add-support-for-linux-3.8.0.patch:
    - Add support for Linux 3.8 (LP: #1095751).
 -- Alberto Milone <email address hidden> Tue, 08 Jan 2013 15:13:17 +0100

Changed in bcmwl (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Please note that this broke building on 3.7, on "struct cfg80211_ibss_params" not having an element "chandef".

Bass_DR (bass-dr) wrote :

Please send the released fix to LTS proposed.
Ubuntu 12.04 has kernel 3.8 in the proposed repo, but the driver is not working on 12.04 right now since the version has not been updated (uses 0ubuntu1.0.1)

summary: - bcmwl fails to build with 3.8 kernels [error: ‘struct
- cfg80211_ibss_params’ has no member named ‘channel’]
+ bcmwl fails to build with 3.8 kernels [error: ‘struct
+ cfg80211_ibss_params’ has no member named ‘channel’]
tags: added: precise

Also seeing this while running linux-generic-lts-raring (currently 3.8.0-26-generic) on precise.

Changed in broadcom-sta (Ubuntu):
status: New → Confirmed
Anthony Wong (anthonywong) wrote :

Alberto, the fix should also applicable for bcmwl in Precise, could you help fix it as well?

Bass_DR (bass-dr) wrote :

I have been using raring version for a while (4 months) without any issue. Version 6.20.155.1+bdcom-0ubuntu6 manualy installed

Po-Hsu Lin (cypressyew) wrote :

Additional information:

On 201302-12844 Dell Latitude 3330 with 12.04.3 (kernel 3.8.0-29)
Wireless network works fine without the proprietary Broadcom STA driver

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
 Subsystem: Dell Device [1028:0015]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at f7b00000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: bcma-pci-bridge
 Kernel modules: bcma

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu Precise):
status: New → Confirmed
Changed in broadcom-sta (Ubuntu Precise):
status: New → Confirmed
Changed in bcmwl (Ubuntu Precise):
status: Confirmed → Triaged
importance: Undecided → High
Changed in bcmwl (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
status: Triaged → In Progress
Alberto Milone (albertomilone) wrote :

SRU request:

please accept bcmwl_6.20.155.1+bdcom-0ubuntu0.0.2 in precise-proposed. It only contains patches to support kernels up to 3.11.

I've tested it with 3.2, 3.5, 3.8 (all from precise) and with 3.11 (from saucy). It won't break compatibility with Precise's default kernel (3.2).

Scott Kitterman (kitterman) wrote :

OK. The bugs needs the standard SRU material, including test case. Please ensure the test case covers testing with all the available kernels.

Matthew Brantley (brantlmt221) wrote :

Since I have the same problem, what can I do to resolve the issue?

fossfreedom (fossfreedom) wrote :

Matthew

"what can I do..." - wait until the SRU is drafted, accepted and rolled out.

Until then - look at askubuntu for a workaround.

 - http://askubuntu.com/questions/337974/broadcom-sta-driver-fails-to-install-missing-wl-on-ubuntu-12-04-3-lts-linux-3

On 10/09/13 15:28, Matthew Brantley wrote:
> Since I have the same problem, what can I do to resolve the issue?
>
Hi Matthew. I tried most of the work rounds with no success. So what I
did was get this.

The Patriot Wireless N USB Adapter, 300Mbps (PCBOWAU2-N).
Here is the website
http://www.patriotmemory.com/product/detail.jsp?prodline=6&catid=97&prodgroupid=163&id=973&type=24

It works flawlessly, absolutely perfect. I have been running this since
the 3/09/13.

Cheers Sean

SRU request:

[Impact]

 * As a result of this bug, bcmwl-kernel-source will fail to build the module against linux-generic-lts-raring in Ubuntu 12.04.

[Test Case]

 * Install linux-generic-lts-raring

 * Enable the precise-proposed repository and install bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu0.0.2).

 * If the package installs without errors from DKMS, then the patches work correctly.

[Regression Potential]

 * The patches that I backported from 13.10 will preserve the current driver behaviour on linux-generic (3.2) and linux-generic-lts-quantal (3.5), thanks to the use of specific macros in the code which check the kernel version. As a result, no regressions of any kind can be expected on these kernels.

Gracias aplicare lo mencionado...
Muy amable por la molestio y te felicito por tan exelente sistema
operativo...
en verdad Gracias....
Espero algun dia aportar en algo...

2013/9/11 Alberto Milone <email address hidden>

> SRU request:
>
> [Impact]
>
> * As a result of this bug, bcmwl-kernel-source will fail to build the
> module against linux-generic-lts-raring in Ubuntu 12.04.
>
> [Test Case]
>
> * Install linux-generic-lts-raring
>
> * Enable the precise-proposed repository and install bcmwl-kernel-
> source (6.20.155.1+bdcom-0ubuntu0.0.2).
>
> * If the package installs without errors from DKMS, then the patches
> work correctly.
>
> [Regression Potential]
>
> * The patches that I backported from 13.10 will preserve the current
> driver behaviour on linux-generic (3.2) and linux-generic-lts-quantal
> (3.5), thanks to the use of specific macros in the code which check the
> kernel version. As a result, no regressions of any kind can be expected
> on these kernels.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1223148).
> https://bugs.launchpad.net/bugs/1095751
>
> Title:
> bcmwl fails to build with 3.8 kernels [error: ‘struct
> cfg80211_ibss_params’ has no member named ‘channel’]
>
> Status in “bcmwl” package in Ubuntu:
> Fix Released
> Status in “broadcom-sta” package in Ubuntu:
> Confirmed
> Status in “bcmwl” source package in Precise:
> In Progress
> Status in “broadcom-sta” source package in Precise:
> Confirmed
>
> Bug description:
> Upcoming 3.8 kernels have broken this DKMS package.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.04
> Package: bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu2
> ProcVersionSignature: Ubuntu 3.8.0-0.1~apw2-generic 3.8.0-rc2
> Uname: Linux 3.8.0-0-generic x86_64
> ApportVersion: 2.7-0ubuntu2
> Architecture: amd64
> Date: Thu Jan 3 17:59:26 2013
> InstallationDate: Installed on 2012-11-07 (57 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64
> (20120627)
> MarkForUpload: True
> SourcePackage: bcmwl
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1095751/+subscriptions
>

Changed in broadcom-sta (Ubuntu):
status: Confirmed → Fix Released
Changed in broadcom-sta (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in bcmwl (Ubuntu Precise):
status: In Progress → Fix Released
GFR (robertsgfr) wrote :

 I downloaded the 12.04.2 and the Broadcom drivers loaded OK and
then I updated and all is well butI could not get the . 3 to work
but with the .2 it loaded ok and now I have no problem ---- hope this
helps

On Wed, Sep 11, 2013 at 12:41 AM, fossfreedom <email address hidden>wrote:

> Matthew
>
> "what can I do..." - wait until the SRU is drafted, accepted and rolled
> out.
>
> Until then - look at askubuntu for a workaround.
>
> - http://askubuntu.com/questions/337974/broadcom-sta-driver-fails-to-
> install-missing-wl-on-ubuntu-12-04-3-lts-linux-3
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1222111).
> https://bugs.launchpad.net/bugs/1095751
>
> Title:
> bcmwl fails to build with 3.8 kernels [error: ‘struct
> cfg80211_ibss_params’ has no member named ‘channel’]
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1095751/+subscriptions
>

--
gfr

@Virgo - has this really been released - I only see bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu0.0.1) in http://packages.ubuntu.com/search?suite=precise-updates&searchon=names&keywords=bcmwl

Also it appears Alberto's 0.0.2 package is in the unapproved upload queue list
 - https://launchpad.net/ubuntu/precise/+queue?queue_state=1

Po-Hsu Lin (cypressyew) wrote :

Sorry Virgo, I don't think it has been released.

Also affects 201304-13207 Dell Inspiron 5437 Broadcom [14e4:4365]

@Alberto, as fossfreedom indicated, the bcmwl-kernel-source (6.20.155.1+bdcom-0ubuntu0.0.2) cannot be found even with precise-proposed repository enabled.

Changed in broadcom-sta (Ubuntu):
status: Fix Released → Confirmed
Changed in bcmwl (Ubuntu):
status: Fix Released → In Progress
Changed in broadcom-sta (Ubuntu Precise):
status: Fix Released → Confirmed
tags: added: 201304-13207 blocks-hwcert blocks-hwcert-enablement
Po-Hsu Lin (cypressyew) on 2013-09-16
tags: added: 201304-13462 201305-13495 lexington-lab taipei-lab
Alberto Milone (albertomilone) wrote :

yes, the package hasn't been approved by the SRU team yet.

Changed in bcmwl (Ubuntu Precise):
status: Fix Released → Fix Committed
status: Fix Committed → In Progress

Hello Andy, or anyone else affected,

Accepted into raring-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
tags: added: verification-needed

Hi Scott - once it has completed its passage through raring proposed, will you similarly release this into precise-proposed?

fossfreedom (foss-freedom) wrote :

The last time I tried to upgrade to the Raring HWE, the old v0.0.1 of bcmwl did not work.

Great news.

I can confirm that bcmwl v6.20.155.1+bdcom-0ubuntu0.0.2 in proposed works correctly with LTS-Quantal kernel in precise.
The dkms module was correctly created.

Because of bug report https://bugs.launchpad.net/ubuntu/+source/xorg-lts-raring/+bug/1191563 I had to use this workaround to install the LTS-Raring kernel in precise

 - http://askubuntu.com/questions/336138/dependency-issues-while-trying-to-upgrade-12-04-2-to-the-12-04-3-hwe-stack

However I can confirm that after installing the Raring HWE stack, my broadcom works correctly.

Well done Alberto. Many thanks.

tags: added: verification-done
removed: verification-needed
aivan (ivan-arandjelovic) wrote :

I can confirm that new package builds with 3.5 and 3.8 kernel.

Thanks to all!

Po-Hsu Lin (cypressyew) wrote :

Also affects 201303-13027 Dell Inspiron 5535

tags: added: 201303-13207
Changed in bcmwl (Ubuntu):
status: In Progress → Fix Committed
Changed in bcmwl (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in bcmwl (Ubuntu):
status: Fix Committed → Fix Released
Yang Kun (YK) (dayangkuncn) wrote :

@Ara, could you please help to verify bcmwl v6.20.155.1+bdcom-0ubuntu0.0.2 in proposed on the Dell Inspiron 5535 and Dell Inspiron 5437 ?

Thank you
-YK

Atlantic777 (nikola.hardi) wrote :

Fresh install of Ubuntu 12.04.3 on HP Pavilion g6. Jockey-gtk failed to isntall additional drivers for wireless card and then I tried to install bcmwl-kernel-source and compiling of the module failed. After enabling proposed and upgrade of system, there was bcmwl-kernel-source upgrade too and everything seems to work ok.

confirmed working on Ubuntu 12.04, kernel 3.8
HP Probook 4720s

bri (briancloughley) wrote :

Success for me too, thanks for the super work peeps

Asaf Ravid (asaf-rvd) wrote :

Success for me as well!! Great work guys!! 12.04 now supports the Broadcom STA. That's what I call Long Term Support!

Troy Ready (troyready) wrote :

Confirmed for me too - fixes the issue on my mid 2012 MacBook Pro 13", using Ubuntu 12.04.3 (3.8 kernel). Thanks!

Marty Lucich (mar3ty) wrote :

bcmwl-kernel-source version 6.20.155.1+bdcom-0ubuntu6
just built and installed without error on my Dell D830 running 3.8.0-30-generic.

Thanks!

Hi Marty,
Don't know what is going wrong, mine is also 3.8.0-30-generic , HP-Pavilion dv4

just reported the same, can u please help me to get rid off this
Bug #1228122 : bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu0.0.1:
bcmwl kernel module failed to build Edit

On Thu, Sep 19, 2013 at 10:11 PM, Marty Lucich <email address hidden> wrote:
> bcmwl-kernel-source version 6.20.155.1+bdcom-0ubuntu6
> just built and installed without error on my Dell D830 running 3.8.0-30-generic.
>
> Thanks!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1224714).
> https://bugs.launchpad.net/bugs/1095751
>
> Title:
> bcmwl fails to build with 3.8 kernels [error: ‘struct
> cfg80211_ibss_params’ has no member named ‘channel’]
>
> Status in “bcmwl” package in Ubuntu:
> Fix Released
> Status in “broadcom-sta” package in Ubuntu:
> Confirmed
> Status in “bcmwl” source package in Precise:
> Fix Committed
> Status in “broadcom-sta” source package in Precise:
> Confirmed
>
> Bug description:
> Upcoming 3.8 kernels have broken this DKMS package.
>
> P
>
> SRU request:
>
> [Impact]
>
> * As a result of this bug, bcmwl-kernel-source will fail to build the
> module against linux-generic-lts-raring in Ubuntu 12.04.
>
> [Test Case]
>
> * Enable the precise-proposed repository and install bcmwl-kernel-
> source (6.20.155.1+bdcom-0ubuntu0.0.2).
>
> * Install linux-generic-lts-raring
>
> * If the package installs without errors from DKMS with both the
> linux-generic and lts-raring kernels, then the patches work correctly.
>
> [Regression Potential]
>
> * The patches that I backported from 13.10 will preserve the current
> driver behaviour on linux-generic (3.2) and linux-generic-lts-quantal
> (3.5), thanks to the use of specific macros in the code which check
> the kernel version. As a result, no regressions of any kind can be
> expected on these kernels.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1095751/+subscriptions

--
Thanks & Regards,
Chenna

Sudarshan (sid296) wrote :
Download full text (5.5 KiB)

Hi,
I managed to fix the problem somehow. The steps I followed are provided in
the below link:

http://askubuntu.com/questions/347103/wireless-networks-are-not-showing-up-for-ubuntu-12-04-lts-in-hp-dv5-laptop

Regards,
Sudarshan

On Fri, Sep 20, 2013 at 7:32 PM, tiwaz <email address hidden> wrote:

> Hi Chenna,
> I also experienced the same problem and have reported it as well,
> that's why I keep receiving updates via the bug's mailing-list.
> I finally manged to solve the problem by doing the 2 simple steps below:
>
> 1. completely remove the problematic bcmwl-kernel packages:
> open terminal and run
> - - -
> sudo apt-get purge bcmwl-kernel-source broadcom-sta-common
> broadcom-sta-source
> - - -
>
> 2. download and install the latest, fixed .deb bcmwl-kernel packages
> download the right version from here (depending on having 32 or 64 bit
> architecture)
>
> http://packages.ubuntu.com/raring/bcmwl-kernel-source
>
> when download finished open and install the .deb file with Ubuntu
> Software Center
>
> 3. problem solved: no more crashes and error messages & wifi works like
> a charm.
>
> Sorry if the above is of no help to you, thought i'd drop a line or
> two to tell how I got it to work myself.
> Cheers,
> T
>
> On Fri, Sep 20, 2013 at 2:49 PM, chenna <email address hidden>
> wrote:
> > Hi Marty,
> > Don't know what is going wrong, mine is also 3.8.0-30-generic ,
> HP-Pavilion dv4
> >
> > just reported the same, can u please help me to get rid off this
> > Bug #1228122 : bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu0.0.1:
> > bcmwl kernel module failed to build Edit
> >
> >
> > On Thu, Sep 19, 2013 at 10:11 PM, Marty Lucich <email address hidden>
> wrote:
> >> bcmwl-kernel-source version 6.20.155.1+bdcom-0ubuntu6
> >> just built and installed without error on my Dell D830 running
> 3.8.0-30-generic.
> >>
> >> Thanks!
> >>
> >> --
> >> You received this bug notification because you are subscribed to a
> >> duplicate bug report (1224714).
> >> https://bugs.launchpad.net/bugs/1095751
> >>
> >> Title:
> >> bcmwl fails to build with 3.8 kernels [error: ‘struct
> >> cfg80211_ibss_params’ has no member named ‘channel’]
> >>
> >> Status in “bcmwl” package in Ubuntu:
> >> Fix Released
> >> Status in “broadcom-sta” package in Ubuntu:
> >> Confirmed
> >> Status in “bcmwl” source package in Precise:
> >> Fix Committed
> >> Status in “broadcom-sta” source package in Precise:
> >> Confirmed
> >>
> >> Bug description:
> >> Upcoming 3.8 kernels have broken this DKMS package.
> >>
> >> P
> >>
> >> SRU request:
> >>
> >> [Impact]
> >>
> >> * As a result of this bug, bcmwl-kernel-source will fail to build the
> >> module against linux-generic-lts-raring in Ubuntu 12.04.
> >>
> >> [Test Case]
> >>
> >> * Enable the precise-proposed repository and install bcmwl-kernel-
> >> source (6.20.155.1+bdcom-0ubuntu0.0.2).
> >>
> >> * Install linux-generic-lts-raring
> >>
> >> * If the package installs without errors from DKMS with both the
> >> linux-generic and lts-raring kernels, then the patches work correctly.
> >>
> >> [Regression Potential]
> >>
> >> * The patches that I backported from 13.10 will preserve the ...

Read more...

Hi Chenna,

Perhaps you are getting a different version of the package than I am?
If I type "aptitude show bcmwl-kernel-source" it shows me:
Version: 6.20.155.1+bdcom-0ubuntu6

If you see an earlier version then maybe I have more or different
repositories enabled in my /etc/apt/sources.list file. I do have
backports enabled:
deb http://us.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse

And also updates:
deb http://us.archive.ubuntu.com/ubuntu/ raring-updates main restricted multiverse

I don't actually know where the package I have came from. Also maybe
you need to update your indexes? (aptitude update)

I also didn't mention that I am running Ubuntu 13.04 and a 64 bit
kernel. I hope there is a clue for you there somewhere.

Best regards,
Marty

Gary Herbison (gary-herbison) wrote :

Marty,

Thanks for your response. I need to install firmware. I installed and ran
b43-fwcutter.

sudo apt-get install firmware-b43-installer

See Link

http://wireless.kernel.org/en/users/Drivers/b43

Everything is working great.

On Fri, Sep 20, 2013 at 2:54 PM, Marty Lucich <email address hidden> wrote:

> Hi Chenna,
>
> Perhaps you are getting a different version of the package than I am?
> If I type "aptitude show bcmwl-kernel-source" it shows me:
> Version: 6.20.155.1+bdcom-0ubuntu6
>
> If you see an earlier version then maybe I have more or different
> repositories enabled in my /etc/apt/sources.list file. I do have
> backports enabled:
> deb http://us.archive.ubuntu.com/ubuntu/ raring-backports main restricted
> universe multiverse
>
> And also updates:
> deb http://us.archive.ubuntu.com/ubuntu/ raring-updates main restricted
> multiverse
>
> I don't actually know where the package I have came from. Also maybe
> you need to update your indexes? (aptitude update)
>
> I also didn't mention that I am running Ubuntu 13.04 and a 64 bit
> kernel. I hope there is a clue for you there somewhere.
>
> Best regards,
> Marty
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1227272).
> https://bugs.launchpad.net/bugs/1095751
>
> Title:
> bcmwl fails to build with 3.8 kernels [error: ‘struct
> cfg80211_ibss_params’ has no member named ‘channel’]
>
> Status in “bcmwl” package in Ubuntu:
> Fix Released
> Status in “broadcom-sta” package in Ubuntu:
> Confirmed
> Status in “bcmwl” source package in Precise:
> Fix Committed
> Status in “broadcom-sta” source package in Precise:
> Confirmed
>
> Bug description:
> Upcoming 3.8 kernels have broken this DKMS package.
>
> P
>
> SRU request:
>
> [Impact]
>
> * As a result of this bug, bcmwl-kernel-source will fail to build the
> module against linux-generic-lts-raring in Ubuntu 12.04.
>
> [Test Case]
>
> * Enable the precise-proposed repository and install bcmwl-kernel-
> source (6.20.155.1+bdcom-0ubuntu0.0.2).
>
> * Install linux-generic-lts-raring
>
> * If the package installs without errors from DKMS with both the
> linux-generic and lts-raring kernels, then the patches work correctly.
>
> [Regression Potential]
>
> * The patches that I backported from 13.10 will preserve the current
> driver behaviour on linux-generic (3.2) and linux-generic-lts-quantal
> (3.5), thanks to the use of specific macros in the code which check
> the kernel version. As a result, no regressions of any kind can be
> expected on these kernels.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1095751/+subscriptions
>

Download full text (3.7 KiB)

Il 20/09/2013 16:02, tiwaz ha scritto:
> Hi Chenna,
> I also experienced the same problem and have reported it as well,
> that's why I keep receiving updates via the bug's mailing-list.
> I finally manged to solve the problem by doing the 2 simple steps below:
>
> 1. completely remove the problematic bcmwl-kernel packages:
> open terminal and run
> - - -
> sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
> - - -
>
> 2. download and install the latest, fixed .deb bcmwl-kernel packages
> download the right version from here (depending on having 32 or 64 bit
> architecture)
>
> http://packages.ubuntu.com/raring/bcmwl-kernel-source
>
> when download finished open and install the .deb file with Ubuntu
> Software Center
>
> 3. problem solved: no more crashes and error messages & wifi works like
> a charm.
>
> Sorry if the above is of no help to you, thought i'd drop a line or
> two to tell how I got it to work myself.
> Cheers,
> T
>
> On Fri, Sep 20, 2013 at 2:49 PM, chenna <email address hidden> wrote:
>> Hi Marty,
>> Don't know what is going wrong, mine is also 3.8.0-30-generic , HP-Pavilion dv4
>>
>> just reported the same, can u please help me to get rid off this
>> Bug #1228122 : bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu0.0.1:
>> bcmwl kernel module failed to build Edit
>>
>>
>> On Thu, Sep 19, 2013 at 10:11 PM, Marty Lucich <email address hidden> wrote:
>>> bcmwl-kernel-source version 6.20.155.1+bdcom-0ubuntu6
>>> just built and installed without error on my Dell D830 running 3.8.0-30-generic.
>>>
>>> Thanks!
>>>
>>> --
>>> You received this bug notification because you are subscribed to a
>>> duplicate bug report (1224714).
>>> https://bugs.launchpad.net/bugs/1095751
>>>
>>> Title:
>>> bcmwl fails to build with 3.8 kernels [error: ‘struct
>>> cfg80211_ibss_params’ has no member named ‘channel’]
>>>
>>> Status in “bcmwl” package in Ubuntu:
>>> Fix Released
>>> Status in “broadcom-sta” package in Ubuntu:
>>> Confirmed
>>> Status in “bcmwl” source package in Precise:
>>> Fix Committed
>>> Status in “broadcom-sta” source package in Precise:
>>> Confirmed
>>>
>>> Bug description:
>>> Upcoming 3.8 kernels have broken this DKMS package.
>>>
>>> P
>>>
>>> SRU request:
>>>
>>> [Impact]
>>>
>>> * As a result of this bug, bcmwl-kernel-source will fail to build the
>>> module against linux-generic-lts-raring in Ubuntu 12.04.
>>>
>>> [Test Case]
>>>
>>> * Enable the precise-proposed repository and install bcmwl-kernel-
>>> source (6.20.155.1+bdcom-0ubuntu0.0.2).
>>>
>>> * Install linux-generic-lts-raring
>>>
>>> * If the package installs without errors from DKMS with both the
>>> linux-generic and lts-raring kernels, then the patches work correctly.
>>>
>>> [Regression Potential]
>>>
>>> * The patches that I backported from 13.10 will preserve the current
>>> driver behaviour on linux-generic (3.2) and linux-generic-lts-quantal
>>> (3.5), thanks to the use of specific macros in the code which check
>>> the kernel version. As a result, no regressions of any kind can be
>>> expected on these kernels.
>>>
>>> To manage notifications about this bug go to:
>>> https...

Read more...

Thanks a lot Marty , Gary and all other techies

it worked for me after upgrading the firmware

steps followed >>

1. Uninstall the bcmwl-kernel-source package by issuing the following command on a terminal:

sudo apt-get remove bcmwl-kernel-source

2. make sure that the firmware-b43-installer and the b43-fwcutter packages are installed (of course you will need internet by others means):

sudo apt-get install firmware-b43-installer b43-fwcutter

3. type into terminal:

cat /etc/modprobe.d/* | egrep 'bcm'
(you may want to copy this) and see if the term 'blacklist bcm43xx' is there

if it is, type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf

put a # in front of the line: blacklist bcm43xx

then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly).

4. reboot

I have a Dell 610D.
I am running Ubuntu 12.4 LTS
My issue with the WiFi not working was resolved by:
installing and running b43-fwcutter.
I did not have the firmware loaded.
See link below, look for the Ubuntu section.
http://wireless.kernel.org/en/users/Drivers/b43

On 09/21/2013 01:45 PM, chenna wrote:
> command on a terminal:
>
> sudo apt-get remove bcmwl-kernel-source

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

This bug was fixed in the package bcmwl - 6.20.155.1+bdcom-0ubuntu0.0.2

---------------
bcmwl (6.20.155.1+bdcom-0ubuntu0.0.2) precise-proposed; urgency=low

  * 0006-add-support-for-linux-3.8.0.patch,
    0007-nl80211-move-scan-API-to-wdev.patch,
    0008-add-support-for-linux-3.9.0.patch,
    0009-add-support-for-linux-3.10.0.patch:
    - Add support for kernels up to 3.11 (LP: #1095751).
 -- Alberto Milone <email address hidden> Mon, 09 Sep 2013 22:07:09 +0200

Changed in bcmwl (Ubuntu Precise):
status: Fix Committed → Fix Released
Po-Hsu Lin (cypressyew) on 2013-11-08
tags: added: 201303-13027
removed: 201303-13207
Daniel Manrique (roadmr) on 2014-01-17
Changed in broadcom-sta (Ubuntu):
importance: Undecided → Critical
summary: - bcmwl fails to build with 3.8 kernels [error: ‘struct
- cfg80211_ibss_params’ has no member named ‘channel’]
+ bcmwl fails to build with 3.8 kernels [error: 'struct
+ cfg80211_ibss_params' has no member named 'channel']
Changed in bcmwl (Ubuntu):
assignee: Alberto Milone (albertomilone) → nobody
Changed in broadcom-sta (Ubuntu):
status: Confirmed → Triaged
Changed in broadcom-sta (Ubuntu Precise):
importance: Undecided → Critical
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers