brasero dvd capacity estimation is broken

Bug #658004 reported by David Balažic on 2010-10-10
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Brasero
Expired
Medium
brasero (Ubuntu)
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

Impact:
Brasero refuses to write discs when the available space is exactly eqal to the image to write

Test Case:
 - insert a DVD+RW with content
 - cp /dev/sr0 dvd.iso
 - check dvd.iso size to be 4,700,372,992 bytes
 - right click dvd.iso and select Write to Disc...

The disc should record rather than claim that the image can't fit on the disc

Regression potential:
Check that the disc records are valid

David Balažic (xerces8) wrote :
David Balažic (xerces8) wrote :

The same image burns without problems using Nero Express v6.6 under Windows XP.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version.Thanks in advance and sorry for the late response.

Changed in brasero (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
David Balažic (xerces8) wrote :

It is the same with 11.04.

Changed in brasero (Ubuntu):
status: Incomplete → Opinion
status: Opinion → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu):
status: New → Confirmed

Same happened with a DVD-R. The ISO image is 4706660352 bytes. Brasero refuses to burn it in a Verbatim DVD-R.

K3B burns it correctly and reports
Track 01: Total bytes read/written: 4706660352/4706660352 (2298174 sectors).

DVD-R format has 2298496 2048-byte sectors totalling 4707319808 bytes of capacity. The ISO image is smaller.

I'm running 64 bit Natty and Brasero 2.32.1.

David Balažic (xerces8) wrote :

Same in ubuntu 11.10
brasero is at version 3.2.0-0ubuntu1

David Balažic (xerces8) wrote :

The error seems to be in the file libbrasero-burn/brasero-session-cfg.c function brasero_session_cfg_check_size() line 873:

 BRASERO_BURN_LOG ("Session size %lli/Disc size %lli",
     priv->session_blocks,
     priv->disc_size);

 if (priv->session_blocks < priv->disc_size) { // line 873
  priv->is_valid = BRASERO_SESSION_VALID;
  return BRASERO_SESSION_VALID;
 }

The log output says:
BraseroBurn: (at brasero-session-cfg.c :871) Session size 2295104/Disc size 2295104

So there is enough space, but the code expects _more_ than enough space. The correct check would be:

 if (priv->session_blocks <= priv->disc_size) { // fixed line 873

David Balažic (xerces8) wrote :

Why is this marked with importance "Low"?
Certain data sets can not be written at all due to this bug.

From https://wiki.ubuntu.com/Bugs/Importance :

Low: Bugs which affect functionality, but to a lesser extent than most bugs, examples are:

Bugs that have easy work-arounds

Bugs that affect unusual end-user configurations or uncommon hardware
Bugs that affect a non-essential aspect and limited scope of the application
Bugs that have a moderate impact on a non-core application
Cosmetic/usability issues that does not limit the functionality of a non-core application
Non-ideal default configurations

None of this applies.

Besides, the fix is trivial. What should be done to have it committed as soon as possible?

Changed in brasero:
importance: Unknown → Medium
status: Unknown → New
Sebastien Bacher (seb128) wrote :

bug #897550 seems similar, the details from comment #8 seems to indicator a by one block error though, and bug #897550 suggests there is a base 2,base 10 units mismatch in the computation, so they might be different issues

Changed in brasero (Ubuntu):
status: Confirmed → Triaged
summary: - brasero claims dvd image is too large for disc
+ brasero dvd capacity estimation is broken
Changed in brasero (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
David Balažic (xerces8) wrote :

Still same in 3.4.1-0ubuntu2 (Ubuntu 12.10)

David Klasinc (bigwhale) wrote :

I've attached a small patch against 3.4.1-0ubuntu3 version which is currently in 12.10.

The attachment "session_size_bug.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in brasero (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Sebastien Bacher (seb128) wrote :

Ok, SRUed to raring and quantal-proposed, we can SRU to precise once the fix is confirmed to work on those series

Changed in brasero (Ubuntu Quantal):
importance: Undecided → Low
status: New → In Progress
Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 3.4.1-0ubuntu4

---------------
brasero (3.4.1-0ubuntu4) raring; urgency=low

  * debian/patches/correct_disk_space_check.diff: don't error out when
    the disk space is eqal to the one taken by the image.
    Thanks David Balažic and David Klasinc for looking at the issue and
    testing the change (lp: #658004)
 -- Sebastien Bacher <email address hidden> Fri, 16 Nov 2012 12:26:47 +0100

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released

Hello David, or anyone else affected,

Accepted brasero into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/brasero/3.4.1-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in brasero (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

could somebody test the update?

I tested the patch before submitting here, if that counts ;)

Brian Murray (brian-murray) wrote :

No, that doesn't count. We need someone to test the package from -proposed.

The fix for this bug has been awaiting testing feedback in the -proposed repository for quantal for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
David Balažic (xerces8) wrote :

installed 3.4.1-0ubuntu3.1 onto ubuntu 12.10 i386

Right clicked a 4700372992 bytes big iso file, selected Write to disc.. and it again complained "The data is too large ... (uncopyable text) ...".

Should I reboot or something?

David Balažic (xerces8) wrote :

I teseted again. When brasero is started from a terminal window, the the old version gives the mentioned "no space" error.
After updating to -ubuntu3.1* it works without giving that error.

The "right click an ISO file and select Write to Disc..." scenario still gives the same error.
Is that handled by a different package? Or somehow the old version is cached (running all the time in background)?

* why does comment 15 mention ubuntu4 ?

Thomas Schmitt (scdbackup) wrote :

Hi,

To my own experience, the code which governs creation and burning of
ISO images on-the-fly is separate from the code that governs burning
of pre-produced image files from hard disk.
(I am developer of libburn and libisofs, not a user of Brasero.
 But i once had reason to find out how Brasero managed to spoil
 their work. Ubuntu bug 780117.)

So i would look for another size check function that is in charge
for image burning.

The found problem about "<" and "<=" cannot explain the report
about the refusal to burn a DVD-R which had more than the needed
capacity. That problem might match bug 897550 if Brasero is daring
enough to ask the operating system for telling the media capacity.
(Of course it should ask the drive, instead.)

Have a nice day :)

Thomas

Brian Murray (brian-murray) wrote :

Given David's comment in comment #22 that the fix works in some cases and the size of the patch I'm going to mark the bug as verification-done. Additionally, since there are no new crashes found at the Ubuntu Error Tracker regarding this version of brasero I'm going to release the update.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 3.4.1-0ubuntu3.1

---------------
brasero (3.4.1-0ubuntu3.1) quantal-proposed; urgency=low

  * debian/patches/correct_disk_space_check.diff: don't error out when
    the disk space is eqal to the one taken by the image.
    Thanks David Balažic and David Klasinc for looking at the issue and
    testing the change (lp: #658004)
 -- Sebastien Bacher <email address hidden> Fri, 16 Nov 2012 12:26:47 +0100

Changed in brasero (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

David Balažic (xerces8) wrote :

Ubuntu 13.10 amd64
brasero 3.8.0-1ubuntu3

Problem still here.

Short test case:
 - create test file: touch test.iso && truncate -s 4700372992 test.iso
 - insert a blank DVD+RW
 - right click test.iso and select Write to Disc...

Result:
The brasero/nautilus dialog claims: The data size is too large for the disc

Changed in brasero (Ubuntu):
status: Fix Released → New
tags: removed: removal-candidate
tags: added: regression-release saucy
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu):
status: New → Confirmed
Changed in brasero:
status: New → Confirmed
David Balažic (xerces8) wrote :

I tried ubuntu 17.10 (live) and it seems thing changed.

When I try to test an ISO file, in the right click menu there is no more a "Write to Disc..." option.

The closest thing is "Open With Disk Image Writer", which then ask for the destination drive, but does not allow the DVD unit (there is a blank DVD+RW inserted, displayed as so on the desktop) to be selected, it is greyed out.
Even if I try a smaller (391MB) ISO file.

Changed in brasero:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.