brasero does not eject disk after burning

Bug #474233 reported by Tom Louwrier on 2009-11-04
272
This bug affects 81 people
Affects Status Importance Assigned to Milestone
Brasero
Expired
Medium
brasero (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: brasero

When burning a disc (audio, data, or from iso-image) I always check the 'eject after burn' option, but it never does eject. I have to use the button on the drive to get my new disc out. The discs themselves are OK.

I'm using Ububtu 9.10 Karmic (was beta, now stable) on Dell Latitude 131L, in the AMD64 version.

enjoy
Tom

ProblemType: Bug
Architecture: amd64
Date: Wed Nov 4 15:02:26 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/brasero
Package: brasero 2.28.1-0ubuntu1
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: brasero
Uname: Linux 2.6.31-14-generic x86_64

Tom Louwrier (tom-louwrier) wrote :
Pedro Villavicencio (pedro) wrote :

looks like bug https://bugzilla.gnome.org/show_bug.cgi?id=594415 ; could you please add your comments there as well? thanks in advance.

tags: added: likely-dup
Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
Tom Louwrier (tom-louwrier) wrote :

Sure looks like the same bug, yes.
I'll copy my report from here to that one.

Is there no way to link dups from launchpad to bugzilla?

cheers
Tom

Tom Louwrier (tom-louwrier) wrote :

According to Philippe on bugzilla.gnome.org this should have been fixed in version 2.28.2.

I'm currently running version 2.28.2-0ubuntu1.
Just burned an audio CD; disc is fine, but still had to use the hardware button to eject.

cheers
Tom

Pedro Villavicencio (pedro) wrote :

Hello Tom, thanks for checking, could you please add that information to the upstream report (the one on bugzilla)? Thanks in advance!.

hi Pedro,

I did, since Philippe asked me why I linked to the wrong bug. That was a
bug with the same number on bugzilla. I explained and also mentioned
that the current version of Brasero is still not ejecting as it should
as of today.

regards
Tom

Pedro Villavicencio wrote:
> Hello Tom, thanks for checking, could you please add that information to
> the upstream report (the one on bugzilla)? Thanks in advance!.
>
>

Tom Louwrier (tom-louwrier) wrote :

Today I burned a DVD (just straight data files on it) and that ejected OK.
The ones that didn't eject were all audio CD's, with mp3 and wma files as input.

Hope this helps to narrow it down.

cheers
Tom

mono1984 (jcereijo) wrote :

Haie...i'm joining party, hi there

just as you say Brasero won't eject the burner's tray, got to be done manual.
Proyect: ISO to cd... fail, burned twice, with and without test run (dunno if helps)

HP550
Gnome Versión: 2.28.1 (karmic)
Brasero Version: Brasero 2.28.2 (karmic)
Burner: Optiarc DVD RW AD-7581A

David Rahrer (david-rahrer) wrote :

I'm seeing the same issue, tray does not eject on audio CDs.

Gnome Version: 2.28.1 (karmic)
Brasero Version: Brasero 2.28.2 (karmic)
Kernel: Linux 2.6.31-15-generic-pae
Burner: Lite-On DVDRW LH-20A1S

Same issue also for me, the finished disc is never ejected (I usually burn data CDs or DVDs).
I'm on Karmic AMD64

same at me, brasero cannot eject but "eject -r" works perfectly. I have thinkpad t500

Same problem here. I have a Dell studio XPS.

It's particularly annoying when one selects the option "burn to several DVDs". Then the system complains that it cannot write to the second DVD (it's the first one, eh) and proposes cancel as only option.

Eric Donkersloot (ericd) wrote :

Same issue here. I'm on a Vaio VGN-BZ12XN.

Gnome Version: 2.28.1 (karmic)
Brasero Version: Brasero 2.28.2 (karmic)
Kernel: Linux 2.6.31-20-generic
Burner: Optiarc DVD RW AD-7560S

Tom Louwrier (tom-louwrier) wrote :

Still doesn't eject, although it now asks me to remove the freshly burnt CD manually.
Lucid i386 and amd64, both updated twice daily with all the latest and greatest...

Tom

Pedro Villavicencio (pedro) wrote :

Thanks for confirming the issue with latest on Lucid, we don't need more confirmations for now though, but please add a comment if the bug is fixed for you, thanks.

COLIN Stéphane (bigbob-fun) wrote :

Hi,

Same problem with latest lucid package :

Brasero 2.30.0-0ubuntu1

A++

Changed in brasero:
status: Unknown → New
chrone (chrone81) wrote :

i can confirm this with ubuntu 10.04. it also could not burn multiple cd. :(

X I (xandrani) wrote :

Same problem for me on complete new install of 10.04.

I burned a standard CDR... it burned OK but didn't eject.

Right mouse clicking the CD icon on the desktop and selecting "Eject" works. Brasero is obviously not calling the standard "eject" code as all other eject methods seem to work.

Tom rooze.sen (tomrooze-sen) wrote :

Same problem for me on complete new install of 10.04.

I burned a standard CDR... it burned OK but didn't eject.

Right mouse clicking the CD icon on the desktop and selecting "Eject" works. Brasero is obviously not calling the standard "eject" code as all other eject methods seem to work.
Idem this ,i have 2 drives.
By one drive systeem (multi drive) i have this not

Pascal de Bruijn (pmjdebruijn) wrote :

So according to the GNOME bugreport, packaging Brasero 2.30.2 might solve/reduce this issue...

ftp://ftp.gnome.org/pub/GNOME/sources/brasero/2.30/brasero-2.30.2.news

It's not listed there, though there is "misc bug fixes" :)

Pedro Villavicencio (pedro) wrote :

Brasero 2.30.2 was recently uploaded to the proposed repository, may you please enable that and check if the new package in proposed fixes the issue for you? Thanks a lot.

Tom Louwrier (tom-louwrier) wrote :

Haven't seen it yet, but will give it a try as soon as I get it in.

cheers
Tom

Changed in brasero:
status: New → Invalid
Tom Louwrier (tom-louwrier) wrote :

Current versions: Brasero 2.30.2-0ubuntu1 on Ubuntu 10.04 Lucid

Burned a CD yesterday.
Input: some mp3 files
Output: a conventional audio-CD

Option to 'eject disc after burning' seems to has gone, but the CD ejects just fine.

I call it solved. Thanx everybody.

cheers
Tom

Pedro Villavicencio (pedro) wrote :

awesome, marking this as fixed, thanks for the info Tom.

Changed in brasero (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Released
Igor Wojnicki (wojnicki) wrote :

Is it going to be fixed for Karmic?

Changed in brasero:
importance: Unknown → Medium
status: Invalid → Expired
Craig Harding (craigwharding) wrote :

I have brasero 2.30.2 (Ubuntu 10.04) and this is not fixed.
What info can I provide to help fix this issue?

ludo33200 (ludo-cheron) wrote :

Brasero 2.32.0 on Ubuntu 10.10
Seems i've got the same problem
Also log the problem with bug 486114 that seems an other duplicate of this bug ?

Charlie Kravetz (charlie-tca) wrote :

This bug report was fixed with Brasero 2.30.2 for the original reporter. The other bug is still open, marking it a duplicate will mean it is also fixed. I would suggest filing a new bug by opening a terminal and typing

ubuntu-bug brasero

for Ubuntu 10.10. also, please make sure other applications are working. Will exaile or kb3 burn the disc and eject it? If not, it may not be brasero that is causing issues for you.

ludo33200 (ludo-cheron) wrote :

Not shure fixed
see https://bugzilla.gnome.org/show_bug.cgi?id=623485
going to try :
a) clean temporary directory /var/tmp and re-burn
b) try k3b as mentionned

ludo33200 (ludo-cheron) wrote :

Cleaning /var/tmp temporary directory for brasero did NOT resolve
K3B starts burning and says write successul + media is not present=load a media!!!... + overall progress 45%
I'm not shure i understand anything

What/where would you suggest i fill this bug wich may not be relevant to brasero ?

Charlie Kravetz (charlie-tca) wrote :

If there is a problem with more than one different application attempting to burn cd's and you are sure it is not your hardware failing, you can report the issue using

ubuntu-bug storage

in a terminal. Thanks for helping improve Ubuntu.

Laurent Dinclaux (dreadlox) wrote :

I can confirm the bug on my brand new asus laptop and my new desktop computer.

Up to date Maverick 64bit on both.

jayshomebrew (jayshomebrew) wrote :

I have this same bug with brasero ver 2.30.0 and 2.32.0.

Tested today:
Brasero ver 2.32.0
burned iso image gave me this error:
http://img546.imageshack.us/img546/8605/tmpejwa3z.png
and shows successful burn:
http://img524.imageshack.us/img524/5009/tmpoidjxz.png

Ran K3b Version: 2.0.1
burned iso image: success and Ejected after burn.

Hardware:
Burner LG
HL-DT-ST BD-RE WH10LS30 1.00

Note: Running Brasero 2.32.0 and selecting Tools Menu/Eject works when I have a disc already inserted.
Selecting tools menu/eject fails when there is no disk.
http://img220.imageshack.us/img220/4546/tmp8v0ojh.png
error message:
http://img339.imageshack.us/img339/9541/tmpyl7fy.png
also fails with my other LG dvd burner:
http://img546.imageshack.us/img546/415/tmpsiu2ty.png

so if I run
# brasero --brasero-media-debug

and select Tools menu/eject

the debug output is:
BraseroMedia: (at scsi-sg.c:181) Getting handle
BraseroMedia: (at scsi-sg.c:200) Handle ready
BraseroMedia: (at brasero-drive.c:567) Device unlocked
BraseroMedia: (at brasero-drive.c:280) Trying to eject drive
BraseroMedia: (at brasero-gio-operation.c:482) GDrive can't eject

So in summary:
brasero can't eject when a disc is NOT mounted.

Photon (michael-kogan) wrote :

Same story like in the previous comment with Brasero 2.32.1 on Arch Linux.

mitch (mitch-embry) wrote :

Same as above posts with Linux Mint 10 and Brasero 2.32.0 . The disks come out fine but I have to manually eject them.

Hardware:

Core i7
EVGA E758
6GB DDR3
SAMSUNG DVD Burner Model SH-S223F

NoOp (glgxg) wrote :

I think this bug needs to be reopened. I was burning iso's for Natty Daily today & have the same issues (and messages as the png's in comment #33).

$ uname -a
Linux gg 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 19:00:26 UTC 2011 i686 GNU/Linux
$ apt-cache policy brasero
brasero:
  Installed: 2.32.0-0ubuntu2.2
  Candidate: 2.32.0-0ubuntu2.2
  Version table:
 *** 2.32.0-0ubuntu2.2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        100 /var/lib/dpkg/status
     2.32.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

Note that I am using

*-cdrom:0
       description: DVD-RAM writer
       product: DVD DC DQ60
       vendor: BENQ
       physical id: 2
       bus info: scsi@1:0.0.0
       logical name: /dev/cdrom
       logical name: /dev/cdrw
       logical name: /dev/dvd
       logical name: /dev/dvdrw
       logical name: /dev/scd0
       logical name: /dev/sr0
       version: MRCC
       capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
       configuration: ansiversion=5 status=open
$ /lib/udev/cdrom_id /dev/sr0
ID_CDROM=1
ID_CDROM_CD=1
ID_CDROM_CD_R=1
ID_CDROM_CD_RW=1
ID_CDROM_DVD=1
ID_CDROM_DVD_R=1
ID_CDROM_DVD_RW=1
ID_CDROM_DVD_RAM=1
ID_CDROM_DVD_PLUS_R=1
ID_CDROM_DVD_PLUS_RW=1
ID_CDROM_DVD_PLUS_R_DL=1
ID_CDROM_MRW=1
ID_CDROM_MRW_W=1

$ dmesg | tail
[14367.630148] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out of range
[14367.630155] sr 1:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
[14367.630167] end_request: I/O error, dev sr0, sector 0
[14367.630171] Buffer I/O error on device sr0, logical block 0
[14367.631115] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[14367.631121] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
[14367.631126] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out of range
[14367.631133] sr 1:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
[14367.631145] end_request: I/O error, dev sr0, sector 0
[14367.631149] Buffer I/O error on device sr0, logical block 0

Note that I am using 2.32.0-0ubuntu2-2. The last time that I burnt iso was about 8-9 weeks ago (before 2.32.0-0ubuntu2-2) and had no issues. I'll back down to 2.32.0-0ubuntu2 to see if I have the same results.

NoOp (glgxg) wrote :

Same issue with 2.32.0-0ubuntu2 - see: Screenshot-9.png

$ apt-cache policy brasero
brasero:
  Installed: 2.32.0-0ubuntu2
  Candidate: 2.32.0-0ubuntu2.2
  Version table:
     2.32.0-0ubuntu2.2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
 *** 2.32.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy brasero-common
brasero-common:
  Installed: 2.32.0-0ubuntu2
  Candidate: 2.32.0-0ubuntu2.2
  Version table:
     2.32.0-0ubuntu2.2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
 *** 2.32.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy brasero-cdrkit
brasero-cdrkit:
  Installed: 2.32.0-0ubuntu2
  Candidate: 2.32.0-0ubuntu2.2
  Version table:
     2.32.0-0ubuntu2.2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
 *** 2.32.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy libbrasero-media1
libbrasero-media1:
  Installed: 2.32.0-0ubuntu2
  Candidate: 2.32.0-0ubuntu2.2
  Version table:
     2.32.0-0ubuntu2.2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
 *** 2.32.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

$ dmesg | tail
[17736.630477] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out of range
[17736.630485] sr 1:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
[17736.630497] end_request: I/O error, dev sr0, sector 0
[17736.630501] Buffer I/O error on device sr0, logical block 0
[17736.631550] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[17736.631556] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
[17736.631562] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out of range
[17736.631569] sr 1:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
[17736.631581] end_request: I/O error, dev sr0, sector 0
[17736.631585] Buffer I/O error on device sr0, logical block 0

NoOp (glgxg) wrote :

k3b burns and ejects the CD properly. But I'm still seeing dmesg errors:

$ dmesg | tail
[18943.648200] sr 1:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
[18943.648212] end_request: I/O error, dev sr0, sector 0
[18943.648217] Buffer I/O error on device sr0, logical block 0
[18943.649326] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[18943.649333] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
[18943.649340] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out of range
[18943.649347] sr 1:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
[18943.649359] end_request: I/O error, dev sr0, sector 0
[18943.649364] Buffer I/O error on device sr0, logical block 0
[19085.131871] cdrom: This disc doesn't have any tracks I recognize!

Xavier (rxaviers) wrote :

I was wondering if you have any updates on this bug?

thanks

Danillo (danillo) wrote :

This bug is still present in Brasero 3.4.1 on Ubuntu 12.04.

Stefan Pappalardo (sjuk) wrote :

This bug is still present in Brasero 3.4.1 on Ubuntu 12.04.

CHRISTMAS SALE!!!

> Wonder why we are figure 1 replica watches online? Because there is no dissimilarity between them and the real ones except for the cost. Just buy it for your Christmas presents! We use the same materials and final to the original brand name watches, such as real Sapphire Crystal, real solid stainless steel, and 99.9% accurate markings, finish and heaviness. We answer for the excellence!

> All we are waiting for the time when even adults believe in fairytales - Christmas and New Year holidays. Prestige is the best place where you can find everything to make the best presents for the best people.

*************************************************************
"About two weeks ago, I ordered two watches. A Rolex Daytona, and a Vacheron Constantin. I found your web site by chance, and decided to take a gamble and order these two watches. To my surprise and delight, my watches arrived in just under a week. The watches are amazing. We checked the Daytona against a real one, and you cant tell the difference. First class all the way. I just received my third watch, an A. Lange & Sohne!!!! The watch is fantastic!!! You can use me as a reference, if you would like. Just use my initials."

                     Liza Knutson
*************************************************************

CLICK HERE --->>> http://inemy.ru

------------------------
--------------
------
15% DISCOUNT FOR EVERY $250 OR MORE ORDER!!!

robert (ekstraadresse3) wrote :

Brasero 3.4.1 in Ubuntu 12.04 on my amd64 system still has this bug and for a long time also.

Tom Louwrier (tom-louwrier) wrote :

Running 12.04 64bit, updated daily, Brasero 3.4.1. Have been a long time sufferer of this bug.
Today I burned an image from disc and guess what? After burning it ejected all automagically and I even got a proper notification and a friendly 'ping' sound to go with it. To be sure I burned another cd and yes, it worked ok again.

Cheers
Tom

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.