Ubuntu

Error while burning - some files may be corrupted on the disc

Reported by manzur on 2009-04-25
154
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Brasero
New
Medium
OEM Priority Project
Medium
Canonical Desktop Team
brasero (Debian)
Fix Released
Unknown
brasero (Ubuntu)
Medium
Unassigned

Bug Description

brasero 2.26.0- this is happening after burning, but burned disk (DVD/CD) is "OK" so I send you an screen-shot and a brasero-session.log file, so you can see what is happening, I think I get this bug is because brasero check the file on the disk after ejected

manzur (sl-solaris) wrote :
manzur (sl-solaris) wrote :
Krzysztof Klimonda (kklimonda) wrote :

Hmm..
BraseroChecksumImage Setting new checksum (type = 2) a095ed71814f23366fd5cb5ebde9a312 (6e237b177f06d45652f7df597cf282b6 before) It means that for some reason validation failed.
Are you sure that all files are ok? The best way would be to check all files that you have burned with some utility like md5sum against those that you have at your hard drive.

manzur (sl-solaris) wrote :

it was just one video file, size: 4.4GB, I checked it and everything went well, why?

nmsalgueiro (nmsalgueiro) wrote :

I confirm this behaviour. It's been happening to me on every burn I perform, and the disks are always OK.

Resa Gusto (rasmus-rasnic) wrote :

I can only repeat what nmsalgueiro and others are saying. The discs are fine, despite the error message and checking the checksum in terminal confirms this.

Andrew (andrewk8) wrote :

Also a problem in Brasero 2.26.1. I burned a LiveDVD .iso with Brasero. Brasero reported this error.

I rebooted into the LiveDVD and used the disc's own "test disc" utility and it said that there were no errors.

Log file attached.

MMarking (cpt-mocha) wrote :

I have this as well with every ISO I burn to DVD from Nautilus using the "write to disc.." right-click menu option. Burned discs are fine.

Bart Kroon (bart-kroon) wrote :

MMarking: I have this as well with every ISO I burn to DVD from Nautilus using the "write to disc.." right-click menu option. Burned discs are fine.

Same for me; with old and current DVD writer.

Bart Kroon (bart-kroon) wrote :
MarcRandolph (mrand) wrote :

Upstream might need some help on this... it is marked as info needed.

Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → brasero (Ubuntu)
Vlad Novak (vnovak06) wrote :

I confirm this behavior on Brasero 2.26.1. The ISO file and the burned CD have the same md5 hash value, but Brasero reports that the md5 hash for CD is different:

ERROR WHILE BURNING - SOME FILES MAY BE CORRUPTED ON THE DISC

From the log:

BraseroChecksumImage Setting new checksum (type = 2) a21d60303c26cbefb09adcf93f653b4d (8790491bfa9d00f283ed9dd2d77b3906 before)
BraseroChecksumImage called brasero_job_error
BraseroChecksumImage finished with an error

Checking from the command line:

$ md5sum /dev/cdrom
8790491bfa9d00f283ed9dd2d77b3906 /dev/cdrom

$ md5sum ubuntu-9.10-desktop-i386.iso
8790491bfa9d00f283ed9dd2d77b3906 ubuntu-9.10-desktop-i386.iso

The burned image is OK. There are actually no errors.

Brasero Version: 2.26.1

Changed in brasero (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
mozartomaniac (mozartomaniac) wrote :
Download full text (99.6 KiB)

this the log file of brasero write failure. brasero cant rename files for windows compatibility. please help <email address hidden>

Checking session consistency (brasero_burn_check_session_consistency brasero-burn.c:1848)
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_set_output_size_for_current_track
BraseroBurnURI stopping
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_session_output_size
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_current_track
BraseroBurnURI no burn:// URI found
BraseroBurnURI stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_set_output_size_for_current_track
BraseroLocalTrack stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_session_output_size
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_current_track
BraseroLocalTrack no remote URIs
BraseroLocalTrack stopping
BraseroChecksumFiles called brasero_job_get_output_type
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_set_output_size_for_current_track
BraseroChecksumFiles stopping
BraseroChecksumFiles called brasero_job_get_output_type
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_session_output_size
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_set_current_action
BraseroChecksumFiles called brasero_job_get_flags
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles Adding graft for checksum file /.checksum.md5 file:///tmp/brasero_tmp_LZL79U.md5
BraseroChecksumFiles called brasero_job_add_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles Finished track successfully
BraseroChecksumFiles stopping
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs getting varg
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs called brasero_job_get_flags
BraseroGrowisofs called brasero_job_get_speed
BraseroGrowisofs called brasero_job_get_device
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_session_output_size
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs called brasero_job_get_fd_in
BraseroGrowisofs Using genisoimage
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs called brasero_job_get_tmp_dir
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_set_current_action
BraseroGrowisofs got varg:
 growiso...

bojan (mitkovskibojan) wrote :

Version Brasero 2.30.0-0ubuntu1
I It's been happening to me on every burn I perform except on one, and the disks are always OK. I`m using lucid beta 2 but i had this problem in 9.10 to and then my dvd player could not read the disks.

jeffbl (jeff-mulb) wrote :

Same trouble on Lucid RTM upgrade from Karmic AMD64. Figured this would be fixed in latest LTS, but no dice.

Seem like a solution here (http://www.zyxware.com/articles/615/solution-to-checksum-error-and-md5-sum-error-in-brasero-k3b-and-other-burning-software) but I couldn't find an easy way to search bugzilla and report this to Brasero developers. I don't know why importance is "medium" since burning DVD is a basic operation in any other OS. Also FOSS is supposed to repair things faster and this bug has more than a year old. My programming skills are not enugh to post a solution.

Ok. Filed a bug in https://bugzilla.gnome.org/show_bug.cgi?id=628493 (Brasero team official bug track).

Changed in brasero:
importance: Unknown → Medium
status: Unknown → New
acidrums4 (acidrums4) wrote :

I'm getting the same problem with Brasero 2.30.3 under Gentoo ~x86. It's an issue from some years ago.

Marius Gavrilescu (mgvx) wrote :

I have the same problem with Brasero 2.32.1-0ubuntu1 under Natty. I get this error after burning a disc, but the disc is not fine, ubuntu can't read it

ludo33200 (ludo-cheron) wrote :

Same problem also described in Lanchpad concerning Brasero packaged in Ubuntu
https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/486114

Francesco Placco (frapla) wrote :

I have the same problem on Ubuntu 11.04

lopthopman (lopthopman-ann0) wrote :

Also have brasero burning problems in Ubuntu 10.10.

Except that the resulting disk really is unreadable. Not sure why some people have posted that the error message is a false alarm. Tried different media and different drives here, always produces coasters. The file structure is there, but each file is corrupted.

Changed in oem-priority:
status: New → Triaged
importance: Undecided → High
MestreLion (mestrelion) wrote :

@lopthman: this bug is about a false alarm, not actual burning problem.

Also, for developers, my comment on a duplicate bug may help find the answer:
https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/385540/comments/2

Lukáš Chmela (lukaschmela) wrote :

I can confirm it on Ubuntu 11.04 too.

Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
Changed in oem-priority:
assignee: Canonical Platform QA Team (canonical-platform-qa) → Canonical Desktop Team (canonical-desktop-team)
lopthopman (lopthopman-ann0) wrote :

"@lopthman: this bug is about a false alarm, not actual burning problem."

Is this confirmed? Because each time I've tried, I get this error and an unreadable coaster. In my experience, it is indeed a burn error :)

Changed in oem-priority:
importance: High → Medium
NoOp (glgxg) wrote :

Regarding comment #24: This is not a 'false alarm' but actually may not be related to brasero.

In performing several tests related to:
<https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/691482>
[Brasero Disc Burner > wrongly named]
I encountered the checksum errors. Sample:

BraseroReadom disconnecting BraseroReadom from BraseroChecksumImage
BraseroReadom deactivating
BraseroChecksumImage called brasero_job_get_current_track
BraseroChecksumImage Setting new checksum (type = 2)
631bb631ab92d6b965051b4b42346158 (a2c9eb7d63f603b6f9ae4b3deb3d2d48 before)
BraseroChecksumImage called brasero_job_error
BraseroChecksumImage finished with an error
BraseroChecksumImage asked to stop because of an error
 error = 27
 message = "Some files may be corrupted on the disc"
BraseroChecksumImage stopping
BraseroChecksumImage closing connection for BraseroChecksumImage
Session error : Some files may be corrupted on the disc
(brasero_burn_record brasero-burn.c:2862)

However, when burning a CD using the exact same files using brasero (rather than CD/DVD Creator offered in nautilus) as a 'Data disc' the operation & burn works fine (with the exception of brasero's failure to eject the disc properly (https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/519935). So it's possible that complaints regarding brasero may actually be related to the nautilus CD/DVD Creator application instead.

Alfonso (gin-cognac) wrote :

My experience is that until recently CD/DVD Creator has always worked however last time I used it I ended up with CDs which had the correct directory structure and correct file sizes but unreadable *.jpg. files. The program was unable to eject the CD and when I did - as instructed - I got the message "some files may be corrupted". I suspect the problem may have been caused when I recently upgraded via the update manager from 10.04 to 10.10. I don't recall having burned any CDs before this attempt since that upgrade.
 What is somewhat bizarre is that according to the "software centre" CD/DVD creator and Brasero are listed separately as if they are different applications and Brasero is down as supported and CD/DVD creator isn't. CD/DVD creator 'more info' does not mention Brasero.
When I insert a blank CD it offers to open "CD/DVD Creator" and if I select "open with" it does not offer me Brasero yet Brasero is listed in my applications menu and CD/DVD Creator isn't.
According to the software centre" "CD/DVD Creator" is not installed. on my computer and Brasero is.

affects: debian → brasero (Debian)
Changed in brasero (Debian):
status: Unknown → New
alejandro (nosferatu2011) wrote :
Download full text (11.0 KiB)

Checking session consistency (brasero_burn_check_session_consistency brasero-burn.c:1744)
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_set_output_size_for_current_track
BraseroBurnURI stopping
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_session_output_size
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_current_track
BraseroBurnURI burn:// URI found burn:///Unsaved%20Document%201
BraseroBurnURI called brasero_job_set_current_action
BraseroBurnURI called brasero_job_get_current_track
BraseroBurnURI Information retrieval for burn:///Unsaved%20Document%201
BraseroBurnURI Added file /home/david/Unsaved Document 1 at /Unsaved Document 1
BraseroBurnURI called brasero_job_add_track
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI Finished track successfully
BraseroBurnURI stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_set_output_size_for_current_track
BraseroLocalTrack stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_session_output_size
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_current_track
BraseroLocalTrack no remote URIs
BraseroLocalTrack stopping
BraseroChecksumFiles called brasero_job_get_output_type
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_set_output_size_for_current_track
BraseroChecksumFiles stopping
BraseroChecksumFiles called brasero_job_get_output_type
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_session_output_size
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_set_current_action
BraseroChecksumFiles called brasero_job_get_flags
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles Adding graft for checksum file /.checksum.md5 file:///tmp/brasero_tmp_PZC73V.md5
BraseroChecksumFiles called brasero_job_add_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles Finished track successfully
BraseroChecksumFiles stopping
BraseroChecksumImage called brasero_job_get_current_track
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage called brasero_job_get_flags
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs creating input
BraseroGrowisofs getting varg
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs called brasero_job_get_fd_in
BraseroGrowisofs got varg:
BraseroGrowisofs deactivating
BraseroChecksumImage called brasero_job_get_ac...

alejandro (nosferatu2011) wrote :

problem is CDRDAO drives fix
libdvdcss2 fix---------------------------------->

I fixed this problem on my system by manually installing the newest version of cdrdao. It can be downloaded from here http://cdrdao.sourceforge.net/ For those of you unfamiliar with the installation of tarballs. Open the containing folder. Right click the file and select extract here. Open terminal and cd to location. For me this was the default firefox location of # cd Downloads/cdrdao-1.2.3/
type ./configure
after the program is congigured
type make
after the makefile is ready type
sudo make install
enter your password. Once this is done you may need to restart brasero if it's open. This completely fixed the issues on my system and hopefully it helps at least a few of you.
is a critical error in the dependencies of packages to and to check if the dvd and cd drives parareser debian stable has this same error but not reported in other example by distributing linux redhat and suse to and take into account that a serious error of cdrdao and other libraries that are dependencies of ubuntu can ay that actualis tar patching broken: (

alejandro (nosferatu2011) wrote :

This bug affects critical bug ----> 10.11 04.11 distributions based on Debian and Ubuntu
  obsolete dependencies

MestreLion (mestrelion) wrote :

@lopthopman (#26):

I just said that you are experiencing a different issue than what is reported here. This bug here is for false alarms, when copy is OK but Brasero calculares checksum incorrectly and thus reports burning errors.

If you are actually getting coasters, this should be reported in a different bug (new or already existing one)

James M. Leddy (jm-leddy) wrote :

Does anyone know where you can get an ISO that doesn't line up on 32kb boundaries? I just checked the ubuntu alternate install iso and at 705998848, it's a clean multiple of 32kb.

James M. Leddy (jm-leddy) wrote :

This worked for me:

BraseroBurn: (at burn-checksum-image.c:531) BraseroChecksumImage Setting new che
cksum (type = 2) 5b920a4988ce60621131d58429ffa95f (5b920a4988ce60621131d58429ffa
95f before)
BraseroBurn: (at burn-job.c:1071) BraseroChecksumImage Finished track successful
ly

And the file is 358400 bytes, which is not on a 32k boundary. Version of brasero is 3.2.0-0ubuntu1

James M. Leddy (jm-leddy) wrote :

Marking Invalid for now because it seems to work, but may be dependent on the hardware. If this is an issue with OEM again I will reopen.

Changed in oem-priority:
status: Triaged → Won't Fix
status: Won't Fix → Invalid
Changed in brasero (Debian):
status: New → Incomplete
Jim Barfield (jim-barfield) wrote :

All I know is that on the lastest Mint it does the same as before: In order burn ap a DVD I have to reboot. In some cases I can burn 2 DVDs by opening Brasero from the right click file menu, and then reboot if I want more to burn more.

Hope this helps- it did the exact same thing on the last Mint distro, on Lenovo GS-550, also on Lenovo IdeaPad

I get the SCSI disc callibration error, and then sometimes I can re-install the blank disc and it works.

Seems that both times letting the system update most recent drivers caused the problem.

Also the default disc writer no longer works - just like last time

-Newbie

Changed in brasero (Debian):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.