unable to eject cd-rom after burning disk

Bug #519935 reported by Marc Deslauriers on 2010-02-10
586
This bug affects 123 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Medium
One Hundred Papercuts
Undecided
Brahmprakash Mishra
brasero (Debian)
Fix Released
Unknown
brasero (Ubuntu)
High
Canonical Desktop Team
Precise
Undecided
Unassigned

Bug Description

Binary package hint: brasero

When burning a DVD with brasero, once it completes, I get a dialog box stating:

######
# Please eject the disc from "<DRIVE_NAME_HERE>" manually.
#
# The disc could not be ejected though it needs to be removed for the
# current operation to continue.
######

The dialog has only one button, marked "Cancel". See attached screenshot.

- Why can't it eject the disc?
- Do I press cancel? Does that cancel burning my disc? Shouldn't it be marked "Continue"?

ProblemType: Bug
Architecture: amd64
Date: Wed Feb 10 11:34:07 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
NonfreeKernelModules: nvidia
Package: brasero 2.29.90-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: brasero
Uname: Linux 2.6.32-12-generic x86_64

Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :

cela donne le même message lorsque je clique sur outils puis sur éjecter puis encore sur éjecter

traduction of google:
it gives the same message when I click on tools then eject and still eject

Changed in brasero (Ubuntu):
importance: Undecided → Low
Saivann Carignan (oxmosys) wrote :

I can confirm this bug report, which seems to happen each time that I burn a ISO file, on all my computers on Lucid. The disk is burned correcly, but it is just never ejected by brasero.

Changed in brasero (Ubuntu):
status: New → Confirmed
Tom Gelinas (tomgelinas) on 2010-03-17
Changed in hundredpapercuts:
status: New → Confirmed
cmyrland (carl-rahien) wrote :

Manually ejecting the disc finished the process correctly, so it's just ejecting the tray automatically that's bugged. Should be an easy fix for those who know how.

Jane Atkinson (irihapeti) wrote :

I have a couple of Bash scripts that involved DVD handling that I've used successfully in Hardy for well over a year.

I've been getting an error message in Lucid, and I wonder if it's connected with this bug.

eject: unable to find or open device for: `cdrom'

Lucid doesn't use "cdrom" as a device by default.

If I change the scripts to "eject /dev/sr0", then they work. There are no references to "cdrom" in the scripts, by the way.

Maybe this error is occurring when Brasero tries to eject the disk. Just a thought.

b0ggyb33 (rl406) wrote :

For me, ejecting the disc does not finish the process so I have to cancel it. I've attached dmesg tail if that helps anyone.

Blake (ljsilver23) wrote :

I was able to solve a problem on lucid with the CD not ejecting burning a .iso by selecting a temporary directory other than /tmp I chose /home/user/Documents/tmp After that I no longer got the eject errors.

komputes (komputes) on 2010-10-15
summary: - Confusing "eject disc" error message when burning dvd
+ unable to eject cd-rom after burning disk
komputes (komputes) on 2010-10-15
description: updated
komputes (komputes) wrote :

This issue clearly affects many users. I have marked many bugs as duplicates of this one. Anyone experiencing this issue is asked to visit Bug #519935 and click on "This bug affects you and ## other people".

Reported on other bug trackers:

Debian:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=503915
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=551679
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583821

GNOME:
https://bugzilla.gnome.org/show_bug.cgi?id=623485

Changed in brasero (Ubuntu):
status: Confirmed → Triaged
importance: Low → Medium
Changed in brasero (Debian):
status: Unknown → Incomplete
Changed in brasero:
importance: Unknown → Medium
status: Unknown → New

I'm on Brasero 2.32 on Maverick and it still happens, no matter what kind of media I burn. The media always burns successfully so I suppose it's not much of a problem, just hit cancel.

I like the idea that was suggested above of just relabeling the button "continue" instead of "cancel", at least until the bug gets fixed. That way new users won't wonder if their media burned correctly or not.

Marc Deslauriers (mdeslaur) wrote :

I am still seeing this with brasero on natty, so unmarking as duplicate as the other bug has been marked as resolved.

Aaron Knight (knightrous) wrote :

As with Marc Deslauriers, I am also experiencing this problem in Natty (Also in Maverick & Lucid).
Unfortunately, since upgrading to Natty, when it fails to eject, it also fails to complete the burning process. Previously in Maverick/Lucid, it would still have completed the burn, but failed to eject.

Blake commented on using another directory other then /tmp/ which has worked for me, I used /home/$USER and it the burn completed, but failed to eject.

Akos Mate (mateakos1) wrote :

Hi
In my situation brasero can't eject the disc after writing, and it produces unreadable discs (both CD and DVD). In some rare cases with CD burning, it works correctly, ejects the disk, and everithing is correct. I think it's not media problem, because media problem cant cause eject errors.

Akos Mate (mateakos1) wrote :

DVD writing work's well with the same drive and the same media type on Windows 7.
I'm using Ubuntu natty, and i would be happier, if i don't need to switch to windows, when i want to burn CD or DVD.
 Best regards: Akos.

Changed in hundredpapercuts:
assignee: nobody → Brahmprakash Mishra (brainwave92)
Pedro Villavicencio (pedro) wrote :

raising the priority this is affecting a lot of users.

Changed in brasero (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Medium → High
Changed in hundredpapercuts:
assignee: Brahmprakash Mishra (brainwave92) → nobody
Changed in hundredpapercuts:
assignee: nobody → Brahmprakash Mishra (brainwave92)
mavosaure (mavosaure) wrote :

I can confirm this bug, trying to burn a simple data CD, I lose 2 Cd (one on a natty i386, and the other on a natty amd64, both up to date). I was unable to eject the CD, and the burning process fail with the log attached.

mavosaure (mavosaure) wrote :

I can confirm this bug, trying to burn a simple data CD, I lose 2 Cd (one on a natty i386, and the other on a natty amd64, both up to date). I was unable to eject the CD, and the burning process fail with the log attached.

alejandro (nosferatu2011) wrote :
Download full text (29.2 KiB)

Checking session consistency (brasero_burn_check_session_consistency brasero-burn.c:1739)
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_set_output_size_for_current_track
BraseroBurnURI stopping
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_session_output_size
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_current_track
BraseroBurnURI no burn:// URI found
BraseroBurnURI stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_set_output_size_for_current_track
BraseroLocalTrack stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_session_output_size
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_current_track
BraseroLocalTrack no remote URIs
BraseroLocalTrack stopping
BraseroChecksumFiles called brasero_job_get_output_type
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_set_output_size_for_current_track
BraseroChecksumFiles stopping
BraseroChecksumFiles called brasero_job_get_output_type
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_session_output_size
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_set_current_action
BraseroChecksumFiles called brasero_job_get_flags
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles Adding graft for checksum file /.checksum.md5 file:///tmp/brasero_tmp_1JNR3V.md5
BraseroChecksumFiles called brasero_job_add_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles Finished track successfully
BraseroChecksumFiles stopping
BraseroChecksumImage called brasero_job_get_current_track
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage called brasero_job_get_flags
BraseroLibburn called brasero_job_get_action
BraseroLibburn creating input
BraseroLibburn called brasero_job_get_action
BraseroLibburn unsupported operation
BraseroLibburn deactivating
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage creating input
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage called brasero_job_get_fd_in
BraseroChecksumImage deactivating
BraseroLibisofs called brasero_job_get_action
BraseroLibisofs called brasero_job_get_action
BraseroLibisofs called brasero_job_set_current_action
BraseroLibisofs creating volume
BraseroLibisofs called brasero_job_get_data_label
BraseroLibisofs called brasero_job_get_flags
BraseroLibisofs called brasero_job_get_current_track
BraseroLibisofs Adding graft disc path = /S...

Changed in brasero (Ubuntu):
status: Triaged → Confirmed
Timothy Arceri (t-fridey) wrote :

@mavosaure, alejandro

There is no need to post log information against this bug. The cause of this bug is know, just read the upstream gnome bug if you want to know more details.
https://bugzilla.gnome.org/show_bug.cgi?id=620151

Also mavosaure this bug should not cause any problems with burning, if you manually eject the disc everything should be fine this bug is not about burning problems its just about ejecting the disc once it has burnt.

This bug is also not a papercut as it requires changes to the glib api see: https://bugzilla.gnome.org/show_bug.cgi?id=627116

Changed in hundredpapercuts:
status: Confirmed → Invalid
alejandro (nosferatu2011) wrote :
Download full text (11.2 KiB)

Checking session consistency (brasero_burn_check_session_consistency brasero-burn.c:1744)
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_set_output_size_for_current_track
BraseroBurnURI stopping
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_session_output_size
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_current_track
BraseroBurnURI burn:// URI found burn:///Unsaved%20Document%201
BraseroBurnURI called brasero_job_set_current_action
BraseroBurnURI called brasero_job_get_current_track
BraseroBurnURI Information retrieval for burn:///Unsaved%20Document%201
BraseroBurnURI Added file /home/david/Unsaved Document 1 at /Unsaved Document 1
BraseroBurnURI called brasero_job_add_track
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI Finished track successfully
BraseroBurnURI stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_set_output_size_for_current_track
BraseroLocalTrack stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_session_output_size
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_current_track
BraseroLocalTrack no remote URIs
BraseroLocalTrack stopping
BraseroChecksumFiles called brasero_job_get_output_type
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_set_output_size_for_current_track
BraseroChecksumFiles stopping
BraseroChecksumFiles called brasero_job_get_output_type
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_session_output_size
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles called brasero_job_set_current_action
BraseroChecksumFiles called brasero_job_get_flags
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles called brasero_job_get_current_track
BraseroChecksumFiles Adding graft for checksum file /.checksum.md5 file:///tmp/brasero_tmp_PZC73V.md5
BraseroChecksumFiles called brasero_job_add_track
BraseroChecksumFiles called brasero_job_get_action
BraseroChecksumFiles Finished track successfully
BraseroChecksumFiles stopping
BraseroChecksumImage called brasero_job_get_current_track
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage called brasero_job_get_flags
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs creating input
BraseroGrowisofs getting varg
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs called brasero_job_get_fd_in
BraseroGrowisofs got varg:
BraseroGrowisof...

affects: brasero → gnome-utils
Dan Becker (beckerz) wrote :

Had this problem over the last three versions of Ubuntu (currently 11.10). Had been using gnome-baker instead, but gnome-baker is not longer available on 11.10. Tried the switching of temp directories mentioned by ljsilver23 above. Did not work for me.
Certainly low priority as XfBurn seems to not have this problem.

Hi,
I've got dell studio 1558 with slot DVD and no manual eject button. I used to reboot system to eject CD after burning until I found here: "eject /dev/sr0".
WORKS for me !
Thx

Simplexion (simplexion) on 2012-03-24
Changed in hundredpapercuts:
status: Invalid → Opinion
status: Opinion → Incomplete
Timothy Arceri (t-fridey) wrote :

As per my comment #19 this is not a valid papercut is requires difficult changes to glib as brasero uses different functionality under the covers which caused this issue to appear. For more information see the upstream gnome bug.

Changed in hundredpapercuts:
status: Incomplete → Invalid
David Robert Lewis (afrodeity) wrote :

This is one of those bugs which together with all the other interface bugs in Ubuntu, gives new uses a fright. Major papercut IMHO.

Toni Förster (stonerl) wrote :

Just one question. Is there any progress on this bug? I just browsed through the bugreports here on launchpad and on gnome-bugzilla. But there seems to be no fix at all.

V字龍(Vdragon) (vdragon) wrote :

Still reproduce (+2 discs) on Linux Mint 13 (using ubuntu 12.04LTS package)

rooijan (rrossouw) wrote :

This issue is still happening in 12.04. It is slightly worse than just hitting cancel and the world is ok again. Yes the burn is successful but hitting cancel and ejecting manually does not finish the brasero process for me. Then on my next burn nothing happens. Brasero just plain does not start at all.

Off course I get around it by killing the old brasero process but really how many users are going to just give up and say bad bad Linux.

josemanuel (josemanuelqm) wrote :

Thanks beckerz #23),

eject /dev/sr0

also works for me (Ubuntu 12.04 amd64 in MacBook Pro)

JC (nothingness) wrote :

This has been an issue for me for a long time. I get an error, after burning an .iso image, that the disc is unable to eject. If I click cancel, the burning is ruined. If I eject manually, then click cancel, all is good. I do not recall if I ran into this issue in Ubuntu 10.04, but I have run 10.10, 11.04, 11.10, 12.04, AND 12.10 and all have the problem.
I run arch linux on my laptop and I have absolutely no problems with brasero.
There must be something wrong on the ubuntu or debian end of brasero.

Adam Niedling (krychek) wrote :

For me Brasero was able to eject the disc after burning in 12.10.

Why can't this problem be solved?

Marc Deslauriers (mdeslaur) wrote :

I confirm, this is now solved in 12.10.

Changed in brasero (Ubuntu):
status: Confirmed → Fix Released
Shahar Or (mightyiam) wrote :

Oh, how cool. Thank you :)

Naftuli Kay (naftulikay) wrote :

This problem has been affecting Ubuntu for YEARS. I'm glad that it's fixed in 12.10, but it's pretty sad that it took this long.

Klaus Bielke (k-bielke) wrote :

I am using brasero 3.4.1 from
package 3.4.1-0ubuntu1.1
on ubuntu 12.04 LTS i386 32 bit.

The problem is NOT fixed!

I still have to eject manually. Burned CDs are OK if ejected before closing the window but sometimes corrupted when ejected after closing the window.

After closing the window with the hint "Please eject manually …" brasero does not terminate. In order to burn another ISO to CD I first must kill the old brasero process with "sudo killall brasero".

Problem was reported fixed for 12.10. You stated you are using 12.04.

Also, I believe the bug was that even when trying to eject manually the
disk would not. I have to restart my computer to eject a disk after brasero.

On 01/23/2013 06:55 AM, Klaus Bielke wrote:
> I am using brasero 3.4.1 from
> package 3.4.1-0ubuntu1.1
> on ubuntu 12.04 LTS i386 32 bit.
>
> The problem is NOT fixed!
>
> I still have to eject manually. Burned CDs are OK if ejected before
> closing the window but sometimes corrupted when ejected after closing
> the window.
>
> After closing the window with the hint "Please eject manually …" brasero
> does not terminate. In order to burn another ISO to CD I first must kill
> the old brasero process with "sudo killall brasero".
>

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu Precise):
status: New → Confirmed
Tom Louwrier (tom-louwrier) wrote :

Running 12.04 64bit, updated daily, Brasero 3.4.1. Have been a long time sufferer of this bug.
Today I burned an image from disc and guess what? After burning it ejected all automagically and I even got a proper notification and a friendly 'ping' sound to go with it. To be sure I burned another cd and yes, it worked ok again.

Cheers
Tom

Changed in gnome-utils:
status: New → Fix Released
John Rose (johnaaronrose) wrote :

This happens when multiple copies are requested to be burned. After ejecting the new DVD manually, it then displays another popup stating that insertion of a new blank DVD will cause another copy to be created. However, it doesn't start burning. Workaround is to end brasero process (in System Monitor) & to start brasero again.

Please advise whether a new bug should be created.

affects: gnome-utils → brasero
Changed in brasero (Debian):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.