Brasero Checksum Error

Bug #354995 reported by mrwizer on 2009-04-04
164
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
High
brasero (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

I get an error when trying to burn an ISO image to CD through Brasero.

Same error occurs on two different Ubuntu (9.04 Beta, development branch) installs. Both drives are IDE, error occurred on different ISO files. Image appears to burn correctly yet errors upon checksum.

Version: Brasero 2.26.0

Error message is attached.

mrwizer (public-sekoconcepts) wrote :
Pedro Villavicencio (pedro) wrote :

Hello mrwizer, it seems that you're using wodim, could you please try to burn with growisofs (remove wodim) and test again? that could be the cause of the problem, thanks!.

Changed in brasero (Ubuntu):
importance: Undecided → Low
assignee: nobody → desktop-bugs
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in brasero (Ubuntu):
status: Incomplete → Invalid

Pedro,

I too have this error happening on my Toshiba Satellite A300 with Jaunty. I'm not sure what you want the original poster to add since into Synaptic and removing wodim requires the removal of Brasero as well (package dependency). I just installed K3B and it burned successfully without reporting any errors ending in:

Session error : Some files may be corrupted on the disc (brasero_burn_record burn.c:2599)

I haven't tried with DVD blanks but with CD-ROM blanks and so I can't figure out how to tell growisofs how to do this. Either way this is a bug.

vocx (eliudcabrera) wrote :

I don't think a definite answer has been given.
This errors still occurs.
Or perhaps somebody can show that this is a duplicate to another bug?

Changed in brasero (Ubuntu):
status: Invalid → Incomplete
Pedro Villavicencio (pedro) wrote :

Then please answer the questions asked above, there's no point on just re open bugs and don't say anything.

Changed in brasero:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

bug was filed upstream, marking this as Triaged, thanks Savvas.

Changed in brasero (Ubuntu):
status: Incomplete → Triaged
emarkay (mrk) wrote :

"Hello mrwizer, it seems that you're using wodim, could you please try to burn with growisofs (remove wodim) and test again? that could be the cause of the problem, thanks!."

I am getting this error also - how do I do the above?
I confirmed that there are no MD5 entries in Gconf-Editor > Apps > Brasero

emarkay (mrk) wrote :

Also see: "Solution to checksum error and md5 sum error in Brasero, K3B and other burning software"

http://www.zyxware.com/articles/615/solution-to-checksum-error-and-md5-sum-error-in-brasero-k3b-and-other-burning-
software

Still not a unified solution but may indicate a problem.

vocx (eliudcabrera) wrote :

emarkay

About using "growisofs" instead of "wodim", there seems to be some confusion from Pedro Villavicencio.

Currently, Ubuntu 9.04, "brasero (2.26.1-0ubuntu1)" depends on "wodim (1.1.9-1ubuntu1)", and therefore is not possible to install brasero without it.
Besides that, I believe brasero actually uses one or another program depending on the media used, CD or DVD, and the type of data being burned.

I have logs that show that "BraseroWodim" is being used when burning a CD-RW, but "BraseroGrowisofs" when the media is DVD-RW. You can see the logs when running brasero in debug mode "brasero -g"

I also believe that the problem may not be brasero itself, but may be with the underlying "wodim", "genisoimage", or other packages. I remember I had a similar problem with "gnomebaker (0.6.4-1)", which resulted in a "fixation error" like that of bug #234521

Therefore, in order to really troubleshoot this a lot of testing needs to be done. This is in fact the problem, because it means that you need to waste several blank CDs or DVDs if you want to exhaust all the possibilities and, of course, using rewritable (-RW) media is not enough.

I get the same error in Kubuntu Jaunty, actually am staring at it right now. Just linking them up, someone in the answers section asked about this, https://answers.launchpad.net/ubuntu/+question/72024, and I put a link back to here.

zertz (zertz) wrote :

some of this is copied from another bug report before i realized it was a duplicate. attached is my brasero-session.log. fully up to date jaunty, same problem as mentioned here, except its well after jaunty has been released (not in development). the resulting burned iso images onto dvd's are good burns.

launching brasero from a terminal and writing an iso gives:

I/O warning : failed to load external entity "/home/bobcat/.config/brasero/brasero.session"

the error while burning, some files may be corrupted by disc log is attached to this post.

i believe that brasero simply wont burn a windows 7 iso. my father wanted me to retrieve that iso, and with a little googling, i found that it wasn't doable using the usual burning tools in ubuntu. i did try a trial of "nero for linux" and it burned it without issue. i am unsure what it is about the format about that iso, but brasero wont burn it. the issue i am having, is iwith burning jaunty isos, or any other iso. after every linux iso i burn, i get a error saying that some files may be corrupted on disc please check error log ? the error log is attached to this post. i thought it might be attributed to the burner i was using but i swapped burners today, and it still gives me that error burning jaunty or other linux related isos, and i've reinstalled jaunty every time, so i know its a common problem, and i'm doing nothing other than right click write iso. i cannot burn a windows 7 iso, and of course, i should be able to, its in iso format, but i care much less about that and much more about jaunty isos, and the error that says something went wrong. despite it saying something went wrong, the dvd's that were burned (use dvd's instead of cd media for lack of media) actually turn out just fine. despite the error log, they are functional burns. i'm on 32 bit jaunty using the latest up to date kernel.

Thomas Lunde (tlunde) wrote :

In bug 373591 Pedro Villavicencio wrote on 2009-05-08:

Thanks for the report, could you get us the full debug log? please get one with: brasero --brasero-media-debug &> brasero.txt and attach that file to the report? are you using wodim or growisofs? thanks.

I get the same errors as Arthur, John, et al within the Brasero GUI whenever I burn any image, even ones that are known to be good. (I know it's good because it burns without complaint and with verification on my OS X box.)

I have attached the requested brasero.txt file produced with the above command.

Kip Warner (kip) wrote :

I also confirm this bug. I manually ran md5sum on the contents of the burned disc, and also again on the contents of the ISO after mounting it through the local loop back device. The checksums file by file are fine.

I have attached my session log.

Kip Warner (kip) wrote :

Here is my Brasero debug log:

(brasero:10208): BraseroMedia-DEBUG: At brasero-medium-monitor.c:436: Polling for drives
(brasero:10208): BraseroMedia-DEBUG: At brasero-medium-monitor.c:446: Found 1 drives
(brasero:10208): BraseroMedia-DEBUG: At brasero-medium-monitor.c:449: Probing /org/freedesktop/Hal/devices/storage_model_CDDVDW_TS_L633A
(brasero:10208): BraseroMedia-DEBUG: At brasero-drive.c:960: Drive caps are 639
(brasero:10208): BraseroMedia-DEBUG: At brasero-drive.c:981: Drive /dev/sr0 has bus,target,lun = 1 0 0
(brasero:10208): BraseroMedia-DEBUG: At brasero-drive.c:831: Contents changed

use KD3
  ----- Original Message -----
  From: Kip Warner
  To: <email address hidden>
  Sent: Friday, August 14, 2009 11:53 PM
  Subject: [Bug 354995] Re: Brasero Checksum Error

  I also confirm this bug. I manually ran md5sum on the contents of the
  burned disc, and also again on the contents of the ISO after mounting it
  through the local loop back device. The checksums file by file are fine.

  I have attached my session log.

  ** Attachment added: "Brasero session log"
     http://launchpadlibrarian.net/30351814/brasero-session.log

  --
  Brasero Checksum Error
  https://bugs.launchpad.net/bugs/354995
  You received this bug notification because you are a direct subscriber
  of the bug.

  Status in A disc burning application for gnome 2: New
  Status in “brasero” package in Ubuntu: Triaged

  Bug description:
  Binary package hint: brasero

  I get an error when trying to burn an ISO image to CD through Brasero.

  Same error occurs on two different Ubuntu (9.04 Beta, development branch) installs. Both drives are IDE, error occurred on different ISO files. Image appears to burn correctly yet errors upon checksum.

  Version: Brasero 2.26.0

  Error message is attached.

Kip Warner (kip) wrote :

I have no idea what that is, how it will solve the problem, or why you top posted a redundant message with the above thread.

Rocko (rockorequin) wrote :

I just burned two Ubuntu ISO CDs using nautilus' "write to CD" menu command (ie not brasero), and for both it reported that there might be errors. The first one did have errors, but the second one was fine.

Pedro Villavicencio (pedro) wrote :

nice this was finally fixed upstream, change is going to land into ubuntu soon.

Changed in brasero:
status: New → Unknown
Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
Changed in brasero:
status: Unknown → Fix Released
causeitsme (bobbystanley) wrote :

Same Problem.

BraseroChecksumImage asked to stop because of an error
 error = 24
 message = "Some files may be corrupted on the disc"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.27.92-0ubuntu1

---------------
brasero (2.27.92-0ubuntu1) karmic; urgency=low

  * New upstream release (LP: #425998)
    - Some improvements when handling DVD-RW sequential
    - #593829 - Brasero gets stuck in a loop at "Getting size" while burning another session on a multi-session disk
    - #578466 - Unable to overburn
    - #593314 - Brasero is failing to burn from sftp
    - #593492 - Compilation must be ordered by file name
    - #587122 - Copying DVD - "Error while reading video DVD (no error)"
    - #592026 - brasero crashes when eject a medium
    - #592025 - brasero crashes on detecting src images on a NFS path when preparing burning an image
    - #591880 - Image checksumming causes internal error (LP: #354995)
    - #591397 - Brasero Main window pops up after exiting from Image Burning window.
    - Translation updates
    - lots of small fixes and improvements

 -- Robert Ancell <email address hidden> Tue, 08 Sep 2009 09:33:41 +1000

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
George Farris (george-gmsys) wrote :
Download full text (3.9 KiB)

Still not working as of 2009-10-14

Running Karmic with updates to 2009-10-14 I can write one DVD then Brasero will fail on the second one with the following log: Logout and back in and burn one iso.

Checking session consistency (brasero_burn_check_session_consistency brasero-burn.c:1799)
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_set_output_size_for_current_track
BraseroBurnURI stopping
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_session_output_size
BraseroBurnURI output set (IMAGE) image = /tmp/brasero_tmp_DKT01U.bin toc = none
BraseroBurnURI called brasero_job_get_action
BraseroBurnURI called brasero_job_get_current_track
BraseroBurnURI no burn:// URI found
BraseroBurnURI stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_set_output_size_for_current_track
BraseroLocalTrack stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_session_output_size
BraseroLocalTrack output set (IMAGE) image = /tmp/brasero_tmp_1WT01U.bin toc = none
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_current_track
BraseroLocalTrack no remote URIs
BraseroLocalTrack stopping
BraseroChecksumImage called brasero_job_get_current_track
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage called brasero_job_get_flags
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage called brasero_job_get_fd_in
BraseroChecksumImage called brasero_job_set_output_size_for_current_track
BraseroChecksumImage stopping
BraseroChecksumImage called brasero_job_get_current_track
BraseroChecksumImage called brasero_job_get_action
BraseroChecksumImage There is a checksum already 0
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs getting varg
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs got varg:
BraseroGrowisofs deactivating
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs getting varg
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_flags
BraseroGrowisofs called brasero_job_get_speed
BraseroGrowisofs called brasero_job_get_device
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_session_output_size
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs called brasero_job_get_fd_in
BraseroGrowisofs called brasero_job_set_current_action
BraseroGrowisofs got varg:
 growisofs
 -use-the-force-luke=notray
 -use-the-force-luke=4gms
 -dvd-compat
 -speed=16
 -use-the-force-luke=tracksize:386112
 -use-the-force-luke=tty
 -Z
 /dev/sr0=/home/george/Desktop/9.04-custom-livecd.iso
BraseroGrowisofs Launching command
BraseroGrowisofs called brasero_job_get_fd_out
BraseroGrowisofs stdout: Executing 'builtin_dd if=/home/george/Desktop/9.04-custom-livecd.iso of=/dev/sr0 obs=32k seek=0'
BraseroGrowisofs called brasero_job_set_dangerous
Braser...

Read more...

Richard Theil (richard-theil) wrote :

Could some of your issues be related to a TAO vs. SAO write mode issue as described in my (yet unconfirmed) bug

https://bugs.launchpad.net/ubuntu/+source/cdrkit/+bug/465035

? (Analysis is in Comment#1) I can get wodim to work reliably from the command line if I force -sao. But all the GUI tools or wodim by default use TAO and that causes a short write as described above. I list related debian bug 427771 and some further analysis on a list as well.

Is my bug a duplicate of this one, or are we seeing different issues?

Brinley Ang (brinley) wrote :

Brasero 2.28.2-0ubuntu1 now works fine for me on karmic

fermulator (fermulator) wrote :

If Brasero 2.28.2 works, can we allow the latest Brasero for Ubuntu 9.04 then?

Changed in brasero:
importance: Unknown → High
Pavlo Verba (pavlo.s.verba) wrote :

I still have similar problem on Maverick with Brasero 2.32.0.

I tried to burn two disks, and it failed with the checksum error every second time, quite irritating.

I am attaching the log, thought it's 3.3 Mb.

Derek (azmotoryder) wrote :

I'm having the same trouble as Paul. Trying to burn a CD-R from an iso image in Meerkat. I followed the directions here: http://www.ubuntu.com/desktop/get-ubuntu/download
Mine is still at the "creating image checksum" dialog box. So far, it has been 30 minutes since burn ended.

Dawning (dawning) wrote :

I'm having this problem as well - though judging by the time stamps, I'm a bit unsure if this could be a regression or a PEBKAC. I've tried quite a few things to no successful ends as yet. I tried removing wodim and just leaving growisofs - that seemed to have no impact.

Many pandas are crying right now.

Brasero 2.31.1-0ubuntu2
Ubuntu 11.04 x64 (all installed pkgs updated as of time of posting)

Pedro Villavicencio (pedro) wrote :

Please open a new bug report if you are still seeing this, Thanks.

Kenny Peng (knypng) wrote :

That seemed to happen to me on Ubuntu 10.2. Like I wrote on Bug #808115 and it's NOT a duplicate because it never goes down.

sdowney717 (sdowney717) wrote :

I just tried burning a win 10 64bit iso I downloaded in ubuntu.
It is stuck on creating checksum for over 30 minutes now.
So is the disk now destroyed?
I had right clicked the iso and told it to burn the iso.

On another forum, someone said Brasero is no good, use xfburn, so I installed it and might try it.
I dual boot with win7, and win7 can easily burn iso's to DVD disks.

sdowney717 (sdowney717) wrote :

adding, I just hit cancel, the tray went in and out several times, then it claims a successful burn,

who knows, but here it is.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.