Ubuntu

Brasero doesn't utilize .desktop translations from Rosetta

Reported by Timo Jyrinki on 2008-03-10
16
Affects Status Importance Assigned to Milestone
brasero (Baltix)
Undecided
Unassigned
brasero (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: brasero

The title says it all, Brasero doesn't utilized .desktop translations from Rosetta. It'd need the X-Ubuntu-Gettext-Domain tag in the .desktop file like other applications in main.

Currently Finnish translation is missing, since it was not included in the 0.7.1 release (it's in upstream 0.7 branch and trunk).

Related branches

Timo Jyrinki (timo-jyrinki) wrote :

Attached is a patch to add a new patch under debian/patches that would fix this by allowing .desktop translations from PO files to be used by Ubuntu's .desktop gettext. Fixes the problem for me.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. What verison of brasero and architecture do you use? The desktop on my hardy installation has the domain information, could you attach the version installed on your hardy?

Changed in brasero:
importance: Undecided → Low
status: New → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

x86, brasero 0.7.1-3, also seen at http://packages.ubuntu.com/hardy/brasero. As it's a direct Debian sync, it "cannot" have the X-Ubuntu-Gettext-Domain in its .desktop file, or...?

Some languages like fr do have the new menu string ("Burning" instead of "Burner") translated, so the translation is shown for some (few) of the upstream translated languages, but without the patch I provided other languages miss the .desktop translation and the translation from Rosetta isn't used.

Timo Jyrinki (timo-jyrinki) wrote :

x86, brasero 0.7.1-3, also seen at http://packages.ubuntu.com/hardy/brasero. As it's a direct Debian sync, it "cannot" have the X-Ubuntu-Gettext-Domain in its .desktop file, or... hmm, I do see the domain information at the end of a file (whatever adds it there), but maybe the problem is because it's only under [Desktop Action OpenProject] section and my patch adds it together with the X-Gnome lines that are in the section about the actual menu entry?

Some languages like fr do have the new menu string ("Burning" instead of "Burner") translated, so the translation is shown for some (few) of the upstream translated languages, but without the patch I provided other languages miss the .desktop translation and the translation from Rosetta isn't used.

After using the patch provided to build the package, the Finnish translation from the language pack's translations appeared in the menu, but without it does not.

Changed in brasero:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

cdbs automatically adds the translation domain during the build in ubuntu so debian syncs can have it, the issue is likely due to the section where it's added

Timo Jyrinki (timo-jyrinki) wrote :

Seems so. It was good to get that bit of information that cdbs adds it automatically, since many packages do it manually and I thought it should be always done so.

Anyway, can my patch be included to fix this or is there another way this should be corrected for hardy?

Timo Jyrinki (timo-jyrinki) wrote :

Subscribed ubuntu-main-sponsors as recommended. Also uploaded to PPA as not recommended, but I just wanted to test the real build system. The fixed package with the patch added is at: http://ppa.launchpad.net/timo-jyrinki/ubuntu/pool/main/b/brasero/brasero_0.7.1-3ubuntu1.dsc. Debdiff attached.

Daniel Holbach (dholbach) wrote :

Sébastien: can you take a look at it?

Sebastien Bacher (seb128) wrote :

Thank you for your work, change uploaded now

Changed in brasero:
status: Confirmed → Fix Released
Kamil Páral (kamil.paral) wrote :

I don't think it's still correct. In two sections ([Desktop Entry] and [Desktop Action OpenProject]) the "X-Ubuntu-Gettext-Domain=brasero" is supplied, but in the remaining section [Desktop Action BurnImage] the gettext line is still missing.

Timo Jyrinki (timo-jyrinki) wrote :

It is missing, but the most important aspect, ie. the menu item in Applications -> Sound & Video, is translated now according to translations from Rosetta in PO files. I'm not aware of those two other sections actually being used in Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers