bcmwl driver does not work with kernel 4.4.0-21 when secure boot enabled

Bug #1572659 reported by Eugene Romanenko
264
This bug affects 48 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Unassigned

Bug Description

After updating ubuntu 16.04 to latest kernel 4.4.0-21, bcmwl driver (package bcmwl-kernel-source) does not load and wifi not work.

sudo modprobe wl
modprobe: ERROR: could not insert 'wl': Required key not available

If I boot with kernel 4.4.0-18 - bcmwl loads normally and wifi works.

If secure boot disabled - bcmwl loads normally with kernel 4.4.0-21 and wifi works.

---
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
InstallationDate: Installed on 2015-12-02 (140 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
NonfreeKernelModules: wl
Package: bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu8
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Tags: xenial
Uname: Linux 4.4.0-18-generic x86_64
UpgradeStatus: Upgraded to xenial on 2016-03-03 (47 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Eugene Romanenko (eros2)
tags: added: bcmwl-kernel-source
Revision history for this message
Eugene Romanenko (eros2) wrote : Dependencies.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
Eugene Romanenko (eros2) wrote : JournalErrors.txt

apport information

Revision history for this message
Eugene Romanenko (eros2) wrote : ProcEnviron.txt

apport information

Revision history for this message
Torsten Gilles (torsten-gilles) wrote : Re: bcmwl driver does not work with kernel 4.4.0-21

I notice exactly the same problems with kernel 4.4.0-21 and bcmwl.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Revision history for this message
Torsten Gilles (torsten-gilles) wrote :

I tried the new 16.04 release ISO and the problem exists for me (DELL XPS 13) also which makes it unusable for me for now. Choosing an older daily build before 20.4 where the 4.4.0-18 kernel is still used works fine.

Revision history for this message
Rodney Karemba (rodneykaremba) wrote :

I can also confirm that this issue affects a Dell XPS 13 (9343) running 16.04 with the kernel the 4.4.0-21. This install was done through an upgrade from an existing Ubuntu installation.

Revision history for this message
Torsten Gilles (torsten-gilles) wrote :

The same issue exists when using the broadcom-sta-dkms package instead of bcmwl-kernel-source on kernel 4.4.0-21 (also as with bcmwl-kernel-source this packages works on kernel-4.4.0-18):
The loading of the module fails with modprobe: ERROR: could not insert 'wl': Required key not available. The reason seems to be because of insufficient privileges for some underlying action.

Revision history for this message
Pedro (pdfrod) wrote :

It seems to be something related with Secure Boot, as disabling it fixed the problem for me. See (http://askubuntu.com/questions/760075/cant-view-wifi-networks-after-upgrading-to-ubuntu-16-04)

Revision history for this message
Torsten Gilles (torsten-gilles) wrote :

Pedro, thank you for the hint, I'll try if that works as a workaround for me :-). I though the module build would disable secure boot since a dialog for a password for disabling pops up.
But it remains the question to me what changed from kernel-4.4.0-18 to 4.4.0-21 that somehow broke the wl module loading process. Maybe it's that disabling that does not work anymore and if you disable security boot in BIOS you come around this?

Eugene Romanenko (eros2)
summary: - bcmwl driver does not work with kernel 4.4.0-21
+ bcmwl driver does not work with kernel 4.4.0-21 when secure boot enabled
description: updated
tags: added: secure-boot
Changed in bcmwl (Ubuntu):
importance: Undecided → High
Revision history for this message
Matt Austin (mattaustin) wrote :

Same problem continues with 4.4.0-22.

Revision history for this message
Sébastien (s-vanvelthem) wrote :

Same applies with
- Dell XPS 15,
- Broadcom Corporation BCM43602 802.11ac Wireless LAN SoC (rev 01)
- kernel 4.4.0-22.
- Secure boot disabled in BIOS !.

----
> sudo apt-get install bcmwl-kernel-source

Segmentation fault
modprobe: ERROR: ../libkmod/libkmod-module.c:977 command_do() Error running install command for wl
modprobe: ERROR: could not insert 'wl': Unknown error 139

Revision history for this message
Joacim Haglund (joaha) wrote :

In case it helps tracking down why the bug appears between -18 and -21, I found this in -19:

linux (4.4.0-19.35) xenial; urgency=low
...
* linux: Enforce signed module loading when UEFI secure boot (LP: #1566221)
    - [Config] CONFIG_EFI_SECURE_BOOT_SIG_ENFORCE=y

Revision history for this message
Richard (rvandieren) wrote :

Experienced the same. WIFI no longer working after upgrading on Dell XPS 13 9343 to Ubuntu 16.04 LTS.

SecureBoot is enabled (and will remain so)

lspci -nnk | grep 0280 -A2
02:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
 Subsystem: Dell BCM4352 802.11ac Wireless Network Adapter [1028:0019]
 Kernel modules: bcma, wl

sudo lshw -C network
  *-network UNCLAIMED
       description: Network controller
       product: BCM4352 802.11ac Wireless Network Adapter
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 03
       <snip>

Revision history for this message
Michael Fox (mfox-trentu) wrote :

I can report the same, Dell xps 13- 9343 running Ubuntu 16.04 with kernel 4.4.0-24 as well as 4.4.0-22.

Revision history for this message
J. Lowry Snow (lsnow) wrote :

any plans to get this fixed so SecureBoot can be enabled w 16.04?

Revision history for this message
Pablo Saavedra (pablo-a-saavedra) wrote :

I tried to solve it by following the instructions in http://askubuntu.com/questions/760671/could-not-load-vboxdrv-after-upgrade-to-ubuntu-16-04-and-i-want-to-keep-secur (with 'wl' as the module) with no luck

Revision history for this message
Pablo Saavedra (pablo-a-saavedra) wrote :

BTW, I am having the issue in 14.04, after upgrading to kernel 3.19.0-65-generic. Booting with 3.19.0-64-generic and reinstalling bcmwl-kernel-source fixes the problem.

I think we need proper instructions to sign the module, or an automated step that takes care of that for us.

Revision history for this message
Gery (stofei) wrote :

Signing the wl module worked fine for me.

Revision history for this message
Pablo Saavedra (pablo-a-saavedra) wrote :

Gery, can you share the steps you took yo sign it?

Thanks

Revision history for this message
Gery (stofei) wrote :

Exactly the ones you linked in #17. Not sure why it didn't work for you.

Revision history for this message
Pablo Saavedra (pablo-a-saavedra) wrote : Re: [Bug 1572659] Re: bcmwl driver does not work with kernel 4.4.0-21 when secure boot enabled

Thanks, I'll look into it then

On Sun, Aug 7, 2016 at 3:35 PM Gery <email address hidden> wrote:

> Exactly the ones you linked in #17. Not sure why it didn't work for you.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1572659
>
> Title:
> bcmwl driver does not work with kernel 4.4.0-21 when secure boot
> enabled
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1572659/+subscriptions
>

Revision history for this message
jtzero (jtzero) wrote :

Here are better steps https://askubuntu.com/questions/810229/network-disabled-device-not-ready-16-04, however mine gets stuck at the `modprobe wl` even when the secure boot is disabled it hangs, so I couldn't install bcmwl even if I wanted to.

Revision history for this message
jtzero (jtzero) wrote :

As well here is an example if the MOK util that will popup when you reboot https://sourceware.org/systemtap/wiki/SecureBoot

FWIW my PCI.ID isn't on the list mentioned here https://askubuntu.com/questions/55868/installing-broadcom-wireless-drivers/60395#60395, it's possible I am stupidly trying to use the wrong package.

Revision history for this message
Ben (benbonne) wrote :

I'm having the same issue. My laptop is Dell XPS 13 (9343) with Ubuntu 16.04 and a kernel version 4.4.0-31. lshw -c network would give me the output "*-network UNCLAIMED".

Revision history for this message
Roger (rogerr) wrote :

i have the same problem.
WIFI works after reboot fine.
but if change the location, the WIFI hotspots are still the old and not available..

Ubuntu 16.04 XPS-13
linux-headers-4.4.0-38-generic

 *-network
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:3a:00.0
       logical name: wlp58s0
       version: 3a
       serial: e4:a7:a0:50:f2:58
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-38-generic firmware=16.242414.0 ip=192.168.0.17 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:283 memory:dc200000-dc201fff

Revision history for this message
Ben (benbonne) wrote :

It has been almost 6 month since the bug is discovered, isn't it resolved by now?

Revision history for this message
Anne (rusty75) wrote :

I am having the same problem now with my xps 13 9343
Software&updates dialog shows 1 entry under 'Additional Drivers':
Broadcom corporation:BCM4352 802.11ac Wireless Network Adapter
(x) Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)

No idea what it means

Revision history for this message
Anne (rusty75) wrote :

Ps kernel version 3.16.0-77-generic

Ubuntu 14.04.5 LTS

Revision history for this message
Anne (rusty75) wrote :

Kernel 3.16.0-76-generic works

Revision history for this message
Master (umely) wrote :

Now kernel 4.4.0-67-generic, signing and signing modules as vbox* and wl when update new kernel, but this is not the way...

Revision history for this message
Richard Moon (richaradjmoon) wrote :

I can also confirm that this issue affects my Dell XPS 13 (9343) running 17.04 with the kernel the 4.10.0-40. I upgraded from 16.04 hoping that the bug would have been fixed. When I disable Secure Boot it works fine.

Revision history for this message
Asaf Sarid (asafs-sarid) wrote :

I am having the exact same issue.
I just installed Ubuntu 16.04 on my Dell XPS 13. During the installation I turned off the secure boot, and when I came back to enable secure boot the WiFi suddenly didn't work.
It's 100% related to the secure boot. I see that this bug is opened and marked as High since May 2016, please fix this ASAP.

Revision history for this message
Martin Dünkelmann (nc-duenkekl3) wrote :

Still happen with 4.13 Kernel Updates.

Need to manually reinstall the bcmwl package after every kernel upgrade.

Revision history for this message
Jordan Enev (jordan-enev) wrote :

The same issue here. Kernel: 4.15.0-24-generic. Ubuntu: 16.04.3 LTS

Revision history for this message
Daniel Klein (danielkgo) wrote :

Confirmed also for Ubuntu 18.04.2 LTS

Kernel: 4.15.0-55-generic.

Machine: Lenovo Yoga 3 Pro.

This Yoga uses same chip as Dell users noted above ("BCM4352 802.11ac Wireless Network Adapter").

* Generally speaking this Broadcom integrated chip causes many issues for many people - but for years now the drivers worked for me - I have 8 operating systems on this machine (old releases) with which wifi works fine.

* 2016-04-20 --> 2019-08-19 .. 'High' importance.. 3 years for wifi? ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers