FFe: Sync audacity 3.2.0+dfsg-1 (universe) from Debian unstable (main)

Bug #1991252 reported by Benjamin Drung
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
audacity (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Please sync audacity 3.2.0+dfsg-1 (universe) from Debian unstable (main)

Explanation of FeatureFreeze exception:
audacity was removed from kinetic in bug #1983862 due to the missing support for FFmpeg 5.0. Upstream audacity 3.2.0 added support for FFmpeg 5.0. I have tested the Debian package on Debian and Ubuntu. A PPA build can be found in https://launchpad.net/~bdrung/+archive/ubuntu/ppa. Please get audacity back into the archive since it is a very high-profile application.

All changelog entries:

audacity (3.2.0+dfsg-1) unstable; urgency=medium

  [ Dennis Braun ]
  * New upstream version (LP: #1924841)
    + Fix track volume and panning slider's pop-up visibility (Closes: #946167)
    + Support Italian language (Closes: #962077)
    + Fix FTBFS with ffmpeg 5.0 (Closes: #1004598, LP: #1983862)
    + Fix AAC (m4a) file support (LP: #1978405)
    + Fix export to .opus (Closes: #1005082)
    + Fix length and position of selection is not shown correctly
      (Closes: #1010892, LP: #1973052)
    + Build against wxwidgets 3.2 (Closes: #1019831)
    + Exclude libs from lib-src, we want to use system libs
  * d/patches:
    + Refresh patchset
    + Fix build with wxwidgets 3.2 and portsmf system lib
    + Remove obsolete patches
  * d/control:
    + Update and sort B-Ds
    + Bump Standards-Version to 4.6.1
    + Fix order of uploaders
  * d/copyright:
    + Add comment why we exclude files
    + Update entries and licenses
  * Refresh lintian-overrides
  * d/not-installed: Do not install usr/audacity
  * d/rules:
    + Update configure options
    + Remove obsolete commands after dh auto install
    + Do not override dh_auto_test anymore
  * Add salsa CI config

  [ Benjamin Drung ]
  * d/rules: Set audacity_has_networking explicitly to Off (Closes: #990737)
  * Use gbp-pq to format patches
  * Fix rpath for private libraries on Linux
  * d/rules: Set cmake build type to RelWithDebInfo
  * Disable vst3sdk support (not packaged yet)
  * Add new build dependency libwavpack-dev
  * Replace build dependency libmad0-dev by libmpg123-dev
  * Drop git from build dependencies
  * Drop anchient UBUNTU_MENUPROXY=0 workaround
  * Update debian/copyright
  * Use lame.pc from libmp3lame-dev 3.100-5
  * Add mime type for 'aup3' file extension
  * Add support for cross compiling

 -- Benjamin Drung <email address hidden> Thu, 29 Sep 2022 13:18:00 +0200

CVE References

Benjamin Drung (bdrung)
Changed in ubuntu:
importance: Undecided → Wishlist
affects: ubuntu → audacity (Ubuntu)
Benjamin Drung (bdrung)
summary: - FFe: Sync audacity 2.4.2~dfsg0-5 (universe) from Debian unstable (main)
+ FFe: Sync audacity 3.2.0+dfsg-1 (universe) from Debian unstable (main)
description: updated
Revision history for this message
Graham Inggs (ginggs) wrote :

Given that audacity is not currently in kinetic, and not currently seeded, I don't believe a FFe is required, but here, have one anyway! FFe granted.

As per:
https://wiki.ubuntu.com/FreezeExceptionProcess#FeatureFreeze_for_new_packages
one will be required if it is to be added to a seed.

Changed in audacity (Ubuntu):
status: New → Triaged
Changed in ubuntustudio-meta (Ubuntu):
importance: Undecided → Medium
no longer affects: ubuntustudio-meta (Ubuntu)
Revision history for this message
Benjamin Drung (bdrung) wrote :

Waiting for the lame 3.100-6 sync to pass the queue.

Revision history for this message
Benjamin Drung (bdrung) wrote :
Download full text (47.2 KiB)

This bug was fixed in the package audacity - 3.2.0+dfsg-1

---------------
audacity (3.2.0+dfsg-1) unstable; urgency=medium

  [ Dennis Braun ]
  * New upstream version (LP: #1924841)
    + Fix track volume and panning slider's pop-up visibility (Closes: #946167)
    + Support Italian language (Closes: #962077)
    + Fix FTBFS with ffmpeg 5.0 (Closes: #1004598, LP: #1983862)
    + Fix AAC (m4a) file support (LP: #1978405)
    + Fix export to .opus (Closes: #1005082)
    + Fix length and position of selection is not shown correctly
      (Closes: #1010892, LP: #1973052)
    + Build against wxwidgets 3.2 (Closes: #1019831)
    + Exclude libs from lib-src, we want to use system libs
  * d/patches:
    + Refresh patchset
    + Fix build with wxwidgets 3.2 and portsmf system lib
    + Remove obsolete patches
  * d/control:
    + Update and sort B-Ds
    + Bump Standards-Version to 4.6.1
    + Fix order of uploaders
  * d/copyright:
    + Add comment why we exclude files
    + Update entries and licenses
  * Refresh lintian-overrides
  * d/not-installed: Do not install usr/audacity
  * d/rules:
    + Update configure options
    + Remove obsolete commands after dh auto install
    + Do not override dh_auto_test anymore
  * Add salsa CI config

  [ Benjamin Drung ]
  * d/rules: Set audacity_has_networking explicitly to Off (Closes: #990737)
  * Use gbp-pq to format patches
  * Fix rpath for private libraries on Linux
  * d/rules: Set cmake build type to RelWithDebInfo
  * Disable vst3sdk support (not packaged yet)
  * Add new build dependency libwavpack-dev
  * Replace build dependency libmad0-dev by libmpg123-dev
  * Drop git from build dependencies
  * Drop anchient UBUNTU_MENUPROXY=0 workaround
  * Update debian/copyright
  * Use lame.pc from libmp3lame-dev 3.100-5
  * Add mime type for 'aup3' file extension
  * Add support for cross compiling

 -- Benjamin Drung <email address hidden> Thu, 29 Sep 2022 13:18:00 +0200

audacity (2.4.2~dfsg0-5) unstable; urgency=medium

  * Workaround patch for playback cursor under wayland
    Audacity has no full wayland support yet, so we use X11 to start
    (Closes: #950150, #962389, #988632, LP: #1877833)
    The patch can probably be removed when wxwidgets 3.1.3 is in debian archive
  * Add lintian-overrides to override false positive lintian errors

 -- Dennis Braun <email address hidden> Wed, 26 May 2021 22:26:01 +0200

audacity (2.4.2~dfsg0-4) unstable; urgency=medium

  [ Sebastian Ramacher ]
  * Bump cmake requirement (Closes: #969571)

  [ Dennis Braun ]
  * Fix temporary audio .au files exposure (CVE-2020-11867). (Closes: #976874)
  * Bump S-V to 4.5.1, no changes needed

 -- Dennis Braun <email address hidden> Tue, 08 Dec 2020 23:46:09 +0100

audacity (2.4.2~dfsg0-3) unstable; urgency=medium

  * Team upload
  * debian/rules: Properly link ffmpeg libraries

 -- Sebastian Ramacher <email address hidden> Fri, 24 Jul 2020 00:27:55 +0200

audacity (2.4.2~dfsg0-2) unstable; urgency=medium

  * Team upload
  * debian/rules: Disable use of embedded sbsms

 -- Sebastian Ramacher <email address hidden> Thu, 23 Jul 2020 22:26:16 +0200

audacity (2.4.2~dfsg0-1) unstable; urgency=medium

  * Team upload

  [ D...

Changed in audacity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers