aptitude can no longer show changelogs: "Changelog download failed: Download queue destroyed."

Bug #824708 reported by zigi on 2011-08-11
500
This bug affects 95 people
Affects Status Importance Assigned to Milestone
aptitude (Debian)
Fix Released
Unknown
aptitude (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned

Bug Description

Aptitude (<< 0.6.8) can't download/view package changelogs with
libapt-pkg (>= 0.8.16~exp3). This affects both the command line
interface and the interactive (ncurses) interface.

Viewing a packages changelog is a significant part of deciding which
updates to apply. Although the changelogs can still be viewed using
apt-get, it is a great inconvenience to no longer be able to do this
from aptitude's interactive interface.

[Test Case]

* An unrelated issue in aptitude requires deb-src lines to fetch
  changelogs from the command line. Ensure the system has some valid
  deb-src lines:

  $ sudo echo "deb-src http://archive.ubuntu.com/ubuntu/ precise main" >> /etc/apt/sources.list
  $ sudo apt-get update
  […]

* Choose a package, say python-apt, and verify the changelog is
  available with apt-get:

  $ apt-get changelog python-apt
  Get:1 Changelog for python-apt (http://changelogs.ubuntu.com/changelogs/pool/main/p/python-apt/python-apt_0.8.0ubuntu7/changelog) [109 kB]
  Fetched 109 kB in 0s (370 kB/s)

* Attempt to fetch the same changelog using aptitude:

  $ aptitude changelog python-apt
  Err Changelog of python-apt
  E: Changelog download failed: Download queue destroyed.
  E: Couldn't find a changelog for python-apt

[Regression Potential]

Small.

* Moderate size patch which is mostly trivial updates of types to
  unsigned long long as used in libapt-pkg.

* The updated module is only used to acquire changelogs[1], so any
  regression is likely to be limited to interacting with changelogs.

* Fixed in Debian sid since June with no regressions reported.

[1] The module is also used to acquire screenshots by the experimental
    GTK+ interface which is no longer developed and was never
    considered supported by upstream.

zigi (ziegleka) on 2011-08-11
tags: added: oneiric
Changed in aptitude (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2011-09-07
Changed in aptitude (Ubuntu):
status: Confirmed → Triaged
Victor Zamanian (victorz) wrote :

I'm seeing this bug all the way into the final release of Ubuntu 11.10 (same version of aptitude).

Rolf Leggewie (r0lf) on 2011-10-19
tags: added: precise
Changed in aptitude (Ubuntu):
milestone: none → precise-alpha-2
Rolf Leggewie (r0lf) wrote :

I didn't spot a Debian ticket for this, could be Ubuntu-specific.

B.J. Stobiecki (bjfs) wrote :

I've attached a strace if anyone finds it useful for debugging. The error is outputted on line 4706 (some strings are translated since I have pl_PL locale set). Command issued: % aptitude changelog aptitude

Ubuntu Studio 11.10 Linux amilo 3.0.0-12-generic-pae #20-Ubuntu SMP Fri Oct 7 16:37:17 UTC 2011 i686 i686 i386 GNU/Linux

Rolf Leggewie (r0lf) wrote :

The program does seem to actually download the log, I believe, but somehow fails to display it. My local proxy has copies of several changelogs for precise packages. So, they must have been downloaded but fail to display.

Nikolai Bochev (n-bochev) wrote :

Same here, very annoying for server deployments, since you can't check the changes in packages.

totya (totya) wrote :

Just a side note:

I found a workaround. You can use "apt-get changelog" until aptitude will be fixed.

Changed in aptitude (Ubuntu):
importance: Undecided → Medium
tags: added: regression-release
MSch (msch) wrote :

Will you fix this in a point release? precise-alpha-2 seems kinda late.

Edward Donovan (edward.donovan) wrote :

I agree about the bug seeming Ubuntu-specific. This problem doesn't happen on my plain-Debian boxes. Same upstream aptitude version, 0.6.4, in both distros. I haven't dug any further than that, yet.

Martin Pitt (pitti) on 2012-02-06
Changed in aptitude (Ubuntu):
milestone: precise-alpha-2 → ubuntu-12.04-beta-1
description: updated
tags: added: workaround
Martin Pitt (pitti) on 2012-03-02
Changed in aptitude (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Martin Pitt (pitti) on 2012-03-30
Changed in aptitude (Ubuntu):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Axel Beckert (xtaran) wrote :

This seems related to being compiled against apt 0.9.x (or 0.8.16~exp). Also happens if you press Shift-C in interactive mode.

Tracked in Debian at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669569

Changed in aptitude (Debian):
status: Unknown → Confirmed

In line with the last post, my plain Debian boxes now DO show this problem. So discount my previous comment on that. Thank you for the info, Axel.

Changed in aptitude (Debian):
status: Confirmed → Fix Committed
Changed in aptitude (Debian):
status: Fix Committed → Fix Released
tags: added: quantal
Jan Henke (jhe) wrote :

Does anybody back port the fix for this bug to precise as SRU?

Since the fix hasn't made it to quantal yet, that will probably have to happen before an SRU is considered. Just a user's impression.

tags: added: upgrade-software-version
summary: - Changelog download failed: Download queue destroyed.
+ aptitude can no longer show changelogs: "Changelog download failed:
+ Download queue destroyed.
summary: aptitude can no longer show changelogs: "Changelog download failed:
- Download queue destroyed.
+ Download queue destroyed." Please merge the fixed version, 0.6.8, from
+ Debian.

On 2 July 2012 20:25, Marcin Juszkiewicz <email address hidden> wrote:
> Can someone take a look at aptitude 0.6.1-1ubuntu1 at
> http://marcin.juszkiewicz.com.pl/~hrw/ubuntu/ ?

* Between 0.6.6 and 0.6.8 there has been many changes made upstream to
the files under debian/. Have you given consideration to those
changes?

* Removed debian/05aptitude, yet this is still mentioned in
debian/changelog. Why removed?

diff -Nru aptitude-0.6.6/debian/05aptitude aptitude-0.6.8/debian/05aptitude
--- aptitude-0.6.6/debian/05aptitude 2012-03-28 20:36:07.000000000 +0800
+++ aptitude-0.6.8/debian/05aptitude 1970-01-01 08:00:00.000000000 +0800
@@ -1,3 +0,0 @@
-aptitude::Keep-Unused-Pattern "^linux-image.*$ |
^linux-restricted-modules.*$ | ^linux-ubuntu-modules.*$";
-aptitude::Get-Root-Command "sudo:/usr/bin/sudo";
-

* Unexplained changes to debian/control:

  - Maintainer:

diff -Nru aptitude-0.6.6/debian/control aptitude-0.6.8/debian/control
--- aptitude-0.6.6/debian/control 2012-03-28 20:57:43.000000000 +0800
+++ aptitude-0.6.8/debian/control 2012-07-02 18:58:38.000000000 +0800
@@ -1,30 +1,29 @@
 Source: aptitude
 Section: admin
 Priority: important
-Maintainer: Ubuntu Developers <email address hidden>
-XSBC-Original-Maintainer: Aptitude Development Team
<email address hidden>
+Maintainer: Aptitude Development Team <email address hidden>
 Uploaders: Daniel Burrows <email address hidden>, Daniel Hartwig
<email address hidden>
 DM-Upload-Allowed: yes

  - VCS:

-XS-Debian-Vcs-Git: git://git.debian.org/git/aptitude/aptitude.git
-XS-Debian-Vcs-Browser: http://git.debian.org/?p=aptitude/aptitude.git;a=summary
+Vcs-Git: git://git.debian.org/git/aptitude/aptitude.git
+Vcs-Browser: http://git.debian.org/?p=aptitude/aptitude.git;a=summary
 Standards-Version: 3.9.3
 Homepage: http://aptitude.alioth.debian.org/

* Dropped debian/patches/11_ubuntu_uses_sudo -- ok, this has been
merged upstream.

* Dropped debian/patches/12_point_manpage_to_doc_package -- ok, also
merged upstream.

* debian/patches/14_html2text_preferred:

  - file paths have version number hardcoded:

diff -Nru aptitude-0.6.6/debian/patches/14_html2text_preferred
aptitude-0.6.8/debian/patches/14_html2text_preferred
--- aptitude-0.6.6/debian/patches/14_html2text_preferred 2012-03-28
20:36:07.000000000 +0800
+++ aptitude-0.6.8/debian/patches/14_html2text_preferred 2012-07-02
18:39:24.000000000 +0800

---- aptitude.orig/doc/html-to-text
-+++ aptitude/doc/html-to-text

+--- aptitude-0.6.8.orig/doc/html-to-text
++++ aptitude-0.6.8/doc/html-to-text

  - upstream introduced $encoding in html-to-text which is not used by
your updates to this patch. Is it ok that your patched version
ignores it and forces encoding to ASCII?

* debian/patches/no-google-mock:

  - File paths also now have version hardcoded.
  - Diff is very large, are the changes reliable?

Marcin Juszkiewicz (hrw) wrote :

On 2 July 2012 20:25, Marcin Juszkiewicz <email address hidden> wrote:
> > Can someone take a look at aptitude 0.6.1-1ubuntu1 at
> > http://marcin.juszkiewicz.com.pl/~hrw/ubuntu/ ?

> * Between 0.6.6 and 0.6.8 there has been many changes made upstream to
> the files under debian/. Have you given consideration to those
> changes?

Yes, I had and adapted to it.

> * Removed debian/05aptitude, yet this is still mentioned in
> debian/changelog. Why removed?

Mistake - restored, added to aptitude.install

> * Unexplained changes to debian/control:

Fixed

> * debian/patches/14_html2text_preferred:
>
> - file paths have version number hardcoded:

refreshed to not have version

> - upstream introduced $encoding in html-to-text which is not used by
> your updates to this patch. Is it ok that your patched version
> ignores it and forces encoding to ASCII?

Fixed to use utf-8 all the time and added info why

> * debian/patches/no-google-mock:
>
> - File paths also now have version hardcoded.
> - Diff is very large, are the changes reliable?

Refreshed patch

tags: added: patch
Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package aptitude - 0.6.8-1ubuntu1

---------------
aptitude (0.6.8-1ubuntu1) quantal; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - debian/05aptitude: Never autoremove kernels.
    - Drop aptitude-doc to Suggests.
    - 03_branding: Ubuntu branding.
    - 04_changelog: Take changelogs from changelogs.ubuntu.com.
    - 14_html2text_preferred: Switch back to html2text in favor of elinks,
      since html2text is in main and elinks isn't. Convert all files to utf-8
      encoding as it is better then ascii for iso-8859-1 (English docs).
    - no-google-mock: Don't use google-mock as it and libgtest-dev are in
      universe. Refreshed to cover all changes.

aptitude (0.6.8-1) unstable; urgency=low

  * Fix build with g++ 4.7
    Thanks Adrian Lang for the patch (Closes: #672335)
  * New binary packages:
    - aptitude-doc-it: Italian documentation (Closes: #674664)
    - aptitude-common: data files and translations
  * debian/rules:
    - use dh (debhelper command sequencer)
  * Require libapt-pkg 0.9.3 to avoid "Method http has died
    unexpectedly" (Closes: #669322)
  * Removed preinst script, the one transition it handled is
    over ten years old.
  * New upstream release.
    - Update to tasks support: task packages, multi-arch, syntax

      Task packages (introduced with tasksel 3.0) are
      meta-packages which define the dependencies of tasks. The
      packages themselves have always worked but the 'tasks'
      grouping policy and '?task' search term did not support
      them. This update corrects for this.

      As a result of this change to tasksel all Debian tasks now
      function exactly like meta-packages. (Closes: #382631)

      The syntax for installing tasks from the command line has
      been updated. It now supports specifying an arch and
      requires the same syntax as apt-utils ('^' must be the last
      part of the name). Examples:

        # aptitude install gnome-desktop^
        # aptitude install ssh-server^:armel

      This avoids ambiguity that may arise when a task and
      package have the same name.
    - Changelog downloading is restored
      (Closes: #669569, LP: #824708)
    - Exit with non-zero status when a package run is
      aborted. (Closes: #293008)
    - Restore candidate version on undo, keep
      (Closes: #529403)
    - Adjust default widths of localized columns:
      broken_count, downloadsize (Closes: #674045)
    - Update package views after 'Cancel pending actions'
      (Closes: #595753)
    - Fix minor errors in documentation. Thanks to Beatrice Torracca
      (Closes: #674675)
    - Fix groff warning in manpage (Closes: #675085)
    - Translation updates:
      + French (Closes: #673827, LP: #642840)
      + German (Closes: #672467, #668875)
      + Simplified Chinese

aptitude (0.6.7-1) unstable; urgency=low

  * Fix FTBFS in sid: include build of gtest when building gmock
   (Closes: #670403, #671439)

  * New upstream release.

    - Avoid dpkg and infinite loop in download-only mode
      (Closes: #629266, LP: #975793)

    - Check for apt_init errors in cmdline_download.cc (Closes: #670379)

    - Downloading/installing...

Read more...

Changed in aptitude (Ubuntu):
status: Triaged → Fix Released
Jan Henke (jhe) wrote :

Great that the problem has been fixed in 12.10, but we really really need a SRU here!
Since aptitude is a console based utility I guess most people (like me) are using it on server installation since desktop installations offer a variety of other tools for that purpose.
Viewing the change log for a packet before installing it is one of the core features of aptitude! We need to have the fix as SRU for 12.04.

Daniel Hartwig (wigs) wrote :

The patch from upstream commit eb9f6c2.

description: updated
Daniel Hartwig (wigs) on 2012-08-21
description: updated
Marcin Juszkiewicz (hrw) wrote :

Thanks to Daniel Hartwig I managed to build Precise package: http://tygrysek.juszkiewicz.com.pl/~hrw/ubuntu/

On 27 August 2012 22:02, Marcin Juszkiewicz <email address hidden> wrote:
> Thanks to Daniel Hartwig I managed to build Precise package:
> http://tygrysek.juszkiewicz.com.pl/~hrw/ubuntu/

Great. Please consider adding the patch for bug #975793 to this also.
 I was meaning to follow these two up but could not get a hold of
anyone to nominate the bugs (?).

There is no need for this personal credit in the changelog:

+ (patch extracted by Daniel Hartwig)

as I am also the author of the upstream commits ;-)

Updated package to have also fix for bug #975793 as suggested.

Same location and version: http://tygrysek.juszkiewicz.com.pl/~hrw/ubuntu/

Daniel: I know, that You are upstream ;) Rewrote changelog entry.

Daniel Hartwig (wigs) wrote :

Updated copy of debdiff from Marcin's repository.

Daniel Hartwig (wigs) on 2012-09-07
summary: aptitude can no longer show changelogs: "Changelog download failed:
- Download queue destroyed." Please merge the fixed version, 0.6.8, from
- Debian.
+ Download queue destroyed."
Micah Gersten (micahg) wrote :

Taking a look

Changed in aptitude (Ubuntu Precise):
assignee: nobody → Micah Gersten (micahg)
status: New → In Progress
Micah Gersten (micahg) wrote :

Normally I wouldn't upload such large patches to proposed, but since this is the LTS and it's pretty broken, I'll let the SRU team make the final call. Other paperwork seems to be in order.

Changed in aptitude (Ubuntu Precise):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

I am unsubscribing the sponsors team since this was uploaded to precise-proposed queue.

Jan Henke (jhe) wrote :

I would like to bring this topic back to attention. The status reads fix committed, still I can't see any update to aptitude in precise-proposed. I kindly ask to push this update to the standard precise archives so that everybody can benefit from this fix.

Hello zigi, or anyone else affected,

Accepted aptitude into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/aptitude/0.6.6-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Jan Henke (jhe) wrote :

Tested with Ubuntu Server 12.04.1 LTS installation. After upgrading to 0.6.6-1ubuntu1.1 viewing the changelog of any given packet works again. No regressions experienced.

tags: added: verification-done
removed: verification-needed
Yucong Sun (sunyucong) wrote :

This is still happening on my 12.04 .1 LTS x64

aptitude version is 0.6.6-1unbutu1

Please re-verify the necessary release is really released

tags: added: verification-needed
removed: verification-done
Daniel Hartwig (wigs) wrote :

sunyucong: you must enable the -proposed repository first. See the instructions referred to in comment #28.

Restoring previous tags.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptitude - 0.6.6-1ubuntu1.1

---------------
aptitude (0.6.6-1ubuntu1.1) precise-proposed; urgency=low

  * Apply cherry-picked patches from upstream:
    - fix changelog fetching. LP: #824708
    - avoid dpkg and infinite loop in download-only mode. LP: #975793
 -- Marcin Juszkiewicz <email address hidden> Mon, 10 Sep 2012 14:22:56 -0500

Changed in aptitude (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.