aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file descriptor

Bug #741370 reported by dolfdiop on 2011-03-24
This bug affects 424 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: aptdaemon

nothing

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: aptdaemon 0.41+bzr604-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Thu Mar 24 00:46:13 2011
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/sbin/aptd
ProcEnviron:

PythonArgs: ['/usr/sbin/aptd']
SourcePackage: aptdaemon
Title: aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file descriptor
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/aptdaemon/progress.py", line 421, in _copy_io_master
     os.close(source)
 OSError: [Errno 9] Bad file descriptor
UpgradeStatus: Upgraded to natty on 2011-03-23 (0 days ago)
UserGroups:

dolfdiop (dolfdiop) wrote :
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
visibility: private → public
Kevin (kevinshlee) wrote :

I've just got this error in Ubuntu 11.04 Desktop amd64 beta1 (Live USB).

$ lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

$ uname -a
Linux ubuntu 2.6.38-7-generic #39-Ubuntu SMP Fri Mar 25 21:24:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ apt-cache policy aptdaemon
aptdaemon:
  Installed: 0.41+bzr604-0ubuntu1
  Candidate: 0.41+bzr604-0ubuntu1
  Version table:
 *** 0.41+bzr604-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status

Matthew Hollis (mdhollis) wrote :

This also happened to me while trying to report an error with the GStreamer ugly plugins.

It also happen to me when I try to update GStreamer ugly plugins.

installArchives() failed: (Lecture de la base de donnes...
(Lecture de la base de donnes... 5%%
(Lecture de la base de donnes... 10%%
(Lecture de la base de donnes... 15%%
(Lecture de la base de donnes... 20%%
(Lecture de la base de donnes... 25%%
(Lecture de la base de donnes... 30%%
(Lecture de la base de donnes... 35%%
(Lecture de la base de donnes... 40%%
(Lecture de la base de donnes... 45%%
(Lecture de la base de donnes... 50%%
(Lecture de la base de donnes... 55%%
(Lecture de la base de donnes... 60%%
(Lecture de la base de donnes... 65%%
(Lecture de la base de donnes... 70%%
(Lecture de la base de donnes... 75%%
(Lecture de la base de donnes... 80%%
(Lecture de la base de donnes... 85%%
(Lecture de la base de donnes... 90%%
(Lecture de la base de donnes... 95%%
(Lecture de la base de donnes... 100%%
(Lecture de la base de donnes... 129046 fichiers et rpertoires dj installs.)

Prparation du remplacement de gstreamer0.10-plugins-ugly 0.10.17-1 (en utilisant .../gstreamer0.10-plugins-ugly_0.10.17-1ubuntu1_i386.deb) ...

Dpaquetage de la mise jour de gstreamer0.10-plugins-ugly ...

dpkg: erreur de traitement de /var/cache/apt/archives/gstreamer0.10-plugins-ugly_0.10.17-1ubuntu1_i386.deb (--unpack):

 tentative de remplacement de /usr/share/locale/af/LC_MESSAGES/.mo, qui appartient aussi au paquet gstreamer0.10-plugins-bad 0.10.21-1ubuntu10

No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess coller was killed by signal (Broken pipe)

Des erreurs ont t rencontres pendant l'excution:

 /var/cache/apt/archives/gstreamer0.10-plugins-ugly_0.10.17-1ubuntu1_i386.deb

Douglas Hayse (z28hayse) wrote :

if i do not run in classic the screen has large black blocks that move around as I move the mouse and makes it unusable

Download full text (179.9 KiB)

The following was in the Package Operation Failed windows. I hope this info is helpful.

installArchives() failed:
Extracting templates from packages: 34%%
Extracting templates from packages: 69%%
Extracting templates from packages: 100%%

Preconfiguring packages ...

Extracting templates from packages: 34%%
Extracting templates from packages: 69%%
Extracting templates from packages: 100%%

Preconfiguring packages ...

Extracting templates from packages: 34%%
Extracting templates from packages: 69%%
Extracting templates from packages: 100%%

Preconfiguring packages ...

(Reading database ...
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 170148 files and directories currently installed.)

Preparing to replace libc6-i386 2.13-0ubuntu11 (using .../libc6-i386_2.13-0ubuntu12_amd64.deb) ...

Unpacking replacement libc6-i386 ...

Preparing to replace libc-dev-bin 2.13-0ubuntu11 (using .../libc-dev-bin_2.13-0ubuntu12_amd64.deb) ...

Unpacking replacement libc-dev-bin ...

Preparing to replace libc6-dev 2.13-0ubuntu11 (using .../libc6-dev_2.13-0ubuntu12_amd64.deb) ...

Unpacking replacement libc6-dev ...

Preparing to replace libc-bin 2.13-0ubuntu11 (using .../libc-bin_2.13-0ubuntu12_amd64.deb) ...

Unpacking replacement libc-bin ...

Processing triggers for man-db ...

Setting up libc-bin (2.13-0ubuntu12) ...

(Reading database ...
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 170148 files and directories currently installed.)

Preparing to replace libc6 2.13-0ubuntu11 (using .../libc6_2.13-0ubuntu12_amd64.deb) ...

Unpacking replacement libc6 ...

Setting up libc6 (2.13-0ubuntu12) ...

Processing triggers for libc-bin ...

ldconfig deferred processing now taking place

(Reading database ...
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ...

Namlee85 (namlee85) wrote :

was updating and gstreamer plugin failed to install

Yes, when I tried to update this plugin fail the apt.

Best regards

Alejandro Bartolomeo

On Tue, Apr 5, 2011 at 1:54 PM, Namlee85 <email address hidden> wrote:

> was updating and gstreamer plugin failed to install
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (751593).
> https://bugs.launchpad.net/bugs/741370
>
> Title:
> aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file
> descriptor
>
> Status in “aptdaemon” package in Ubuntu:
> New
>
> Bug description:
> Binary package hint: aptdaemon
>
> nothing
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr604-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
> Uname: Linux 2.6.38-7-generic i686
> Architecture: i386
> Date: Thu Mar 24 00:46:13 2011
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
> InterpreterPath: /usr/bin/python2.7
> ProcCmdline: /usr/bin/python /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file
> descriptor
> Traceback:
> Traceback (most recent call last):
> File "/usr/lib/python2.7/dist-packages/aptdaemon/progress.py", line
> 421, in _copy_io_master
> os.close(source)
> OSError: [Errno 9] Bad file descriptor
> UpgradeStatus: Upgraded to natty on 2011-03-23 (0 days ago)
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/741370/+subscribe
>

Ayke (ayke) wrote :

It seems like a bad package (see https://bugs.launchpad.net/ubuntu/+source/gst-plugins-ugly0.10/+bug/751690) causes this error.

Juan Montoya (th3pr0ph3t) wrote :

I get a message that apt crashed.
I think the bug report process is bugged so what we see here is not the real bug: It crashed when it tries to report a crash...

Ayke (ayke) wrote :

Yes, it crashed when reporting a crash. But I think that crash is caused by the previous crash. By me dpkg failed to install the gstreamer update, and, I think, that caused the crash in aptd. So, yes, there crashes something while the first crash is being reported.

Chad A. Davis (chadadavis) wrote :

This is related to Bug 751911.

While that might be the cause for this crash, this is probably still a bug of it's own. It doesn't seem that conflicting packages should be able to crash aptd.

Has anyone here had this issue resulting from something other than gstreamer-plugins?

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Lord Delta (lorddefinitia) wrote :

How would I check?

Lorem Daijoh (lorem-daijoh) wrote :

In my case the crash was preceded by this:

Errors were encountered while processing:

 linux-image-2.6.38-8-generic

 linux-image-generic

 linux-generic

etn plnxiae263--eei 263-.1 .
unn emd
paeiirms eeaig/otiir.m-..88gnrccyteu:WRIG aldt eetcnncldvc faf
rpstp ANN:cudntdtriero eiefo ecftbEaiig/t/enlpsis..rnprs xctn eckre/otntddm ..88gnrc/otvlnz263--eei
*dm:rnigat ntlainsriefrkre ..88gnrc 8G
* bml(.0.23+do). [0 7G K]rnprs xctn eckre/otntdiirmstos263--eei bo/miu-..88gnrcrnprs xctn eckre/otntdnii-omn263--eei bo/miu-..88gnrcrnprs xctn eckre/otntdp-tl ..88gnrc/otvlnz263--eei
u-at:eeuig/t/enlpsis./paentfe ..88gnrc/otvlnz263--eei
u-at:eeuig/t/enlpsis./zudt-rb263--eei bo/miu-..88gnrc/s/bngu-rb:err antsa af'
u-at:/t/enlpsis./zudt-rbeie ihrtr oe1Fie opoes/t/enlpsis. t/a/i/pgif/iu-mg-..88gnrcpsis ie11.dk:errpoesn iu-mg-..88gnrc(-ofgr)
sbrcs ntle otisalto citrtre ro xtsau
pg eednypolm rvn ofgrto flnxiaegnrc
lnxiaegnrcdpnso iu-mg-..88gnrc oee: Pcaelnxiae263--eei sntcniue e.dk:errpoesn iu-mg-eei -cniue: eednypolm evn nofgrddk:dpnec rbespeetcniuaino iu-eei: iu-eei eed nlnxiaegnrc( ..882) oee: Pcaelnxiaegnrci o ofgrdyt
pg ro rcsiglnxgnrc(-ofgr)
dpnec rbes-laigucniue

The crash happened while trying to report above problem. That report is unfortunately now gone and that is only thing left.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr614-0ubuntu2

---------------
aptdaemon (0.41+bzr614-0ubuntu2) natty; urgency=low

  * debian/patches/02_fix_unicode_in_convert_struct.patch:
    - Decode non-unicode strings in _convert_struct (LP: #736507)
  * debian/patches/03_do_not_close_invalid_fd.patch:
    - Do not close invalid streams (LP: #741370)
 -- Julian Andres Klode <email address hidden> Thu, 07 Apr 2011 10:02:21 +0200

Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released
Tom Hauser (doogie128) wrote :

using a persistant USB i was using the update manager to update the new
install with firefox open in the foreground,
 sorry i was not paying much attention and it might have been a cascaded bug
from a net connection bug that kept popping up

On Wed, Apr 6, 2011 at 6:21 PM, Lord Delta <email address hidden>wrote:

> How would I check?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/741370
>
> Title:
> aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file
> descriptor
>
> Status in “aptdaemon” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: aptdaemon
>
> nothing
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr604-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
> Uname: Linux 2.6.38-7-generic i686
> Architecture: i386
> Date: Thu Mar 24 00:46:13 2011
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
> InterpreterPath: /usr/bin/python2.7
> ProcCmdline: /usr/bin/python /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file
> descriptor
> Traceback:
> Traceback (most recent call last):
> File "/usr/lib/python2.7/dist-packages/aptdaemon/progress.py", line
> 421, in _copy_io_master
> os.close(source)
> OSError: [Errno 9] Bad file descriptor
> UpgradeStatus: Upgraded to natty on 2011-03-23 (0 days ago)
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/741370/+subscribe
>

Alex Bell (ubuntu-upb) wrote :

I was running update manager and got this bug. It is reported in duplicated thread here: https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/753466

Ant Dickens (antonydickens) wrote :

Crashed during running update manager. Whilst booted in to the default Unity interface.

Sense Egbert Hofstede (sense) wrote :

This crash occurred again today when branding-update failed to update to 0.6. It interrupted the udev update, making it divert, preventing update-initramfs to run and causing the system to become unbootable. Finishing dpkg --configure -a using chroot solved that.

Udev issue reported in bug #753853

Maybe I have same problem. And it's with update branding-ubuntu:

Rozbaluji náhradu branding-ubuntu …
dpkg: chyba při zpracovávání /var/cache/apt/archives/branding-ubuntu_0.6_all.deb (--unpack):
 zkouším přepsat soubor „/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg“, který je také v balíku quadrapassel 1:2.32.1-0ubuntu3
Při zpracování nastaly chyby:
 /var/cache/apt/archives/branding-ubuntu_0.6_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hugo Venhorst (yougo) wrote :

ran an update just now, asked me to reboot. after logging in again, got this report about Aptd. doesn't seem to be fixed sadly?

Patrick Toy (lifebeyondwalls) wrote :

Experiencing this issue as well. Crashes during regular update-manager process. Related info:

Preparing to replace branding-ubuntu 0.5 (using .../branding-ubuntu_0.6_all.deb) ...
Unpacking replacement branding-ubuntu ...
dpkg: error processing /var/cache/apt/archives/branding-ubuntu_0.6_all.deb (--unpack):
 trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3
Errors were encountered while processing:
 /var/cache/apt/archives/branding-ubuntu_0.6_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hugo Venhorst (yougo) wrote :

had the bug yesterday, updated just now, bug still appeared :( ar you sure it's patched, or is the patch yet to roll out?

joopbraak (joopbraak) wrote :

@Sense Hofstede, Yougo, Pavel Studeník, Patrick Toy

Stop posting irrelevant information and making things more complicated!
All these things have nothing to do with this bug!

Hugo Venhorst (yougo) wrote :

how would we know? how would you know?

all we do is try to update, get an error, and report the bug, like the helpful ubuntu enthousiasts we are.
The bug description matches this bug's word for word. Launchpad itself directed me to this particular bug. who am i not to follow?

i'd appreciate if I weren't told to stop reporting bugs, on launchpad.

i see this bug is supposed to be fixed, however, i'm still getting the error.
if there is any additional log or info i can submit, please specify

joopbraak (joopbraak) wrote :

Yeah, sorry, I was wrong. I had the update errors with gstreamer0.10-plugins-ugly and branding-ubuntu, but not the apt crash, and I never experienced apt crashing because one package conflicted with another package, so I jumped to conclusions.

joopbraak (joopbraak) wrote :

@ Yougo : what's the output of "apt-cache show aptdaemon|grep Version" ?

Hugo Venhorst (yougo) wrote :

it's ok :-)

i have aptdaemon version 0.41+bzr614-0ubuntu2 installed

Lord Delta (lorddefinitia) wrote :

Same version here.

"apt-cache show aptdaemon|grep Version
Version: 0.41+bzr614-0ubuntu2"

On Mon, Apr 11, 2011 at 2:59 PM, Yougo <email address hidden> wrote:

> it's ok :-)
>
> i have aptdaemon version 0.41+bzr614-0ubuntu2 installed
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/741370
>
> Title:
> aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file
> descriptor
>
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: aptdaemon
>
> nothing
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr604-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
> Uname: Linux 2.6.38-7-generic i686
> Architecture: i386
> Date: Thu Mar 24 00:46:13 2011
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
> InterpreterPath: /usr/bin/python2.7
> ProcCmdline: /usr/bin/python /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file
> descriptor
> Traceback:
> Traceback (most recent call last):
> File "/usr/lib/python2.7/dist-packages/aptdaemon/progress.py", line
> 421, in _copy_io_master
> os.close(source)
> OSError: [Errno 9] Bad file descriptor
> UpgradeStatus: Upgraded to natty on 2011-03-23 (0 days ago)
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/741370/+subscribe
>

Hugo Venhorst (yougo) wrote :

as a result of bug 752220 (and maybe others) the package is about to be upgraded to version 0.41+bzr614-0ubuntu3
let's wait and see what this version does?

OK for me.

Best regards

Alejandro Bartolomeo

On Tue, Apr 12, 2011 at 1:48 PM, Yougo <email address hidden> wrote:

> as a result of bug 752220 (and maybe others) the package is about to be
> upgraded to version 0.41+bzr614-0ubuntu3
> let's wait and see what this version does?
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (751593).
> https://bugs.launchpad.net/bugs/741370
>
> Title:
> aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file
> descriptor
>
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: aptdaemon
>
> nothing
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: aptdaemon 0.41+bzr604-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
> Uname: Linux 2.6.38-7-generic i686
> Architecture: i386
> Date: Thu Mar 24 00:46:13 2011
> ExecutablePath: /usr/sbin/aptd
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
> InterpreterPath: /usr/bin/python2.7
> ProcCmdline: /usr/bin/python /usr/sbin/aptd
> ProcEnviron:
>
> PythonArgs: ['/usr/sbin/aptd']
> SourcePackage: aptdaemon
> Title: aptd crashed with OSError in _copy_io_master(): [Errno 9] Bad file
> descriptor
> Traceback:
> Traceback (most recent call last):
> File "/usr/lib/python2.7/dist-packages/aptdaemon/progress.py", line
> 421, in _copy_io_master
> os.close(source)
> OSError: [Errno 9] Bad file descriptor
> UpgradeStatus: Upgraded to natty on 2011-03-23 (0 days ago)
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/741370/+subscribe
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers