Ubuntu

Opening a known good *.deb with software centre, fails to install as lintian errors cannot be overidden

Reported by Dave Walker on 2011-02-03
416
This bug affects 90 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
High
Michael Vogt
Natty
High
Michael Vogt
software-center (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: software-center

"The package is of bad quality
The installation of a package which violates the quality standards isn't allowed. This could cause serious problems on your computer. Please contact the person or organisation who provided this package file and include the details beneath."

This is a known good package, the linitan errors are valid - but a deb should not have to comply with the latest policy standards to be able to be installed.

Errors which should really be ignored:
 no-copyright-file
 dir-or-file-in-opt

These two errors do not inherently make a package of bad quality. However, there should always be the ability to say, "No, i know better - please continue".

Thanks.

Robert Roth (evfool) on 2011-02-04
Changed in software-center (Ubuntu):
status: New → Confirmed
clark3934 (clark3934) wrote :

I can confirm this bug when trying to install the latest Dropbox .deb (https://www.dropbox.com/downloading?os=lnx).

bonimba (altrobonimba) wrote :

I also can confirm this bug when trying to install the google-talkplugin for .deb (http://www.google.com/chat/video/download.html).

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

Since these same packages that software center refuses to install can be installed using "sudo apt-get install PACKAGE", this is a serious issue for those uses left wondering what happened.

Thanks for taking the time to make Ubuntu better!

Changed in software-center (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Philip Muškovac (yofel) on 2011-02-26
tags: added: natty
Jinxi Cheng (jinxi-cheng) wrote :

I can also confirm this bug with latest dropbox .deb file using Ubuntu Software Center version 3.1.20 (Natty).

Skype should be blocked.

Sebastian Heinlein (glatzor) wrote :

The error dialog should in the case provide an action to force the installation of the package. You just have to call aptdaemon.client.install_file(path, force=True) to override the warning.

Ingo Gerth (igerth) wrote :

Will not let me install Google Chrome and Skype either.

Dimitri John Ledkov (xnox) wrote :

Apt-get won't help, and dpkg will complain about dependencies.

$ sudo apt-get install gdebi

and then

$ sudo gdebi package.deb

gdebi will manage to install your chrome/skype/talk-plugins/etc.

James Pursey (jamespursey) wrote :

I have encountered this bug with Crossover

Michael Vogt (mvo) wrote :

I looked at this and I think instead of using "-F" (the ftpmaster-reject option) we should add our own file based on that. Its e.g. fine to have a package installing stuff in /opt or with a missing copyright file. But others (like no-package-name, no-version-field) we definitely want.

Michael Vogt (mvo) wrote :

We should blog/mail about it (from irc):
<joaopinto> mvo, apart from the improvements maybe someone could write a short summary about the change ? Probably due to the lack of information I have already seen some comments about eventual Canonical interference
<mvo> joaopinto: that sounds reasonable, I can blog about it

Valery Kondakoff (strauss) wrote :

Still reproducible in Alpha 3.

Here are some particulars using 11.04 A3 /w latest "stable" updates as of time of this posting...

Dropbox 0.6.7: https://www.dropbox.com/downloading?os=lnx
E: nautilus-dropbox: copyright-contains-dh_make-todo-boilerplate

W: nautilus-dropbox: maintainer-script-ignores-errors postrm

W: nautilus-dropbox: killall-is-dangerous postinst:139

E: nautilus-dropbox: pkg-has-shlibs-control-file-but-no-actual-shared-libs

W: nautilus-dropbox: postinst-has-useless-call-to-ldconfig

W: nautilus-dropbox: postrm-has-useless-call-to-ldconfig

Skype 2.1 Beta 1: http://www.skype.com/intl/en-us/get-skype/on-your-computer/linux/
E: skype: description-starts-with-package-name

W: skype: extended-description-line-too-long

W: skype: extended-description-line-too-long

W: skype: possible-unindented-list-in-extended-description

W: skype: new-package-should-close-itp-bug

W: skype: binary-without-manpage usr/bin/skype

Google Chrome Beta: http://www.google.com/chrome?platform=linux
E: google-chrome-beta: no-copyright-file

Can't call method "data" on an undefined value at /usr/share/lintian/checks/deb-format line 63.

internal error: cannot run deb_format check on package google-chrome-beta

warning: skipping check of binary package google-chrome-beta

oraculum (damon-abdiel) wrote :

I tried to install teamviewer and received same error.

http://www.teamviewer.com/

Lintian check results for /home/damon/teamviewer_linux.deb:
W: teamviewer6: unknown-section non-free/internet
W: teamviewer6: postinst-has-useless-call-to-update-menus
W: teamviewer6: postrm-has-useless-call-to-update-menus
E: teamviewer6: no-copyright-file
W: teamviewer6: binary-without-manpage usr/bin/teamviewer6
W: teamviewer6: maintainer-script-ignores-errors prerm
W: teamviewer6: maintainer-script-ignores-errors preinst
W: teamviewer6: maintainer-script-ignores-errors postrm
W: teamviewer6: maintainer-script-ignores-errors postinst
warning: collect info objdump-info about package teamviewer6 failed
warning: skipping check of binary package teamviewer6
/usr/bin/strings: 'unpacked/./opt/teamviewer/teamviewer/6/wine/lib/wine/actxprxy.dll.so': No such file
/bin/rm: cannot remove `/tmp/TGLBihgDlr/binary/teamviewer6': Directory not empty
warning: cannot remove lab directory /tmp/TGLBihgDlr (please remove it yourself)
warning: cannot remove lab directory /tmp/TGLBihgDlr (please remove it yourself)
internal error: command failed with error code 1

Doug McMahon (mc3man) wrote :

Hopefully it's been decided that install location and copyright have no place in this ... (among others

For plain users that want some relief while this is being worked on -
ATM lintian is just a recommend of aptdaemon, if you don't need it otherwise then just remove, aptdaemon will not error in it's absence.

If you do make use of lintian and are bothered by this than you can just remove the section of code causing this in worker.py
(currently look around starting at line 1155

This is a pretty major bug isn't it? Can't install Skype, Chrome, Dropbox, etc. It's the one thing keeping me from using Ubuntu. Love the new interface, close to being a convert, but not having skype and chrome are big holdups.

IKT (ikt) wrote :

Yep and it's got a pretty high importance.

You can install all of those packages via the command line using: sudo dpkg -i name_of_deb_package_here.deb

Ahhh sweet! I'm back in business. You the man IKT. ;)

Matthew Young (gtrsdk) wrote :

I was unable to install Skype and CrossOver. Hopefully this is fixed soon. I was able to install GDebi using the package manager for installing .deb files.

Daniel Banck (dbanck) wrote :

Still present in beta 1.

JunLe Li (lijunle) wrote :

i got this bug, too.
but the deb can be installed using `sudo dpkg -i NAME.deb`

Lemuel Cantos (lemuelinchrist) wrote :

I have this bug too. still isnt fixed.

cigrainger (cigrainger) wrote :

I have this bug in Natty Beta 1 64-bit, and using the terminal to install with dpkg is not working either for Chrome. Should be 'sudo dpkg -i name_of_pkg.deb' and that's encountering errors while processing, failing after processing triggers for python support. Dpkg worked for Skype.

Lorenz (lorenzloidl) wrote :

Still present in the 32-bit Desktop Beta 1 too. Very annoying, I like to avoid the terminal as much as I can ;)

Apt-get won't help, and dpkg will complain about dependencies.

$ sudo apt-get install gdebi

and then

$ sudo gdebi package.deb

gdebi will manage to install your chrome/skype/talk-plugins/etc.

that works well for me for google talk plugin !!! just right click the plugin and open it whit GDEBI package insaller after those steps !

thx Dmitrijs Ledkovs !!!

I also had to use GDebi, but I was able to simply right-click on the
packages and select GDebi.

Similar errors as the main post for Teamviewer 6 as well.

You can however install the Google plugin and Teamviewer 6 with "sudo dpkg -i (*.deb file)".

Changed in software-center (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
Michael Vogt (mvo) on 2011-04-05
Changed in software-center (Ubuntu Natty):
status: Triaged → In Progress
affects: software-center (Ubuntu Natty) → aptdaemon (Ubuntu Natty)
sp1d3r (miguelomonroyb) wrote :

Affected by this bug when i was trying to install chrome, dropbox, teamviewer 6, and a long etc.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr614-0ubuntu1

---------------
aptdaemon (0.41+bzr614-0ubuntu1) natty; urgency=low

  * New bzr bugfix snapshot:
    - fix i18n crash (LP: #724735)
    - Allow to specify package names with an architecture
      (for multiarch)
    - Client: Exit the transaction processing if there has been an
      error
    - Make the run method of the GTK2 progress dialog deferable
      (LP: #626798)
  * debian/patches/01_relax_lintian_checks.patch:
    - add lp:~mvo/aptdaemon/relax-lintian-checks as distro patch
      until upstream (LP: #712377)
 -- Michael Vogt <email address hidden> Tue, 05 Apr 2011 16:31:37 +0200

Changed in aptdaemon (Ubuntu Natty):
status: In Progress → Fix Released
Michael Vogt (mvo) wrote :

I uploaded a new version now that massively relaxes the checks. Some stuff is still checked, let me know if there are failures, but now it should really only test for critical issues.

Giovanni Mellini (merlos) wrote :

Installed skype 2.2 deb. I can confirm this is fixed. Tks

Sjoerd (sjoerd1993) wrote :

I have tried installing World of Goo but I got the same problem again. I've got the download from the humble bundle site, so it's perfectly trusted. I get the same problem too with Google App Inventor, so it's not a bug in the World of Goo package.
I've also tried installing Skype, this does work for some mysterious reason.

I'm running 11.04 with the latest updates.
Please note that I do have a PPA with the latest daily of Unity, but I don't think that's the problem.

Here's the error message (with Google App Inventor, from the regular Google site):
"
The package is of bad quality
The installation of a package which violates the quality standards isn't allowed. This could cause serious problems on your computer. Please contact the person or organisation who provided this package file and include the details beneath."
And here are more details:
"Lintian check results for /home/sjoerd/Downloads/appinventor-setup_1.1_all.deb:
E: appinventor-setup: arch-independent-package-contains-binary-or-object ./usr/google/appinventor/commands-for-Appinventor/adb

E: appinventor-setup: arch-independent-package-contains-binary-or-object ./usr/google/appinventor/commands-for-Appinventor/emulator

E: appinventor-setup: arch-independent-package-contains-binary-or-object ./usr/google/appinventor/commands-for-Appinventor/mksdcard

"

I run Ubuntu 11.04, latest updates. I do run the 64-bit edition.
And again, Skype didn't install before and now it does. But the fix doesn't work for all software, in fact, it doesn't work for most software.

Altough I don't think it's really relevant, here are my hardware specs:
AMD Athlon II X4 640 3.0GHz
2GB DDR2 RAM 800MHz
500GB Hard disk, 7200RPM
ATI RADEON HD3450 Videocard, 256Mb
And the basic stuff (17" Monitor, USB, disk drive etc..)

Narcis Garcia (narcisgarcia) wrote :

Travis Reeder, I'm sure that if you don't use Ubuntu, this bug is not the reason.
If you would like Ubuntu you would use a finished version and not look for developing versions.

Yuji Saito (yuji-saito) wrote :

I tried to install LSB printer drivers [1][2], but that failed with the error message below[3].
LSB printer driver packages don't have a direct dependency on libc, because they depend on the lsb package.
The lsb package has to depend on libc to conform to the LSB.

Package version is
    * software-center_3.1.26.i386.deb
    * aptdaemon_0.41+bzr614-0ubuntu2_i386.deb

[1] http://www.openprinting.org/driver/lm1100/
    http://www.openprinting.org/download/printdriver/debian/dists/lsb3.2/contrib/binary-i386/openprinting-lm1100_1.0.2a-6lsb3.2_i386.deb

[2] http://www.openprinting.org/driver/epson-escpr/
    http://linux.avasys.jp/drivers/lsb/epson-inkjet/stable/debian/dists/lsb3.2/main/binary-i386/epson-inkjet-printer-escpr_1.0.2-1lsb3.2_i386.deb

[3]
------------------------------------------------
Lintian check results for /tmp/epson-inkjet-printer-escpr_1.0.2-1lsb3.2_i386.deb
E: epson-inkjet-printer-escpr: missing-dependency-on-libc needed by ./opt/epson-inkjet-printer-escpr/cups/lib/filter/epson-escpr and 4 others
------------------------------------------------

Sjoerd (sjoerd1993) wrote :

Just a little update:
So I re-installed Ubuntu 11.04. I've got the latest updates from the main-server and I run the 64-bit edition.
The problem still exists, here's the information I got from (trying) installing World of Goo. (From the official Humble Bundle Package)

"The package is of bad quality
The installation of a package which violates the quality standards isn't allowed. This could cause serious problems on your computer. Please contact the person or organisation who provided this package file and include the details beneath."

And under detailed, yet again:
"Lintian check results for /home/sjoerd/Ubuntu One/Crap/WorldOfGooSetup.1.41.deb:
E: WorldOfGoo: package-not-lowercase

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/WorldOfGoo.bin32

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/WorldOfGoo.bin64

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs32/libSDL-1.2.so.0

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs32/libSDL_mixer-1.2.so.0

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs32/libogg.so.0

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs32/libvorbis.so.0

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs32/libvorbisfile.so.3

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs64/libSDL-1.2.so.0

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs64/libSDL_mixer-1.2.so.0

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs64/libogg.so.0

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs64/libvorbis.so.0

E: WorldOfGoo: arch-independent-package-contains-binary-or-object ./opt/WorldOfGoo/libs64/libvorbisfile.so.3
"

I regret to say the 'fix released' status is false.

Sjoerd (sjoerd1993) wrote :

I'm sorry if I'm doing it wrong, but I wanted to say that the status is wrong...
The problem still exists with a lot of packages. At the moment I'm not able to install World Of Goo or Google App Inventor for example. Both well-known products from reliable and trusted sources.

I should tell you that I am able to install Skype since the 'fix'. I wasn't before (in Natty).
The only problem is that it still doesn't work on a lot of other (trusted) packages.

Knef (knef) wrote :

Confirmed with World of Goo and Osmos deb files, both from the Humble Indie Bundle.

hackel (hackel) wrote :

Ugh, please make sure that any override to allow the installation of crappy packages gives users a big, fat warning about how stupid and dangerous it is to install such packages. I am so tired of these PAID employees churning out such utter crap packages and refusing to follow the Debian policy guidelines. Perhaps if we start calling them on this shoddy development work and publicly shaming these commercial companies for it, they will start to take packaging more seriously or even work with Ubuntu to have them properly packaged in the partner repository.

LSB compliant printer drivers with a libc dependency as distributed via the Linux Foundation's OpenPrinting Database still fail to install. These packages do not specify an explicit dependency on libc but rely on the distribution's lsb package to do so. The LSB is clear about what API of libc has to be present. Compliant drivers only use what is in specified in the LSB.

Please remove "missing-dependency-on-libc" from data/lintian-checks. It is already listed in a non fatal section, so please don't bomb on this.

FYI, the drivers distributed via the OpenPrinting Database are normally installed automatically when people connect their printer. This is a new feature in Natty and works fine. However, manually downloading that same driver and double clicking it bombs. It really shouldn't, at least not because of an indirect libc dependency via the lsb package.

Sebastian Heinlein (glatzor) wrote :

Actually this is also a software-center issue. Since sc doesn't allow to override the lintian test.

Changed in aptdaemon (Ubuntu Natty):
status: Fix Released → Fix Committed
Changed in software-center (Ubuntu Natty):
status: New → In Progress
Sebastian Heinlein (glatzor) wrote :

By the way the non-fatal linitian warnings can be overriden by the package itself shipping a corresponding usr/share/lintian/overrides/PACKAGE_NAME file, see man linitan

It must be possible to install LSB-based packages. To make them distribution-independent, they do not have lots of dependencies (like on libc) but depend only on the meta package "lsb" which in turn is dependent on everything what the LSB requires. These packages should be installable with Software Center, also architecture-independent packages without any dependency should be installable with Software Center.

Reopening. This needs to get fixed in Natty.

Changed in aptdaemon (Ubuntu Natty):
status: Fix Committed → Confirmed
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
Changed in software-center (Ubuntu Natty):
milestone: none → ubuntu-11.04
Changed in software-center (Ubuntu Natty):
importance: Undecided → High
Changed in aptdaemon (Ubuntu Natty):
status: Confirmed → Fix Released
assignee: nobody → Michael Vogt (mvo)
Changed in software-center (Ubuntu Natty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.26.3

---------------
software-center (3.1.26.3) natty; urgency=low

  [ Michael Vogt ]
  * softwarecenter/db/reviews.py:
    - do not crash on multiple origins for the same version
      (LP: #756415)
  * softwarecenter/db/application.py:
    - ensure docid is updated on database reopen() (LP: #757054)
  * softwarecenter/models/appstore.py:
    - refresh docids in active searches if the database is reopend
      (LP: #710920)
  * softwarecenter/backend/aptd.py:
    - do not run update-apt-xapian-index in --update mode to avoid
      in-place database modfications (LP: #507836)
  * test/test_load_icons.py:
    - add test for the icon loader
  * merged lp:~glatzor/software-center/force-bad-quality, this
    fixes the missing ability to override the lintian warning
    (LP: #712377)
  * don't show reviews if we can't determine the origin
  * fix crash when enabling new components (LP: #636429)
  * fix missing details when a channel or a component just got added

  [ Gary Lasker ]
  * softwarecenter/app.py:
    - temporarily disable the deauth option until we have support
      for remove repository in aptdaemon (see LP: #723911)
  * softwarecenter/backend/aptd.py :
    - fix empty error dialog for the case where aptdaemon returns
      an error code with no value (LP: #747172)
    - fix intermittent crash when updating the a-x-i (LP: #657494)
  * softwarecenter/models/viewswitcherlist.py:
    - mark string "In Progress..." for translation, many thanks to
      Hendrik Knackstedt and Florian Greinus for finding this
      (LP: #759240)
  * softwarecenter/view/catview_gtk.py:
    - fix broken translation string (LP: #758656)
  * refresh .pot file
  * softwarecenter/db/update.py:
    - fix crash when reinstalling previous purchases (LP: #760353)
 -- Michael Vogt <email address hidden> Thu, 14 Apr 2011 19:59:42 +0200

Changed in software-center (Ubuntu Natty):
status: Fix Committed → Fix Released
Gary Lasker (gary-lasker) wrote :

For the convenience of translators, I've attached a screenshot of the dialog that is displayed to allow the user to choose to continue the installation of a deb that has been found to have packaging problems. The new string is for the "Ignore and install" button.

Gary Lasker (gary-lasker) wrote :

Just a note that the translations team has been alerted of the added string:

  https://lists.ubuntu.com/archives/ubuntu-translators/2011-April/004650.html

pablomme (pablomme) wrote :

Shouldn't the icon be the gtk-dialog-warning instead of gtk-dialog-error? The message would need some rewording, too; "isn't allowed" is not true any more.

Gaston Fourcade (g-fourcade) wrote :

It's my first time translating any Ubuntu related text, and I don't know where to put it so here it goes:

Spanish:

El paquete es de mala calidad

No está permitida la instalación de un paquete que viole los estándares de calidad, ya que este podría causar graves problemas en el sistema. Favor de contactar la persona o la organización que provee este paquete e incluir los detalles subsiguientes.

→ Detalles

[Aceptar] [Ignorar e instalar]

French:

Le paquet est de mauvaise qualité

L'installation d'un paquet qui viole les standards de qualité n'est pas autorisée. Cela pourrait entraîner des graves problèmes au système. Veuillez contacter la personne ou l'organization chargée de fournir ce paquet et inclure les détails ci dessous.

→ Détails

[OK] [Ignorer et installer]

Please redirect me to the place to post these translations next time. Happy to contribute.
You can contact me on <email address hidden>

Gaston Fourcade

Following up from #41.

Sorry but the changes to software-center don't cut it for the distribution independent LSB compliant printer driver packages. The real problem is not just that you can't force installation of the package, it is also the fact that these printer drivers are labelled "bad quality" on insufficient grounds.

Don't get me wrong, I'm all for applying quality checks on third party packages before installation. It's a Good Thing. The problem that we have here is that the implementation is questionable. The quality checks that are applied here, a subset of those provided by lintian, check for Debian Policy compliance and a few questionable packaging practices. Debian Policy is distribution specific, for the Debian distribution to be precise, and concerns itself with packages meant for that distribution. It makes little to no provisions for the LSB.

Now aptdaemon goes ahead and tries to impose these distribution specific compliance tests on a package that is a) not part of Debian, b) meant to be distribution independent and c) LSB compliant. Failing any of the Debian specific compliance checks does not warrant a "bad quality" label.

Feel free to pull the distribution independent LSB compliant printer driver packages through LSB compliance tests and label them "bad quality" when any of those fail, but please don't do so for failing a Debian distribution compliance test.

That said, please remove "missing-dependency-on-libc" from data/lintian-checks.

@Gary
ITALIAN:

L'installazione di un pacchetto che viola gli standard di qualità non è permessa.
Questo potrebbe causare seri problemi al tuo computer. Per favore contatta la persona o l'organizzazione che ha fornito questo pacchetto includendo i dettagli qui sotto.

Regards

Michael Vogt (mvo) on 2011-04-15
Changed in aptdaemon (Ubuntu Natty):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr645-0ubuntu1

---------------
aptdaemon (0.41+bzr645-0ubuntu1) natty; urgency=low

  * New bzr bugfix snapshot:
    - fix state of queue transactions (LP: #702442)
    - unify cache open (LP: #694505)
    - relax lintian check on libc (for lsb)
    - catch overflow errors (LP: #758837)
  * debian/lintian-{fatal,nonfatal}.tag.Ubuntu:
    - rename from "tag" to "tags" so that they actually get applied
      (LP: #712377)
 -- Michael Vogt <email address hidden> Fri, 15 Apr 2011 13:57:10 +0200

Changed in aptdaemon (Ubuntu Natty):
status: In Progress → Fix Released

I have checked the new package now and the problem is actually fixed. Thank you very much.

Sjoerd (sjoerd1993) wrote :

I can confirm that this problem is fixed.
It still gives the error, but with the option to 'ignore and install'.

The only thing I don't get is why World of Goo for example never gave any errors in previous Ubuntu releases.
Did the software center become more strict in scanning packages, or is this quality check entirely new?

Re #52, we've also checked a few affected LSB compliant distribution independent printer driver packages and they are no longer labelled "bad quality". Thanks!

Rafal (rafalcom) wrote :

I have somewhat related problem with this error.
I had a 10.10 instal where I used SecureCRT 6.7 and inSSIDer (both Linux 64bit versions). They worked fine. Then I made an upgrade to 11.04 beta 2 and both apps worked fine. But after I made a fresh install of 11.04 beta 2 I could not install both apps from the same archives I used before. Both give me this "Bad Quality" errors and even if using GDebi they install fine both do not start, ever. As I said the archives used are exactly the same which worked before so I am not sure where is the problem.

I running Xubuntu 11.04 64bit and this problem appeared for me first time today.

Lintian check results for /home/faie/Hämtningar/appinventor-setup_1.1_all.deb:
E: appinventor-setup: arch-independent-package-contains-binary-or-object usr/google/appinventor/commands-for-Appinventor/adb
E: appinventor-setup: arch-independent-package-contains-binary-or-object usr/google/appinventor/commands-for-Appinventor/emulator
E: appinventor-setup: arch-independent-package-contains-binary-or-object usr/google/appinventor/commands-for-Appinventor/mksdcard

When trying to install the app inventor from Google Android
http://www.appinventorbeta.com/learn/setup/setuplinux.html

Adam Niedling (krychek) wrote :

I have the same issue with Google Chrome and Ubuntu 12.10 x64:

Lintian check results for /home/krychek/Desktop/google-chrome-stable_current_amd64.deb:
E: google-chrome-stable: file-in-etc-not-marked-as-conffile etc/cron.daily/google-chrome

madbiologist (me-again) wrote :

Adam - Does sudo dpkg -i <packagename>.deb work? If not, is there any different output?

Adam Niedling (krychek) wrote :

madbiologist: It does work but it's merely a workaround, not a fix for this problem. I wonder if I should open a new bug report for this.

Sebastian Heinlein (glatzor) wrote :

Am Montag, den 05.11.2012, 19:48 +0000 schrieb Adam Niedling:
> I have the same issue with Google Chrome and Ubuntu 12.10 x64:
>
> Lintian check results for /home/krychek/Desktop/google-chrome-stable_current_amd64.deb:
> E: google-chrome-stable: file-in-etc-not-marked-as-conffile etc/cron.daily/google-chrome

The warning can be overriden nowadays, I think since Quantal. This is
just a packaging bug done by Google.

Kevin Leeds (knleeds) wrote :

What would be a good place to look to find definitive information on "file-in-etc-not-marked-as-conffile"? (In case I am paranoid and don't trust Google packages much or forum contributions from people not very well known to me, or interested to know where definitive documentation can be found in general for Ubuntu issues?)

Sebastian Heinlein (glatzor) wrote :

Am Samstag, den 15.12.2012, 18:02 +0000 schrieb Kevin Leeds:
> What would be a good place to look to find definitive information on
> "file-in-etc-not-marked-as-conffile"? (In case I am paranoid and don't
> trust Google packages much or forum contributions from people not very
> well known to me, or interested to know where definitive documentation
> can be found in general for Ubuntu issues?)

Take a look at *.desc in /usr/share/lintian

Adam Niedling (krychek) wrote :

I just tried it again in Ubuntu 13.04 and I was able to install Chrome.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers