Ubuntu

apt-get moo doesn't look like a cow

Reported by Pavel Rojtberg on 2006-08-12
316
This bug affects 53 people
Affects Status Importance Assigned to Milestone
APT
Fix Released
Unknown
apt (Debian)
Fix Released
Unknown
apt (Guadalinex Edu)
Undecided
Unassigned
apt (Ubuntu)
Wishlist
Unassigned
Declined for Dapper by Brian Murray
Declined for Feisty by Brian Murray
Declined for Gutsy by Brian Murray
Declined for Hardy by Brian Murray
Declined for Intrepid by Brian Murray
Declined for Jaunty by Colin Watson
Nominated for Karmic by arielg
Nominated for Lucid by David Stansby
Nominated for Maverick by David Stansby
apt (nUbuntu)
Undecided
Unassigned

Bug Description

the animal produced by "apt-get moo" doesnt really look like a cow:
         (__)
         (oo)
   /------\/
  / | ||
 * /\---/\
    ~~ ~~

gentoos cow looks much better:
 ^__^
 (oo)\_______
 (__)\ )\/\
     ||----w |
     || ||

perhaps we could adopt mouth:

         (__)
         (oo)
   /-----(__)
  / | ||
 * /\---/\
    ~~ ~~

I think this does not give up much of Debians identity, while looking much better. :D

the animal produced by "apt-get moo" doesnt really look like a cow:
         (__)
         (oo)
   /------\/
  / | ||
 * /\---/\
    ~~ ~~

gentoos cow looks much better:
 ^__^
 (oo)\_______
 (__)\ )\/\
     ||----w |
     || ||

perhaps we could adopt mouth:

         (__)
         (oo)
   /-----(__)
  / | ||
 * /\---/\
    ~~ ~~

I think this does not give up much of Debians identity, while looking much better. :D

Pavel Rojtberg (rojtberg) wrote :
KarlGoetz (kgoetz) wrote :

Not sure if this should actualy be rejected or not... its true, it could look more cowlike, but is it that important?

btw. funnyst bug ever.
kk

Changed in apt:
status: Unconfirmed → Confirmed
mc44 (mc44) wrote :

apt has Super Cow powers. Super cows do not look like normal cows. kthxbye

               (__)
               (oo)
   /------\/
  / | ||
 * /\---/\
       ~~ ~~
...."Have you mooed today?"...

From "apt-get moo" in Simply Mepis 6.0 Final

Changed in apt:
status: Unknown → Unconfirmed

++ for the proposed one :)

FWIW, Gentoo's cow seems to be the same as the cowsay default. There doesn't seem to be any reason to downgrade APT to such mainstream cow technology.

right. so lets concentrate on the following:

alternative #1:

         (__)
         (oo)
   /-----(__)
  / | ||
 * /\---/\
    ~~ ~~
...."Have you mooed today?"...

alternative #2:
                     \_/
   m00h (__) -(_)-
      \ ~Oo~___ / \
         (..) |\
   ________|_|_|__________
..."Have you mooed today?"...

#1 is the updated APT default
#2 was taken from the debian bug tracker and originates from http://apt-get.mine.nu/

Changed in apt:
importance: Untriaged → Wishlist
Christian Reis (kiko) wrote :

Adding a Launchpad task to ensure this cow really looks like a cow in comments -- because it currently doesn't!

Changed in launchpad:
assignee: nobody → mpt
status: Unconfirmed → Confirmed
James Henstridge (jamesh) wrote :

We currently don't preserve whitespace after the beginning of the line, which is the cause of the problem here.

We probably should be replacing runs of whitespace (both leading whitespace and embedded whitespace) with the pattern "     ...   " such that the run ends with a normal whitespace (so that if the line gets wrapped, we don't have a space at the beginning of the next line).

Vit Hrachovy (flaska) wrote :

This depends on your picture interpretation:

I consider (oo) nostrils, so it's perfectly fine cow pointing its nose at me.

You consider (oo) eyes.

I still prefer the original image and consider it more cow-ardly :-)

Fernando Ribeiro (fa-ribeiro) wrote :

well, why not this one?

           (__)
 _______~(..)~
   ,----\(oo)
  /|____|,'
 * /"\ /\
   ~ ~ ~ ~

Changed in launchpad:
status: Confirmed → Rejected

^^that last one was good^^

This wouldn't be called a "bug" but is still an interesting thing to bring up as it is an easter egg.

Toma (tomhaste) wrote :

Is this bug fixed in Gutsy?

Fernando Ribeiro (fa-ribeiro) wrote :

hi all
In my original post (https://bugs.launchpad.net/ubuntu/+source/apt/+bug/56125/comments/11) the fist line was not aligned...
I hope this is ok:

         (__)
 _______~(..)~
   ,----\(oo)
  /|____|,'
 * /"\ /\
   ~ ~ ~ ~

thanks once again,
Fernando Ribeiro

tags 271810 +patch
thankyou

Please find attached a patch to make this the cow:
         (__)
         (oo)
   /-----(__)
  / | ||
 * /\---/\
    ~~ ~~

Thanks.

Kumar
--
Kumar Appaiah,
458, Jamuna Hostel,
Indian Institute of Technology Madras,
Chennai - 600 036

I hate to be the bearer of bad news on this issue, but cows don't have horns.

Bulls do.

LaserJock (laserjock) wrote :

ZenGuy,
  I hate to be the bearer of even more bad news, but many cows actually do have horns and some bulls don't. It's not a gender-specific feature, but rather breed-specific. ;-)

In theory, cows can not speak either. Which is probably why they're so tasty.
Nom Nom Nom.

KarlGoetz (kgoetz) wrote :

On Fri, 2008-03-07 at 16:35 +0000, Toma wrote:
> In theory, cows can not speak either. Which is probably why they're so tasty.
> Nom Nom Nom.
>

this exchange of messages ( last 3 ) had me crying with laughter.
who says bugs have to be boring? :)

Its a Deer..

I'd say it's a goat. We should fill a bug for the command used. It should have been apt-get méééh or apt-get baah.
Yes, please change ascii image to the originally proposed one :)

Robb Munson (r.munson) wrote :

i say bug closed due to going way off topic, by the way sudo apt-get moo is a fully functional cow, including yep, horns and all :D

David D Short (chameleondave) wrote :

I think we should just put our tail on Gentoo's cow.

# Automatically generated email from bts, devscripts version 2.9.26
severity 271810 wishlist

Perhaps we could add some grass for the cow to graze on.

              (__)
 _______~(..)~
   ,--------- (oo)
  /|____|,'
 * /"\ /\
   ~ ~ ~ wwww

Let's see... the change is necessary because the animal needs be renewed in order that it see better ;)

The alternative by Fernando Ribeiro is really nice.

lionel47 (lionel-laratte) wrote :

I thought it was an Ibex....

         (__)
         (oo)
   /------ \/
  / | ||
 * /\---/\
    ~~ ~~

Looks like an Intrepid Ibex to me.

Fred (eldmannen+launchpad) wrote :

Yes, cow don't look like cow.
It has pointy mouth. :(

CooLMaN (gbinder-gmail) wrote :

Very bad, I am truly disappointed with the quality of this feature.
Please fix ASAP!

Sidarth Dasari (sirsid) wrote :

Ribeiro's cow looks pretty good. I say we use it

Wagner Volanin (volanin) wrote :

This is a patch to replace the default apt-super-cow with the much improved
Fernando Ribeiro's apt-super-cow!

The only difference is that I removed the ground from Fernando's original,
since the ASCII design gets cleaner, and it also seems that the cow is flying,
like the gentoo's version! It's very easy to undo this modification if desired!

         (__)
 _______~(..)~
   ,----\(oo)
  /|____|,'
 * /"\ /\

...."Have you mooed today?"...

The patch must the applied against the latest version of apt, located at:
http://code.launchpad.net/~ubuntu-core-dev/apt/ubuntu

Wagner Volanin (volanin) wrote :

Man, I tried the to use the " " but it messed everything up.
"apt-get moo" output will be this:

         (__)
 _______~(..)~
   ,----\(oo)
  /|____|,'
 * /"\ /\

...."Have you mooed today?"...

Tareeq (spock-rock) wrote :

. . . . . . . . . . . . . . . . . . . . . . . . . . . .IT'S A TRAP!. . .
. . . . . . . . . . . . . . . . _,,,--~~~~~~~~--,_ . . . . . . . . .
. . . . . . . . . . . . . . ,-‘ : : : :::: :::: :: : : : : :º ‘-, . . . . . . . . . . . .
. . . . . . . . . . . . .,-‘ :: : : :::: :::: :::: :::: : : :o : ‘-, . . . . . . . . . .
. . . . . . . . . . . ,-‘ :: ::: :: : : :: :::: :::: :: : : : : :O ‘-, . . . . . . . . .
. . . . . . . . . .,-‘ : :: :: :: :: :: : : : : : , : : :º :::: :::: ::’; . . . . . . . .
. . . . . . . . .,-‘ / / : :: :: :: :: : : :::: :::-, ;; ;; ;; ;; ;; ;; ;\ . . . . . . . .
. . . . . . . . /,-‘,’ :: : : : : : : : : :: :: :: : ‘-, ;; ;; ;; ;; ;; ;;| . . . . . . .
. . . . . . . /,’,-‘ :: :: :: :: :: :: :: : ::_,-~~,_’-, ;; ;; ;; ;; | . . . . . . .
. . . . . _/ :,’ :/ :: :: :: : : :: :: _,-‘/ : ,-‘;’-‘’’’’~-, ;; ;; ;;,’ . . . . . . . .
. . . ,-‘ / : : : : : : ,-‘’’ : : :,--‘’ :|| /,-‘-‘--‘’’__,’’’ \ ;; ;,-‘ . . . . . . . .
. . . \ :/,, : : : _,-‘ --,,_ : : \ :\ ||/ /,-‘-‘x### ::\ \ ;;/ . . . . . . . . . . .
. . . . \/ /---‘’’’ : \ #\ : :\ : : \ :\ \| | : (O##º : :/ /-‘’ . . . . . . . . . . .
. . . . /,’____ : :\ ‘-#\ : \, : :\ :\ \ \ : ‘-,___,-‘,-`-,, . . . . . . . . . . .
. . . . ‘ ) : : : :’’’’--,,--,,,,,,¯ \ \ :: ::--,,_’’-,,’’’¯ :’- :’-, . . . . . . . . .
. . . . .) : : : : : : ,, : ‘’’’~~~~’ \ :: :: :: :’’’’’¯ :: ,-‘ :,/\ . . . . . . . . .
. . . . .\,/ /|\\| | :/ / : : : : : : : ,’-, :: :: :: :: ::,--‘’ :,-‘ \ \ . . . . . . . .
. . . . .\\’|\\ \|/ ‘/ / :: :_--,, : , | )’; :: :: :: :,-‘’ : ,-‘ : : :\ \, . . . . . . .
. . . ./¯ :| \ |\ : |/\ :: ::----, :\/ :|/ :: :: ,-‘’ : :,-‘ : : : : : : ‘’-,,_ . . . .
. . ..| : : :/ ‘’-(, :: :: :: ‘’’’’~,,,,,’’ :: ,-‘’ : :,-‘ : : : : : : : : :,-‘’’\\ . . . .
. ,-‘ : : : | : : ‘’) : : :¯’’’’~-,: : ,--‘’’ : :,-‘’ : : : : : : : : : ,-‘ :¯’’’’’-,_ .
./ : : : : :’-, :: | :: :: :: _,,-‘’’’¯ : ,--‘’ : : : : : : : : : : : / : : : : : : :’’-,
/ : : : : : -, :¯’’’’’’’’’’’¯ : : _,,-~’’ : : : : : : : : : : : : : :| : : : : : : : : :
: : : : : : : :¯’’~~~~~~’’’ : : : : : : : : : : : : : : : : : : | : : : : : : : : :

I know its not a cow but any chance we can get admiral ackbar instead??

............................................________........................
....................................,.-...................``~.,..................
.............................,.-...................................-.,............
.........................,/...............................................:,........
.....................,?......................................................\,.....
.................../...........................................................,}....
................./......................................................,:`^`..}....
.............../...................................................,:........./.....
..............?.....__.........................................:`.........../.....
............./__.(.....~-,_..............................,:`........../........
.........../(_....~,_........~,_....................,:`........_/...........
..........{.._$;_......=,_.......-,_.......,.-~-,},.~;/....}...........
...........((.....*~_.......=-._......;,,./`..../............../............
...,,,___.\`~,......~.,....................`.....}............../.............
............(....`=-,,.......`........................(......;_,,-...............
............/.`~,......`-...............................\....../\...................
.............\`~.*-,.....................................|,./.....\,__...........
,,_..........}.>-._\...................................|..............`=~-,....
.....`=~-,_\_......`\,.................................\........................
...................`=~-,,.\,...............................\.......................
................................`:,,...........................`\..............__..
.....................................`=-,...................,%`>--==``.......
........................................_\..........._,-%.......`\...............
...................................,<`.._|_,-&``................`\..............

If this feature is not fixed I am switching back to windows. This is a very crucial feature, and without it I can not get anything done.

Vadim Peretokin (vperetokin) wrote :

It's a killer here. My clients are re-considering their redeployment of Ubuntu 8.04 LTS because of the cow!

Changed in apt:
status: New → Unknown
dbergen (dbergen) wrote :

apt-get itsatrap! not working for you?

W3ird_N3rd (w3ird-n3rd) wrote :

I've found a workaround: use aptitude instead. Even though aptitude moo just isn't the same, it will work for package management.

dirken (dirkvranckaert) wrote :

Since when is an easter egg a bug??
Seriously, does superman looks like a normal human being, no cause he's wearing that costum. So should the super cow look like an ordanary cow? Offcourse not!
It's true that gentoo's cow is more a usual cow but come on, we have are special cow and let it this way, don't open a bug for this!

Ertai88 (ertai88) wrote :

It needs udders.

To be honest, when this got on the reddit front page, the comments
were less stupid.
Now that its been recycled to digg, its full of stupid comments.

Also, try to address the bug, rather than suggesting other things
(Tareeq), you could always for fork cowsay and make an Admiral Ackbar
program. If so, make a new wishlist and see if anyone picks it up. :)

KarlGoetz (kgoetz) wrote :

On Wed, 2008-07-16 at 20:23 +0000, shingalated wrote:
> If this feature is not fixed I am switching back to windows. This is a
> very crucial feature, and without it I can not get anything done.

hehehe.
kk

KarlGoetz (kgoetz) wrote :

On Thu, 2008-07-17 at 00:46 +0000, Toma wrote:
> To be honest, when this got on the reddit front page, the comments
> were less stupid.
> Now that its been recycled to digg, its full of stupid comments.
>

That explains it (I wondered about the sudden new intrest).
kk

How on earth can I trust a group of people that can't make an ASCII cow properly to make an entire OS?!? I'm going back to Windows.

mog (launchpad-net-mog) wrote :

How can i trust a package manager that doesn't produce realistic cows? I'm switching back to slackware's gzipped tarballs.

pschastain (pschas69) wrote :

It doesn't look like a cow because it isn't a cow; it's a McDonalds Elk. Common mistake.

Changed in apt:
status: Unknown → New
Breakable (igalvelis) wrote :

Reproduced in Hardy!

Blake Smith (smith-blake) wrote :

Can someone issue a fix for this?

Unfortunately this is why Linux will never take off, I can see this supermegabug appear on that pesky Linux Haters Blog.. we need a proper cow

I think the current "cow" looks a lot like a goat.

Paul C. Bryan (pbryan) wrote :

Please, don't have a cow. The issue of how it looks is moot. This continued debate is udderly ridiculous. We should instead be focusing on how to beef up security.

Did you mean an armoured cow?

(and this isn't wasting too much time, don't worry)

Toma (tomhaste) wrote :

Paul, stop milking the joke! :)

2008/7/31 Paul C. Bryan <email address hidden>:
> Please, don't have a cow. The issue of how it looks is moot. This
> continued debate is udderly ridiculous. We should instead be focusing on
> how to beef up security.
>
> --
> apt-get moo doesnt look like a cow
> https://bugs.launchpad.net/bugs/56125
> You received this bug notification because you are a direct subscriber
> of the bug.
>

(warning: the following humour might be offensive)

cowsay -f head-in.cow "In progress."

Changed in apt:
status: Confirmed → In Progress
Changed in apt:
status: In Progress → Confirmed

This is a definite blocker, it affects one's ability to moo, I recommend setting severity to Critical as this is one of apt's few defining features.

Please keep in mind that this bug made one of my friends switch back to windows. Fix it ASAP or you will lose Ubuntu users.
Thank moo...
.
..
...
I mean you...

danifv (danifv-gmail) wrote :

Still not fixed? OMG!

ben (brouits) wrote :

workaround: thanks to dpkg-divert, one can display his own moo!

$ sudo su -
[passwd]
# dpkg-divert --divert /usr/bin/apt-get.real --rename /usr/bin/apt-get
# cat > /usr/bin/apt-get
#!/bin/sh
#
if [ "$1" = "moo" ]
then
 /usr/bin/apt-get.real moo | sed -e 's/-\\\//(__)/'
else
 /usr/bin/apt-get.real $@
fi
^d
# chmod +x /usr/bin/apt-get
# exit

spitfire (mieszkoslusarczyk) wrote :

How long do we have to wait, to get this crucial bugfix?

Ben (ben2talk) wrote :

Continually declined throughout the distros - maybe the cow will become a dinosaur.

Can't we put a herd of cows in taxis? We need more drivers don't we?

apt-get moo
moo drive printer
moo drive webcam

Do you understand?

To err is human, to moo bovine

Nuhaa All Bakry (cawanpink) wrote :

it looks like a goat to me than a cow
maybe it should just be apt-get mbek instead ...

Jan Nekvasil (jan-nekvasil) wrote :

I can confirm this bug in apt 0.7.20.2ubuntu6 on Jaunty. As a fix I suggest this nifty cow, which I made specially for apt - it's completely original and nobody else uses it for any purpose. And it looks like a cow a lot, which counts.
          _ _
         ((__))
     ____"\''/"
   / (oo)
  /|_______/
    ||W ||
    `` ``

I think that with this new Ayatana project thing and surpassing Apple approach it's important to pay attention even to such a small details as a apt's eastern egg. Whats more, this allows us to finally close this bug and get some attention from media for Ubuntu (I'm looking at You, Digg). Let the world know that we care.

Jan Nekvasil (jan-nekvasil) wrote :

Whoops, Lunchpad messed up my ASCII art, despite all efforts. Please check the cow.png for refference.

arielg (goldblattster) wrote :

confirm.

David Kalnischkies (donkult) wrote :

Okay, i think we never get in compliance which cow is the best super cow, so i propose the following:
APT provides two standard cows: the "old" cow and the cow from Fernando Ribeiro accessible with "apt-get moo" and "apt-get moo moo".
This should be suitable for most users.

For the more advanced users: Possibility to dynamical add (or replace the defaults with) other cows with config settings.
Configuration items are "APT::Get::SuperCow::MOOCOUNTER::LINENUMBER"

Example: the default cow as a config entry which would be displayed by "apt-get moo moo moo":
APT::Get::SuperCow::3 {
1 " (__)";
2 " (oo)";
3 " /------\/";
4 " / | ||";
5 " * /\---/\";
6 " ~~ ~~";
7 "...Have you mooed today?...";
};
(most likely borged by launchpad - but you get the idea)

Note: Quotes can't be used in this cow-construction-code, but you can use escape characters... (colored cows anybody?)

See attached patch for implementation details.
(also available in my experimental branch)
1 file changed, 51 insertions(+), 10 deletions(-)

starscalling (starscalling) wrote :

i like the cow just how it is, however i would not be apposed to more/multiple cows the more o's there are on moo; similar to the `Super Cow Power`ed aptitude

Alexandros (alexandros-t) wrote :

I suggest that bug #1 should be marked as dependent on this bug.

Alexandros (alexandros-t) wrote :

Can someone check if this is reproducible with apt-build moo? If so, we will have to add the apt-build package as being affected by this bug and update the bug description.

ferrouswheel (joel-pitt) wrote :

What about vegetarians? I think it is very meat-centrist to only have a super cow confined within the barriers of a ~120k executable. Super cows should be able to roam the filesystem freely!

I think we should replace it with the meat-free "apt-get carrot".

ferrouswheel wrote:
> What about vegetarians? I think it is very meat-centrist to only have a
> super cow confined within the barriers of a ~120k executable. Super cows
> should be able to roam the filesystem freely!
>
> I think we should replace it with the meat-free "apt-get carrot".

The cow is vegetarian, so vegetarians should be super-happy to have a mate in apt.

Andreas Braml (a-strich-b) wrote :

OK folks, I'm really getting tired of this. We're at 910 - read my lips: ninehundredandten - shortly, and still no fix?

And will someone please mark bug #1 as dependent on this one, as Alexandros suggested?

Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu 9.10 install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

-This is not a usability bug. Hence not a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
affects: hundredpapercuts → null
xaliqen (xaliqen) wrote :

I suggest a big and dramatic fix for the bug is appropriate and in line with the goals of Ubuntu.

An appropriately cow-like image provides a sense of usability and a friendly 'can-do' attitude that encourages the user and generously manifests a sense of well-being. On the other hand, previous suggestions involving Ackbar and other non-sequitur enhancements gives everyone a strong pat on the back when they feel like nothing they do makes any sense anymore.

As a compromise, perhaps a bovine species involving a fantastical graft of Ackbar's head onto the body of the animal may be the most 'apt' solution. After all, a super cow must distinguish itself aesthetically and otherwise.

David Stansby (dstansby) wrote :

I would just like to thank the above comments for entertaining me for the afternoon. That is all.

* Thosten <Thorsten@111.com> [2004-09-15 14:27:57 CEST]:
> If i type "apt-get moo" the cow in apt-get dont look nice. I found a
> better looking cow at: http://apt-get.mine.nu/

 Unfortunately, that site isn't reachable at the moment, so I can't
check there.

> It would be nice if you would fix this bad looking cow to this nicer
> one ;)

 Who's the author of that cow, and what license does it bear? Ascii art
is serious business too and shouldn't be reused or modified without
permissions neither.

 Thanks in advance for further informations,
Rhonda

Changed in apt (Guadalinex Edu):
status: New → Won't Fix
Fred (eldmannen+launchpad) wrote :

Still an issue in Ubuntu 10.04 LTS.
It does not look like a cow!

Changed in launchpad-foundations:
assignee: Matthew Paul Thomas (mpt) → nobody
dE (de-techno) wrote :

Maybe they tired to make a wildebeest

dE (de-techno) wrote :

 _______________________
< Have you mooed today? >
 -----------------------
        \ ^__^
         \ (oo)\_______
            (__)\ )\/\
                ||----w |
                || ||

Update -- Gentoo's moo now looks like this.

David Stansby (dstansby) on 2010-07-31
tags: added: patch-forwarded-debian
Juan Pablo (juanps90) wrote :

Where can I download the source code for apt-get?

I've found the code for aptitude and making changes to the apt-get moo is pretty straightforward.

Juan Pablo (juanps90) on 2010-08-15
Changed in apt (Ubuntu):
status: Confirmed → Fix Committed
Philip Muškovac (yofel) wrote :

Where was the fix committed? Please don't change the status without telling why.

Changed in apt (Ubuntu):
status: Fix Committed → Confirmed
linuxrules (linuxrules) wrote :

hey this bug fix went though I think, I tried it on a new Ubuntu and the cow was different

lol, this is a bug? was it marked critical?

linuxrules (linuxrules) wrote :

oh it was, ha ha haa

linuxrules (linuxrules) wrote :

it was fixed that’s funny

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: launchpad
no longer affects: null
IKT (ikt) wrote :

Still not fixed in 12.04.2.

Debian asked this question:

"Who's the author of that cow, and what license does it bear? Ascii art is serious business too and shouldn't be reused or modified without permissions neither."

Nobody replied.

         (__)
         (oo)
   /-----(__)
  / | ||
 * /\---/\
    ~~ ~~

José Antonio Rey (jose) wrote :

Can confirm that the bug is back on 13.04 with the first cow being on apt.

Changed in apt:
status: New → Fix Released
Changed in apt (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.