Devel package not installable in 14.04.2

Bug #1424466 reported by Doug McMahon on 2015-02-22
218
This bug affects 56 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
mesa (Ubuntu)
Undecided
Unassigned
Trusty
High
Timo Aaltonen

Bug Description

[Impact]
 * Some -dev packages like ubuntu-sdk and libglew-dev cannot be installed when the lts-utopic stack is used.

[Test Case]
 * Install the lts-utopic stack.
 * apt-get install ubuntu-sdk
 * Good: you get a whole list of packages to install.
 * Bad: apt-get install fails like pasted in the original bug report.
 * Also test the same without the lts-utopic stack, to make sure there are no regressions.

[Regression Potential]
 * Low, this has been done for precise before, and mesa packaging has to be updated for every LTS release. Unfortunately there are no alternatives. :(

[Other Info]
 * There's probably an apt bug in here too. Nudging the resolver by specifying libgl1-mesa-dev-lts-utopic and libgles2-mesa-dev-lts-utopic works, but I didn't find a good way to express this in the depends, and that would have to be done for every package.

[Original bug report]
Not the first, likely not the last devel to not be installable in 14.04.2 or any mesa-lts-utopic install
Another one is libglew-dev

 sudo apt-get install freeglut3-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcheese-gtk23 : Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed
                   Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libcheese7 : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed
              Depends: gstreamer1.0-clutter but it is not going to be installed
 libclutter-1.0-0 : Depends: libcogl-pango15 (>= 1.15.8) but it is not going to be installed
                    Depends: libcogl15 (>= 1.15.8) but it is not going to be installed

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: freeglut3-dev (not installed)
ProcVersionSignature: Ubuntu 3.16.0-31.41~14.04.1-generic 3.16.7-ckt5
Uname: Linux 3.16.0-31-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Feb 22 18:03:30 2015
InstallationDate: Installed on 2015-02-08 (14 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150203.2)
SourcePackage: freeglut
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
summary: - Not installable in 14.04.2 (mesa-lts-utopic
+ Devel package not installable in 14.04.2 (mesa-lts-utopic

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in freeglut (Ubuntu):
status: New → Confirmed
Charl P. Botha (cpbotha) wrote :

Under 14.04.2, it is completely impossible to install the OpenGL Utility Library (GLU) development files. This is a showstopper if you do OpenGL development make use of GLU, something that is very often the case.

In 14.04.1 this worked without a hitch, one could install libglu1-mesa-dev providing libglu-dev. In 14.04.2 there is no equivalent package.

Doug McMahon (mc3man) wrote :

I would suggest that anyone wishing a full function 14.04 use the 14.04.1 image then update. That will give you 14.04.2 minus the neutered & unique named mesa build.

The lts-utopic kernel can be installed separately if wishing.
(- log outs can be slow with Intel gpu but fixable with above kernel & normal 14.04 mesa. Also keep in mind the lts-utopic kernel has intel_pstate enabled & the wrong ondemand script for pstate, another bug that should have been addressed...

Newer mesa for 14.04 can be had from xorgers ppa if desired, that has the advantage using ppa-purge if wanting to revert.
(there is no real easy way to go back from 14.04.2 image/lts-utopic-mesa

Doug McMahon (mc3man) on 2015-03-07
description: updated
description: updated

Hello Doug, or anyone else affected,

Accepted mesa into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/10.1.3-0ubuntu0.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
affects: freeglut (Ubuntu) → mesa (Ubuntu)

Tested with -proposed enabled a number of apt-get sims, all looked good.
freeglut3-dev
libglew-dev
libsdl1.2-dev
libsdl2-dev

So will mark verification-done & dupe related bugs that will be fixed.

There still are a few cases open, one is obscure enough not to warrant a look? (osmesa is not built in the hwe mesa), others may need to be adjusted in the sources (like fglrx-updates, ect.

tags: added: verification-done
removed: verification-needed
Tholl1989 (mariajcore) wrote :

[Verified test case]
#ubuntu-14.04.1-desktop-amd64 live system (proposed enabled)
*apt-get update && apt-get -y upgrade
*apt-get -s install ubuntu-sdk
Works fine, see attachment

#ubuntu-14.04.2-desktop-amd64 live system (proposed enabled)
*apt-get update && apt-get -y upgrade
*apt-get -s install ubuntu-sdk
Works fine, see attachment

[Comment]
From the changelog:
"Allow unrenamed -dev packages to work with the renamed stack."
Works around APT not being able to resolve dependencies with the utopic stack, but are Mesa 10.1.3 dev packages a good idea for Mesa 10.3.2?

Ara Pulido (ara) on 2015-03-12
Changed in mesa (Ubuntu Trusty):
status: New → Fix Committed
Yung Shen (kaxing) wrote :

Further verification with fglrx installation,

As mention in lp #1428972,

Verification Steps:
1. Fresh install 14.04.2
2. Enable -proposed
3. apt-get dist-upgrade
4. apt-get install fglrx

Result:
apt tells unmet dependencies
Workaround still works after system upgraded, mentioned here: https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1424491/comments/43

Alberto Milone (albertomilone) wrote :

yes, the problem with fglrx is well known and I'm working on it.

ADR (adr-007) wrote :

1) Run Ubuntu 14.04.2 LiveUSB
2) Try to install QtCreator
Result:
apt tells unmet dependencies

fcole90 (fcole90) wrote :

I had the same bug, I confirm that enabling the proposed repositories made things work correctly and allowed ubuntu-sdk to be installed. Nice work guys ;)

Changed in mesa (Ubuntu):
status: Confirmed → Invalid
Changed in mesa (Ubuntu Trusty):
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 10.1.3-0ubuntu0.4

---------------
mesa (10.1.3-0ubuntu0.4) trusty; urgency=medium

  * Allow unrenamed -dev packages to work with the renamed stack. (LP: #1424466)
 -- Maarten Lankhorst <email address hidden> Tue, 10 Mar 2015 12:04:39 +0100

Changed in mesa (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Unfortunately the same issue affects the following package :
libsdl2-2.0-0:i386

Third party 32bit games that do not bundle SDL 2 are affected, and cannot be installed on an Ubuntu 14.04.2 (clean install from media).

Tuomas Lähteenmäki (lahtis) wrote :

all x86 dev packages are broken.

Timo Aaltonen (tjaalton) on 2015-09-02
Changed in mesa (Ubuntu Trusty):
assignee: Maarten Lankhorst (mlankhorst) → nobody
Timo Aaltonen (tjaalton) wrote :

so it's actually a bug in the apt resolver, there's no point modifying every package depending on libgl1-mesa-dev to add lts-packages as valid candidates to fulfil the dep.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu Trusty):
status: New → Confirmed
Changed in apt (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

reopening so that we can add support for lts-wily and lts-xenial too..

Changed in mesa (Ubuntu Trusty):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Fix Released → Triaged
Timo Aaltonen (tjaalton) on 2016-01-12
summary: - Devel package not installable in 14.04.2 (mesa-lts-utopic
+ Devel package not installable in 14.04.2

Hello Doug, or anyone else affected,

Accepted mesa into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/10.1.3-0ubuntu0.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Timo Aaltonen (tjaalton) on 2016-01-19
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 10.1.3-0ubuntu0.6

---------------
mesa (10.1.3-0ubuntu0.6) trusty; urgency=medium

  * control: Allow unrenamed -dev packages to work with lts-wily and lts-
    xenial (LP: #1424466).

 -- Timo Aaltonen <email address hidden> Tue, 12 Jan 2016 16:02:56 +0200

Changed in mesa (Ubuntu Trusty):
status: Fix Committed → Fix Released
Ludovic Angot (ludoangot) wrote :

The janitor said that the bug is fixed in the here above named package but how to install this package / patch? I'd rather not do any new upgrade (I am on LTS 14.04 upgraded from 13.10 and wish to remain there).

@ ludoangot:

If you have questions pls go there:
https://answers.launchpad.net/ubuntu/+source/mesa

This bug was fixed & closed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers