package libapt-pkg4.12 0.8.16~exp12ubuntu10.3 failed to install/upgrade: './usr/share/locale/sk/LC_MESSAGES/libapt-pkg4.12.mo' is different from the same file on the system

Bug #1039685 reported by yacoov on 2012-08-21
118
This bug affects 18 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned

Bug Description

can not upgrade system

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libapt-pkg4.12 0.8.16~exp12ubuntu10.3
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
NonfreeKernelModules: ndas_core fglrx
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Tue Aug 21 20:45:30 2012
ErrorMessage: './usr/share/locale/sk/LC_MESSAGES/libapt-pkg4.12.mo' is different from the same file on the system
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: apt
Title: package libapt-pkg4.12 0.8.16~exp12ubuntu10.3 failed to install/upgrade: './usr/share/locale/sk/LC_MESSAGES/libapt-pkg4.12.mo' is different from the same file on the system
UpgradeStatus: No upgrade log present (probably fresh install)

yacoov (d4vid) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed

Workaround to untangle the mess and get updates working again can be found here:
http://ubuntuforums.org/showthread.php?t=2045321&page=2

Following all the steps in
http://ubuntuforums.org/showthread.php?t=2045321&page=2
didn't help for me.
Please help

Dominique Lasserre (lasall) wrote :

It is not possible to install both amd64 and i386 packages in parallel (without modifications) because translations files are *really* different. You can use dpkg diversions to workaround this problem. See thread in German Ubuntu forum: http://forum.ubuntuusers.de/topic/aktualisierungsproblem-wine-1-5/3/#post-4851602 (use Google Translate if you don't understand German)

@APT maintainers: Please rebuild packages from same source.

The discussion in the link I gave is not very clear, probably because the guys were working it out as they went. Nevertheless, judicious use of the various tools they talk about there did (eventually) solve it for me. The key in my case was to delete and re-install the i386 package.

Daniel Hartwig (wigs) wrote :

This is [1] affecting multiple packages and fixed in gettext 0.18.1.1-8. The fix should be SRU to Precise and all affected packages will need to be rebuilt.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=671257

Changed in gettext (Ubuntu):
status: New → Fix Released
Daniel Hartwig (wigs) wrote :

See also bug #924628 which has similar symptoms but is already addressed.

Daniel Hartwig (wigs) on 2012-10-02
summary: - package libapt-pkg4.12 0.8.16~exp12ubuntu10.3 failed to install/upgrade:
- './usr/share/locale/sk/LC_MESSAGES/libapt-pkg4.12.mo' is different from
- the same file on the system
+ gettext: msgfmt output format prevents multiarch migration [affecting
+ apt in precise; fixed in sid, quantal]
tags: added: patch

The attachment "06-msgfmt-default-little-endian" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Daniel Hartwig (wigs) wrote :

Scratch that. Since the archs involved are i386 and amd64 this is probably just bug #924628 again.

no longer affects: gettext (Ubuntu)
no longer affects: gettext
summary: - gettext: msgfmt output format prevents multiarch migration [affecting
- apt in precise; fixed in sid, quantal]
+ package libapt-pkg4.12 0.8.16~exp12ubuntu10.3 failed to install/upgrade:
+ './usr/share/locale/sk/LC_MESSAGES/libapt-pkg4.12.mo' is different from
+ the same file on the system
no longer affects: apt
tags: removed: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.