apport-gtk crashed with TypeError in function(): markup_escape_text() takes at most 1 argument (2 given)

Bug #829635 reported by Matthew Paul Thomas
This bug affects 260 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Critical
Martin Pitt

Bug Description

Seems to be the same as bug 828010, but I've installed all updates and restarted since that bug was marked Fix Released.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: apport-gtk 1.21.3-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
NonfreeKernelModules: wl
ApportLog:
 ERROR: apport (pid 14238) Fri Aug 19 17:47:19 2011: called for pid 1529, signal 11
 ERROR: apport (pid 14238) Fri Aug 19 17:47:19 2011: executable: /usr/bin/compiz (command line "compiz")
 ERROR: apport (pid 14238) Fri Aug 19 17:47:35 2011: wrote report /var/crash/_usr_bin_compiz.1000.crash
Architecture: amd64
Date: Wed Aug 17 14:34:56 2011
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64+mac (20110705.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with TypeError in function(): markup_escape_text() takes exactly 2 argument(s) (1 given)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
Matthew Paul Thomas (mpt) wrote :
tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
status: New → Confirmed
Steve Beattie (sbeattie)
visibility: private → public
Revision history for this message
Martin Pitt (pitti) wrote :

This particular problem was fixed with a newer apport release. However, now we have the opposite problem, as the API of markup_escape_text() was actually fixed in pygobject:

 Traceback (most recent call last):
   File "/usr/share/apport/apport-gtk", line 368, in <module>
     app.run_argv()
   File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 599, in run_argv
     return self.run_crashes()
   File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 177, in run_crashes
     self.run_crash(f)
   File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 246, in run_crash
     response = self.ui_present_crash(desktop_entry)
   File "/usr/share/apport/apport-gtk", line 75, in ui_present_crash
     n = GLib.markup_escape_text(n, -1).decode('UTF-8')
 TypeError: glib.markup_escape_text() takes at most 1 argument (2 given)

Changed in apport (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → In Progress
summary: apport-gtk crashed with TypeError in function(): markup_escape_text()
- takes exactly 2 argument(s) (1 given)
+ takes at most 1 argument (2 given)
Changed in apport (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.22.1-0ubuntu1

---------------
apport (1.22.1-0ubuntu1) oneiric; urgency=low

  [ Martin Pitt ]
  * New upstream release:
    - dupdb-admin: Add "removeid" command.
    - dupdb-admin: Use the in-memory CrashDB implementation for simple
      operations like dump or changeid, which do not require an actual
      backend. This makes the command work in checkouts without a
      /etc/apport/crashdb.conf.
    - dupdb-admin: Fix UnicodeEncodeError crash.
    - launchpad.py: Fix crash if a crash report does not have a DistroRelease.
    - Set the default "Apport" title for choice dialogs instead of the default
      apport-gtk title. Thanks Robert Roth. (LP: #608222)
    - apport-gtk: Update markup_escape_text() call to current glib.
      (LP: #829635)
  * data/package-hooks/source_ubiquity.py: Only set a DuplicateSignature and
    change the source package if we are reporting a package or program crash,
    not for ProblemType == 'Bug'.

  [ Brian Murray ]
  * data/general-hooks/ubuntu.py: check the device holding /, /var and /usr
    partitions for I/O errors and if they exist make the bug unreportable
  * data/package-hooks/source_ubiquity.py: Use attachment OemConfigLog to determine
    whether or not to tag the bug oem-config not information in syslog
 -- Martin Pitt <email address hidden> Tue, 06 Sep 2011 08:16:46 +0200

Changed in apport (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Mad Maks (mad.maks) wrote :

My bug #843694 is marked af duplicate of this bug. but i have apport - 1.22.1-0ubuntu1 installed

Revision history for this message
Jeff Licquia (jeff-licquia) wrote :

My bug (845893) was filed against apport 1.22.1-0ubuntu2.

Revision history for this message
Mirco Müller (macslow) wrote :

I still get this with apport-gtk 1.23-0ubuntu1, therefore I reopened it.

Changed in apport (Ubuntu):
status: Fix Released → New
Revision history for this message
Martin Pitt (pitti) wrote : Re: [Bug 829635] Re: apport-gtk crashed with TypeError in function(): markup_escape_text() takes at most 1 argument (2 given)

 status fixreleased

Mirco Müller [2011-09-15 2:59 -0000]:
> I still get this with apport-gtk 1.23-0ubuntu1, therefore I reopened it.
>
> ** Changed in: apport (Ubuntu)
> Status: Fix Released => New

Closing again. This bug has already too many duplicates and times out
in LP, and it is definitively fixed in Apport. Most likely cause is
that you have held back packages, you need gir1.2-glib-2.0
1.29.17-0ubuntu1.

Changed in apport (Ubuntu):
status: New → Fix Released
Revision history for this message
Mirco Müller (macslow) wrote :

*sigh* yeah... I've only gir1.2-glib-2.0 1.29.16-0ubuntu1 here

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers