Ubuntu

Integrate apport-retrace into GUI

Reported by Brian J. Murrell on 2006-12-15
78
This bug affects 7 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Wishlist
Martin Pitt
Precise
Wishlist
Martin Pitt

Bug Description

If apport-retrace is installed, the GUI should offer to retrace it locally. This requires the downloading of a lot of dbgsym packages, but some developers prefer that.

Martin Pitt (pitti) wrote :

-dbg packages are obsolete. We really do use 'debug debs' (.ddeb) that end in -dbgsym (see [1]).

The 'auto-magically show a stack trace in the comment section for any attached apport report' bit is already covered by the bug reporting tool spec [2].

So I dedicate this to integrating apport-retrace into the GUI frontend.
[1] https://lists.ubuntu.com/archives/ubuntu-devel-announce/2006-September/000195.html
[2] https://wiki.ubuntu.com/BugReportingTool

Changed in apport:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed

On Thu, 2006-12-21 at 11:29 +0000, Martin Pitt wrote:
> -dbg packages are obsolete. We really do use 'debug debs' (.ddeb) that
> end in -dbgsym (see [1]).

Ahh. OK. So I should remove my -dbg packages?

> The 'auto-magically show a stack trace in the comment section for any
> attached apport report' bit is already covered by the bug reporting tool
> spec [2].

So the "show stack trace in launchpad" part is not yet done?

> So I dedicate this to integrating apport-retrace into the GUI frontend.

Indeed. Along with a "load debugging packages" option?

b.

--
My other computer is your Microsoft Windows server.

Brian J. Murrell

Martin Pitt (pitti) on 2009-09-02
description: updated
Changed in apport (Ubuntu):
status: Confirmed → Triaged
Martin Pitt (pitti) on 2011-07-20
tags: added: pet-bug
Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Now that apport-retrace stopped ruining your installed system (http://www.piware.de/2011/08/apport-retrace-made-useful/), I want to try and get this into precise.

Changed in apport (Ubuntu Precise):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Wishlist
status: New → Triaged
Martin Pitt (pitti) wrote :

Fixed in trunk for -cli and -gtk. I'll send a call for help for the -kde UI.

Changed in apport (Ubuntu Precise):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.25-0ubuntu1

---------------
apport (1.25-0ubuntu1) precise; urgency=low

  * New upstream release:
    - Add new response "Examine locally" to presenting the report details,
      which runs apport-retrace in the chosen mode in a terminal. This should
      be made available for crash reports if apport-retrace and a Terminal
      application are installed; add an abstrace UI method for this.
      (LP: #75901)
    - apport-gtk: Add "Examine locally..." button, and implement
      ui_run_terminal().
    - apport-cli: Add "Examine locally..." responses, and implement
      ui_run_terminal().
    - apport-cli: Greatly speed up displaying large reports. This also changes
      the format to avoid indenting each line with a space, and visually set
      apart the keys in a better way.
    - apport_python_hook.py: Move tests out of this file into test/python, to
      avoid having to parse the unit tests at each Python startup.
    - test/python: Also make tests work if Python hook is not installed in
      system's sitecustomize.py.
    - packaging.py: Add get_modified_conffiles() API, and implement it in
      packaging-apt-dpkg.py.
    - hookutils.py: Add attach_conffiles().
    - hookutils.py: Add attach_upstart_overrides().
    - launchpad.py: Remove "Ubuntu" in bug response, replace with "this
      software". (LP: #883234)
    - apport-kde: Rearrange order of imports to get intended error message if
      PyKDE is not installed.
    - packaging-apt-dpkg.py: Ignore hardening-wrapper diversions, to make
      gcc_ice_hook work if hardening-wrapper is installed.
    - apport_python_hook: Respect $APPORT_REPORT_DIR.
    - apport_python_hook: Limit successive crashes per program and user to 3
      per day, just like signal crashes. (LP: #603503)
    - packaging-apt-dpkg.py: Skip online tests when there is no default route.
    - ui.py: Fix test suite to not fail if system has some obsolete or
      non-distro packages.
 -- Martin Pitt <email address hidden> Wed, 02 Nov 2011 20:45:08 -0400

Changed in apport (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers