Add a remember option to whoopsie so that users can diminish crash interactions

Bug #1778497 reported by Didier Roche on 2018-06-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Didier Roche
Bionic
High
Didier Roche

Bug Description

[ Impact ]
A lot of users are bother by the number of whoopsie dialog. We introduced on "G-C-C privacy option don't allow sending manual report" bug (https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1774597) a way for users to change from always reporting manually (prompting an UI) to auto reporting or never reporting, via a "Remember this in future".

This only impacts the apport gtk UI, still offering the underlying capability to other UIs type without changing them.

This was a goal for 18.04, but due to a lack of time, we want to introduce this in 18.04.1

[ Test Case ]
 * There are multiples dialog forms (a good 20 of them), but they are all covered by unit tests which have been updates. One use case would be:
 * Install the new version and trigger a crash
 * Check that the dialog has a "Remember this in future" option, check it, and click send.
 * Check in g-c-c UI, privacy option, that the crash reporting is now in auto mode, always send.
 * Revert in g-c-c to manual
 * Create another crash, check "Remember this…" and click don't send
 * Check in g-c-c UI that crash reporting is now disabled.

[ Regression potential ]
 * The impacted code is both UI and fileutils. It's covered by an extensive testsuite, and checking under KDE has also been done to not trigger a crash.

----

We introduce 5 new strings to translate:
"Can't remember send report status settings"
"Saving crash reporting state failed. Can't set auto or never reporting mode."
"Remember this in future"
"Relaunch this application"
"Don't send"

We are reusing an existing transalted string "Send problem report to the developers?"

Related branches

Didier Roche (didrocks) on 2018-06-25
Changed in apport (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in apport (Ubuntu Bionic):
assignee: nobody → Didier Roche (didrocks)
Changed in apport (Ubuntu):
importance: Undecided → High
Changed in apport (Ubuntu Bionic):
importance: Undecided → High
Didier Roche (didrocks) on 2018-06-25
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.10-0ubuntu5

---------------
apport (2.20.10-0ubuntu5) cosmic; urgency=medium

  * Assume if no whoopsie that crash reporting is enabled:
     As the old configuration that was a whoopsie configuration file that was
     that was never updated by the whoopsie API, we assume that no
     whoopsie installed (not the default) == manual send report is allowed.
     If people want to disable crash reporting:
     - get whoopsie installed and disable crash reporting in g-c-c
     - uninstall apport

 -- Didier Roche <email address hidden> Mon, 02 Jul 2018 10:59:22 +0200

Changed in apport (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2018-07-10
description: updated

Hello Didier, or anyone else affected,

Accepted apport into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apport/2.20.9-0ubuntu7.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apport (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

I tried verifying this SRU today using apport version 2.20.9-0ubuntu7.3 from bionic-proposed. I was able to verify the first part of the test case, that a "Remember this in the future" option appeared when the privacy option was set to auto (the default). However, when I set the privacy option, "Problem Reporting", to Manual the crash report dialog just said "If you notice further problems, try restarting the computer." and there was no "Don't Send" button only a "Continue" one.

tags: added: verification-failed verification-failed-bionic
removed: verification-needed verification-needed-bionic
Didier Roche (didrocks) wrote :

Are you sure that your configuration was still set to manual and not "never"? (there is a timeout bug in whoopsie-preferences which reset the condition to "never" if g-c-c is kept opened).

I just tried with the -proposed version, generated a crash which can be reported (note as well that some crashes can't be reported under some condition, hence the "Continue"), and got Don't Send/Send. Marking as verified as I guess your issue is due to the above issue in -preferences (and I tested a lot of combinations) ^

tags: added: verification-done verification-done-bionic
removed: verification-failed verification-failed-bionic
Brian Murray (brian-murray) wrote :

I tried this again and it looks the setting was set to "never". I now see the send and don't send buttons with the version in bionic-proposed.

Łukasz Zemczak (sil2100) wrote :

All good with the verification, but I am slightly worried about the apport autopkgtest failure on i386. It seems to be timing out on the upstream test-suite and re-runs seem to end up the same. Can someone take a look and maybe try reproducing it locally? I triggered an ADT run for the previous version to see if it's not something else in the archive that broke, but seeing that it had one successful run for the old version in the meantime, I doubt it.

I don't want to release it if we don't know what's going on.

Brian Murray (brian-murray) wrote :

If they are timeouts it is likely the following bug:

https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1780767

The verification of the Stable Release Update for apport has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.9-0ubuntu7.3

---------------
apport (2.20.9-0ubuntu7.3) bionic; urgency=medium

  [ Didier Roche ]
  * Add a remember option to whoopsie so that users can diminish
    crash interactions (LP: #1778497)
  * Move apport autoreport service files to apport binary package.
    Having them in apport-noui was creating a bug where autoreport
    wasn't working on desktop. As we check in the launched script
    for whoopsie and autoreport file, we don't autoreport by default.
    (LP: #1778694)
    apport-noui still touches the file to enable autoreport on install.
  * Remove upstart service and watershed dependency.
  * Assume if no whoopsie that crash reporting is enabled:
    As the old configuration that was a whoopsie configuration file that was
    that was never updated by the whoopsie API, we assume that no
    whoopsie installed (not the default) == manual send report is allowed.
    If people want to disable crash reporting:
    - get whoopsie installed and disable crash reporting in g-c-c
    - uninstall apport

  [ Brian Murray ]
  * Start apport-autoreport after installing apport-noui which is part of
    improving apport's automatic crash reporing feature. (LP: #1778694)

 -- Didier Roche <email address hidden> Tue, 10 Jul 2018 11:10:15 +0200

Changed in apport (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers