G-C-C privacy option don't allow sending manual report

Bug #1774597 reported by Didier Roche on 2018-06-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Didier Roche
Bionic
Low
Didier Roche

Bug Description

[ Impact ]
  * The current label "Manual" is in fact shutting down whoopsie completely and not providing any graĥical way to set manual reports (which is our default on 18.04)
  * We want to SRU apport with a "remember this" option which will trigger "never" or "auto" mode.

[ Test Case ]
  * Install new gnome-control-center version, go to the privacy panel
  * Click on the error reporting line
  * In the model window, play with the switch and toggle, and check in d-feet the whoopsie state. Basically you can't adapt error reporting mode (manual/auto) if you decided to not report error mode.
  * Check as well that the main UI toggles between "never/manual/auto"

[ Regression potential ]
  * This code would affect the privacy g-c-c panel.
  * Note that we have 3 new strings to translate ("never" is already translated in G-C-C). Those are:
    - "Send error reports to Canonical"
    - "Send reports automatically"
    - "Show a dialog for each error before reporting"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.1-0ubuntu5

---------------
gnome-control-center (1:3.28.1-0ubuntu5) cosmic; urgency=medium

  * debian/{gbp.conf,control{,.in}}: Added and updated for Ubuntu
  * debian/patches/privacy-panel-whoopsie.patch:
    - display and enable correct section of error reporting mode
      (never/manual/auto) (LP: #1774597)

 -- Didier Roche <email address hidden> Thu, 31 May 2018 17:21:59 +0200

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2018-06-04
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in gnome-control-center (Ubuntu Bionic):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

Translator team emailed.

Brian Murray (brian-murray) wrote :

How does the send reports automatically selection work?

Didier Roche (didrocks) wrote :

It's an option which was already present (only the "never" one wasn't): whoopsie upload crash reports automatically.

See the g-c-c panel from that version to see the option dialog box.

Sebastien Bacher (seb128) wrote :

the SRU is in the bionic queue now

Changed in gnome-control-center (Ubuntu Bionic):
importance: Undecided → Low
status: New → Fix Committed

Hello Didier, or anyone else affected,

Accepted gnome-control-center into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.28.1-0ubuntu1.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic

On Fri, Jun 22, 2018 at 05:54:41AM -0000, Didier Roche wrote:
> It's an option which was already present (only the "never" one wasn't):
> whoopsie upload crash reports automatically.
>
> See the g-c-c panel from that version to see the option dialog box.

As someone familiar with whoopsie and apport, and not an SRU team
member, I'm more curious about what is going on under the hood with the
automatic option. I'd be surprised if the crash reports were actually
automatically reported as, if I remember correctly, that'd require
installing apport-noui.

--
Brian Murray

Didier Roche (didrocks) wrote :

If there is a need for a 3rd party package for it, it means that whoopsie-preferences is broken for quite some years: the automatic option was present in g-c-c for years in ubuntu, and just use whoopsie-preferences API to turn this automatic send mode. Note that the API doesn't report any error in the default install configuration.

As you are familiar with the internal of whoopsie and apport, do you mind having a look? As this only introduces a "never" report mode, and the "auto" one was here since whoopsie integration?

Didier Roche (didrocks) wrote :

@Brian: I just had a deeper look after an initial tests, and brought jibel along.

Indeed, there are quite some flaws on those options which never worked (but was shipped since 12.04). On top of that, I found another regression that happened probably during the upstart -> systemd transition.

Those aren't linked to the current SRU, which are doing the expected thing (and those options were already available before). But we need to fix those. Let me know what you think:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1778694
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1778697

Didier Roche (didrocks) on 2018-06-29
description: updated

SRU verification for Bionic:
I have reproduced the problem with gnome-control-center 1:3.28.1-0ubuntu1.18.04.1 in bionic-updates and have verified that the version of gnome-control-center 1:3.28.1-0ubuntu1.18.04.2 in -proposed fixes the issue.

Note that the test case where reporting is set to never and the apport UI is not displayed fails but this is a fix to do in update-notifier.

Marking as verification-done

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.1-0ubuntu1.18.04.2

---------------
gnome-control-center (1:3.28.1-0ubuntu1.18.04.2) bionic; urgency=medium

  * debian/gbp.conf, debian/control*: Adapt to gbp buildpackage on bionic
    branch and with correct upstream tag version.
  * debian/patches/privacy-panel-whoopsie.patch:
    - display and enable correct section of error reporting mode
      (never/manual/auto) (LP: #1774597)

 -- Didier Roche <email address hidden> Mon, 18 Jun 2018 14:37:34 +0200

Changed in gnome-control-center (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-control-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers