Ubuntu

the pidgin accounts menus are not displayed

Reported by Tatu Pheba on 2010-10-05
164
This bug affects 26 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
High
Cody Russell
appmenu-gtk (Ubuntu)
Medium
Michael Terry
Maverick
Medium
Unassigned
Natty
Medium
Michael Terry

Bug Description

What you expected to happen:
Each of favorite folders appears only once in the markers menu
----------------------------------------------------------------------

What happened instead:
The favorite folders appears several times in the markers menu

TEST CASE:
 1. add indicator applet appmenu to panel and minimize all windows
 2. click on the 'places' menu in indicator appmenu
 3. you will see a long list of repeated items
 4 install appmenu-gtk from maverick-proposed
 5. login again and see there wont be any duplicate menus when repeating step 1,2

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Tue Oct 5 13:29:00 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 LANG=pt_BR.utf8
 SHELL=/bin/bash
SourcePackage: nautilus

Tatu Pheba (tatupheba) wrote :
Tatu Pheba (tatupheba) on 2010-10-05
tags: added: nautilus ui
Omer Akram (om26er) on 2010-10-05
affects: nautilus (Ubuntu) → appmenu-gtk (Ubuntu)
Changed in appmenu-gtk (Ubuntu):
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → Medium
status: New → Confirmed
Cody Russell (bratsche) on 2010-10-06
Changed in appmenu-gtk (Ubuntu):
status: Confirmed → In Progress
Changed in appmenu-gtk:
status: New → In Progress
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → High
Omer Akram (om26er) wrote :

confirmed the attached branch fixes the issue in desktop menu and pidgin
built it in my ppa https://edge.launchpad.net/~om26er/+archive/test

Omer Akram (om26er) wrote :

here is a diff between the two versions. the problem is not specific to the desktop menu. its a general problem as it happens in pidgin too

josepgl (josepgl) on 2010-11-15
description: updated
Changed in appmenu-gtk (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Medium
Omer Akram (om26er) on 2010-11-20
summary: - The favorite folders appears several times in the markers menu
+ some applications show duplicated menus
Omer Akram (om26er) on 2010-11-22
description: updated
Michael Vogt (mvo) on 2010-11-22
Changed in appmenu-gtk (Ubuntu Maverick):
status: Triaged → In Progress
Michael Vogt (mvo) on 2010-11-22
description: updated

Accepted appmenu-gtk into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in appmenu-gtk (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed

why not update the natty one?

Gediminas Paulauskas (menesis) wrote :

Confirmed that the new package in maverick-proposed fixes the issue in Pidgin and Nautilus. Using Ubuntu Desktop and indicator-appmenu applet.

Omer Akram (om26er) on 2010-11-24
Changed in appmenu-gtk:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-gtk - 0.1.9-0ubuntu5

---------------
appmenu-gtk (0.1.9-0ubuntu5) natty; urgency=low

  * debian/patches/do_not_show_duplicate_menus.patch:
    - do not show duplicate menu items (LP: #655241)
 -- Omer Akram <email address hidden> Wed, 24 Nov 2010 21:12:55 +0500

Changed in appmenu-gtk (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) on 2010-11-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-gtk - 0.1.9-0ubuntu4.1

---------------
appmenu-gtk (0.1.9-0ubuntu4.1) maverick-proposed; urgency=low

  * debian/patches/do_not_show_duplicate_menus.patch:
    - do not show duplicate menu items (LP: #655241)
 -- Omer Akram <email address hidden> Sat, 20 Nov 2010 15:28:43 +0500

Changed in appmenu-gtk (Ubuntu Maverick):
status: Fix Committed → Fix Released
Alexander Skiba (ghostlyrics) wrote :

After this the submenus for Accounts in Pidgin's "Accounts" menu are now gone.

Martin Pitt (pitti) wrote :

Reopening then, thanks for reporting back! And marking as regression.

Changed in appmenu-gtk (Ubuntu):
status: Fix Released → Triaged
Changed in appmenu-gtk (Ubuntu Maverick):
status: Fix Released → Triaged
tags: added: regression-updates
Rolf Leggewie (r0lf) on 2010-12-17
tags: added: regression-update
removed: regression-updates
Changed in appmenu-gtk (Ubuntu Natty):
assignee: Cody Russell (bratsche) → Michael Terry (mterry)
Omer Akram (om26er) wrote :

the issue is fixed in Natty

Omer Akram (om26er) wrote :

*and also in maverick too though the backport brought in a regression(s?).

Michael Terry (mterry) on 2011-02-03
Changed in appmenu-gtk:
status: Fix Committed → Fix Released
Changed in appmenu-gtk (Ubuntu Natty):
status: Triaged → Fix Released
Changed in appmenu-gtk (Ubuntu Maverick):
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

The issue created by the update is still there in natty, reopening and updating the title

Changed in appmenu-gtk (Ubuntu Natty):
status: Fix Released → Triaged
summary: - some applications show duplicated menus
+ the piding accounts menus are not displayed
summary: - the piding accounts menus are not displayed
+ the pidgin accounts menus are not displayed
Omer Akram (om26er) wrote :

> The issue created by the update is still there in natty, reopening and updating the title

I believe the fix to bug 696896 also fixed this issue since both sound like the same issues

Michael Terry (mterry) wrote :

The submenu in pidgin's account menu? That is fixed on updated natty, as far as I can tell, between either the fix for handling submenus or the fix for handling new items, both of which happened last week/today.

Changed in appmenu-gtk (Ubuntu Natty):
status: Triaged → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers