Ubuntu

Comment 0 for bug 239580

Binary package hint: amule

This release could be considered a bugfix release since most of the innovations of aMule 2.2.1 are already included in the latest svn.

Download tarball (it is necessary to rename debian by debian-upstream):
http://downloads.sourceforge.net/amule/aMule-2.2.1.tar.bz2

I removed "configure_ignore_gdlib-config_garbage.diff" patch for 2 reasons:
 * It modifies files of source code that are constantly changing and therefore we must be continually updated.
 * I have consulted 2 aMule developers (Kry and GonoszTopi) and they have recommended that I not use this patch. The conversation is in an attachment.

amule (2.2.1-0ubuntu1) intrepid; urgency=low

  * New upstream, aMule 2.2.1
    - The "Soon" release ;D
    - Renamed debian/ to debian-upstream/
  * debian/control
    - Require libupnp3 for uPnP support in amule-daemon
    - Change to libcrypto++-dev (>= 5.5.2-2)
    - Updated Standards-Version to 3.8.0
  * debian/amuled_home_wrapper.sh
    - aMule 2.2.1 no longer assumes a Latin-1 charset, and refuses
      to handle files with non-ASCII characters if the running
      locale does not support them. (from debian package)
  * debian/patches
    - removing_SVN_warning_window.diff
      Removed. It is no longer needed.
    - configure_ignore_gdlib-config_garbage.diff
      Removed. It is no longer needed (never been necessary)
  * debian/amule-utils.postinst
    - Install amule-utils package avoid the manual process of
      configuring the firefox 3 to accept ed2k links. In the future
      this will be extended to more browsers.

 -- Festor Wailon Dacoba <email address hidden> Wed, 11 Jun 2008 20:55:14 +0000