Ubuntu

No webcam found, says capture extension not loaded

Reported by David Nielsen on 2009-01-07
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
amsn (Ubuntu)
Undecided
Adrien Cunin
Nominated for Jaunty by André Gondim

Bug Description

I am unable to use my webcam with amsn, it says that the capture extension isn't loaded. The same webcam works in cheese and the driver is uvc (a creative, I can't remember the exact model).

This is Jaunty, x86_64, da_DK.UTF-8.

amsn:
  Installeret: 0.97.2~debian-1ubuntu2
  Kandidat: 0.97.2~debian-1ubuntu2
  Versionstabel:
 *** 0.97.2~debian-1ubuntu2 0
        500 http://dk.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

Related branches

This might be related. When I run the test.tcl program from the amsn tarball I get the following error.

Error in startup script: couldn't load file "/usr/lib/amsn/utils/linux/capture/capture.so": /usr/lib/amsn/utils/linux/capture/capture.so: undefined symbol: v4l2_open
    while executing
"load /usr/lib/amsn/utils/linux/capture/capture.so capture"
    ("package ifneeded capture 0.5" script)
    invoked from within
"package require capture"
    (file "./test.tcl" line 5)

I found a workaround, before launching amsn we can export the following and the webcam is once more detected and available
export LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so

Florent (florent.x) wrote :

The workaround just works also for Ubuntu 32bits:

export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so

It works also with:
export LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so

Florent (florent.x) wrote :

confirmed on Ubuntu Jaunty

Changed in amsn:
status: New → Confirmed
André Gondim (andregondim) wrote :

My webcam is:

Bus 006 Device 002: ID 05a9:2640 OmniVision Technologies, Inc.

And works on intrepid, but not in Jaunty.

This workaround did not work with me.

export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so

export LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so

cheers

Peter Clifton (pcjc2) wrote :

The binary build of those .so files isn't correctly linking against the required libraries, including -ltk-8.5 and -ltcl-8.5ls

If you rebuild the sources manually adding those libraries, "-lv4l2 -ltk8.5 -ltcl8.5" (I just hacked Makefile.in line 107:

LDLIBS := @LDLIBS@ -lpng -lz -lm -ljpeg -lv4l2 -ltk8.5 -ltcl8.5

Then you get an amsn which works with web-cam.

nyarnon (cabal) wrote :

I can confirm the same problem, as Peter Clifton seems to have a solution I do hope de maintainer will act soon.

nyarnon (cabal) wrote :

I can confirm Peters solution is working, thanks Peter. Tried the package manager release first but that didn't do the trick. Compilation of the source did. For completeness I attach the Makefile.in file.

I can confirm the same problem. My webcam is the Logitech Quickcam pro 9000, works perfectly in Cheese webcam booth but have the 'capture extension not loaded' problem in aMSN, thus unable to use the webcam. The same webcam worked perfectly in Ubuntu 8.10 on aMSN and cheese.

Helli (helli000) wrote :

hi Peter & nyarnon:

I have the same problem. And it bothered me recently. I don't know how to install amsn by rebuilding source files of amsn. I tried to rebuild before. My environment is Unbuntu alpha / Arm CPU. My steps are below:

1). download the amsn-xxx.tar.gz, tcl-xxx.targz, tk-xxx.tar.gz
2). unzip amsn-xxx.tar.gz
3). unzip tcl-xxx.tar.gz
4). unzip tk-xxx.tar.gz
5). cd tcl-xxx/unix/
6). ./configure
7). make
8). make install
9). cd ../../tk-xxx/unix
10). ./configure --with-tcl=/path/to/tcl
11). make

Then, I got error messages about missing some files.

Would you please tell me how to rebuild the source files of amsn? Or how to solve this problem?

It is going to dry me crazy!

Best regards
Helli

This is insanity, there's a fix present and this bug is still open nearly a month after.

Assigning this to Jorge, he will know what to do to make the hurting stop

Changed in amsn:
assignee: nobody → jorge
Aritra Dalal (aritra-dalal) wrote :

so, when does the fix release in the maintainer's packages?

Aritra Dalal (aritra-dalal) wrote :

I was trying to install it through the sourcecode, but i got and error when i applied the "make" command..
The error was:
LDX utils/TkCximage/src/TkCximage.cpp.so
/usr/bin/ld: cannot find -lv4l2

Please help....

Can anyone please guide me step by step how I can configure my Logitech quickcam pro 9000 to work with aMSN in Jaunty. I know there's a fix but I havent a clue how to implement it. I've recently moved from windows to Ubuntu and miss the webcam function in aMSN. I really don't want to move back to windows or Ubuntu 8.10 just so I can use my webcam on msn.

Jamin W. Collins (jcollins) wrote :

for those of you that would like to apply the patch, the following should work:

mkdir -p ~/src/amsn
cd ~/src/amsn
apt-get source amsn
sudo apt-get build-dep amsn
sudo apt-get install devscripts fakeroot
cd amsn-0.97.2~debian
wget http://launchpadlibrarian.net/22503405/Makefile.in
debuild -r fakeroot
cd ..
sudo dpkg -i amsn*.deb

Florent (florent.x) wrote :

@amw3465

The easiest workaround is the one described in comment 2 or 3 (depending if it is Ubuntu 64bits or 32bits):

 - Launch a console
 - Type:
user@jaunty$ export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
user@jaunty$ amsn

 - If it works, you can create a shell script in folder "/usr/local/bin":
user@jaunty$ sudo nano /usr/local/bin/amsn

 - Type
  #!/bin/sh
  LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so exec /usr/share/amsn/amsn

 - And set the executable bits
user@jaunty$ sudo chmod ugo+x /usr/local/bin/amsn

 - This script will be launched when you select "aMSN" in the menu

I've tried both the above methods but unfortunately neither have worked. I'm attaching the output from the terminal by odt attachment when I followed Jamin's instructions. The written output from the terminal following Florent's instructions is below
alan@alan-desktop:~$ export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
alan@alan-desktop:~$ amsn
sudo nano /usr/local/bin/amsn
#!/bin/sh
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so exec /usr/share/amsn/amsn
sudo chmod ugo+x /usr/local/bin/amsn

I'd like to add a screenshot image of the actual error message in aMSN.

Changed in amsn:
assignee: jorge → desktop-bugs
Florent (florent.x) wrote :

it's a shame, this issue is not fixed in last version :
  amsn 0.97.2~debian-2ubuntu1

Aritra Dalal (aritra-dalal) wrote :

same here... when i saw a patch with libv4l2 quoted in it, i got so excited, thinking this would be a patch for amsn.... shame indeed!!

anyone have an idea when a patch for this will be released on the repository?

I've been asking for while but nothing seems to be happening. I guess the
developers are too busy at the moment. It's a shame really as I'd be using
Ubuntu 100% of the time if it wasn't for this issue as I now have no choice
but to go back to windows to talk with my friends and family with webcam as
they only have msn. Skype is good and I can use that but no one I know has
it or even wants it.

2009/4/5 Adalal <email address hidden>

> same here... when i saw a patch with libv4l2 quoted in it, i got so
> excited, thinking this would be a patch for amsn.... shame indeed!!
>
> anyone have an idea when a patch for this will be released on the
> repository?
>
> --
> No webcam found, says capture extension not loaded
> https://bugs.launchpad.net/bugs/314805
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “amsn” source package in Ubuntu: Confirmed
>
> Bug description:
> I am unable to use my webcam with amsn, it says that the capture extension
> isn't loaded. The same webcam works in cheese and the driver is uvc (a
> creative, I can't remember the exact model).
>
> This is Jaunty, x86_64, da_DK.UTF-8.
>
> amsn:
> Installeret: 0.97.2~debian-1ubuntu2
> Kandidat: 0.97.2~debian-1ubuntu2
> Versionstabel:
> *** 0.97.2~debian-1ubuntu2 0
> 500 http://dk.archive.ubuntu.com jaunty/universe Packages
> 100 /var/lib/dpkg/status
>

Adrien Cunin (adri2000) on 2009-04-08
Changed in amsn (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Adrien Cunin (adri2000)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amsn - 0.97.2~debian-2ubuntu2

---------------
amsn (0.97.2~debian-2ubuntu2) jaunty; urgency=low

  * debian/rules: added -lv4l2 to LDFLAGS for libv4l support to work correctly,
    fixes LP: #314805

 -- Adrien Cunin <email address hidden> Wed, 08 Apr 2009 23:53:46 +0200

Changed in amsn (Ubuntu):
status: In Progress → Fix Released
Florent (florent.x) wrote :

It works. Thank you.

It works, thanks very much

2009/4/8 Launchpad Bug Tracker <email address hidden>

> This bug was fixed in the package amsn - 0.97.2~debian-2ubuntu2
>
> ---------------
> amsn (0.97.2~debian-2ubuntu2) jaunty; urgency=low
>
> * debian/rules: added -lv4l2 to LDFLAGS for libv4l support to work
> correctly,
> fixes LP: #314805
>
> -- Adrien Cunin <email address hidden> Wed, 08 Apr 2009 23:53:46 +0200
>
> ** Changed in: amsn (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> No webcam found, says capture extension not loaded
> https://bugs.launchpad.net/bugs/314805
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “amsn” source package in Ubuntu: Fix Released
>
> Bug description:
> I am unable to use my webcam with amsn, it says that the capture extension
> isn't loaded. The same webcam works in cheese and the driver is uvc (a
> creative, I can't remember the exact model).
>
> This is Jaunty, x86_64, da_DK.UTF-8.
>
> amsn:
> Installeret: 0.97.2~debian-1ubuntu2
> Kandidat: 0.97.2~debian-1ubuntu2
> Versionstabel:
> *** 0.97.2~debian-1ubuntu2 0
> 500 http://dk.archive.ubuntu.com jaunty/universe Packages
> 100 /var/lib/dpkg/status
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers