Multimedia keys not working in Feisty (no need to confirm behavior anymore)

Bug #87299 reported by Andrew Conkling on 2007-02-23
38
Affects Status Importance Assigned to Milestone
Amarok
Unknown
Medium
Banshee
Fix Released
Medium
amarok (Ubuntu)
Undecided
Unassigned
banshee (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: banshee

See bug #32917 for a bug in Rhythmbox.

Banshee's multimedia keys are not working here. For me, the problem happened at the same time that they broke for Rhythmbox, but now that RB is working again, Banshee's still are not.

0.11.7 on Feisty

description: updated
Changed in banshee:
status: Unknown → Unconfirmed
David Corrales (davidcorrales) wrote :

They don't work here either. They do work for volume up/down and Rhythmbox, so it's a banshee bug.

Taylor Mitchell (tmitchell) wrote :

I'm seeing the same issue with amaroK. The buttons worked fine before upgrading from Edgy to Feisty. Volume up and down works, xev shows activity, and the buttons work in RhythmBox.

John Dong (jdong) wrote :

Same thing for me in Feisty, they work fine in Rhythmbox but are borked for Banshee and amarok.

Changed in banshee:
status: Unconfirmed → Confirmed
9johnny (s.j.) wrote :

here is the bug in banshee with a patch:
http://bugzilla.gnome.org/show_bug.cgi?id=395433
cheers,
John

ps. also, someone could confirm this bug on gnome bugzilla so the patch gets accepted upstream?

Andrew Conkling (andrewski) wrote :

Linked upstream to original bug, not duplicate.

Changed in banshee:
status: Unknown → Unconfirmed
Loe Spee (lgespee) wrote :

Same here with Banshee 0.12.0 in Ubuntu 7.04 Feisty Fawn Beta 1.
The volume up, down and mute buttons work, but this is functionality in Gnome itself I think. The next track, previous track and play/pause buttons don't work in Banshee. (The "Multimedia keys" plug-in has been activated.)

Chris Halse Rogers (raof) wrote :

Here's a debdiff incorporating that patch from Gnome Bugzilla. I haven't been able to test that it works, but it does build cleanly in a pbuilder, and the patch works for at least one person on Gnome bugzilla.

Loe Spee (lgespee) wrote :

If somebody could arrange this patch will be committed and an update for Feisty will appear, I will test it, and report back here.

Andrew Conkling (andrewski) wrote :

I can confirm that this patch builds cleanly and works as expected.

The package is easily rebuilt through instructions here: https://wiki.ubuntu.com/UbuntuPackagingGuide/BuildFromDebdiff. I got some help on IRC in #ubuntu-motu, so head there if you need help. :)

Chris Halse Rogers (raof) wrote :

I have also tested the debdiff, now, and it works (on AMD64). Assigning to ubuntu-universe-sponsors to get it into the archive.

Changed in banshee:
assignee: nobody → ubuntu-universe-sponsors
Daniel T Chen (crimsun) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 30 Mar 2007 16:40:10 +1000
Source: banshee
Binary: banshee banshee-daap
Architecture: source
Version: 0.12.0+dfsg-1ubuntu2
Distribution: feisty
Urgency: low
Maintainer: Sebastian Dröge <email address hidden>
Changed-By: Christopher James Halse Rogers (RAOF) <email address hidden>
Description:
 banshee - Audio Management and Playback application
 banshee-daap - Audio Management and Playback application (DAAP sharing plugin)
Launchpad-Bugs-Fixed: 87299
Changes:
 banshee (0.12.0+dfsg-1ubuntu2) feisty; urgency=low
 .
   * debian/patches/02_fix_2.18_multimedia_keys
     + Patch from Gnome bugzilla (# 395433) to update multimedia
       key plugin to new 2.18 API (LP: #87299)
Files:
 446c9fc3313ade53caf1e235a83a9399 1698 sound optional banshee_0.12.0+dfsg-1ubunt
u2.dsc
 fbc4a6219c23d8514b587a614cf6b21a 12391 sound optional banshee_0.12.0+dfsg-1ubun
tu2.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGDxQye9GwFciKvaMRAtA2AKCgzF9mO/CBkRuBw3ogIuEeXzc7rwCdFVrc
cXB4I9v/vVC7LfAd1xyGTlw=
=VR1V
-----END PGP SIGNATURE-----

Changed in banshee:
assignee: ubuntu-universe-sponsors → nobody
status: Confirmed → Fix Committed
Daniel T Chen (crimsun) on 2007-04-01
Changed in banshee:
status: Fix Committed → Fix Released
Loe Spee (lgespee) wrote :

I just received the update, and I confirm the fix.
It works now, thanks everybody who helped fixing this, I just love my multimedia keys ;).

Kevin Gagnon (gagnon-kevin) wrote :

Bug still present in Amarok under gnome.

I can configure the keys correctly under Amarok's preferences but it won't react when I press a key.

Any updates/comments about this issue?

Loe Spee (lgespee) wrote :

To Kevin Gagnon:

In the Banshee upstream bug report (http://bugzilla.gnome.org/show_bug.cgi?id=395433) it says,
> Since control-center 2.17.5 there is a new DBUS interface in GNOME for
> multimedia key support. It would be nice if banshee would use this interface if
> available.

I think the application that needs to be controlled by the multimedia keys needs to have support for this new DBUS interface.
So I guess Amarok hasn't got this yet, you could post a bug upstream for Amarok.

Changed in banshee:
status: Unconfirmed → Fix Released
Epper (m-epper) wrote :

I can confirm that the problem persists with Amarok: Multimedia keys are configurable by the "Configure Global Shortcuts" dialog but they don't work.

Ronny Haryanto (ronnyh) wrote :

Also not working in quodlibet since feisty. Appears to be dbus related.
See bug #43464.

Damian Frick (mozork) wrote :

Same with me, multimedia shortcuts not working under feisty

dizastix (dizastix) wrote :

I can also confirm that the global shortcuts for Amarok do not work in Feisty. I can configure them fine, but they don't work.

Changed in amarok:
status: Unconfirmed → Confirmed
Rodrigo (publicurinal598) wrote :

Likewise, confirmed. Global Shortcuts are configured, but nothing happens.

Kaïs Bejaoui (kais) wrote :

The problem is not solved yet with Amarok, shortcuts are configured but don't work.

Confirmed here for amarok.
I created a new bug in KDE bugtracker.

Version: 1.4.5 (using KDE KDE 3.5.6)
Installed from: Ubuntu Packages

The special multimedia keys of certain keyboards (play, pause, next track, etc.) do not work anymore, when running Amarok under Gnome 2.18.

The keys are recognized in "Global Shortcuts" settings, but pressing them does not have any effect. Any normal shortcuts like Super+X work normally.

Apparently there is a new Dbus interface for multimedia keys since Gnome 2.17/2.18.

Here is a link to Ubuntu bugtracker which might provide more info:
https://bugs.launchpad.net/ubuntu/+source/amarok/+bug/87299

Also a link to Gnome bugtracker for Banshee music player which had the same problem. There is a patch for Banshee there; maybe it's useful to fixing this in amarok too:
http://bugzilla.gnome.org/show_bug.cgi?id=395433

You are asking us to implement a Gnome specific interface for the multimedia keys? No thanks, we're a kde app, and that is just going to pull more dependencies and configure checks.

Perhaps this will be able to be sorted when we reach Amarok 2 where KDE will be using dbus.

(or maybe i misunderstand the bug)

Changed in amarok:
status: Unknown → Rejected

I am not a programmer, but I don't think you would need more dependencies. Just check if the new interface is available, if yes use it, if not, use the old. This is what the Banshee people did. Did you look at their patch?
Maybe the change is trivial since the keys are basically recognized correctly and everything worked in Gnome 2.16 and earlier?

But these are all guesses since I don't know anything about the program code of amarok.

I think there are a lot Gnome amarok users and it would be too bad if they lost this functionality.
Or would you say that fixing this is the responsibility of distributors?

James Wright (crazygunnut) wrote :

I have a tempory solution; disable all the media keys in the KDE control centre, via regional and Accessibility, keyboard shortcuts.

I believe, however, that this will stop the media keys from working globally.

I got the media keys working on amarok also, but not exactly by the same way.

I deleted every shortcut from kcontrol, but that didn't help. Then I deleted every media key from Gnome Shortcuts Applet. After that the "Next" and "Prev" keys started working, but not the "Play/Pause". I then played around with the amarok shortcuts dialog, changing the media keys to different places etc., and then eventually got everything working normally.

After that, I could restore the KDE shortcut settings and everything still worked. But when changing back the Gnome ones, sometimes the next/prev keys stopped working. Then I had again to mess around the amarok and gnome settings, setting, unsetting and changing the media key shortcuts...

Now I have the media keys working in amarok and in the gnome settings. But I have not the slightest idea how to do that exactly, except for keep changing them in amarok and gnome until it works.

dizastix (dizastix) wrote :

Yeah, I got it to work in Amarok under Gnome like this: Clear all the shortcuts from System > Prefrences > Keyboard Shortcuts. Then, I wanted Win + C to be Play/Pause, so I set it as that in Amarok (Settings > Configure Global Shortcuts) but if you're using Beryl, that combination is already used for something else. So goto Beryl Settings Manager and under General Options > Shortcuts search for <super>c (or whatever other combination you might want to use) and clear if from being a shortcut for whatever Beryl has it set for. Then it works for Amarok. Did this and got Previous Track, Play/Pause and Next Track to work which is all I wanted anyways. However, some keys wouldn't work like I wanted Win + V to be next track but I couldn't get it to work but Win + B worked perfectly. Good enough for now...

Kevin Gagnon (gagnon-kevin) wrote :

The best way to make those multimedia keys to work is by using keytouch2 and keytouch2-editor ( can be installed via Synaptics). You can then configure all your keys to do what you want. Worked very well for me.

dizastix:
The problem are not the normal key combinations. We are talking about the special multimedia keys most of the new keyboards today have, like special keys for muting sound, setting the volume, play, stop, next and prev track etc.

The standard combinations like Win+C etc. have always worked normally if there was no conflict (like with Beryl, as you described).

As a workaround, use keytouch:
http://keytouch.sourceforge.net/index.php

(shamelessly stolen from the gnome bug thread)

BrowneR (chris-scotland) wrote :

I have written a script for Amarok that can be used to fix this issue.

see here: http://kde-apps.org/content/show.php?content=60910

it should be available for install via Amarok's built in script manager but i have also attached it.

BrowneR (chris-scotland) wrote :

as a second thought maybe this script should be added to the amarok deb and enabled by default to save confusion for users?
it would obviously need a lot more testing first. its my first experience with python so suggestions are most welcome.

I have written a script for Amarok that can be used to fix this issue.

Get it here: http://kde-apps.org/content/show.php?content=60910

or alternatively it should be available for install via Amarok's built in script manager.

It is available in Amarok's script manager automatically :)

Thanks for your help Chris!

And Seb is correct. Looking at the script we will be able to implement this when we have DBus in Amarok 2.0.

Thanks BrowneR, that script works perfectly.

Since Amarok won't fix this until 2.0, I think it would be great and also in the spirit of Ubuntu ("it just works") to include it in the deb.

Feel free to use the script.

I'm not sure how this will interfere with amarok on KDE, either.

Changed in amarok:
status: Confirmed → Won't Fix
BrowneR (chris-scotland) wrote :

Sarah Hobbs:
          I'm not sure how this will interfere with amarok on KDE, either.

As far as I understand it KDE users should not have this problem in the first place (altho i havnt checked).
If you are referring to the operation of the script then I could easily add a check to make sure we were running on a Gnome 2.18 system and otherwise do nothing. As it stands the script would most likely grumble and fail to load under KDE due to the lack of DBUS on which it depends.

Sarah, could you explain why you set this to Wontfix? Is there no possibilty for BrowneR's script to be installed automatically only for Amarok/Gnome users? And if not, shouldn't this remain open anyway till 2.0 is released and if it's fixed then, the bug can be closed.

BrowneR (chris-scotland) wrote :

I have written a script for Amarok that can be used to fix this issue.
see here: http://kde-apps.org/content/show.php?content=60910
it should be available for install via Amarok's built in script manager.
maybe this script should be added to the amarok deb and enabled by default to save confusion for users?
it would obviously need a lot more testing first. its my first experience with python so suggestions are most welcome.

Changed in amarok:
status: Won't Fix → Fix Released
Andrew Conkling (andrewski) wrote :

This fix hasn't been released in Ubuntu yet, changing to 'In Progress'. Maybe, once tested, it could be added to the Amarok package?

Changed in amarok:
status: Fix Released → In Progress
BrowneR (chris-scotland) wrote :

sorry i misunderstood the term 'released' there.

amarok (2:1.4.7-0ubuntu3) gutsy; urgency=low

  * Added kubuntu_05_utf8_to_mtp_devices_fix.diff from upstream. (KDE
    Bug #139722)
  * Added kubuntu_06_fix_amarok_freeze_installing_mp3.diff from
    upstream. (KDE Bug #147126, LP: #58617) Thanks markey for fixing
    this!
  * Added amarok Suggests: libxine1-ffmpeg. (LP: #134741)
  * Added kubuntu_07_gnome_multimedia_keys.diff, a script that lets the
    multimedia keys in GNOME work in amarok. (LP: #87299)
  * Use adept_batch update in install-mp3 not apt-get update

 -- Sarah Hobbs <email address hidden> Sat, 01 Sep 2007 00:11:20 +1000

Changed in amarok:
status: In Progress → Fix Released
Bart Samwel (bart-samwel) wrote :

First of all, I've installed 1.4.7-0ubuntu3 and I'm not seeing the script. It's not present in /usr/share/appl/amarok/scripts. Do I need to do anything to install it, or am I looking in the wrong place?

Second, I've tried the script from the link, and it only works partly -- the play button now works while I've got the Amarok window focused, but not while I'm running Amarok in the tray -- which is exactly what I want this for.

Changed in banshee:
importance: Unknown → Medium
Changed in amarok:
status: Invalid → Unknown
Changed in amarok:
importance: Unknown → Medium

Closing correctly as Amarok 1.x is unmaintained since quite some time anyway.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.