[hardy] Amarok install-mp3 fails silently

Bug #187406 reported by Sven Boden on 2008-01-30
8
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amarok

This looks like an old bug, but is a new bug on hardy:

Version: Amarok 1.4.8 (using KDE 3.5.8, Kubuntu (hardy) 4:3.5.8-4ubuntu7)
Compiler: Target: i486-linux-gnu
OS: Linux (i686) release 2.6.24-5-generic

The first time I play an mp3 in amarok on Kubuntu hardy heron (alpha2) I get the dialog "Amarok currently cannot play MP3 files." ... I click the "Install MP3 Support" button. It goes away and comes back with "MP3 support now installed, you will need to restart Amarok.". I restart and I still can't play mp3s.

This is on a brand new installed hardy 8.4 alpha2 running 1 user (the one from the setup with id 1000).

-------------------

The work around is to execute following from a Konsole:
                  sudo aptitude install libxine1-ffmpeg

-------------------

I debugged a bit and the reason is the following:

It's in the install-mp3 script (/usr/lib/amarok). If I run it manually I get following:

bash -x ./install-mp3
++ dpkg --get-selections libxine1-ffmpeg
++ grep install
+ INSTALLED=
++ lsb_release -sc
+ RELEASE=hardy
+ '[' -z '' ']'
+ '[' -x /usr/bin/kdesu ']'
+ '[' -x /usr/bin/adept_batch ']'
+ kdesu -d 'bash -c "adept_batch update; adept_batch install libxine1-ffmpeg"'
update;: -c: line 0: unexpected EOF while looking for matching `"'
update;: -c: line 1: syntax error: unexpected end of file

+ check_mp3
+ '[' 0 -eq 0 ']'
+ '[' -x /usr/bin/kdialog ']'
+ kdialog --msgbox 'MP3 support now installed, you will need to restart Amarok.'
+ exit 0

----------

So the kdesu line 'blows' up and the check afterwards fails.

-----------------------

Also reported at https://bugs.launchpad.net/ubuntu/+source/amarok/+bug/61972 in which an amarok developer states it's probably a distro bug.

Sven Boden (svenboden) wrote :

As a patch... replacing the kdesu line by:

kdesu -d "adept_batch update ; adept_batch install libxine1-ffmpeg"

works for me... the gksudo statement suffers from the same problem probably.

The check_mp3 is pretty braindead, it just checks whether the kdsudo/gksudo was successful (the kdesudo succeeds, it's the executed command that fails but that error code will be eaten probably).

Sven Boden (svenboden) wrote :

diff fixing the problem

Sven Boden (svenboden) wrote :

debdiff attachment which supercedes the previous diff.gz
Additional change is the use of absolute paths for security reasons.

Sven Boden (svenboden) wrote :

Anyone willing to test/commit the debdiff to "install-mp3" for amarok in ubuntu?

Sven Boden (svenboden) on 2008-02-27
Changed in amarok:
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

Why does it need bash? Can we have a solution that doesn't require a non-standard shell?

Sven Boden (svenboden) wrote :

The change I made makes it work for Kubuntu hardy (without bash if you check the debdiff). I don't change what I can't test, but feel free to further enhance it.

I'll also see whether I find the time today to remove the other bash'es and test them.

Sven Boden (svenboden) wrote :

new debdiff where bash is completely removed. I tested the kubuntu branch, libxinel-ffmpeg doesn't appear for me in synaptic so the gnome version doesn't work for me (it's not worse than the original version).

Frank Bob (frankbob) wrote :

This problem still exists in Kubuntu Hardy Alpha5 updated as of 2008-03-05
Amarok offers to install mp3 support
then does nothing
then says that mp3 support is installed but it isn't

Sven Boden (svenboden) wrote :

The debdiff above and the one for LP #197105 do work, it's just a matter of getting someone to "commit" them.

For the mp3 support... short term workaround:

/usr/bin/kdesu -d "/usr/bin/adept_batch update" && /usr/bin/kdesu -d "/usr/bin/adept_batch install libxine1-ffmpeg"

There are easier ways, but this is what the debdiff would execute.

Shaikailash (steve-doc-brown) wrote :

So, I have just installed the kubuntu hardy 32bit alpha 5 and the problem is still here.
I can't believe this goes up since the 7.04 and never solved....I fix it simply installing the "libxine1-ffmpeg" but it's so a bad presentation for all the friends who try the first time ubuntu, and find always this problem.

Please, fix it in the next release!

Ouch. Uploading for hardy.

Changed in amarok:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:1.4.8-0ubuntu3

---------------
amarok (2:1.4.8-0ubuntu3) hardy; urgency=low

  [ Sven Boden ]
  * Fix for bug "187406: Amarok install-mp3 fails silently" (LP #187406)

  [ Sarah Hobbs ]
  * Sponsored upload. (Closes LP: #187406)
  * Reworked patch to avoid setting absolute paths (eg /usr/bin/kdesu)

 -- Sarah Hobbs <email address hidden> Wed, 12 Mar 2008 00:50:22 +1100

Changed in amarok:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers