Amarok Ver 1.4.3 / KDE 3.5.4 - Will not play MP3 files, nor install MP3 Support, when chosen.

Bug #61972 reported by QuestZone on 2006-09-23
8
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amarok

Version: 1.4.3 (using KDE 3.5.4, Kubuntu (edgy) 4:3.5.4-0ubuntu16)
Compiler: Target: i486-linux-gnu
OS: Linux (i686) release 2.6.17-8-generic

Will not play MP3 files, nor install MP3 Support, when chosen.

Andrew Ash (ash211) wrote :

Try installing these packages, from https://help.ubuntu.com/community/RestrictedFormats

 Kubuntu 6.06:
      libxine-extracodecs
      w32codecs
      libarts1-mpeglib
      libarts1-xine
      libakode2-mpeg

Amarok should be installing these automatically. Is there an internet connection available on this pc?

Changed in amarok:
status: Unconfirmed → Needs Info
QuestZone (mscott7319) wrote :

The pc has an Internet connection.
Amarok only installed "libxine-extracodecs"
As suggested, I installed; w32codecs, libarts1-mpeglib, libarts1-xine, libakode2-mpeg.
None of which solved the problems.

Brandon Holtsclaw (imbrandon) wrote :

i cannot reporduce this , problem on dapper or edgy, can i get someon to confim this

with libxine-extracodecs installed amarok should play mp3's fine, does it play ogg's ?

QuestZone (mscott7319) wrote :

* This error began when I installed Edgy Knot 3 from the alternate install CD, and I've since installed 100's of MB of updates to Edgy.
* Please note, this was a fresh install, not an update from dapper. I have 3 partitions, Root, Home & Swap.
* Ogg & wav files play fine.
* My current workaround solution has been to install XMMS 1.2.10 multimedia player, which will play MP3 files.

Tiger Chen (tiger-mails) wrote :

Yes, I confirm this bug. Kubuntu edgy, with newest updates.
even with libxine-extracodecs installed, amarok still can't play mp3.

Andrew Ash (ash211) wrote :

Tiger Chen: do ogg and wav work fine?

I'm not sure what's causing this problem. Hopefully somebody with more knowledge than me can address this.

ingmar (ingmar-vanhassel) wrote :

I can confirm this bug.

Here's how I worked around it on my machine:
I uninstalled amarok, and all xine-related packages I had ( might not be necessary though ) and I deleted the ~/.xine folder.

Then I reinstalled amarok & it's xine dependencies, and when I tried to play an mp3, I got the kdialog asking me to install libxine-extracodecs, which I did. After restarting amarok, mp3's played fine again.

I hope this helps something.

QuestZone (mscott7319) wrote :

I uninstalled Amarok, xine-related packages and deleted /.xine. Then I installed Amarok and when opening a MP3 file I was prompted with "Install MP3 Support" and the following happened;
===================================
Adept Batch
Selecting previously deselected package libmad0.
(Reading database ... 131406 files and directories currently installed.)
Unpacking libmad0 (from .../libmad0_0.15.1b-2.1_i386.deb) ...
Selecting previously deselected package libxine-main1.
Unpacking libxine-main1 (from .../libxine-main1_1.1.2귪婲䞝0ubuntu3_all.deb) ...
Selecting previously deselected package libxine-extracodecs.
Unpacking libxine-extracodecs (from .../libxine-extracodecs_1.1.1릻Ꞷ2_i386.deb) ...
Setting up libmad0 (0.15.1b-2.1) ...

Setting up libxine-main1 (1.1.2귪婲䞝0ubuntu3) ...
Setting up libxine-extracodecs (1.1.1릻Ꞷ2) ...
dpkg run finished!

MP3 support now installed, restart Amarok.
===============================
 I restarted Amarok and it will not play MP3 files, nor install MP3 Support (since it's already installed), when chosen.

ingmar, what xine packages did you select for deletion? Maybe I missed one.
I also noticed that mpeg videos play, but without sound in kaffine, which maybe related to this mp3 issue.

Tim Williams (auto-timsweb) wrote :

Just like to say that I can confirm this problem (on Edgy).

Ogg/wav worked fine, just mp3 that was buggered.

The workaround for me was to get synatpic to reinstall most xine related things (including amarok). This time amarok was able to install mp3 support.

I installed Edgy Eft kubuntu and copied my home directory, including the .xine directory from the old installation.

I couldn't play .mp3 and .ogg files. When trying to do this amarok raised an error message saying the following text:
------------------------------------------------------------
Error Loading Media
No suitable demux plugin. This often means that the file format is not supported.
-----------------------------------------------------------

The file ~/.xine/catalog.cache was created from an old version.
Deleting this file forces xine to rebuild it (i.e. at the start of amarok).
Now I can play these mp3s and oggs (of course I installed the packages).

Reinstallation of the amarok or some other packages does not purge the ~/.xine files, so this does not work.

Andrew Ash (ash211) wrote :

It sounds like most of the errors here are from stale ~/.xine files. Can anybody replicate this from a fresh install of Edgy?

Changed in amarok:
status: Needs Info → Confirmed
QuestZone (mscott7319) wrote :

* The error began after a fresh install of Edgy Knot 3 from the "Alternate Install CD".

Thank you for the suggestions. However, none of them worked on my machine.
A fresh install of Kubuntu 6.10 (Edgy) has resolved this mp3 issue with Amarok.

Andrew Ash (ash211) wrote :

I guess that's why Knot 3 was called a beta! If nobody else is having any problems, I'll close the bug in a few days.

Andrew Ash (ash211) on 2006-12-22
Changed in amarok:
assignee: nobody → ash211
Andrew Ash (ash211) wrote :

Closing the bug then. If anybody is still having problems and clean installed Edgy, feel free to reopen this bug. Thanks for your contributions to Kubuntu.

Changed in amarok:
assignee: ash211 → nobody
status: Confirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers