Ubuntu

Comment 39 for bug 352732

I love you, Gavindi, that worked!

I'd like to run more tests though, because I only tried restarting.
Will do that ASAP.

On Mon, Jun 1, 2009 at 19:47, Gavindi <email address hidden> wrote:
> Ok,
> I've found a fix that works for me. I was find that if I didn't shut down my computer gracefully (and there letting /etc/init.d/alsa-utils run it's stop procedure) that the sound levels would be set and un-muted on next boot.
>
> Therefore, I commented out line 372 in /etc/init.d/alsa-utils:
>
> # mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1
>
> Now when I reboot gracefully, the sound levels are correct. I would
> suspect that there is a bit a race condition happening. I am supposing
> the alsa-utils script is being called twice and as the levels have been
> "muted and zero'd" the first time around, the second time around sees
> the zero'd levels get saved as the Alsa state.
>
> I think the udev and rc.d is invoking the script twice......
>
> This is however just a theory, but it makes sense!!! (I Hope)
>
> --
> [jaunty] Sound muted after boot
> https://bugs.launchpad.net/bugs/352732
> You received this bug notification because you are a direct subscriber
> of the bug.
>