Ubuntu

Sound muted after boot

Reported by Alexander Hunziker on 2009-03-31
432
This bug affects 89 people
Affects Status Importance Assigned to Milestone
PulseAudio
New
Unknown
alsa-utils (Ubuntu)
Undecided
Daniel T Chen
Declined for Jaunty by Brian Murray
Nominated for Karmic by Singpolyma
Nominated for Lucid by Singpolyma
Nominated for Maverick by Daniel Añez Scott

Bug Description

After every boot, the master channel of my sound card is muted. I see there's bugs 316430 and 299093 which describe a similar problem, but they are both marked as fixed and I have Jaunty updated with the latest packages, so I'm maybe having another issue?

This is on a Thinkpad T60 laptop, with an Intel onboard sound chip:

hunzikea@AlexT60:/proc/asound$ cat cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xee400000 irq 17

I'll attach the outputs of /var/lib/alsa/asound.state and amixer -Dhw:0 directly after boot, and after resetting the volume to something decent.

---------------
Status (from #81):
IDT/Sigmatel HDA: fixed in Lucid
Analog Devices: work in progress

affects: ubuntu → alsa-driver (Ubuntu)

Upon sudo invoke-rc.d alsa-utils, the mixer levels seem to get saved and restored successfully. What else can I check here?

I noticed that in System->Administration->Services, "Audio settings management" had been unticked, though ticking it did not solve the problem.

Ricardo Pérez López (ricardo) wrote :

I can confirm this problem in my Jaunty, too. However, it's not always reproducible: sometimes the audio is properly restored after boot, and sometimes is muted. The problem appears in Jaunty; working perfectly in Intrepid.

$ cat /proc/asound/cards
 0 [VT82xx ]: HDA-Intel - HDA VIA VT82xx
                      HDA VIA VT82xx at 0xdfdfc000 irq 17

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Ricardo Pérez López (ricardo) wrote :

Seems to be a problem in the udev rule. I've patched the /etc/init.d/alsa-utils script this way:

case "$1" in
  start)
        date > /root/alsa-utils.log # Log the script startups
        EXITSTATUS=0
        TARGET_CARD="$2"
[...]

So I can see when the script has been started. And I see that the /root/alsa-utils.log is never created, so the script is never started.

Ricardo Pérez López (ricardo) wrote :

I can't confirm that the problem is in the udev rule. I manually created:

  $ cd /etc/rc2.d
  $ sudo ln -s ../init.d/alsa-utils S40alsa-utils

so now alsa-utils is always called at boot time. However, the mixer is still muted when I go into GNOME.

Ricardo Pérez López (ricardo) wrote :

Today, I turn on the computer and I see the sound muted again. Alsamixer shows the device muted, too.

After doing "sudo /lib/udev/alsa-utils" in a terminal prompt, the device gets unmuted.

I attach two screenshots (before and after running "sudo /lib/udev/alsa-utils", respectively).

I can confirm that executing "sudo /lib/udev/alsa-utils" unmutes my soundcard.

More info, step by step:

1. I boot the computer.
2. When GDM appears, I go into VT1 (Ctrl-Alt-F1) and log into my user.
3. If I do "alsamixer -Dhw:0" or "alsamixer -c0", I get all the channels unmuted.
4. If I then do "alsamixer", I get only one muted PulseAudio channel, and the following error messages in the console:
  I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
  I: caps.c: Dropping root privileges.
  I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
5. Since then, If I repeat "alsamixer -Dhw:0" or "alsamixer -c0", I get the Master channel muted.
6. To unmute the Master channel previously muted on step #5, I need to do "sudo /lib/udev/alsa-utils". After that, all the channels gets unmuted and all works OK.

OK, now I can see the problem. I't my fault. We had two files, ~/.asoundrc and ~/.asoundrc.asoundconf. The last one contained the following:

  pcm.!default { type pulse }
  ctl.!default { type pulse }

The above was causing troubles. I'd just removing the two files, and now it seems to works well.

Alexander, can you check the presence of the above two files? Try removing them, and tell me if that works.

Bad luck: today I booted the computer again, and I still had the Master channel muted. I don't know what else I can do :(

I did have a home-grown ALSA config file, though system-wide in /etc/asound.conf containing the same config as yours. Removing did indeed *not* solve the problem.

I'd just booted my computer this morning, and again I had a Master channel muted. This bug is definitely NOT solved for me.

Since I enabled the "Audio settings management" in System->Administration->Services some days ago, I can't reproduce the problem. Maybe a coincidence?

Ricardo: I'm not sure you are experiencing the same bug. For me, the sound is *always* muted. Also enabling the "Audio settings management" in the services did not improve things for me, as I said above.

Well, this morning again I had a Master channel muted, even with the "Audio settings management" enabled. Now I'm officially confused.

Daniel, I don't know what can I do in order to debug the problem. Can you take a quick look, please?

ski (skibrianski) wrote :

I'm having the same problem as Alexander - sound on the main speakers NEVER works. Master channel gives no output, but headphone jack works just fine. HP mini 1035nr. Fresh install of jaunty RC1, upgraded to latest. It seems like sometimes alsa starts with audio muted on both the Master and PCM channels, but running alsamixer and restoring to 100 does no good. Please let me know what info would be useful to have.

cbrmichi (cbrmichi) wrote :

i got the same problem here. i can turn my sound on again by booting windows... so where can be the problem?

ski (skibrianski) wrote :

In my case the problem was solved using this:
  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/318942

But I'm not sure if everyone experiencing this bug is using a hp mini nettop (or if it might work for you anyway). Good luck!

Singpolyma (singpolyma) wrote :

I have this problem as well.

Whenever I boot, the master channel is turned all the way down and muted. I can unmute and turn it up and then it works fine until I reboot.

Singpolyma (singpolyma) wrote :

GDM has sound to make the "login ready" sound.

If I run alsamixer instantly on starting my window manager (dwm) I see that all my volume settings are correct.

Moments later they are wrong.

It is not the gnome-settings-daemon... it does it even with that off.

I am beginning to suspect the pulseaudio daemon, but don't know how to configure it.

Singpolyma (singpolyma) wrote :

Confirmed the problem is PulseAudio.

Used http://idyllictux.wordpress.com/2009/04/21/ubuntu-904-jaunty-keeping-the-beast-pulseaudio-at-bay/ (well, almost, had to put exit at the top of /etc/init.d/pulseaudio, because update-rc.d wouldn't cooperate, and ran asoundconf reset-default-card at the end and left GNOME sound settings on "autodetect") ... now pulseaudio never starts and my volume settings remain the way I want them ! :D

Montblanc (montblanc) wrote :

The same is happening with KDE too. Volume gets muted every 60 seconds or something. Disabling pulseaudio following this guide helped:
http://idyllictux.wordpress.com/2009/04/21/ubuntu-904-jaunty-keeping-the-beast-pulseaudio-at-bay/

Jimmy Buck (jimmybuck) wrote :

Same thing is happening to me with my Intel HDA chipset.

If I stay within Gnome, everything seems to work fine. But if I set my default session to XBMC (possible in the latest builds of XBMC), the master channel is at 0% when I boot up sometimes.

I haven't tried building XBMC with Pulse Audio disabled yet. That was my next plan of action.

Alfredas Beinartas (fuxialis) wrote :

Disabling alsa-utils in System -> Administration -> Services solves the problem for me

I can confirm that after booting, but before logging in, my master channel is *not* yet muted, as it should be. So it's something in the Gnome login process with mutes it, PulseAudio is a prime suspect ;-)

Jimmy Buck (jimmybuck) wrote :

Disregard my previous comment about staying in Gnome doesn't exhibit the problem. It definitely does.

I did, however, find that it doesn't happen when forcing a reboot instead of using the menu in Gnome to reboot. If I do a 'sudo reboot', the sound isn't muted when coming back up.

Either way, using the guide a few posts above mine to disable Pulse fixed the problem for me.

ptn (tn-pablo) wrote :

Same issue here. I followed http://idyllictux.wordpress.com/2009/04/21/ubuntu-904-jaunty-keeping-the-beast-pulseaudio-at-bay/ but it didn't help, I enabled alsa-utils in Services but still nothing. My ~/.asoundrc* files didn't have the lines mentioned, so I didn't try deleting them.

I miss the login sound...

I confirm what Jimmy Buck already said: when you shutdown your system in a forced way (or if it crashes, as it was in my case), the sound is not muted after a reboot. It looks like something mutes the channels upon shutdown, and then re-mutes them upon login. That's why the master channel is unmuted after boot, but gets muted at login.

smurf (luca-dgh) wrote :

If this can have some interest I found that adding /lib/udev/alsa-utils in "sessions" can solve the problem, but what happens is:
1) the splash image that I added with the Gnome utility appears
2) the login sound start (I put a large sound, about 30 seconds)
3) during the execution the login sound stop for 3-4 seconds
4) the login sound restart until the end

Please note that I enabled the automatic login for my account

ptn (tn-pablo) wrote :

I can confirm that the sound is not muted when booting after a system crash.

Changed in pulseaudio:
status: Unknown → New
Gavin Graham (gavingraham) wrote :

For me, manually running /etc/init.d/alsa-utils restart will unmute the sound.

Mmmm that didn't do it for me:

    $ sudo /etc/init.d/alsa-utils restart
    * Shutting down ALSA...
     [OK ]
     * Setting up ALSA...

and still no sound. I also tried:

$ sudo alsa reload
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/ptn/.gvfs
      Output information may be incomplete.
/sbin/alsa: Warning: Processes using sound devices: 4127(pulseaudio)
4169(mixer_applet2).
Unloading ALSA sound driver modules: snd-hda-intel snd-pcm-oss
snd-mixer-oss snd-pcm snd-timer snd-page-alloc (failed: modules still
loaded: snd-hda-intel snd-pcm snd-timer snd-page-alloc).
Loading ALSA sound driver modules: snd-hda-intel snd-pcm-oss
snd-mixer-oss snd-pcm snd-timer snd-page-allocWARNING: All config
files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a
future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it
will be ignored in a future release.

 and didn't work either.

On Sat, May 30, 2009 at 18:38, Gavindi <email address hidden> wrote:
> For me, manually running /etc/init.d/alsa-utils restart will unmute the
> sound.
>
> --
> [jaunty] Sound muted after boot
> https://bugs.launchpad.net/bugs/352732
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hi PTN,

Yeah my bad. Upon further investigation, my suggestion wasn't working as I thought it was....

Keep looking....

Gavin Graham (gavingraham) wrote :

Ok,
I've found a fix that works for me. I was find that if I didn't shut down my computer gracefully (and there letting /etc/init.d/alsa-utils run it's stop procedure) that the sound levels would be set and un-muted on next boot.

Therefore, I commented out line 372 in /etc/init.d/alsa-utils:

# mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

Now when I reboot gracefully, the sound levels are correct. I would suspect that there is a bit a race condition happening. I am supposing the alsa-utils script is being called twice and as the levels have been "muted and zero'd" the first time around, the second time around sees the zero'd levels get saved as the Alsa state.

I think the udev and rc.d is invoking the script twice......

This is however just a theory, but it makes sense!!! (I Hope)

I love you, Gavindi, that worked!

I'd like to run more tests though, because I only tried restarting.
Will do that ASAP.

On Mon, Jun 1, 2009 at 19:47, Gavindi <email address hidden> wrote:
> Ok,
> I've found a fix that works for me. I was find that if I didn't shut down my computer gracefully (and there letting /etc/init.d/alsa-utils run it's stop procedure) that the sound levels would be set and un-muted on next boot.
>
> Therefore, I commented out line 372 in /etc/init.d/alsa-utils:
>
> # mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1
>
> Now when I reboot gracefully, the sound levels are correct. I would
> suspect that there is a bit a race condition happening. I am supposing
> the alsa-utils script is being called twice and as the levels have been
> "muted and zero'd" the first time around, the second time around sees
> the zero'd levels get saved as the Alsa state.
>
> I think the udev and rc.d is invoking the script twice......
>
> This is however just a theory, but it makes sense!!! (I Hope)
>
> --
> [jaunty] Sound muted after boot
> https://bugs.launchpad.net/bugs/352732
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Gavindi's solution works, in the sense that if I comment that line I have all volumes up after the desktop is loaded. But the strange thing is that it makes the "login sound" disappear. Summing up, this is how it works for me:

1) with the line un-commented (default situation)
- "drum sound" at the beginning
- "login sound" at desktop loading
- master channel muted

2) with the line commented (Gavindi's solution)
- "drum sound"
- NO "login sound"
- master channel unmuted

This seems a real puzzle. How to get out from it?

Daniel T Chen (crimsun) on 2009-06-08
affects: alsa-driver (Ubuntu) → pulseaudio (Ubuntu)
Changed in pulseaudio (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: Confirmed → Fix Committed
Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
Changed in pulseaudio (Ubuntu):
status: Fix Released → Confirmed
Singpolyma (singpolyma) on 2009-11-12
summary: - [jaunty] Sound muted after boot
+ [jaunty,karmic] Sound muted after boot
Singpolyma (singpolyma) on 2009-11-12
tags: added: jaunty
tags: added: karmic mute pulseaudio sound
Daniel T Chen (crimsun) on 2009-12-17
affects: pulseaudio (Ubuntu) → alsa-utils (Ubuntu)
Changed in alsa-utils (Ubuntu):
status: Confirmed → Fix Released
41 comments hidden view all 121 comments

Re #81: Dear Mr. Chen. Thanx for your efforts! However, I don't understand what you're saying. Powerdown symptoms?
When and how was this fixed? I still have no sound on login. Using the fix #38 will work ONLY for the Master level and PCM level which are successfully restored on boot. But all other settings still get muted including front and headphones, which means - all output is still muted. Thus, running "alsactl restore" on every login is the only functioning workaround for me right now.
If I understand you right this won't be fixed before April 2010?
Is Pulseaudio the culprit in all this?

Tony Kernan (ackernan) wrote :

Making the change in #77 helped me. I had a problem of the sound being muted when I rebooted or exited my window manager.

Olli Niemikorpi (mr-oole) wrote :

I had also the problem that the master channel was muted in every boot (i have intel hda)

I confirm that making the change proposed by #77 solved also my problem. Maybe a "howto: fix intel hda muted on startup" should be created to wiki or ubuntu forums?

Olli Niemikorpi (mr-oole) wrote :

I discovered #38 and #77 methods in Karmic. #77 works as confirmed earlier. #38 doesn't work solely, but that method works together with #77 (actually I'm not sure whether #38 method has any action to Karmic sound settings). #77 seems to be an easy way to get audio unmuted in Karmic, at least for me and for some others that have reported here in a way like that..

BTW: For me, method #77 doesn.t enable "drum" sound at the beginning. The login sound is enabled as well as master channel set to the previous "shutdown level". Actually, this is not a great problem, but an interesting dilemma..

Mark Rice (ricemark20) wrote :

I had the same problem as #76, where default ubuntu (gnome) sound was fine, but after installing xubuntu-desktop
over it, the sound was muted.

I found #77 works alone, without #38 in Karmic.

Justyn Butler (justyn) wrote :

I ran into this bug suddenly today on a standard Karmic gnome installation that was working fine before. I've no idea what I did for it to suddenly start happening, I didn't do an upgrade and I didn't install xubuntu-desktop like in some other comments.

I can confirm that #38 (commenting out "mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1") did not work for me.

However #77 (commenting out "load-module module-device-restore" in PA config) has fixed my problem. I don't know what the other consequences of using this fix are.

Justyn Butler (justyn) wrote :

I realize I did not mention my audio chipset in my above post.
I can't clearly see what it is, except that it is not Intel audio.
It is an AMD 780G board, using the IEC958 (SPDIF) output.

Olli Niemikorpi (mr-oole) wrote :

Hi Justyn,

What's the output for "Audio device" if you type lspci in the terminal and press enter?

For me, it says
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

I have Asus M3A MB (ATI 770) but it seems to exhibit as Intel HDA as "lspci" says..

Olli

Hi

I just run into this on a fresh Karmic install, #77 cured the problem, in spite I applied 38. I found that the problem was on the pulse audio mixer, I could unmute and crank up all volumes at the alsa mixer without anything happening. Bug 456013 may be the expression of the same symptoms.

Antonio

alwaysanewbie (glennh) wrote :

#77 worked for me on my Karmic as well.

Thanx!

Tony Lill (ajlill) wrote :

I'll add my vote for #77 as well. Before I tried this solution, I ran the following experiment: I got all my settings the way I wanted them. I started alsamixer to monitor the settings, then I killed /usr/bin/pulseaudio. When the daemon restarted, it muted the audio. This tells me the problem is entirely in pulsaudio.

Now I had thought I had fixed the problem for a couple of weeks by setting alsa-utils to run at system startup. Whatever bug pulseaudio gets up its arse just comes and goes to reasons currently unknown, so just because it goes away when you fiddle with alsa-utils doesn't mean you've found the problem.

The issue with alsa-utils, as far as I can tell, is that ubuntu sets up the stop script to run, which saves settings and mutes, without setting up the start script to run. You need both or neither. Deleting the line that mutes doesn't really fix this. It happens to work when you re-boot because the hardware probably doesn't get reset. I'll bet that booting to another operating system with different settings or possibly even powercycling will cause other, harder to diagnose problems.

papukaija (papukaija) wrote :

Bug 514713 is not a dupplicate of this bug since I'm running Karmic and I have no sound on login.

Olli Niemikorpi (mr-oole) wrote :

Papukaija: Take a look to #38, #77 and #81. Fix has already been released for a bug related to alsa-utils, but it seems that we deal with a pulseaudio bug in Karmic affecting to mute sound with Intel HDA.

Try #77. Hope it works.

papukaija (papukaija) wrote :

The workaround from comment 77 seems to work, my card is however an Analog Devices card and not an Intel card.

I think I've found a simpler way to fix the problem of setting the audio at a desidered level at start up.
I used the "aslactl" function with a custom file (http://manpages.ubuntu.com/manpages/gutsy/man1/alsactl.1.html).
 I set the options as I liked , then I typed from a terminal : aslactl store -f /filename...
this will create a file with the otions setted as I wanted .
then I added at start up the command : aslactl restore -f /filename...

and it works all the times.

papukaija (papukaija) wrote :

Your workaround increases desktop's loading time :(

I use an old thinkpad x20 with 196mb and I can tell you that the desktop loading time did not change. I have other performance problem later on but not at starting

papukaija (papukaija) wrote :

Anyway, the workaround from comment 77 is working for me and is imo a simpler temporary fix.

Brian (x-brian) wrote :

Workaround from #77 fixed this for me in Karmic 9.10. In Jaunty I had killed pulse but it came back on upgrade to Karmic, though I don't seem to be having any troubles from it in Karmic save this. Now that I commented that line in /etc/pulse/default.pa I get the drum sound before login, the login sound, and the volume on both are at the same level they were on logout. Seems to work fine! :^)

I have an Intel HDA sound controller (82801G).

Kacela (robert-jochim) wrote :

Using Karmic 9.10 - Same issue as previously described here - volume is muted upon rebooting.

Workaround outlined in #77 worked for me. Start-up sound is now back and the volume remains where I left it during it's previous session. I tested shutting the machine down hard and shutting down gracefully; sound is at normal levels upon rebooting after both. Thanks @André Gaul

Tomi Pieviläinen (tpievila) wrote :

Had this problem since Karmic, persisted after upgrading to Lucid. Fix in #77 solved the problem.

Johnny Bilek (johnnyvw) wrote :

Just wanted to pile on. #77 without #38 works for my Latitude CPx with Karmic. #38 kind of worked. It didn't boot up muted, but would change the volume levels to 38% master and 75% PCM (I keep them at 54%/50%).

I changed #38 back and applied #77. Yay!

Johnny Bilek (johnnyvw) wrote :

Oops, forgot... I'm using Xubuntu Karmic. This was an upgrade from 8.10, to 9.04, 9.10.

Kent deVillafranca (kdevilla) wrote :

I'm on an MSI X340. Didn't have this problem in Karmic, but did after upgrading to Lucid (the "Speaker" setting in alsamixer would drop to the lowest level possible on every boot). The advice from post #77 fixed it. I had also previously raised the levels back to normal in alsamixer and did a "sudo alsactl store", which may or may not have done anything to help.

psgoodrich. (psgoodrich) wrote :

Getting Ubuntu Lucid Lynx 10.04 to play audio on EeePC. This worked for me.

Thanks to André Gaul at

https://bugs.launchpad.net/ubuntu/+source/alsa-utils/+bug/352732/comments/77

who wrote --

"This issue may be a problem in pulseaudio. I managed to get it to work as expected by replacing the line
load-module module-device-restore
in /etc/pulse/default.pa with
#load-module module-device-restore
Perhaps you have to logout, kill all pulseaudio daemons, login, adjust volumes, logout and login again to see if it works."

Being new to linux, at first, I couldn't modify -- /etc/pulse/default.pa

because I didn't have "ownership permission" so first I had to go to

http://ubuntuguide.org/wiki/Ubuntu:Lucid to find out how to

http://ubuntuguide.org/wiki/Ubuntu#How_to_change_files.2Ffolders_permissions

You need to open Terminal (located in the Accessories group)

then type --

sudo chown system_username /location_of_files_or_folders

(My user name is "u" so substiture your user name for "u")

so I typed --

sudo chown u /etc/pulse/default.pa

(My user name is "u" so substiture your user name for "u")

this allows you to use "gedit" (located in the Accessories group) or another word processor to modify the file by adding the "#" to the

"load-module module-device-restore" line

You may search for this combination by type <Ctrl>-F then filling in --
load-module module-device-restore

Before you make any changes to "default.pa" copy it to the Desktop "just in case"

After I made the changes, I right clicked on "default.pa" and changed all the permissions back to "Read Only".

Restart Ubuntu and, if you are as lucky as I was, you will have sound!

Hope this helps, but feel free to contact me if you get stuck. Gesundheit. Doktor Krankheit.

Andrea Amoroso (heiko81) wrote :

I have the same problem with Ubuntu Maverick alpha 2..at startup the volume is always off..

Andrea Amoroso (heiko81) wrote :

The solution proposed in #38 worked from me, except for the fact that the alsa-utils file is under /sbin and not /etc/init.d..again, Ubuntu Maverick alpha 2..

Hell will freeze when I will do the move to Maverick. Lucid is already an enormous headache. I have this fixed, maybe it was the following:

***************
Therefore, I commented out line 372 in /etc/init.d/alsa-utils:
# mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

in /etc/pulse/default.pa with
#load-module module-device-restore
*********************************

because nobody at the right level cared for this one since jaunty. an this is a pita...

papukaija (papukaija) on 2010-07-27
summary: - [jaunty,karmic] Sound muted after boot
+ Sound muted after boot
tags: added: lucid maverick
removed: mute sound
Jamie Kitson (jamie-kitson) wrote :

Yep, fixed this issue as #38 says in Karmic and had to do the same in /sbin/ after upgrading to Lucid.

Berthold (bsc1976) wrote :

Following instructions in #106 fixed muted sound in ubuntu 10.04 on a HP dv6700. Thx

The error persists in Maverick.
'~$ uname -a; Linux MD97600 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:36:48 UTC 2010 i686 GNU/Linux'

The errior persists in 11.04
uname -a
2.6.38-10-generic-pae #46-Ubuntu SMP Tue Jun 28 16:54:49 UTC 2011 i686 i686 i386 GNU/Linux

mikewhatever (mikewhatever) wrote :

Still unfixed in Lucid 10.04.3. Had to use the workaround as outlined is #106.

László Monda (mondalaci) wrote :

It's a 3 years old bug which really should have been fixed by now. Instead of using workarounds I'd like to understand what's the root cause of the issue and get it fixed.

I've done as written in #63 to track this down and got:

2012-05-15 01:51:58 Running alsactl store
2012-05-15 12:11:28 Running alsactl restore
2012-05-15 12:11:28 Running alsactl restore 1
2012-05-15 12:11:28 Running alsactl restore 0
[muted and manually corrected]
2012-05-16 04:21:32 Running alsactl store
2012-05-16 15:01:49 Running alsactl restore
2012-05-16 15:01:49 Running alsactl restore 1
2012-05-16 15:01:49 Running alsactl restore 0
[muted and manually corrected]
2012-05-17 03:27:04 Running alsactl store
2012-05-17 12:41:22 Running alsactl restore 1
2012-05-17 12:41:22 Running alsactl restore 0
2012-05-17 12:41:22 Running alsactl restore
[muted and manually corrected]

According to /etc/init/alsa-restore.conf and /etc/init/alsa-store.conf instead of "restore 1", "restore 0" and "restore" only "restore" should be executed, right?

If anyone has any idea about the above or about the root cause of this issue please don't hesitate to share. This is a disturbing sucker that should be eliminated.

László Monda (mondalaci) wrote :

Minor correction: In my previous comment I erroneously wrote /etc/init/alsa-{re}store.conf instead of /etc/init/alsa-{re}store.

In the meantime I commented out the "load-module module-device-restore" line in /etc/pulse/default.pa according to #77. Unlike for others it didn't fix the issue for me.

It's also important to mention that sometimes the volume level gets restored correctly and other times it doesn't so this issue seems too be non-deterministic.

At this point I'm not sure what the culprit is. Given that alsactl gets called by Upstart this seems like it's an ALSA issue but PulseAudio related tweaks resolved this issue for some which suggests me that it may be a PulseAudio issue.

I've just reported https://bugtrack.alsa-project.org/alsa-bug/view.php?id=5586 to the ALSA bugtracker.

papukaija (papukaija) on 2012-05-27
tags: added: natty oneiric
removed: jaunty karmic maverick pulseaudio
papukaija (papukaija) on 2012-05-27
description: updated
description: updated
keesp (cees-pieters) wrote :

I had the same issue with Xubuntu 12 (and earlier). As I didn't need advanced audio possibilities I removed PulseAudio and used alsamixer alone. That seemed to do the trick. If it is a bug, i think it has to do with pulseaudio and not alsa

Commoner (commoner51) wrote :

I had the same problem with Ubuntu 12.04. Fix in #77 solved it.

maxim (maximn) wrote :

Using Xubuntu 12.04.1, muted sound after boot/login to XFCE. Using workaround in comment #77, problem does not occur.

vsespb (vi1tsr) wrote :

same in ubuntu 10.04 (except sound not muted, but set to lower level), fixed by #77

Displaying first 40 and last 40 comments. View all 121 comments or add a comment.